Καταχώρηση δεδομένων απευθείας σε μια σελιδοποιημένη αναφορά στο εργαλείο δόμησης αναφορών - Power BIEnter data directly in a paginated report in Report Builder - Power BI

ΙΣΧΥΕΙ ΓΙΑ:APPLIES TO: ✔️ Υπηρεσία Power BI✔️ Power BI service ✔️ Σελιδοποιημένες αναφορές του Power BI✔️ Power BI paginated reports ✔️ Power BI Premium✔️ Power BI Premium ❌ Power BI Desktop❌ Power BI DesktopΙΣΧΥΕΙ ΓΙΑ:APPLIES TO: ✔️ Υπηρεσία Power BI✔️ Power BI service ✔️ Σελιδοποιημένες αναφορές του Power BI✔️ Power BI paginated reports ✔️ Power BI Premium✔️ Power BI Premium ❌ Power BI Desktop❌ Power BI Desktop

Σε αυτό το άρθρο, θα μάθετε σχετικά με μια δυνατότητα στη νέα έκδοση του Microsoft Power BI Report Builder που σας επιτρέπει να εισάγετε δεδομένα απευθείας σε μια αναφορά RDL ως ένα ενσωματωμένο σύνολο δεδομένων.In this article, you learn about a feature in the new version of Microsoft Power BI Report Builder that lets you enter data directly into an RDL report as an embedded dataset. Αυτή η δυνατότητα είναι παρόμοια με το Power BI Desktop.This feature is similar to Power BI Desktop. Μπορείτε να πληκτρολογήσετε τα δεδομένα απευθείας σε ένα σύνολο δεδομένων στην αναφορά σας ή να τα επικολλήσετε από κάποιο άλλο πρόγραμμα, όπως το Microsoft Excel.You can type the data directly in a dataset in your report, or paste it from another program like Microsoft Excel. Αφού δημιουργήσετε ένα σύνολο δεδομένων εισάγοντας δεδομένα, μπορείτε να το χρησιμοποιήσετε όπως θα κάνατε με οποιοδήποτε άλλο ενσωματωμένο σύνολο δεδομένων που έχετε δημιουργήσει.After you've created a dataset by entering data, you can use it just like you would any other embedded dataset you've created. Επιπλέον, μπορείτε να προσθέσετε περισσότερους από έναν πίνακες και να χρησιμοποιήσετε τον ένα ως φίλτρο για τον άλλο.Plus you can add more than one table and use one as a filter for the other. Αυτή η δυνατότητα είναι ιδιαίτερα χρήσιμη για μικρά, στατικά σύνολα δεδομένων που ίσως χρειάζεται να χρησιμοποιήσετε στην αναφορά σας, όπως είναι οι παράμετροι αναφοράς.This feature is especially useful for small, static datasets you might need to use in your report, like report parameters.

ΠροαπαιτούμεναPrerequisites

Δημιουργία προέλευσης δεδομένων και συνόλου δεδομένωνCreate a data source and dataset

Αφού πραγματοποιήσετε λήψη του εργαλείου δόμησης αναφορών και το εγκαταστήσετε, μπορείτε να ακολουθήσετε την ίδια ροή εργασιών που χρησιμοποιείτε για να προσθέσετε μια ενσωματωμένη προέλευση δεδομένων και ένα σύνολο δεδομένων στην αναφορά σας.After you’ve downloaded and installed Report Builder, you follow the same workflow you use to add an embedded data source and dataset to your report. Στην παρακάτω διαδικασία, στην περιοχή Προελεύσεις δεδομένων θα δείτε μια νέα επιλογή: Εισαγωγή δεδομένων.In the following procedure, under Data Sources you see a new option: Enter Data. Χρειάζεται να ορίσετε αυτήν την προέλευση δεδομένων μία φορά σε μια αναφορά.You only need to set up this data source once in a report. Μετά από αυτό, μπορείτε να δημιουργήσετε πολλούς πίνακες εισαγόμενων δεδομένων ως ξεχωριστά σύνολα δεδομένων, χρησιμοποιώντας για όλα αυτή την προέλευση δεδομένων.After that, you can create multiple tables of entered data as separate datasets, all using that single data source.

  1. Στο τμήμα παραθύρου Δεδομένα αναφοράς, επιλέξτε Νέο > Σύνολο δεδομένων.In the Report Data pane, select New > Dataset.

    Στιγμιότυπο οθόνης για το "Νέο σύνολο δεδομένων εργαλείου δόμησης αναφορών".

  2. Στο παράθυρο διαλόγου Ιδιότητες συνόλου δεδομένων, επιλέξτε Χρήση συνόλου δεδομένων που έχει ενσωματωθεί στην αναφορά μου.In the Dataset Properties dialog box, select Use a dataset embedded in my report.

  3. Δίπλα στην ένδειξη Προέλευση δεδομένων, επιλέξτε Δημιουργία.Next to Data source, select New.

    Στιγμιότυπο οθόνης για τη "Νέα ενσωματωμένη προέλευση δεδομένων".

  4. Στο παράθυρο διαλόγου Ιδιότητες προέλευσης δεδομένων, επιλέξτε Χρήση σύνδεσης που έχει ενσωματωθεί στην αναφορά μου.In the Data Source Properties dialog box, select Use a connection embedded in my report.

  5. Στο πλαίσιο Επιλογή τύπου σύνδεσης, επιλέξτε ΕΙΣΑΓΩΓΗ ΔΕΔΟΜΈΝΩΝ > OK.In the Select connection type box, select ENTER DATA > OK.

    Στιγμιότυπο οθόνης για την προέλευση δεδομένων ΕΙΣΑΓΩΓΗ ΔΕΔΟΜΈΝΩΝ.

  6. Στο παράθυρο διαλόγου Ιδιότητες συνόλου δεδομένων, επιλέξτε Εργαλείο σχεδίασης ερωτημάτων.Back in the Dataset Properties dialog box, select Query Designer.

  7. Στο τμήμα του παραθύρου Εργαλείο σχεδίασης ερωτημάτων, κάντε δεξιό κλικ και επικολλήστε τα δεδομένα σας στον πίνακα.In the Query Designer pane, right-click and paste your data in the table.

    Στιγμιότυπο οθόνης για την Εισαγωγή δεδομένων στο Εργαλείο σχεδίασης ερωτημάτων.

  8. Για να ορίσετε τα ονόματα των στηλών, κάντε διπλό κλικ σε κάθε πεδίο NewColumn και πληκτρολογήστε το όνομα της στήλης.To set the column names, double-click each NewColumn and type the column name.

    Στιγμιότυπο οθόνης για τον Ορισμό ονομάτων στηλών.

  9. Εάν η πρώτη γραμμή περιέχει επικεφαλίδες στηλών από τα αρχικά δεδομένα, κάντε δεξιό κλικ και διαγράψτε τα.If the first row contains column headings from the original data, right-click and delete it.

  10. Από προεπιλογή, ο τύπος δεδομένων για κάθε στήλη είναι συμβολοσειρά.By default, the data type for each column is String. Για να αλλάξετε τον τύπο δεδομένων, κάντε δεξιό κλικ στην κεφαλίδα της στήλης > Αλλαγή τύπου και ορίστε την σε κάποιον άλλο τύπο δεδομένων, όπως ημερομηνία ή κινητή υποδιαστολή.To change the data type, right-click the column header > Change Type, and set it to another data type, such as Date or Float.

    Στιγμιότυπο οθόνης για την Αλλαγή τύπου δεδομένων.

  11. Όταν ολοκληρώσετε τη δημιουργία του πίνακα, επιλέξτε OK.When you’ve finished creating the table, select OK.

    Το ερώτημα που δημιουργείται είναι το ίδιο που θα βλέπατε με μια προέλευση δεδομένων XML.The query that’s generated is the same as you’d see with an XML data source. Στο παρασκήνιο, χρησιμοποιούμε XML ως υπηρεσία παροχής δεδομένων.Under the covers, we’re using XML as the data provider. Την έχουμε προσαρμόσει ώστε να εξυπηρετεί και αυτό το σενάριο.We’ve repurposed it to enable this scenario as well.

    Στιγμιότυπο οθόνης για την Δομή δεδομένων XML.

  12. Στο παράθυρο διαλόγου Ιδιότητες συνόλου δεδομένων, επιλέξτε ΟΚ.In the Dataset Properties dialog box, select OK.

  13. Θα δείτε την προέλευση δεδομένων και ένα σύνολο δεδομένων στο παράθυρο Δεδομένα αναφοράς.You see your data source and dataset in the Report Data pane.

    Στιγμιότυπο οθόνης για το Σύνολο δεδομένων στο τμήμα παραθύρου "Δεδομένα αναφοράς".

Μπορείτε να χρησιμοποιήσετε το σύνολο δεδομένων σας ως βάση για απεικονίσεις δεδομένων στην αναφορά σας.You can use your dataset as the basis for data visualizations in your report. Επίσης, μπορείτε να προσθέσετε ένα άλλο σύνολο δεδομένων και να χρησιμοποιήσετε την ίδια προέλευση δεδομένων για αυτό.You can also add another dataset and use the same data source for it.

Σχεδίαση της αναφοράςDesign the report

Τώρα που έχετε μια προέλευση δεδομένων και ένα σύνολο δεδομένων, είστε έτοιμοι να δημιουργήσετε την αναφορά σας.Now that you have a data source and dataset, you're ready to create your report. Η ακόλουθη διαδικασία δημιουργεί μια απλή αναφορά με βάση τα δεδομένα στην προηγούμενη ενότητα.The following procedure creates a simple report based on the data in the previous section.

  1. Στο μενού Εισαγωγή, επιλέξτε Πίνακας > Οδηγός πινάκων.On the Insert menu, select Table > Table Wizard.

    Στιγμιότυπο οθόνης της επιλογής του στοιχείου Οδηγός πινάκων.

  2. Επιλέξτε το σύνολο δεδομένων που μόλις δημιουργήσατε > Επόμενο.Select the dataset you just created > Next.

    Στιγμιότυπο οθόνης του παραθύρου διαλόγου Επιλογή συνόλου δεδομένων.

  3. Στη σελίδα Τακτοποίηση πεδίων, σύρετε τα πεδία που θέλετε να ομαδοποιήσετε από το πλαίσιο Διαθέσιμα πεδία στο πλαίσιο Ομάδες γραμμών.In the Arrange fields page, drag fields you want to group by from the Available fields box to the Row groups box. Σε αυτό το παράδειγμα:In this example:

    • CountryRegionCountryRegion
    • SalesYearSalesYear
  4. Σύρετε τα πεδία που θέλετε να συναθροίσετε από το πλαίσιο Διαθέσιμα πεδία στο πλαίσιο Τιμές.Drag the fields you want to aggregate from the Available fields box to the Values box. Σε αυτό το παράδειγμα:In this example:

    • SalesAmountSalesAmount

    Από προεπιλογή, το Report Builder αθροίζει τα πεδία στο πλαίσιο Τιμές, αλλά μπορείτε να επιλέξετε μια άλλη συνάθροιση.By default, Report Builder sums the fields in the Values box, but you can choose another aggregation.

    Στιγμιότυπο οθόνης διαφορετικών συναθροίσεων για να επιλέξετε.

  5. Επιλέξτε Επόμενο.Select Next.

  6. Στη σελίδα Επιλογή της διάταξης, διατηρήστε όλες τις προεπιλεγμένες ρυθμίσεις, αλλά καταργήστε την επιλογή Ανάπτυξη/σύμπτυξη ομάδων.In the Choose the layout page, keep all the default settings, but clear Expand/collapse groups. Γενικά, η επέκταση και η σύμπτυξη ομάδων είναι μεγάλη, αλλά αυτή τη φορά θέλουμε να δούμε όλα τα δεδομένα.In general, expanding and collapsing groups is great, but this time we want to see all the data.

  7. Επιλέξτε Επόμενο > Τέλος.Select Next > Finish. Ο πίνακας εμφανίζεται στην επιφάνεια σχεδίασης.The table is displayed on the design surface.

    Στιγμιότυπο οθόνης της αναφοράς στην Προβολή σχεδίασης.

Εκτέλεση της αναφοράςRun the report

Για να δείτε τις πραγματικές τιμές και να κάνετε προεπισκόπηση της αναφοράς, μπορείτε να την εκτελέσετε.To see the actual values and preview the report, you run it.

  1. Επιλέξτε Εκτέλεση στην κορδέλα Αρχική.Select Run in the Home ribbon.

    Στιγμιότυπο οθόνης της επιλογής Εκτέλεση στην Αρχική κορδέλα.

    Τώρα βλέπετε τις τιμές.Now you see the values. Η μήτρα διαθέτει περισσότερες γραμμές από όσες βλέπετε στην Προβολή σχεδίασης!The matrix has more rows than you saw in Design view! Μπορείτε είτε να μορφοποιήσετε τη σελίδα είτε να αποφασίσετε να χρησιμοποιήσετε τις προεπιλεγμένες ρυθμίσεις πριν από την αποθήκευση στον τοπικό υπολογιστή σας ή τη δημοσίευση στην υπηρεσία.You can either format the page or decide to use the default settings before saving to your local computer or publishing to the service.

  2. Για να δείτε πώς θα εμφανίζεται η αναφορά σας όταν την εκτυπώσετε, επιλέξτε Διάταξη εκτύπωσης.To see how your report will look when you print it, select Print Layout.

    Στιγμιότυπο οθόνης επιλογής του στοιχείου Διάταξη εκτύπωσης.

    Τώρα μπορείτε να το δείτε όπως θα φαίνεται σε μια εκτυπωμένη σελίδα.Now you see it as it will look on a printed page.

    Στιγμιότυπο οθόνης μιας αναφοράς σε προβολή διάταξης εκτύπωσης.

Αποστολή μιας σελιδοποιημένης αναφοράς στην υπηρεσία Power BIUpload the paginated report to the Power BI service

Τώρα που υποστηρίζονται σελιδοποιημένες αναφορές στην υπηρεσία Power BI, μπορείτε να αποστείλετε τη σελιδοποιημένη αναφορά σας σε ένα σύνολο Premium εκχωρημένων πόρων.Now that paginated reports are supported in the Power BI service, you can upload your paginated report to a Premium capacity. Ανατρέξτε στο θέμα Αποστολή σελιδοποιημένης αναφοράς για λεπτομέρειες.See Upload a paginated report for details.

Αποστολή μιας σελιδοποιημένης αναφοράς σε έναν διακομιστή αναφορώνUpload the paginated report to a report server

Επίσης, μπορείτε να αποστείλετε τη σελιδοποιημένη αναφορά σας σε έναν διακομιστή Power BI Report Server ή στις Υπηρεσίες αναφοράς του SQL Server 2016 ή σε Report Server 2017.You can also upload your paginated report to a Power BI Report Server or SQL Server Reporting Services 2016 or 2017 report server. Πρώτα πρέπει να προσθέσετε το παρακάτω στοιχείο στο αρχείο σας RsReportServer.config ως πρόσθετη επέκταση δεδομένων.Before you do, you need to add the following item to your RsReportServer.config as an additional data extension. Δημιουργήστε αντίγραφο ασφαλείας στο αρχείο σας RsReportServer.config πριν να κάνετε την αλλαγή, σε περίπτωση που αντιμετωπίσετε τυχόν προβλήματα.Back up your RsReportServer.config file before you make the change, in case you run into any issues.

<Extension Name="ENTERDATA" Type="Microsoft.ReportingServices.DataExtensions.XmlDPConnection,Microsoft.ReportingServices.DataExtensions">
    <Configuration>
        <ConfigName>ENTERDATA</ConfigName>
    </Configuration>
</Extension>

Όταν τελειώσετε την επεξεργασία του αρχείου, η λίστα των υπηρεσιών παροχής δεδομένων στο αρχείο ρύθμισης παραμέτρων πρέπει να μοιάζει ως εξής:After you've edited it, here's what the list of data providers in the config file should look like:

Στιγμιότυπο οθόνης του αρχείου ρύθμισης παραμέτρων RsReportServer.config.

Αυτό είναι όλο – μπορείτε πλέον να δημοσιεύσετε αναφορές που χρησιμοποιούν αυτήν τη νέα λειτουργικότητα στον διακομιστή αναφορών.That’s it – you can now publish reports that use this new functionality to your report server.

Επόμενα βήματαNext steps