Outlook can't set up a new profile by using Exchange Autodiscover for an Exchange Online mailbox in Microsoft 365
Article
02/28/2025
Applies to: Exchange Online
Symptoms
When you try to set up a new mail account for Microsoft 365 by using the Add New Account Wizard in Microsoft Outlook, your Outlook profile isn't automatically set up. Additionally, you receive the following error message when Outlook tries to set up the server settings for your profile:
An encrypted connection to your mail services is not available
When you test by using the Microsoft Remote Connectivity Analyzer, the following error message might be returned:
Autodiscover cannot process the given e-mail address. Only mailboxes and contacts are allowed.
Cause
This problem occurs for one of the following reasons:
The wrong email address was entered on the Auto Account Setup page of the Add New Account Wizard in Outlook.
The required updates for Outlook to automatically connect to Exchange Online aren't installed for the version of Outlook that you're running.
The Autodiscover CNAME record for your domain doesn't exist or isn't set up correctly.
In organizations that use Active Directory synchronization, the mail, mailNickname, displayName , and proxyAddresses attributes aren't set up correctly for the synced user in the on-premises Active Directory.
Note
This article discusses Outlook 2016, Outlook 2013, and Exchange Online. For help with connecting to Exchange Online from a mobile device, see Set up and use Microsoft 365 on your phone or tablet. For help with connecting Outlook to a third-party service, contact your third-party mail provider.
Resolution
Recommended method
Method 1: Run the Classic Outlook Profile Setup troubleshooter in Get Help
Note
The Get Help troubleshooters aren't available for new Outlook for Windows.
If you receive a pop-up window that displays "This site is trying to open Get Help", select Open.
Follow the instructions in the Get Help app to run the troubleshooter.
After the troubleshooter finishes, it displays the results and provides additional information about how to resolve the issue.
Other methods
If you're using a custom domain
If Method 1 doesn't resolve the problem, and if you're using a custom domain with Microsoft 365, use the following methods in the order in which they're listed. If the first method doesn't resolve the problem, go to the next one.
Method 2: Upgrade to the latest version of Outlook
First, make sure that you enter the correct email address and password on the Auto Account Setup page of the Add New Account Wizard in Outlook.
If this method doesn't resolve the problem, go to Method 3.
Method 3: Make sure that the Autodiscover CNAME record is set up correctly
The Autodiscover CNAME record must exist and must be set up correctly. We strongly recommend that you set up Exchange Autodiscover when you're using Outlook to connect to Exchange Online mailboxes. Setting up Autodiscover and other related DNS records is required for Outlook connectivity in Exchange Online. Administrators can use the Domain Troubleshooting Wizard in Microsoft 365 or Microsoft Remote Connectivity Analyzer to confirm that the records are set up correctly.
Use the Domain Troubleshooting Wizard in Microsoft 365
To use the Domain Troubleshooting Wizard in Microsoft 365, follow these steps.
If you have an Exchange hybrid deployment, set up the Autodiscover public DNS records for your existing SMTP domains to point to an on-premises Exchange server. For more information, see Hybrid deployment prerequisites.
Method 4: Make sure that the user's attributes in Active Directory are set correctly
If you have an Exchange hybrid deployment, you can use the Get-RemoteMailbox cmdlet to determine whether the correct attributes are set for the affected user. Common issues occur when a value isn't set for one or more of these attributes. The following example displays the correct attributes to set for the user.
To update these attributes, you can use the Set-RemoteMailbox cmdlet.
After the correct values are set for these attributes, force directory synchronization to occur, and then try to set up the user's email account in Outlook.
If you're not using a custom domain
Method 2: Use the Add New Account Wizard in Outlook
If Method 1 doesn't resolve the problem, and you're not using a custom domain together with Microsoft 365, you can use the Add New Account Wizard in Outlook to set up your Outlook profile by using the default "onmicrosoft.com"-based email address that's associated Exchange Online mailboxes for users when you signed up for Microsoft 365. When you use the Add New Account Wizard to set up a new mail profile, you specify your Microsoft 365 password and your default Microsoft 365 email address in the form of <user>@<domain>.onmicrosoft.com (for example, kim@contoso.onmicrosoft.com).
This method is supported and works for customers who might not plan to have their own vanity or custom domain. This method also supports Autodiscover. If your mailbox server location changes, Outlook is updated accordingly by using the new location of your mailbox server.
More information
Microsoft doesn't support manually setting up a profile in Outlook for connectivity to mailboxes in Exchange Online in Microsoft 365. However, we can help you complete other tasks, such as setting up DNS and Autodiscover records as discussed in Method 2. This method lets you set up your account through the supported methods.
This module examines how clients connect to Microsoft 365. It also provides instruction on how to configure name resolution and Outlook clients, and how to troubleshoot client connectivity.