Hardware requirements for the Microsoft Teams app

All of the requirements in the following sections apply to both the Teams desktop app and the Teams Web app.

Hardware requirements for the Teams desktop app on a Windows PC

Component Requirement
Computer and processor Minimum 1.6 GHz (or higher) (32-bit or 64-bit).
Memory 2.0 GB RAM
Hard disk 3.0 GB of available disk space
Display 1024 x 768 screen resolution
Graphics hardware Minimum of 128 MB graphics memory
Operating system Windows 10, Windows 8.1, or Windows 7 Service Pack 1 in 32-bit and 64-bit. For the best experience, use the latest version of any operating system.
.NET version Requires .NET 4.5 CLR or later
Video USB 2.0 video camera
Devices Standard laptop camera, microphone, and speakers
Video calls and meetings
  • For a better experience with video calls and online meetings, we recommend using a computer that has a 2.0 GHz processor and 4.0 GB RAM (or higher).
  • The optional Blur my background video effect requires a processor with Advanced Vector Extensions 2 (AVX2) support. See Hardware decoder and encoder driver recommendations for a list of unsupported decoders and encoders.
  • Joining a meeting using proximity detection in a Microsoft Teams Room requires Bluetooth LE, which requires Bluetooth to be enabled on the client device, and for Windows clients requires the 64-bit Teams client. It's not available on 32-bit Teams clients.
Teams live events If you are producing a Teams live events, we recommend using a computer that has a Core i5 Kaby Lake processor, 4.0 GB RAM (or higher) and hardware encoder. See Hardware decoder and encoder driver recommendations for a list of unsupported decoders and encoders.

Hardware requirements for the Teams desktop app on a Mac

Component Requirement
Processor Minimum Intel processor, Core 2 Duo or higher
Memory 2.0 GB RAM
Hard disk 1.5 GB of available disk space
Display 1280 x 800 or higher resolution
Operating system Mac OS X 10.11 El Capitan or later
Video Compatible webcam
Voice Compatible microphone and speakers, headset with microphone, or equivalent device
Video calls and meetings For better experience with video calls and online meetings, we recommend using a computer that has a 2.0 GHz processor and 4.0 GB RAM (or higher).
  • The optional Blur my background video effect requires a processor with Advanced Vector Extensions 2 (AVX2) support, supported on most late 2013 Mac devices and later. See Hardware decoder and encoder driver recommendations for a list of unsupported decoders and encoders.
  • Joining a meeting using proximity detection in a Microsoft Teams Room is not available on Mac OS.

Hardware requirements for the Teams desktop app on a Linux

Component Requirement
Computer and processor Minimum 1.6 GHz (or higher) (32-bit or 64-bit).
Memory 2.0 GB RAM
Hard disk 3.0 GB of available disk space
Display 1024 x 768 screen resolution
Graphics hardware Minimum of 128 MB graphics memory
Operating system Linux distribution capable of installing DEB or RPM.
Video USB 2.0 video camera
Devices Standard laptop camera, microphone, and speakers
Voice Compatible microphone and speakers, headset with microphone, or equivalent device
Video calls and meetings
  • For better experience with video calls and online meetings, we recommend using a computer that has a 2.0 GHz processor and 4.0 GB RAM (or higher).
  • The optional blur my background video effect requires a processor with Advanced Vector Extensions 2 (AVX2) support, supported on most late 2013 Mac devices and later. See Hardware decoder and encoder driver recommendations for a list of unsupported decoders and encoders.
  • Joining a meeting using proximity detection in a Microsoft Teams Room is not available on Linux.
Supported Linux distributions Ubuntu 16.04 LTS, 18.04 LTS, Fedora 30 Workstation, RHEL 8 Workstation, CentOS 8

Hardware requirements for the Teams app on mobile devices

You can use Teams on these mobile platforms:

  • Android - requires Android 5.0 or later. Compatible with Android phones and tablets.

    Support is limited to the last four major versions of Android. When a new major version of Android is released, the new version and the previous three versions are officially supported.

  • iOS - requires iOS 10.0 or later. Compatible with iPhone, iPad, and iPod touch.

    Support is limited to the two most recent major versions of iOS. When a new major version of iOS is released, the new version of iOS and the previous version are officially supported.

For the best experience with Teams, use the latest version of iOS and Android.

Hardware requirements for the Teams app in a Virtual Desktop Infrastructure (VDI) environment

See Teams for Virtualized Desktop Infrastructure for requirements for running Teams in a virtualized environment.