Uso di R nell'Editor di queryUsing R in Query Editor

È possibile usare R, un linguaggio di programmazione ampiamente utilizzato da analisti e data scientist, nell'Editor di query di Power BI Desktop.You can use R, a programming language widely used by statisticians, data scientists, and data analysts, in the Power BI Desktop Query Editor. L'integrazione di R nell'Editor di query consente di pulire i dati con R ed eseguire operazioni di data shaping e analisi in set di dati, tra cui completamento di dati mancanti, stime e clustering.This integration of R into Query Editor lets you perform data cleansing using R, and perform advanced data shaping and analytics in datasets, including completion of missing data, predictions, and clustering, just to name a few. R è un linguaggio potente e può essere usato nell'Editor di query per preparare il modello di dati e creare report.R is a powerful language, and can be used in Query Editor to prepare your data model and create reports.

Installazione di RInstalling R

Per usare R nell'Editor di query di Power BI Desktop, è necessario installare R nel computer locale.To use R in Power BI Desktop's Query Editor, you need to install R on your local machine. È possibile scaricare e installare R gratuitamente da molte posizioni, tra cui la pagina di download di Revolution Open e il repository CRAN.You can download and install R for free from many locations, including the Revolution Open download page, and the CRAN Repository.

Uso di R nell'Editor di queryUsing R in Query Editor

Per illustrare l'uso di R nell'Editor di query si userà un esempio tratto da un set di dati del mercato azionario, basato su un file CSV che è possibile scaricare qui per seguire la spiegazione.To show how to use R in Query Editor, we'll use an example from a stock market dataset, based on a .CSV file that you can download from here and follow along. Ecco la procedura per questo esempio:The steps for this example are the following:

  1. Prima di tutto, caricare i dati in Power BI Desktop.First, load your data into Power BI Desktop. In questo esempio si caricherà il file EuStockMarkets_NA.csv.In this example we'll load the EuStockMarkets_NA.csv file. Selezionare Recupera dati > CSV nella scheda Home della barra multifunzione in Power BI Desktop.Select Get Data > CSV from the Home ribbon in Power BI Desktop.

  2. Selezionare il file e scegliere Apri. Il file CSV verrà visualizzato nella finestra di dialogo File CSV.Select the file and select Open, and the CSV is displayed in the CSV file dialog.

  3. Una volta caricati, i dati saranno visibili nel riquadro ampi in Power BI Desktop.Once the data is loaded, you'll see it in the Fields pane in Power BI Desktop.

  4. Aprire l'Editor di query selezionando Modifica query nella scheda Home in Power BI Desktop.Open Query Editor by selecting Edit Queries from the Home tab in Power BI Desktop.

  5. Nella scheda Trasforma selezionare Esegui script R. Verrà visualizzato l'editor Esegui script R (illustrato nel passaggio successivo).In the Transform tab, select Run R Script and the Run R Script editor appears (shown in the next step). Si noti che nelle righe 15 e 20 c'è un problema di dati mancanti, così come in altre righe non visibili nell'immagine seguente.Notice that rows 15 and 20 suffer from missing data, as do other rows you can't see in the following image. La procedura seguente mostra come usare R per completare automaticamente le righe.The steps below show how R can (and will) complete those rows for you.

  6. In questo esempio si immetterà il codice script seguente:For this example, we'll enter the following script code:

    library(mice)
    tempData <- mice(dataset,m=1,maxit=50,meth='pmm',seed=100)
    completedData <- complete(tempData,1)
    output <- dataset
    output$completedValues <- completedData$"SMI missing values"
    

    Nota

    Per il corretto funzionamento del codice script precedente, è necessario che nell'ambiente R sia installata la libreria mice.You'll need to have the mice library installed in your R environment for the previous script code to work properly. Per installare mice, eseguire quanto segue nell'installazione di R: | > install.packages('mice')To install mice, run the following in your R installation: | > install.packages('mice')

    Quando viene inserito nella finestra di dialogo Esegui script R, il codice sarà analogo al seguente:When put into the Run R Script dialog, the code looks like the following:

  7. Quando si seleziona OK, l'Editor di query mostra un avviso relativo alla privacy dei dati.When we select OK, Query Editor displays a warning about data privacy.

  8. Per il corretto funzionamento degli script R nel servizio Power BI, è necessario impostare tutte le origini dati su pubblico.For the R scripts to work properly in the Power BI service, all data sources need to be set to public. Per altre informazioni sulle impostazioni di privacy e sulle relative implicazioni, vedere Livelli di privacy.For more information about privacy settings and their implications, see Privacy Levels.

    A questo punto viene visualizzata una nuova colonna nell'area Campi denominata completedValues.Once we do so, we see a new column in the Fields well called completedValues. Si noti che alcuni elementi dati risultano mancanti, ad esempio nelle righe 15 e 18.Notice there are a few missing data elements, such as on row 15 and 18. Nella prossima sezione si vedrà come questo problema viene gestito in R.We'll see how R handles that in the next section.

Con appena cinque righe di script R, l'Editor di query ha inserito i valori mancanti con un modello predittivo.With just five lines of R script, Query Editor filled in the missing values with a predictive model.

Creazione di oggetti visivi da dati di script RCreating visuals from R script data

A questo punto è possibile creare un oggetto visivo per osservare come il codice script R con la libreria mice ha completato i valori mancanti, come mostrato nella figura seguente.Now we can create a visual to see how the R script code using the mice library completed the missing values, as shown in the following image.

Una volta completato l'oggetto visivo e qualsiasi altro oggetto visivo si voglia creare con Power BI Desktop, è possibile salvare il file di Power BI Desktop (che viene salvato con estensione pbix) e quindi usare il modello di dati, compresi gli script R che ne fanno parte, nel servizio Power BI.Once that visual is complete, and any other visuals we might want to create using Power BI Desktop, we can save the Power BI Desktop file (which saves as a .pbix file) and then use the data model, including the R scripts that are part of it, in the Power BI service.

Nota

Se si vuole visualizzare un file con estensione pbix completato con questa procedura,Want to see a completed .pbix file with these steps completed? il file di Power BI Desktop completato usato in questo esempio è disponibile per il download qui.You're in luck - you can download the completed Power BI Desktop file used in these examples right here.

Dopo avere caricato il file con estensione pbix nel servizio Power BI, è necessario eseguire alcuni altri passaggi per abilitare l'aggiornamento dei dati (nel servizio) e per abilitare l'aggiornamento degli oggetti visivi nel servizio (i dati devono accedere a R perché gli oggetti visivi vengano aggiornati).Once you've uploaded the .pbix file to the Power BI service, a couple more steps are necessary to enable data refresh (in the service) and to enable visuals to be updated in the service (the data needs access to R for visuals to be updated). I passaggi aggiuntivi sono i seguenti:The additional steps are the following:

  • Abilitare l'aggiornamento pianificato per il set di dati: per abilitare l'aggiornamento pianificato per la cartella di lavoro che contiene il set di dati con gli script R, vedere Configurazione dell'aggiornamento pianificato, che include anche informazioni su Personal Gateway.Enable scheduled refresh for the dataset - to enable scheduled refresh for the workbook that contains your dataset with R scripts, see Configuring scheduled refresh, which also includes information about Personal Gateway.
  • Installare Personal Gateway: è necessario che sia installato Personal Gateway nel computer in cui si trova il file e in cui è installato R. Il servizio Power BI deve accedere alla cartella di lavoro ed eseguire nuovamente il rendering degli oggetti visivi aggiornati.Install the Personal Gateway - you need a Personal Gateway installed on the machine where the file is located, and where R is installed; the Power BI service must access that workbook and re-render any updated visuals. Sono disponibili altre informazioni su come installare e configurare Personal Gateway.You can get more information on how to install and configure Personal Gateway.

LimitazioniLimitations

Esistono alcune limitazioni per le query che includono script R creati nell'Editor di query:There are some limitations to queries that include R scripts created in Query Editor:

  • Tutte le impostazioni dell'origine dati R devono essere impostate su Pubblico e anche tutti gli altri passaggi di una query creata nell'Editor di query devono essere pubblici.All R data source settings must be set to Public, and all other steps in a query created in Query Editor must also be public. Per ottenere le impostazioni dell'origine dati, in Power BI Desktop selezionare File > Opzioni e impostazioni > Impostazioni origine dati.To get to data source settings, in Power BI Desktop select File > Options and settings > Data source settings.

    Nella finestra di dialogo Impostazioni origine dati selezionare le origini dati e quindi scegliere Modifica autorizzazioni per assicurarsi che il Livello di privacy sia impostato su Pubblico.From the Data Source Settings dialog, select the the data source(s) and then select Edit Permissions... and ensure that the Privacy Level is set to Public.

  • Per abilitare l'aggiornamento pianificato degli oggetti visivi o del set di dati R, è necessario abilitare l'opzione Aggiornamento pianificato e che nel computer che ospita la cartella di lavoro e l'installazione di R sia installato Personal Gateway.To enable scheduled refresh of your R visuals or dataset, you need to enable Scheduled refresh and have a Personal Gateway installed on the computer that houses the workbook and the R installation. Per altre informazioni su entrambi, vedere la sezione precedente di questo articolo, in cui sono riportati collegamenti a informazioni più specifiche.For more information on both, see the previous section in this article, which provides links to learn more about each.

Con R e le query personalizzate si possono eseguire moltissime operazioni, esplorando e modellando i dati per visualizzarli nel modo desiderato.There are all sorts of things you can do with R and custom queries, so explore and shape your data just the way you want it to appear.