Visual Studio 用開発者コマンド プロンプトDeveloper Command Prompt for Visual Studio

Visual Studio 用開発者コマンド プロンプトでは、.NET Framework ツールをもっと簡単に使用できます。Developer Command Prompt for Visual Studio enables you to use .NET Framework tools more easily. それは、特定の環境変数を自動的に設定するコマンド プロンプトです。It's a command prompt that automatically sets specific environment variables. 開発者コマンド プロンプトを開いた後、ildasmclrver などの .NET Framework ツールのコマンドを入力できます。After opening Developer Command Prompt, you can enter the commands for .NET Framework tools such as ildasm or clrver.

必須コンポーネントPrerequisites

コンピューター上でのコマンド プロンプトの検索Search for the command prompt on your machine

Visual Studio のバージョンと、インストールした追加の SDK およびワークロードに応じて、複数のコマンド プロンプトがある場合があります。You may have multiple command prompts, depending on the version of Visual Studio and any additional SDKs and workloads you've installed. 次の手順でうまくいかない場合は、マシン上のファイルを手動で探すか、Visual Studio 内からコマンド プロンプトを開始してみることができます。If the following steps don't work, you can try to manually locate the files on your machine or start the command prompt from inside Visual Studio.

Windows 10Windows 10

  1. スタート キーボードの Windows ロゴ キーを選択し、Select Start Windows logo key on the keyboard. 文字 V までスクロールします。and scroll to the letter V.

  2. [Visual Studio 2019] フォルダーを展開します。Expand the Visual Studio 2019 folder.

  3. VS 2019 用開発者コマンド プロンプト (または、使用するコマンド プロンプト) を選択します。Choose Developer Command Prompt for VS 2019 (or the command prompt you want to use).

    また、最初にタスク バーの [検索] ボックスにコマンド プロンプトの名前を入力することもできます。その名前と一致するコマンド プロンプトが結果一覧に表示されたら、その中から必要なものを選択します。Alternatively, you can start typing the name of the command prompt in the search box on the taskbar, and choose the result you want as the result list starts to display the search matches.

    Windows 10 での検索動作を示すアニメーション GIF

Windows 8.1Windows 8.1

  1. キーボードの Windows ロゴ キー キーボードの Windows ロゴ キー を押すなどして、 [スタート] 画面にGo to the Start screen, by pressing the Windows logo key Windows logo key on the keyboard. 移動します。on your keyboard for example.

  2. [スタート] 画面で、Ctrl+Tab キーを押して [アプリ] の一覧を開き、V を押します。インストールされているすべての Visual Studio コマンド プロンプトが含まれた一覧が表示されます。On the Start screen, press Ctrl+Tab to open the Apps list, and then press V. This brings up a list that includes all installed Visual Studio command prompts.

  3. VS 2019 用開発者コマンド プロンプト (または、使用するコマンド プロンプト) を選択します。Choose Developer Command Prompt for VS 2019 (or the command prompt you want to use).

Windows 7Windows 7

  1. [スタート] を選択し、 [すべてのプログラム] を展開します。Choose Start and then expand All Programs.

  2. [Visual Studio 2019] > [Visual Studio Tools] > VS 2019 用開発者コマンド プロンプト、または使用するコマンド プロンプトを選択します。Choose Visual Studio 2019 > Visual Studio Tools > Developer Command Prompt for VS 2019, or the command prompt you want to use.

    コマンド プロンプトが強調表示されている Windows 7 の [スタート] メニュー

Windows 10 SDKそれ以前のバージョンなど、他の SDK がインストールされている場合は、コマンド プロンプトがさらに表示されることがあります。If you have other SDKs installed, such as the Windows 10 SDK or previous versions, you may see additional command prompts. 各ツールのドキュメントを参照して、どのバージョンのコマンド プロンプトを使用する必要があるかを確認してください。Check the documentation for the individual tools to determine which version of the command prompt you should use.

コンピューター上のファイルを手動で探すManually locate the files on your machine

インストール済みのコマンド プロンプトのショートカットは、通常、Visual Studio 用の スタート メニュー フォルダー ( %ProgramData%\Microsoft\Windows\Start Menu\Programs\Visual Studio 2019\Visual Studio Tools 内など) にあります。Usually, the shortcuts for the command prompts you have installed are placed at the Start Menu folder for Visual Studio, such as in %ProgramData%\Microsoft\Windows\Start Menu\Programs\Visual Studio 2019\Visual Studio Tools. ただし、コマンド プロンプトを探しても、何らかの理由によって期待した結果を生成されない場合は、コンピューター上でそのショートカットを手動で探すことができます。But if, for some reason, searching for the command prompt doesn't produce the expected results, you can try to manually locate the shortcut on your machine. VsDevCmd.bat などのコマンド プロンプトのファイル名を検索するか、または Tools フォルダー ( %ProgramFiles(x86)%\Microsoft Visual Studio\2019\Community\Common7\Tools など) に移動します (パスは、Visual Studio のバージョン、エディション、およびインストール先に応じて変わります)。Try searching for the name of the command prompt file, such as VsDevCmd.bat, or go to the Tools folder, such as %ProgramFiles(x86)%\Microsoft Visual Studio\2019\Community\Common7\Tools (path changes according to your Visual Studio version, edition, and installation location).

Visual Studio 内からコマンド プロンプトを開始するStart the command prompt from inside Visual Studio

簡単にアクセスできるように、開発者コマンド プロンプトまたは他のコマンド プロンプトを Visual Studio の [ツール] メニューに追加できます。For easier access, you can add Developer Command Prompt, or any other command prompt, to the Tools menu in Visual Studio. ツールを使用できるようにするには、外部ツール一覧にそれを追加します。To make the tool available, add it to the external tools list. 次に手順を示します。Here are the steps:

  1. Visual Studio を開きます。Open Visual Studio.

  2. スタート ウィンドウで、 [コードなしで続行] を選択します。On the start window, choose Continue without code.

  3. メニュー バーで [ツール] > [外部ツール] の順に選択します。On the menu bar, choose Tools > External Tools.

  4. [外部ツール] ダイアログ ボックスで、 [追加] ボタンをクリックします。On the External Tools dialog box, choose the Add button. 新しいエントリが表示されます。A new entry appears.

  5. 新しいメニュー項目の [タイトル] を入力します (「Command Prompt」など)。Enter a Title for your new menu item such as Command Prompt.

  6. [コマンド] フィールドに、起動するファイル (%comspec%C:\Windows\System32\cmd.exe など) を指定します。In the Command field, specify the file you want to launch, such as %comspec% or C:\Windows\System32\cmd.exe.

  7. [引数] フィールドに、使用する特定のコマンド プロンプトのある場所を指定します (/k "C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\Common7\Tools\VsDevCmd.bat" など)。In the Arguments field, specify where to find the specific command prompt you want to use, such as /k "C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\Common7\Tools\VsDevCmd.bat". このコマンドによって、Visual Studio 2019 Community でインストールされた開発者コマンド プロンプトが起動します。This command launches the Developer Command Prompt that's installed with Visual Studio 2019 Community. この値は、Visual Studio のバージョン、エディション、インストール先に応じて変更します。Change this value according to your Visual Studio version, edition, and installation location.

  8. [初期ディレクトリ] フィールドで、コマンド プロンプトが開始するディレクトリを指定します。In the Initial directory field, specify the directory in which the command prompt will start. フィールドの横にある矢印を選択して、 [プロジェクト ディレクトリ] などの値を選択します。Choose a value such as Project Directory by selecting the arrow next to the field.

  9. [OK] を選択します。Choose the OK button.

    フィールドに値が入力された [外部ツール] ダイアログ。

    新しいメニュー項目が追加され、このコマンド プロンプトに [ツール] メニューからアクセスできるようになります。The new menu item is added, and you can access the command prompt from the Tools menu.

    Visual Studio でのコマンド プロンプト メニュー項目

関連項目See also