復元ポイントに暗号化されたコンテンツがある場合、システムの復元はエラー コード0x8007045bで失敗する可能性があります

この記事では、エラー コード 0x8007045bでシステムの復元が失敗する可能性がある問題の回避策について説明します。

適用対象: Windows 10 - すべてのエディション
元の KB 番号: 3074925

現象

次のような状況で問題が発生します。

  • Windows 8.1またはWindows 8でメール アプリケーションを使用しています。
  • メール アプリケーションを使用して、Microsoft Exchange またはメール サーバーに接続Microsoft Office 365。 (これを行うには、メール サーバーから適用される [PC のセキュリティを強化 する] セキュリティ ポリシーを受け入れる必要があります)。
  • 次のいずれかのアクションを実行します。
    • Windows のシステム復元プログラムを使用して、いくつかの復元ポイントを作成します。
    • システムによって自動的に作成された復元ポイントを使用しようとするとします。
  • 強制的なセキュリティを受け入れた後、復元ポイントのいずれかにシステムを復元しようとするとします。

このシナリオでは、システムの復元が失敗する可能性があり、システムの再起動後に次のようなエラー メッセージが表示されます。

システムの復元が正常に完了しませんでした。 コンピューターのシステム ファイルと設定が変更されませんでした。

詳細:

システムの復元でファイルを抽出できませんでした

C:\Users<ユーザー名>\AppData\Local\Packages\microsoft.windowscommunicationsapps_8wekyb3d8bbwe....

復元ポイントから。

システムの復元中に予期しないエラーが発生しました。 (0x8007045b)

原因

この問題は、システム復元プログラムの既知の問題が原因で発生します。

Exchange または Office 365 サーバーに接続するようにメール アプリケーションを構成し、[PC をより安全なセキュリティ ポリシーにする] を受け入れると、ユーザー プロファイル内の一部のファイルは暗号化ファイル システム (EFS) を使用して暗号化されます。 これらのファイルは、システムの復元を使用して復元ポイントを作成する場合、復元ポイントに含まれます。 システムの復元プログラムを起動してシステムを復元すると、システムの復元によって、実際の復元作業を行うためのシャットダウン タスクが作成されます。 このタスクが実行されている場合、ほとんどのシステム サービスは既に停止しています。 これには EFS が含まれます。

ただし、復元ポイントで EFS によって暗号化されているファイルがある場合、復元ポイントからこの種のファイルを抽出するには、システム復元プログラムが EFS サービスを呼び出す必要があります。 ただし、EFS サービスは既に停止しており、システムがシャットダウンしているため再起動できないため、復元プロセスはエラー コード 0x8007045bで失敗します。 このコードは、ERROR_SHUTDOWN_IN_PROGRESSを意味します。

回避策

この問題を回避するには、次の手順に従ってWindows REに再起動してから、システムの復元プログラムを実行します。

  1. 管理者としてコマンド プロンプトを開き、次のコマンドを実行します。

    reagentc /boottore
    

    注:

    このコマンドが無効になっているWindows REエラーを返す場合は、次のコマンドを実行してインストールしてから、もう一度実行reagentc /enableします。

  2. コンピューターを再起動します。 コンピューターがWindows RE環境に再起動します。

  3. Windows REで、[トラブルシューティング] をクリックし、[詳細オプション] をクリックし、[システムの復元] をクリックし、プロンプトに従ってシステムの復元プログラムを起動します。 EFS は常にWindows REで実行されており、Windows REで復元作業を実行するためにシステムの復元タスクを作成する必要がないため、この特定の問題はWindows REでは発生しません。 REAgentC コマンドの詳細については、「 REAgentC Command-Line オプション」を参照してください。