復元ポイントに暗号化されたコンテンツがある場合、エラー コード 0x8007045bでシステムの復元が失敗する可能性がある

この記事では、システムの復元がエラー コード0x8007045bで失敗する可能性がある問題の回避策について説明します。

適用対象: Windows 10 - すべてのエディション
元の KB 番号: 3074925

現象

以下のシナリオについて考えてみます。

  • Windows 8.1 または Windows 8 でメール アプリケーションを使用している。
  • メール アプリケーションを使用して、Microsoft Exchange または Microsoft Office 365 メール サーバーに接続する場合。 (これを行うには、 を受け入れる必要がありますPC のセキュリティを強化 メール サーバーから適用されるセキュリティ ポリシー)。
  • 次のいずれかのアクションを実行します。
    • Windows のシステム復元プログラムを使用して、いくつかの復元ポイントを作成します。
    • システムによって自動的に作成された復元ポイントを使用しようとするとします。
  • 適用されたセキュリティを受け入れた後、システムを復元ポイントのいずれかに戻そうとします。

このシナリオでは、システムの復元が失敗し、システムの再起動後に次のようなエラー メッセージが表示されます。

システムの復元が正常に完了しませんでした。 コンピューターのシステム ファイルと設定が変更されませんでした。

詳細:

システムの復元でファイルを抽出できませんでした

C:\Users<User Name>\AppData\Local\Packages\microsoft.windowscommunicationsapps_8wekyb3d8bbwe....

復元ポイントから。

システムの復元中に予期しないエラーが発生しました。 (0x8007045b)

原因

この問題は、システム復元プログラムの既知の問題が原因で発生します。

Exchange または Office 365 サーバーに接続するようにメール アプリケーションを構成し、 PC のセキュリティを強化 セキュリティ ポリシーを受け入れると、ユーザー プロファイル内の一部のファイルは暗号化ファイル システム (EFS) を使用して暗号化されます。 また、システム復元を使用して復元ポイントを作成する場合、それらのファイルは復元ポイントに含まれます。 システムの復元プログラムを起動してシステムを復元すると、システムの復元によって、実際の復元作業を行うためのシャットダウン タスクが作成されます。 このタスクが実行されている場合、ほとんどのシステム サービスは既に停止しています。 これには EFS が含まれます。

ただし、復元ポイントで EFS によって暗号化されているファイルがある場合、システム復元プログラムは、復元ポイントからこの種のファイルを抽出するために EFS サービスを呼び出す必要があります。 ただし、EFS サービスは既に停止しており、システムがシャットダウンしているため再起動できないため、復元プロセスはエラー コード0x8007045bで失敗します。 このコードはERROR_SHUTDOWN_IN_PROGRESSを意味します。

回避策

この問題を回避するには、次の手順に従って Windows RE に再起動し、システム復元プログラムを実行します。

  1. 管理者としてコマンド プロンプトを開き、次のコマンドを実行します。

    reagentc /boottore
    

    注意

    このコマンドで Windows RE が無効になっている エラーが返された場合は、次のコマンドを実行してインストールし、 reagentc /enable をもう一度実行します。

  2. コンピューターを再起動します。 コンピューターが Windows RE 環境に再起動します。

  3. Windows RE で、 をクリックしてをクリック Advanced オプションをクリックし、 システム復元をクリックし、プロンプトに従ってシステム復元プログラムを起動します。 EFS は常に Windows RE で実行されており、Windows RE で復元作業を実行するためにシステム復元でシャットダウン タスクを作成する必要がないため、この特定の問題は Windows RE では発生しません。 REAgentC コマンドの詳細については、「 REAgentC コマンド ライン オプションを参照してください。