Visual Studio と Unity を使ってみるGet started with Visual Studio and Unity

注意

このガイドでは、unity Hub プログラムを使用して Unity が既にインストールされていることを前提としています。This guide assumes you already have installed Unity using the Unity Hub program. Unity を初めて使用する場合は、unity の学習と、 unity でのはじめにに関するチュートリアル を最初に実行することをお勧めします。If you are new to Unity, we recommend visiting Unity Learn and complete the Getting Started with Unity tutorial first.

Unity support for Visual Studio のインストールInstall Unity support for Visual Studio

Visual Studio Tools for Unity は、C# などの記述とデバッグをサポートする無料の拡張機能です。Visual Studio Tools for Unity is a free extension that provides support for writing and debugging C# and more. 拡張機能に含まれる内容の完全な一覧については、 「Tools For Unity の概要」 を参照してください。Visit the Tools for Unity overview for a complete list of what the extensions includes.

注意

このインストールガイドは、Visual Studio を対象としています。This installation guide is for Visual Studio. Visual Studio Code を使用している場合は、 VS Code のドキュメントを使用した Unity 開発に関するページを参照してください。If you're using Visual Studio Code, please visit the Unity Development with VS Code documentation.

  1. Visual Studio インストーラーをダウンロードするか、既にインストールされている場合は実行します。Download the Visual Studio installer, or run it if already installed.

  2. [変更] をクリックします (既にインストールされている場合)。または、 [インストール] をクリックして、目的のバージョンの Visual Studio をインストールします (新規インストール)。Click Modify (if already installed) or Install (for new installations) for your desired version of Visual Studio.

  3. [ ワークロード ] タブで、[ ゲーム ] セクションまでスクロールし、[ Unity を使用したゲーム開発 ] ワークロードを選択します。On the Workloads tab, scroll to the Gaming section and select the Game development with Unity workload.

    インストーラーの [Unity を使用したゲーム開発] ワークロードボックス

注意

このインストールガイドは Visual Studio for Mac を対象としています。This installation guide is for Visual Studio for Mac. Visual Studio Code を使用している場合は、 VS Code のドキュメントを使用した Unity 開発に関するページを参照してください。If you're using Visual Studio Code, please visit the Unity Development with VS Code documentation.

Tools for Unity は Visual Studio for Mac のインストールに含まれており、個別のインストール手順は必要ありません。Tools for Unity is included with the installation of Visual Studio for Mac and no separate installation steps are required. これは、[ Visual Studio for Mac > 拡張機能 > ゲーム開発 ] メニューで確認できます。You can verify this in the Visual Studio for Mac > Extensions > Game Development menu. Visual Studio for Mac Tools For Unity が有効になっている必要があります。Visual Studio for Mac Tools for Unity should be enabled.

Visual Studio for Mac Tools for Unity が有効になっている拡張機能マネージャービュー

更新プログラムをチェックするCheck for updates

最新のバグ修正、機能、および Unity サポートを利用できるように、Visual Studio と Visual Studio for Mac を更新しておくことをお勧めします。It's recommended to keep Visual Studio and Visual Studio for Mac updated so you have the latest bug fixes, features, and Unity support. これには、Unity バージョンの更新は必要ありません。This doesn't require an update of Unity versions.

  1. [ ヘルプ > [更新プログラムの確認 ] メニューをクリックします。Click the Help > Check for Updates menu.

    Visual Studio 2019 の [更新プログラムの確認] メニュー

  2. 利用可能な更新プログラムがある場合は、Visual Studio インストーラーに新しいバージョンが表示されます。If there is an update available, the Visual Studio Installer will show a new version. [更新] ボタンをクリックします。Click the Update button.

  1. [ Visual Studio for Mac > [更新プログラムの確認 ] メニューをクリックして、 Visual Studio の更新 ダイアログを開きます。Click the Visual Studio for Mac > Check for Updates... menu to open the Visual Studio Update dialog.
  2. 利用可能な更新プログラムがある場合は、[ インストール ] ボタンをクリックします。If there is an update available, click the Install button.

Visual Studio を使用するように Unity を構成するConfigure Unity to use Visual Studio

既定では、Unity は、Visual Studio または Visual Studio for Mac をスクリプトエディターとして使用するように構成されている必要があります。By default, Unity should already be configured to use Visual Studio or Visual Studio for Mac as a script editor. これを確認するか、Unity エディターから外部スクリプトエディターを Visual Studio の特定のバージョンに変更することができます。You can confirm this or change the external script editor to a specific version of Visual Studio from the Unity Editor.

  1. Unity エディターで、[ > 設定の編集 ] メニューを選択します。In the Unity Editor, select the Edit > Preferences menu..

  2. 左側の [ 外部ツール ] タブを選択します。Select the External Tools tab on the left.

  3. [ 外部スクリプトエディター ] ドロップダウンリストには、Visual Studio のさまざまなインストールを選択する方法が用意されています。The External Script Editor dropdown list provides a way to choose different installations of Visual Studio. ドロップダウンリストから [ 参照... ] をクリックして、一覧にないバージョンを追加することもできます。You can also click Browse... from the dropdown list to add an unlisted version.

    Windows 上の Unity エディターの [外部ツール] 基本設定メニュー

  4. [Browse...](参照...) を選択した場合は、Visual Studio インストール ディレクトリの中の Common7/IDE ディレクトリに移動し、devenv.exe を選択します。If Browse... was selected, navigate to the Common7/IDE directory inside your Visual Studio installation directory and select devenv.exe. 次に、[ 開く] をクリックします。Then, click Open.

  5. [External Script Editor](外部スクリプト エディター) の一覧から Visual Studio を選択した後、 [Editor Attaching](エディターのアタッチ) チェックボックスがオンになっていることを確認します。Once Visual Studio is selected in the External Script Editor list, confirm that the Editor Attaching checkbox is selected.

  6. [Preferences](ユーザー設定) ダイアログを閉じて、構成プロセスを完了します。Close the Preferences dialog to complete the configuration process.

  1. Unity エディターで、[ unity > 基本設定 ] メニューを選択します。In the Unity Editor, select the Unity > Preferences menu..

  2. 左側の [ 外部ツール ] タブを選択します。Select the External Tools tab on the left.

  3. [ 外部スクリプトエディター ] ドロップダウンリストには、Visual Studio のさまざまなインストールを選択する方法が用意されています。The External Script Editor dropdown list provides a way to choose different installations of Visual Studio. ドロップダウンリストから [ 参照... ] をクリックして、一覧にないバージョンを追加することもできます。You can also click Browse... from the dropdown list to add an unlisted version.

    MacOS の Unity エディターの [外部ツール] 基本設定メニュー

  4. [Preferences](ユーザー設定) ダイアログを閉じて、構成プロセスを完了します。Close the Preferences dialog to complete the configuration process.

次のステップNext steps

Visual Studio で Unity プロジェクトを操作およびデバッグする方法については、 Visual Studio Tools for Unity の使用に関するページを参照してください。To learn how to work with and debug your Unity project in Visual Studio, visit Using Visual Studio Tools for Unity.