方法: Visual Studio での Office プロジェクトを作成します。How to: Create Office projects in Visual Studio

使用することができますVisual StudioVisual StudioVSTO アドインとドキュメント レベルの作成に Microsoft Office アプリケーション用のカスタマイズ。You can use Visual StudioVisual Studio to create VSTO Add-in and document-level customizations for Microsoft Office applications. これらの種類のプロジェクトの詳細については、次を参照してください。 Office ソリューション開発の概要(VSTO)します。For more information about these types of projects, see Office solutions development overview (VSTO).

適用対象: このトピックの情報は、ドキュメントに適用されます-レベルのプロジェクトおよび VSTO 追加-プロジェクト。Applies to: The information in this topic applies to document-level projects and VSTO Add-in projects. 参照してくださいOffice アプリケーションおよびプロジェクトの種類で使用できる機能します。See Features available by Office application and project type.

Note

次の手順で参照している Visual Studio ユーザー インターフェイス要素の一部は、お使いのコンピューターでは名前や場所が異なる場合があります。Your computer might show different names or locations for some of the Visual Studio user interface elements in the following instructions. これらの要素は、使用している Visual Studio のエディションや独自の設定によって決まります。The Visual Studio edition that you have and the settings that you use determine these elements. 詳細については、「Visual Studio IDE のカスタマイズ」を参照してください。For more information, see Personalize the IDE.

VSTO アドイン プロジェクトを作成するにはTo create a VSTO Add-in project

  1. [ファイル] メニューで、[新規] > [プロジェクト] の順に選択します。On the File menu, choose New > Project. 使用するかどうか、統合開発環境 (IDE) が設定されますVisual BasicVisual Basic開発設定のファイル] メニューの [選択新規 > プロジェクトします。If your integrated development environment (IDE) is set to use Visual BasicVisual Basic development settings, on the File menu, choose New > Project.

    [新しいプロジェクト] ダイアログ ボックスが表示されます。The New Project dialog box appears.

    Note

    既定では、Office プロジェクトは .NET Framework 4.5.NET Framework 4.5 を対象とします。Office projects target the .NET Framework 4.5.NET Framework 4.5 by default. 詳細については、次を参照してください。 .NET Framework クライアント プロファイルします。For more information, see .NET Framework client profile.

  2. 展開テンプレート ペインで、使用する言語のノードの下でOffice/sharepointします。In the templates pane, under the node for the language you want to use, expand Office/SharePoint.

  3. 選択、 Office アドインノード。Choose the Office Add-ins node.

  4. プロジェクト テンプレートの一覧で、VSTO アドイン プロジェクト テンプレートを選択します。In the list of project templates, select a VSTO Add-in project template. 使用可能な VSTO アドイン プロジェクト テンプレートの一覧は、次を参照してください。 Office プロジェクト テンプレートの概要します。For a list of available VSTO Add-in project templates, see Office project templates overview.

    Note

    選択してもプロジェクト テンプレートが表示されない場合、 Office アドインノード、ことを確認します .NET Framework 4または後で、ダイアログ ボックスの上部にあるコンボ ボックスで選択されています。If project templates are not visible when you select the Office Add-ins node, make sure that .NET Framework 4 or later is selected in the combo box at the top of the dialog box. Office プロジェクト テンプレートは、.NET Framework の両方のバージョンで表示されます。Office project templates are visible for both versions of the .NET Framework.

  5. 名前ボックスに、プロジェクトの名前を入力します。In the Name box, type a name for the project. 既定では、このプロジェクト名がソリューション名としても使用されます。By default, the project name is also used as the solution name.

  6. 場所ボックスに、プロジェクトを作成するパスを入力します。In the Location box, enter the path where you want to create the project. 絶対パスと UNC (Universal Naming Convention) パスを使用できます。You can use absolute and universal naming convention (UNC) paths. HTTP、FTP、またはその他のプロトコル パスは使用しないでください。Do not use HTTP, FTP, or other protocol paths.

    場所は、次の形式で指定します。Locations have the following formats:

    • [ドライブ]:[drive]:

    • \\Server\共有\\Server\Share

      次の文字は使用しないでください。Do not use these characters in the location:

    • アスタリスク (*)Asterisk (*)

    • 縦棒 (|)Vertical bar (|)

    • コロン (:) (ドライブ文字の後に使用する場合は除く)Colon (:) (Except following the drive letter.)

    • 二重引用符 (") (スペースを含むパスには引用符は不要)Double quotation mark (") (Paths that contain spaces do not need quotation marks.)

    • より小さい (<)Less than (<)

    • 大なり (>)Greater than (>)

    • 疑問符 (?)Question mark (?)

    • パーセント記号 (%)Percent sign (%)

  7. [OK] を選択します。Choose the OK button.

    Note

    アドイン プロジェクトを作成すると、必ず保存されます。Add-in projects are always saved when they are created. アドイン プロジェクトを一時プロジェクトとして作成することはできません。They cannot be created as temporary projects. 一時プロジェクトの詳細については、次を参照してください。一時プロジェクトします。For more information about temporary projects, see Temporary projects.

ドキュメント レベルのカスタマイズ プロジェクトを作成するにはTo create a document-level customization project

  1. [ファイル] メニューで、[新規] > [プロジェクト] の順に選択します。On the File menu, choose New > Project. Visual Basic 開発設定を使用するかどうか、IDE が設定されます、ファイル] メニューの [選択新規 > プロジェクトします。If your IDE is set to use Visual Basic development settings, on the File menu, choose New > Project.

    [新しいプロジェクト] ダイアログ ボックスが表示されます。The New Project dialog box appears.

  2. 展開テンプレート ペインで、使用する言語のノードの下でOffice/sharepointします。In the templates pane, under the node for the language you want to use, expand Office/SharePoint.

  3. [Office アドイン] ノードを選択します。Select the Office Add-ins node.

  4. プロジェクト テンプレートの一覧で、ドキュメント レベルのプロジェクト テンプレートを選択します。In the list of project templates, select a document-level project template. 使用できるドキュメント レベルのプロジェクト テンプレートの一覧は、次を参照してください。 Office プロジェクト テンプレートの概要します。For a list of available document-level project templates, see Office project templates overview.

    Note

    選択してもプロジェクト テンプレートが表示されない場合、 Office アドインノード、ことを確認します .NET Framework 4または後で選択されています。If project templates are not visible when you select the Office Add-ins node, make sure that .NET Framework 4 or later is selected.

  5. 名前ボックスに、プロジェクトの名前を入力します。In the Name box, type a name for the project. 既定では、この名前がドキュメントにも使用されます。By default, this name is also used for the document. IDE が Visual C# 開発設定または一般的な開発設定を使用するように設定されている場合は、場所とソリューション名も入力します。If your IDE is set to use Visual C# development settings or General development settings, also enter a location and solution name.

    Note

    プロジェクトの場所へのパス、またはプロジェクト名には、サロゲート文字を使用できません。You cannot use surrogate characters in the path of the project location or in the project name. また、オフラインで使用するソリューションを配置する場合は、プロジェクト名に HTTP プロトコルの仕様に準拠した文字を使用する必要があります。Also, if you plan to deploy the solution for use offline, the characters in the project name must fit the HTTP protocol specifications.

  6. [OK] を選択します。Choose the OK button.

    Visual Studio Tools for Office プロジェクト ウィザード が開きます。The Visual Studio Tools for Office Project Wizard opens.

  7. 選択新しい文書を作成ソリューションでは、新しいドキュメントを作成または選択するかどうか既存のドキュメントをコピーを既存のドキュメントをカスタマイズする場合。Select Create a new document if you want to create a new document for the solution, or select Copy an existing document if you want to customize an existing document.

    新しいドキュメントを作成する場合は、内の名前を指定、名前ボックスし、ドキュメントの形式を使用して、形式ボックス。If you create a new document, specify the name in the Name box and select the format of the document by using the Format box. 使用可能な形式の詳細については、次を参照してください。のドキュメント レベル カスタマイズのアーキテクチャします。For more information about the available formats, see Architecture of document-level customizations.

    既存のドキュメントを使用する場合は、ドキュメントの場所を指定、 、既存のドキュメントの完全なパスボックス。If you use an existing document, specify the location of the document in the Full path of the existing document box. 使用できるパスは、絶対パスと UNC パスです。You can use absolute and UNC paths. ドキュメントへの HTTP パス、FTP パス、または他のプロトコル パスは使用しないでください。Do not use HTTP, FTP, or other protocol paths to the document.

    場所は、次の形式で指定します。Locations have the following formats:

    • [ドライブ]:[drive]:

    • \\Server\共有\\Server\Share

      次の文字は使用しないでください。Do not use these characters in the location:

    • アスタリスク (*)Asterisk (*)

    • 縦棒 (|)Vertical bar (|)

    • コロン (:) (ドライブ文字の後に使用する場合は除く)Colon (:) (Except following the drive letter.)

    • 二重引用符 (") (スペースを含むパスには引用符は不要)Double quotation mark (") (Paths that contain spaces do not need quotation marks.)

    • より小さい (<)Less than (<)

    • 大なり (>)Greater than (>)

    • 疑問符 (?)Question mark (?)

    • パーセント記号 (%)Percent sign (%)

    Note

    Word 2013Word 2013 プロジェクトで既存のドキュメントを使用する場合は、Word 2013Word 2013 で作成したドキュメントか、この形式に変換したドキュメントだけを使用してください。If you use an existing document in a Word 2013Word 2013 project, only use documents that were created in or converted to Word 2013Word 2013. 同様に、Word 2010 プロジェクトで既存のドキュメントを使用する場合は、Word 2010 で作成したドキュメントか、Word 2010 に変換したドキュメントだけを使用してください。Similarly, if you use an existing document in a Word 2010 project, only use documents that were created in or converted to Word 2010. 以前のバージョンの Word で作成した文書を使用すると、文書の一部の機能が使用できなくなります。Certain features will be disabled in the document if you use a document that was created in an earlier version of Word. このような機能を使用するコードを記述しようとすると、プロジェクトでエラーが発生する可能性があります。If you try to write code that uses these features, you might encounter errors in your project. ドキュメントを変換するでを開きますWord 2013Word 2013または Word 2010 で、ファイルリボンのタブで、選択情報 > 変換します。To convert a document, open it in Word 2013Word 2013 or Word 2010, on the File tab on the ribbon, choose Info > Convert.

  8. [完了] を選択します。Choose Finish.

  9. 次の場合、Word のセキュリティ センターにある信頼できる場所の一覧に、プロジェクト フォルダーとそのサブフォルダーを追加します。Add the project folder and its subfolders to the list of trusted locations in the Trust Center in Word in the following cases:

    • 基づく Word 文書を作成して、 .docm VBA プロジェクトを含むファイル、およびドキュメント、または Windows フォーム コントロールをホストします。You are creating a Word Document that is based on a .docm file, and the document contains a VBA project or hosts Windows Forms controls. プロジェクト フォルダーを信頼できる場所の一覧に追加すると、デザイン時に文書が期待どおりに動作するか確認するのに役立ちます。Adding the project folder to the list of trusted locations will help make sure that the document works as expected at design time.

    • 基づく Word テンプレート プロジェクトを作成して、 .dotxファイル。You are creating a Word Template project that is based on a .dotx file. プロジェクトを実行およびデバッグできるようにするために、プロジェクト フォルダーを信頼できる場所の一覧に追加する必要があります。You must add the project folder to the list of trusted locations so that you can run and debug the project.

      信頼できる場所にドキュメントを追加する方法の詳細については、Microsoft Office Online web サイトを参照してください。作成、削除、または変更、ファイルに対して信頼できる場所します。For more information on how to add a document to the trusted locations, see the Microsoft Office Online web site Create, remove, or change a trusted location for your files.

関連項目See also