코드 편집기에서 코드 작성Write code in the code editor

Visual Studio 편집기에서는 코드 및 텍스트를 더 쉽게 작성 및 관리할 수 있는 다양한 기능을 제공합니다.The Visual Studio editor provides many features that make it easier for you to write and manage your code and text. 개요를 사용하여 여러 코드 블록을 확장 및 축소할 수 있습니다.You can expand and collapse different blocks of code by using outlining. IntelliSense, 개체 브라우저및 호출 계층 구조를 사용하여 코드에 대해 자세히 알아볼 수 있습니다.You can learn more about the code by using IntelliSense, the Object Browser, and the Call Hierarchy. 이동, 정의로 이동, 및 모든 참조 찾기 등의 기능을 사용하여 코드를 찾을 수 있습니다.You can find code by using features such as Go To, Go To Definition, and Find All References. 코드 조각이 있는 코드 블록을 삽입할 수 있고 사용법에서 생성과 같은 기능을 사용하여 코드를 생성할 수 있습니다.You can insert blocks of code with code snippets, and you can generate code by using features such as Generate From Usage. 이전에 Visual Studio 편집기를 사용한 적이 없을 경우 빠른 개요를 보려면 코드 편집 을 참조하세요.If you have never used the Visual Studio editor before, see Editing Your Code for a quick overview.

다양한 방법으로 코드를 볼 수 있습니다.You can view your code in a number of different ways. 기본적으로 솔루션 탐색기는 파일별로 구성된 코드를 보여 줍니다.By default, Solution Explorer shows your code organized by files. 창 아래쪽의 클래스 뷰 탭을 클릭하여 클래스별로 구성된 코드를 볼 수 있습니다.You can click on the Class View tab at the bottom of the window to view your code organized by classes.

단일 파일이나 여러 파일에서 텍스트를 검색하고 바꿀 수 있습니다.You can search and replace text in single or multiple files. 자세한 내용은 텍스트 찾기 및 바꾸기를 참조하세요.For more information, see Finding and Replacing Text. 정규식을 사용하여 텍스트를 찾고 바꿀 수 있습니다.You can use regular expressions to find and replace text. 자세한 내용은 Visual Studio에서 정규식 사용을 참조하세요.For more information, see Using Regular Expressions in Visual Studio.

다양한 Visual Studio 언어가 다양한 기능 집합을 제공하고 경우에 따라 기능은 언어별로 다르게 동작합니다.The different Visual Studio languages offer different sets of features, and in some cases the features behave differently in different languages. 이들 차이점은 대부분 기능 설명에 지정되지만 자세한 내용은 특정 Visual Studio 언어에 대한 섹션에서 확인할 수 있습니다.Many of these differences are specified in the descriptions of the features, but for more information you can see the sections on specific Visual Studio languages.

중요

사용 중인 Visual Studio 버전 및 설정이 IDE의 기능에 영향을 줄 수 있습니다.The Visual Studio edition and the settings you are using may affect the features in the IDE. 이 항목에 설명된 내용과 다를 수 있습니다.They might differ from those described in this topic.

편집기 기능Editor Features

구문 색 지정Syntax Coloring 코드 및 태그 파일의 일부 구문 요소에는 구분을 위해 다른 색이 지정됩니다.Some syntax elements of code and markup files are colored differently to distinguish them. 예를 들어 키워드(예: C#의 using 및 Visual Basic의 Imports )는 한 색이지만 형식(예: ConsoleUri)은 다른 색입니다.For example, keywords (such as using in C# and Imports in Visual Basic) are one color, but types (such as Console and Uri) are another color. 문자열 리터럴 및 주석과 같은 기타 구문 요소에도 색이 지정됩니다.Other syntax elements are also colorized, such as string literals and comments. C++에서는 색을 사용하여 기타 토큰 사이에서 형식, 열거형 및 매크로를 구분합니다.C++ uses color to differentiate among types, enumerations, and macros, among other tokens.

각 형식의 기본 색을 확인할 수 있고 도구메뉴에서 열 수 있는 Fonts and Colors, Environment, Options Dialog Box 에서 특정 구문 요소의 색을 변경할 수 있습니다.You can see the default color for each type, and you can change the color for any specific syntax element in the Fonts and Colors, Environment, Options Dialog Box, which you can open from the Tools menu.
오류 및 경고 표식Error and Warning Marks 코드를 추가하고 솔루션을 빌드할 때 코드에는 (a) 다른 색이 지정된 물결 무늬 밑줄(물결선) 또는 (b) 전구가 나타납니다.As you add code and build your solution, you may see (a) different-colored wavy underlines (known as squiggles) or (b) light bulbs appearing in your code. 빨간색 물결선은 구문 오류를 나타내고, 파란색 물결선은 컴파일러 오류를 나타내고, 녹색 물결선은 경고를 나타내고, 자주색 물결선은 기타 유형 오류를 나타냅니다.Red squiggles denote syntax errors, blue denotes compiler errors, green denotes warnings, and purple denotes other types of errors. 전구 는 문제에 대한 수정 내용을 제안하고 수정 내용을 쉽게 적용할 수 있도록 합니다.Light bulbs suggest fixes for problems and make it easy to apply the fix.

도구/옵션/환경/글꼴 및 색 대화 상자에서 각 오류 및 경고 물결선의 기본 색을 확인할 수 있습니다.You can see the default color for each error and warning squiggle in the Tools/Options/Environment/Fonts and Colors dialog box. 구문 오류, 컴파일러 오류, 경고기타 오류를 찾아보세요.Look for Syntax Error, Compiler Error, Warning, and Other Error.
중괄호 일치Brace Matching 코드 파일에서 삽입 지점이 여는 괄호에 배치되면 여는 괄호와 닫는 괄호가 강조 표시됩니다.When the insertion point is placed on an open brace in a code file, both it and the closing brace are highlighted. 이 기능을 통해 잘못 배치되거나 누락된 괄호를 즉시 파악할 수 있습니다.This feature gives you immediate feedback on misplaced or missing braces. 자동 구분 기호 강조 표시 설정(도구/옵션/텍스트 편집기)으로 중괄호 일치를 설정하거나 해제할 수 있습니다.You can turn brace matching on or off with the Automatic Delimiter Highlighting setting (Tools/Options/Text Editor). 글꼴 및 색 설정(도구/옵션/환경)에서 강조 표시 색을 변경할 수 있습니다.You can change the highlight color in the Fonts and Colors setting (Tools/Options/Environment). 중괄호 일치(강조 표시) 또는 중괄호 일치(사각형)를 찾아보세요.Look for Brace Matching (Highlight) or Brace Matching (Rectangle).
구조체 시각화 도우미Structure Visualizer 점선은 코드 파일에서 일치하는 중괄호를 연결하여 열고 닫는 중괄호 쌍을 더욱 쉽게 볼 수 있도록 합니다.Dotted lines connect matching braces in code files, making it easier to see opening and closing brace pairs. 이로써 코드베이스에서 코드를 더욱 빠르게 찾을 수 있습니다.This can help you find code in your codebase more quickly. 도구/옵션/텍스트 편집기/일반 페이지의 디스플레이 섹션에서 구조체 지침 표시를 사용하여 이 줄을 켜고 끌 수 있습니다.You can turn these lines on or off with the Show structure guidelines in the Display section of the Tools/Options/Text Editor/General page.
줄 번호Line Numbers 코드 창의 왼쪽 여백에 줄 번호를 표시할 수 있습니다.Line numbers can be displayed in the left margin of the code window. 줄 번호는 기본적으로 표시되지 않습니다.They are not displayed by default. 텍스트 편집기 모든 언어 설정(도구/옵션/텍스트 편집기/모든 언어)에서 이 옵션을 설정할 수 있습니다.You can turn this option on in the Text Editor All Languages settings (Tools/Options/Text Editor/All Languages). 해당 언어의 설정을 변경하여 개별 프로그래밍 언어의 줄 번호를 표시할 수 있습니다(도구/옵션/텍스트 편집기/<language>).You can display line numbers for individual programming languages by changing the settings for those languages (Tools/Options/Text Editor/<language>). 줄 번호를 인쇄하려면 인쇄 대화 상자에서 줄 번호 포함을 선택해야 합니다.For line numbers to print, you must select Include line numbers in the Print dialog box.
변경 내용 추적Change Tracking 왼쪽 여백의 색을 사용하여 파일에서 수행한 변경을 계속 추적할 수 있습니다.The color of the left margin allows you to keep track of the changes you have made in a file. 파일이 열린 후 변경되었으나 저장되지 않은 내용은 왼쪽 여백(선택 여백)에 노란색 막대로 나타냅니다.Changes you have made since the file was opened but not saved are denoted by a yellow bar on the left margin (known as the selection margin). 변경 내용을 저장하면(파일을 닫기 전) 막대가 녹색으로 바뀝니다.After you have saved the changes (but before closing the file), the bar turns green. 파일을 저장하고 나서 변경을 실행 취소하면 막대가 주황색으로 바뀝니다.If you undo a change after you have saved the file, the bar turns orange. 이 기능을 해제 및 설정하려면 텍스트 편집기 설정( 도구/옵션/텍스트 편집기 )에서변경 내용 추적옵션을 변경합니다.To turn this feature off and on, change the Track changes option in the Text Editor settings (Tools/Options/Text Editor).
코드 및 텍스트 선택Selecting Code and Text 줄 집합이 아니라 텍스트의 사각형 부분을 선택하는 상자 모드 또는 표준 연속 스트림 모드에서 텍스트를 선택할 수 있습니다.You can select text either in the standard continuous stream mode or in box mode, in which you select a rectangular portion of text instead of a set of lines. 상자 모드에서 선택하려면 Alt 키를 누른 채 마우스를 선택 영역 위로 끌거나 Alt+Shift+<화살표 키>를 누릅니다.To make a selection in box mode, press ALT as you drag the mouse over the selection (or press ALT + SHIFT + <arrow key>). 선택 영역에는 선택 영역의 첫 번째 문자와 마지막 문자로 정의된 사각형 안의 모든 문자가 포함됩니다.The selection includes all of the characters within the rectangle defined by the first character and the last character in the selection. 선택 영역으로 입력하거나 붙여넣은 모든 내용이 각 줄의 같은 지점에 삽입됩니다.Anything typed or pasted into the selected area is inserted at the same point on each line.
확대/축소Zoom 코드 창을 확대하거나 축소하려면 CTRL 키를 누른 채 마우스의 스크롤 휠을 이동하거나 CTRL + SHIFT + .를 눌러 확대하고You can zoom in or out in any code window by pressing and holding the CTRL key and moving the scroll wheel on the mouse (or CTRL + SHIFT + . CTRL + SHIFT + ,를 눌러 축소합니다.to increase and CTRL + SHIFT + , to decrease). 코드 창의 왼쪽 아래에 있는 확대/축소 상자를 사용하여 특정 확대/축소 백분율을 설정할 수도 있습니다.You can also use the Zoom box in the lower left corner of the code window to set a specific zoom percentage. 도구 창에서는 확대/축소 기능이 작동하지 않습니다.The zoom feature does not work in tool windows.
가상 공간Virtual Space 기본적으로 Visual Studio 편집기의 줄은 마지막 문자 뒤에서 끝나므로 줄 끝 부분에서 오른쪽 화살표 키를 누르면 커서가 다음 줄의 시작 부분으로 이동합니다.By default, lines in Visual Studio editors end after the last character, so that the RIGHT ARROW key at the end of a line moves the cursor to the beginning of the next line. 다른 편집기에서는 줄이 마지막 문자 뒤에서 끝나지 않고 커서를 줄의 아무 곳에나 배치할 수 있습니다.In some other editors a line does not end after the last character, and you can place your cursor anywhere on the line. 도구/옵션/텍스트 편집기/모든 언어 설정에서 편집기의 가상 공간을 사용할 수 있습니다.You can enable virtual space in the editor in the Tools/Options/Text Editor/All Languages settings. 가상 공간 또는 자동 줄 바꿈의 하나를 사용할 수 있지만 둘 다 사용할 수는 없습니다.Note that you can enable either Virtual Space or Word Wrap, but not both.
인쇄Printing 인쇄 대화 상자의 옵션을 사용하여 파일을 인쇄할 때 줄 번호를 포함하거나 축소된 코드 영역을 숨길 수 있습니다.You can use the options in the Print dialog box to include line numbers or hide collapsed regions of code when you print a file. 페이지 설정 대화 상자에서 페이지 머리글을 선택하여 파일의 전체 경로와 이름을 인쇄하도록 선택할 수도 있습니다.In the Page Setup dialog box, you can also choose to print the full path and the name of the file by choosing Page header.

도구/옵션/환경/글꼴 및 색 대화 상자에서 컬러 인쇄 옵션을 설정할 수 있습니다.You can set color printing options in the Tools/Options/Environment/Fonts and Colors dialog box. 설정 표시 목록에서 프린터 를 선택하여 컬러 인쇄를 사용자 지정합니다.Choose Printer in the Show settings for list to customize color printing. 파일 인쇄 시 파일 편집과 다른 색을 지정할 수 있습니다.You can specify different colors for printing a file than for editing a file.
전역 실행 취소 및 다시 실행Global Undo and Redo 편집 메뉴에서 마지막 전역 작업 실행 취소마지막 전역 작업 다시 실행 명령을 선택하면 여러 파일에 영향을 미치는 전역 작업이 실행 취소되거나 다시 실행됩니다.The Undo Last Global Action and Redo Last Global Action commands on the Edit menu undo or redo global actions that affect multiple files. 전역 작업에는 클래스 또는 네임스페이스 이름 바꾸기, 솔루션에서 찾기 및 바꾸기 작업 수행, 데이터베이스 리팩터링 또는 여러 파일을 변경하는 기타 작업이 포함됩니다.Global actions include renaming a class or namespace, performing a find-and-replace operation across a solution, refactoring a database, or any other action that changes multiple files. 작업이 적용된 솔루션을 닫은 후에도 현재 Visual Studio 세션에서 전역 실행 취소 및 다시 실행 명령을 작업에 적용할 수 있습니다.You can apply the global undo and redo commands to actions in the current Visual Studio session, even after you close the solution in which an action was applied.

고급 편집 기능Advanced Editing Features

편집/고급 하위 메뉴에서 다양한 고급 기능을 찾을 수 있습니다.You can find a number of advanced features on the Edit/Advanced submenu. 모든 이들 기능을 모든 형식의 코드 파일에서 사용할 수 있는 것은 아닙니다.Not all these features are available for all types of code files.

문서 서식Format Document 적절한 코드 줄 들여쓰기를 설정하고 중괄호를 문서의 개별 줄로 이동합니다.Sets the proper indentation of lines of code and moves curly braces to separate lines in the document.
선택 영역 서식Format Selection 적절한 코드 줄 들여쓰기를 설정하고 중괄호를 선택 영역의 개별 줄로 이동합니다.Sets the proper indentation of lines of code and moves curly braces to separate lines in the selection.
선택한 줄의 공백을 탭으로Tabify Selected Lines 해당할 경우 선행 공백을 탭으로 변경합니다.Changes leading spaces to tabs where appropriate.
선택한 줄의 탭을 공백으로Untabify Selected Lines 선행 탭을 공백으로 변경합니다.Changes leading tabs to spaces. 파일의 모든 공백을 탭으로 변환하거나 모든 탭을 공백으로 변환하려면 Edit.ConvertSpacesToTabsEdit.ConvertTabsToSpaces 명령을 사용하면 됩니다.If you want to convert all the spaces in your file to tabs (or all the tabs to spaces), you can use the Edit.ConvertSpacesToTabs and Edit.ConvertTabsToSpaces commands. 이들 명령은 Visual Studio 메뉴에 표시되지 않지만 빠른 실행 창이나 명령 창에서 호출할 수 있습니다.These commands do not appear in Visual Studio menus, but you can call them from the Quick Access window or the command window.
대문자로Make Uppercase 선택 영역의 모든 문자를 대문자로 변경하거나, 선택 영역이 없으면 삽입 지점의 문자를 대문자로 변경합니다.Changes all characters in the selection to uppercase, or if there is no selection, changes the character at the insertion point to uppercase.
소문자로Make Lowercase 선택 영역의 모든 문자를 소문자로 변경하거나, 선택 영역이 없으면 삽입 지점의 문자를 소문자로 변경합니다.Changes all characters in the selection to lowercase, or if there is no selection, changes the character at the insertion point to lowercase.
선택한 줄 위로 이동Move selected Lines Up 선택한 줄을 한 줄 위로 이동합니다.Moves the selected line up one line. 바로 가기: Alt+위쪽 화살표Shortcut: ALT + UP ARROW.
선택한 줄 아래로 이동Move Selected Lines Down 선택한 줄을 한 줄 아래로 이동합니다.Moves the selected line down one line. 바로 가기: Alt+아래쪽 화살표Shortcut: ALT + DOWN ARROW.
문서 유효성 검사Validate Document JScript 코드 파일의 유효성을 검사합니다.Validates JScript code files.
가로 공백 삭제Delete Horizontal White Space 현재 줄의 끝에 있는 탭이나 공백을 삭제합니다.Deletes tabs or spaces at the end of the current line.
공백 보기View White Space 공백을 두껍게 올라온 점으로 표시하고 탭을 화살표로 표시합니다.Displays spaces as raised dots, and tabs as arrows. 파일 끝은 사각형 문자 모양으로 표시됩니다.The end of a file is displayed as a rectangular glyph. 도구/옵션/텍스트 편집기/모든 언어/지동 줄 바꿈/자동 줄 바꿈 시각 문자 모양 표시 를 선택하면 해당 문자 모양도 표시됩니다.If Tools/Options/Text Editor/All Languages/Word Wrap/Show visible glyphs for word wrap is selected, that glyph is also displayed.
자동 줄 바꿈Word Wrap 문서의 모든 줄이 코드 창에 표시됩니다.Causes all the lines in a document to be visible in the code window. 텍스트 편집기 모든 언어 설정(도구/옵션/텍스트 편집기/모든 언어)에서 자동 줄 바꿈을 설정 및 해제할 수 있습니다.You can turn word wrap off and on in the Text Editor All Languages settings (Tools/Options/ Text Editor/All Languages).
선택 영역을 주석으로 처리Comment Selection 주석 문자를 선택 영역이나 현재 줄에 추가합니다.Adds comment characters to the selection or the current line.
선택 영역의 주석 처리 제거Uncomment Selection 선택 영역이나 현재 줄에서 주석 문자를 제거합니다.Removes comment characters from the selection or the current line.
줄 들여쓰기Increase Line Indent 탭이나 해당 공백을 선택한 줄이나 현재 줄에 추가합니다.Adds a tab (or the equivalent spaces) to the selected lines or the current line.
줄 내어쓰기Decrease Line Indent 선택한 줄이나 현재 줄에서 탭이나 해당 공백을 제거합니다.Removes a tab (or the equivalent spaces) from the selected lines or the current line.
태그 선택Select Tag XML 또는 HTML과 같은 태그를 포함한 문서에서 태그를 선택합니다.In a document that contains tags (for example, XML or HTML), selects the tag.
태그 내용 선택Select Tag Content XML 또는 HTML과 같은 태그를 포함한 문서에서 내용을 선택합니다.In a document that contains tags (for example, XML or HTML), selects the content.

이전 삽입 지점으로 뒤로 및 앞으로 이동하고, 형식 또는 멤버의 정의를 보고, 탐색 모음을 사용하여 특정 메서드로 이동하는 등 여러 가지 방법으로 코드 편집기에서 이동할 수 있습니다.You can move around in the code editor in several different ways, including navigating backwards and forwards to previous insertion points, viewing the definition of a type or member, and jumping to a specific method using the navigation bar. 자세한 내용은 코드 탐색을 참조하세요.For more information see Navigating code.

코드베이스에서 참조 찾기Finding references in your code base

코드베이스 전체에서 특정 코드 요소가 참조되는 위치를 찾으려면 모든 참조 찾기 명령을 사용할 수 있습니다.To find where particular code elements are referenced throughout your codebase, you can use the Find All References command. 또한 형식 또는 멤버를 클릭할 때 참조 강조 표시 기능은 해당 형식 또는 멤버에 대한 모든 참조를 자동으로 강조 표시합니다.Also, when you click on a type or member, the reference highlighting feature automatically highlights all references to that type or member. 자세한 내용은 코드에서 참조 찾기를 참조하세요.For more information, see Finding references in your code.

편집기 사용자 지정Customize the Editor

도구 메뉴에서 설정 가져오기 및 내보내기 마법사 명령을 사용하여 Visual Studio 설정을 다른 개발자와 공유하거나, 설정이 표준을 준수하도록 하거나, Visual Studio 기본 설정으로 돌아갈 수 있습니다.You can share your Visual Studio settings with another developer, have your settings conform to a standard, or return to Visual Studio default settings by using the Import and Export Settings Wizard command on the Tools menu. 설정 가져오기 및 내보내기 마법사에서 선택한 일반 설정 또는 언어 및 프로젝트 관련 설정을 변경할 수 있습니다.In the Import and Export Settings Wizard, you can change selected general settings or language and project-specific settings.

새 바로 가기 키를 정의하거나 기존 바로 가기 키를 다시 정의하려면 도구, 옵션, 환경, 키보드로 이동합니다.To define new hotkeys or redefine existing hotkeys, go to Tools, Options, Environment, Keyboard. 바로 가기 키에 대한 자세한 내용은 기본 바로 가기 키를 참조하세요.For more information about hotkeys, see Default Keyboard Shortcuts.

편집기를 사용자 지정하는 방법에 대한 자세한 내용은 편집기 사용자 지정을 참조하세요.For more information about customizing the editor, see Customizing the Editor. 언어별 편집기 옵션에 대한 자세한 내용은 C#에 대한 Visual Studio 개발 환경 사용옵션, 텍스트 편집기, JavaScript, 서식을 참조하세요.For information about language-specific editor options, see Using the Visual Studio Development Environment for C# and Options, Text Editor, JavaScript, Formatting.

참고 항목See Also

Visual Studio IDEVisual Studio IDE