System Windows pokazuje "sprawdzanie systemu plików" podczas uruchamiania maszyny wirtualnej platformy Azure

W tym artykule opisano błąd "Sprawdzanie systemu plików", który może wystąpić podczas rozruchu maszyny wirtualnej z systemem Windows na platformie Microsoft Azure.

Objaw

Maszyna wirtualna z systemem Windows nie jest uruchamiana. Po sprawdzeniu zrzutów ekranu rozruchu w diagnostyce rozruchu zobaczysz, że proces Sprawdzanie dysku (chkdsk.exe) jest uruchomiony z jednym z następujących komunikatów:

  • Skanowanie i naprawianie dysku (C:)
  • Sprawdzanie systemu plików w języku C:

Przyczyna

Jeśli w systemie plików zostanie znaleziony błąd NTFS, system Windows sprawdzi i naprawi spójność dysku podczas następnego ponownego uruchomienia. Zwykle dzieje się tak, jeśli maszyna wirtualna miała nieoczekiwane ponowne uruchomienie lub jeśli proces zamykania maszyny wirtualnej został nagle przerwany.

Rozwiązanie

Porada

Jeśli masz ostatnio utworzoną kopię zapasową maszyny wirtualnej, możesz spróbować przywrócić maszynę wirtualną z kopii zapasowej, aby rozwiązać problem z rozruchem.

System Windows będzie uruchamiany normalnie po zakończeniu procesu Sprawdzanie dysku. Jeśli maszyna wirtualna jest zablokowana w procesie Sprawdzanie dysku, spróbuj uruchomić polecenie Sprawdź dysk na maszynie wirtualnej w trybie offline:

  1. Wykonaj migawkę dysku systemu operacyjnego maszyny wirtualnej, którego dotyczy problem, jako kopię zapasową. Aby uzyskać więcej informacji, zobacz Migawka dysku.

  2. Dołącz dysk systemu operacyjnego do maszyny wirtualnej odzyskiwania.

  3. Na maszynie wirtualnej odzyskiwania uruchom polecenie Sprawdź dysk na dołączonym dysku systemu operacyjnego. W poniższym przykładzie litera sterownika dołączonego dysku systemu operacyjnego to E:

    chkdsk E: /f
    
  4. Po zakończeniu sprawdzania dysku odłącz dysk od maszyny wirtualnej odzyskiwania, a następnie ponownie dołącz dysk do maszyny wirtualnej, której dotyczy problem, jako dysk systemu operacyjnego. Aby uzyskać więcej informacji, zobacz Rozwiązywanie problemów z maszyną wirtualną z systemem Windows przez dołączenie dysku systemu operacyjnego do maszyny wirtualnej odzyskiwania.

Skontaktuj się z nami, aby uzyskać pomoc

Jeśli masz pytania lub potrzebujesz pomocy, utwórz wniosek o pomoc techniczną lub zadaj pytanie w społeczności wsparcia dla platformy Azure. Możesz również przesłać opinię o produkcie do społeczności opinii platformy Azure.