Omówienie zapytań w programie Power BI DesktopQuery overview in Power BI Desktop

Program Power BI Desktop umożliwia łączenie się ze zbiorami danych, tworzenie atrakcyjnych i fundamentalnych raportów oraz udostępnianie wyników pracy innym osobom, które mogą je następnie rozbudowywać i rozwijać własne rozwiązania analizy biznesowej.With Power BI Desktop you can connect to the world of data, create compelling and foundational reports, and share your efforts with others – who can then build on your work, and expand their business intelligence efforts.

W programie Power BI Desktop dostępne są trzy widoki:Power BI Desktop has three views:

  • Widok Raport — umożliwia tworzenie za pomocą zapytań atrakcyjnych wizualizacji i rozmieszczanie ich w sposób, w jaki mają być wyświetlane. Widok zawiera wiele stron, które można udostępniać innym użytkownikom.Report view – where you use queries you create to build compelling visualizations, arranged as you want them to appear, and with multiple pages, that you can share with others
  • Widok Dane — umożliwia wyświetlanie danych w raporcie w formacie modelu danych, w którym można dodawać miary, tworzyć nowe kolumny i zarządzać relacjami.Data view – see the data in your report in data model format, where you can add measures, create new columns, and manage relationships
  • Widok Relacje — zapewnia graficzną reprezentację relacji ustanowionych w modelu danych oraz zarządzanie nimi i modyfikowanie ich według potrzeb.Relationships view – get a graphical representation of the relationships that have been established in your data model, and manage or modify them as needed.

Dostęp do tych widoków można uzyskać, wybierając jedną z trzech ikon z lewej strony programu Power BI Desktop.These views are accessed by selecting one of the three icons along the left side of Power BI Desktop. Na poniższej ilustracji jest wybrany widok Raport, co jest wskazane żółtym paskiem obok ikony.In the following image, Report view is selected, indicated by the yellow band beside the icon.

W programie Power BI Desktop dostępny jest też Edytor zapytań, w którym można połączyć się z jednym lub większą liczbą źródeł danych, kształtować i przekształcać dane zgodnie z potrzebami, a następnie załadować uzyskany model do programu Power BI Desktop.Power BI Desktop also comes with Query Editor, where you can connect to one or many data sources, shape and transform the data to meet your needs, then load that model into Power BI Desktop.

Ten dokument zawiera omówienie pracy z danymi w Edytorze zapytań.This document provides an overview of the work with data in the Query Editor. Oczywiście jest dostępnych znacznie więcej informacji, dlatego na końcu tego dokumentu można znaleźć linki do szczegółowych wskazówek dotyczących obsługiwanych typów danych, łączenia się z danymi, kształtowania danych, tworzenia relacji i rozpoczynania pracy.There's more to learn, of course, so at the end of this document you’ll find links to detailed guidance about supported data types, connecting to data, shaping data, creating relationships, and how to get started.

Jednak najpierw przyjrzyjmy się Edytorowi zapytań.But first, let’s see get acquainted with Query Editor.

Edytor zapytańThe Query Editor

Aby przejść do Edytora zapytań, wybierz pozycję Edytuj zapytania na karcie Narzędzia główne programu Power BI Desktop.To get to Query Editor, select Edit Queries from the Home tab of Power BI Desktop.

Gdy nie ma żadnych połączeń danych, Edytor zapytań ma postać pustego okienka gotowego na dane.With no data connections, Query Editor appears as a blank pane, ready for data.

Po załadowaniu zapytania widok Edytora zapytań staje się bardziej interesujący.Once a query is loaded, Query Editor view becomes more interesting. Jeśli połączymy się z następującym internetowym źródłem danych, w Edytorze zapytań zostaną załadowane informacje o danych, które można następnie zacząć kształtować.If we connect to the following Web data source, Query Editor loads information about the data, which you can then begin to shape.

http://www.bankrate.com/finance/retirement/best-places-retire-how-state-ranks.aspx

Oto wygląd Edytora zapytań po nawiązaniu połączenia z danymi:Here’s how Query Editor appears once a data connection is established:

  1. Na wstążce wiele przycisków jest teraz aktywnych, umożliwiając interakcje z danymi w zapytaniu.In the ribbon, many buttons are now active to interact with the data in the query

  2. Okienko po lewej stronie, które zawiera listę zapytań dostępnych do wyboru, wyświetlenia i kształtowania.In the left pane, queries are listed and available for selection, viewing, and shaping

  3. Środkowe okienko zawiera dane z wybranego zapytania i umożliwia kształtowanie.In the center pane, data from the selected query is displayed and available for shaping

  4. Okno Ustawienia zapytania zawiera listę właściwości zapytania i zastosowanych kroków.The Query Settings window appears, listing the query’s properties and applied steps

W kolejnych sekcjach przyjrzymy się każdemu z tych czterech obszarów — wstążce, okienku zapytania, widokowi danych i okienku Ustawienia zapytania.We’ll look at each of these four areas – the ribbon, the queries pane, the data view, and the Query Settings pane – in the following sections.

Wstążka zapytaniaThe query ribbon

Wstążka w Edytorze zapytań składa się z czterech kart — Narzędzia główne, Przekształć, Dodaj kolumnę i Widok.The ribbon in Query Editor consists of four tabs – Home, Transform, Add Column, and View.

Karta Narzędzia główne zawiera typowe zadania dotyczące zapytania, w tym polecenie do pierwszego kroku w każdym zapytaniu: Pobierz dane.The Home tab contains the common query tasks, including the first step in any query, which is Get Data. Poniższa ilustracja przedstawia wstążkę karty Narzędzia główne.The following image shows the Home ribbon.

Aby połączyć się z danymi i rozpocząć proces tworzenia zapytania, wybierz przycisk Pobierz dane.To connect to data and begin the query building process, select the Get Data button. Zostanie wyświetlone menu z najbardziej typowymi źródłami danych.A menu appears, providing the most common data sources.

Aby uzyskać więcej informacji o dostępnych źródłach danych, zobacz Źródła danych.For more information about available data sources, see Data Sources. Aby uzyskać informacje o łączeniu się z danymi, w tym przykłady i procedury, zobacz Łączenie się z danymi.For information about connecting to data, including examples and steps, see Connect to Data.

Karta Przekształć zapewnia dostęp do typowych zadań przekształcania danych, takich jak dodawanie lub usuwanie kolumn, zmienianie typów danych, dzielenie kolumn i inne zadania oparte na danych.The Transform tab provides access to common data transformation tasks, such as adding or removing columns, changing data types, splitting columns, and other data-driven tasks. Poniższa ilustracja przedstawia kartę Przekształć.The following image shows the Transform tab.

Aby uzyskać więcej informacji na temat przekształcania danych, wraz z przykładami, zobacz Łączenie i kształtowanie danych.For more information about transforming data, including examples, see Combine and Shape Data.

Karta Dodaj kolumnę zapewnia dostęp do dodatkowych zadań związanych z dodawaniem kolumny, formatowaniem danych kolumny i dodawaniem kolumn niestandardowych.The Add Column tab provides additional tasks associated with adding a column, formatting column data, and adding custom columns. Poniższa ilustracja przedstawia kartę Dodaj kolumnę.The following image shows the Add Column tab.

Karta Widok na wstążce służy do wyświetlania i ukrywania określonych okienek i okien.The View tab on the ribbon is used to toggle whether certain panes or windows are displayed. Służy również do wyświetlania Edytora zaawansowanego.It’s also used to display the Advanced Editor. Poniższa ilustracja przedstawia kartę Widok.The following image shows the View tab.

Warto wiedzieć, że wiele zadań dostępnych z poziomu wstążki jest również dostępnych po kliknięciu prawym przyciskiem myszy kolumny lub innych danych w środkowym okienku.It’s useful to know that many of the tasks available from the ribbon are also available by right-clicking a column, or other data, in the center pane.

Lewe okienkoThe left pane

W okienku po lewej stronie wyświetlana jest liczba aktywnych zapytań oraz nazwa zapytania.The left pane displays the number of active queries, as well as the name of the query. Po wybraniu zapytania z okienka po lewej stronie jego dane są wyświetlane w środkowym okienku, w którym można je kształtować i przekształcać zgodnie z potrzebami.When you select a query from the left pane, its data is displayed in the center pane, where you can shape and transform the data to meet your needs. Na poniższej ilustracji przedstawiono lewe okienko z wieloma zapytaniami.The following image shows the left pane with multiple queries.

Środkowe okienko (danych)The center (data) pane

Środkowe okienko (okienko danych) zawiera dane z wybranego zapytania.In the center pane, or Data pane, data from the selected query is displayed. To tutaj realizowana jest znaczna część pracy w widoku zapytania.This is where much of the work of the Query view is accomplished.

Na poniższej ilustracji widać ustanowione wcześniej połączenie z danymi internetowymi. Wybrana jest kolumna Overall score (Wynik ogólny). Jej nagłówek został kliknięty, aby pokazać dostępne elementy menu.In the following image, the Web data connection established earlier is displayed, the Overall score column is selected, and its header is right-clicked to show the available menu items. Wiele z tych elementów menu dostępnych po kliknięciu prawym przyciskiem myszy jest identycznych z przyciskami na kartach wstążki.Notice that many of these right-click menu items are the same as buttons in the ribbon tabs.

Po wybraniu elementu menu dostępnego po kliknięciu prawym przyciskiem myszy (lub przycisku na wstążce) zapytanie spowoduje zastosowanie danego kroku do danych i zapisanie go jako części samego zapytania.When you select a right-click menu item (or a ribbon button), Query applies the step to the data, and saves it as part of the query itself. Kroki są rejestrowane w okienku Ustawienia zapytania w kolejności sekwencyjnej, tak jak to opisano w następnej sekcji.The steps are recorded in the Query Settings pane in sequential order, as described in the next section.

Okienko Ustawienia zapytaniaThe query settings pane

W okienku Ustawienia zapytania wyświetlane są wszystkie kroki związane z zapytaniem.The Query Settings pane is where all steps associated with a query are displayed. Na przykład na poniższej ilustracji sekcja Zastosowane kroki w okienku Ustawienia zapytania odzwierciedla fakt, że właśnie zmieniono typ kolumny Overall score.For example, in the following image, the Applied Steps section of the Query Settings pane reflects the fact that we just changed the type of the Overall score column.

W miarę stosowania do zapytania dodatkowych kroków są one rejestrowane w sekcji Zastosowane kroki.As additional shaping steps are applied to the query, they are captured in the Applied Steps section.

Należy pamiętać, że dane źródłowe nie są zmieniane — Edytor zapytań dostosowuje oraz kształtuje jedynie widok danych. Wszelkie interakcje z danymi źródłowymi są realizowane na podstawie ich widoku ukształtowanego i zmodyfikowanego w Edytorze zapytań.It’s important to know that the underlying data is not changed; rather, Query Editor adjusts and shapes its view of the data, and any interaction with the underlying data occurs based on Query Editor’s shaped and modified view of that data.

W okienku Ustawienia zapytania można zmieniać nazwy kroków, usuwać kroki lub zmieniać ich kolejność według potrzeb.In the Query Settings pane, you can rename steps, delete steps, or reorder the steps as you see fit. Aby to zrobić, kliknij prawym przyciskiem myszy krok w sekcji Zastosowane kroki, a następnie wybierz pozycję z wyświetlonego menu.To do so, right-click the step in the Applied Steps section, and choose from the menu that appears. Wszystkie kroki zapytania są wykonywane w kolejności przedstawionej w okienku Zastosowane kroki.All query steps are carried out in the order they appear in the Applied Steps pane.

Edytor zaawansowanyThe Advanced Editor

Jeśli chcesz wyświetlić kod, który Edytor zapytań tworzy dla każdego kroku, lub chcesz utworzyć własny kod kształtowania, możesz użyć Edytora zaawansowanego.If you want to see the code that Query Editor is creating with each step, or want to create your own shaping code, you can use the Advanced Editor. Aby uruchomić Edytor zaawansowany, wybierz kartę Widok na wstążce, a następnie pozycję Edytor zaawansowany.To launch the advanced editor, select View from the ribbon, then select Advanced Editor. Zostanie wyświetlone okno zawierające istniejący kod zapytania.A window appears, showing the existing query code.

W oknie Edytor zaawansowany ten kod można edytować bezpośrednio.You can directly edit the code in the Advanced Editor window. Aby zamknąć okno, wybierz przycisk Gotowe lub Anuluj.To close the window, select the Done or Cancel button.

Zapisywanie pracySaving your work

Gdy zapytanie ma już odpowiednią postać, można za pomocą Edytora zapytań wprowadzić zmiany w modelu danych w programie Power BI Desktop i zamknąć Edytor zapytań.When your query is where you want it, you can have Query Editor apply the changes to the data model into Power BI Desktop, and close Query Editor. W tym celu wybierz pozycję Zamknij i zastosuj w menu Plik Edytora zapytań.To do that, select Close & Apply from Query Editor's File menu.

W trakcie realizowania postępu w programie Power BI Desktop będzie udostępniane okno dialogowe z jego stanem.As progress is made, Power BI Desktop provides a dialog to display its status.

Gdy zapytanie będzie już gotowe lub aby zapisać wykonaną pracę, można zapisać wyniki pracy w programie Power BI Desktop w postaci pliku pbix.Once you have your query where you want it, or if you just want to make sure your work is saved, Power BI Desktop can save your work in the form of a .pbix file.

Aby zapisać wykonaną pracę, wybierz pozycję Plik > Zapisz (lub Plik > Zapisz jako), jak pokazano na poniższej ilustracji.To save your work, select File > Save (or File > Save As), as shown in the following image.

Następne krokiNext steps

Przy użyciu programu Power BI Desktop można wykonywać różnorodne zadania.There are all sorts of things you can do with Power BI Desktop. Aby uzyskać więcej informacji na temat jego możliwości, skorzystaj z następujących zasobów:For more information on its capabilities, check out the following resources: