Visual Studio 2017 for Mac 产品系列系统要求Visual Studio 2017 for Mac Product Family System Requirements

下面是 Visual Studio 2017 for Mac 系列产品的最低系统要求。The minimum system requirements for the Visual Studio 2017 for Mac family of products is below. 若要安装 Visual Studio 2017 for Mac,请参阅 Visual Studio 2017 下载To install Visual Studio 2017 for Mac, see Visual Studio 2017 Downloads. 有关此次发布版新增功能的详细信息,请参阅 Visual Studio for Mac 2017 发行说明For information about everything that's new in this release, see the Visual Studio for Mac 2017 release notes. 另请参阅 Visual Studio 2017 for Mac 平台目标以及兼容性See also Visual Studio 2017 for Mac Platform Targeting and Compatibility.

Visual Studio 2017 for MacVisual Studio 2017 for Mac

以下产品支持下面的最低系统要求:The following products support the minimum system requirements below:

  • Visual Studio Enterprise 2017 for Mac。Visual Studio Enterprise 2017 for Mac.
  • Visual Studio Professional 2017 for Mac。Visual Studio Professional 2017 for Mac.
  • Visual Studio Community 2017 for Mac。Visual Studio Community 2017 for Mac.

支持的操作系统Supported Operating Systems

Visual Studio 2017 for Mac 可在以下操作系统上安装并运行:Visual Studio 2017 for Mac will install and run on the following operating systems:

  • macOS Sierra 10.12:社区版、专业版和企业版。macOS Sierra 10.12: Community, Professional, and Enterprise.
  • Mac OS X El Capitan 10.11:社区版、专业版和企业版\*。Mac OS X El Capitan 10.11: Community, Professional, and Enterprise\*.
\*最新版本的 Xcode 8.3 需要 macOS Sierra 10.12,因此 Xamarin.iOS 和 Xamarin.Mac 项目也需要该最低版本 \* the latest version of Xcode 8.3 requires macOS Sierra 10.12, therefore Xamarin.iOS and Xamarin.Mac projects also require that minimum version

硬件Hardware

  • 1.8 GHz 或更快的处理器。1.8 GHz or faster processor. 双核或更好的建议。Dual-core or better recommended.
  • 4 GB RAM;建议 8 GB RAM(如果在虚拟机上运行,则最低 4 GB)。4 GB of RAM; 8 GB of RAM recommended (4 GB minimum if running on a virtual machine).
  • 硬盘空间:大约 1 GB。Hard disk space: approx 1GB.

支持的语言Supported Languages

Visual Studio for Mac 提供了以下语言版本:Visual Studio for Mac is available in the following languages:

  • 英语、简体中文、繁体中文、捷克语、法语、德语、意大利语、日语、韩语、波兰语、葡萄牙语(巴西)、俄语、西班牙语和土耳其语。English, Chinese (Simplified), Chinese (Traditional), Czech, French, German, Italian, Japanese, Korean, Polish, Portuguese (Brazil), Russian, Spanish, Turkish.

其他要求Additional Requirements

  • 使用 .NET Core 项目和功能需要 .NET Core SDK 1.1。.NET Core SDK 1.1 is required to use .NET Core projects and features. 下载和安装可以分别进行,需要 Mac OS X El Capitan 10.11 或更高版本。It can be downloaded and installed separately, and requires Mac OS X El Capitan 10.11 or higher.
  • Xamarin.Android 需要 64 位版本的 Java 开发工具包 (JDK)。Xamarin.Android requires the 64-bit Java Development Kit (JDK).
  • Xamarin.iOS 需要 Apple 的 Xcode IDE 和 iOS SDK。Xamarin.iOS requires Apple's Xcode IDE and iOS SDK.
  • Xamarin.Forms 可以面向 Android 和 iOS 平台,只需满足上述要求即可。Xamarin.Forms can target both Android and iOS platforms, given the requirements listed above.