Angiv data direkte i en sideinddelt rapport i Report Builder – Power BIEnter data directly in a paginated report in Report Builder - Power BI

GÆLDER FOR:APPLIES TO: ✔️ Power BI-tjeneste✔️ Power BI service ✔️ Sideinddelte rapporter i Power BI✔️ Power BI paginated reports ✔️ Power BI Premium✔️ Power BI Premium ❌ Power BI Desktop❌ Power BI DesktopGÆLDER FOR:APPLIES TO: ✔️ Power BI-tjeneste✔️ Power BI service ✔️ Sideinddelte rapporter i Power BI✔️ Power BI paginated reports ✔️ Power BI Premium✔️ Power BI Premium ❌ Power BI Desktop❌ Power BI Desktop

I denne artikel får du mere at vide om en funktion i den nye version af Microsoft Power BI Report Builder, som gør det muligt at angive data direkte i en RDL-rapport som et integreret datasæt.In this article, you learn about a feature in the new version of Microsoft Power BI Report Builder that lets you enter data directly into an RDL report as an embedded dataset. Denne funktion er magen til Power BI Desktop.This feature is similar to Power BI Desktop. Du kan skrive data direkte i et datasæt i din rapport eller indsætte dem vha. et andet program, f.eks. Microsoft Excel.You can type the data directly in a dataset in your report, or paste it from another program like Microsoft Excel. Når du har oprettet et datasæt ved at angive data, kan du bruge det på præcis samme måde, som du ville bruge alle andre integrerede datasæt, du har oprettet.After you've created a dataset by entering data, you can use it just like you would any other embedded dataset you've created. Du kan desuden tilføje mere end én tabel og bruge én som et filter for den anden.Plus you can add more than one table and use one as a filter for the other. Denne funktion er især nyttig til små, statiske datasæt, som du evt. vil bruge i din rapport, f.eks. rapportparametre.This feature is especially useful for small, static datasets you might need to use in your report, like report parameters.

ForudsætningerPrerequisites

Opret en datakilde og et datasætCreate a data source and dataset

Når du har downloadet og installeret Report Builder, skal du benytte samme arbejdsproces, som du bruger til at føje en integreret datakilde og et datasæt til din rapport.After you’ve downloaded and installed Report Builder, you follow the same workflow you use to add an embedded data source and dataset to your report. I følgende procedure kan du under Datakilder se en ny indstilling: Angiv data.In the following procedure, under Data Sources you see a new option: Enter Data. Du behøver kun at konfigurere denne datakilde én gang i en rapport.You only need to set up this data source once in a report. Derefter kan du oprette flere tabeller med angivne data som separate datasæt, der alle anvender denne enkelte datakilde.After that, you can create multiple tables of entered data as separate datasets, all using that single data source.

  1. I ruden Rapportdata skal du vælge Nyt > datasæt.In the Report Data pane, select New > Dataset.

    Skærmbillede af Nyt datasæt i Report Builder.

  2. I dialogboksen Egenskaber for datasæt skal du vælge Brug et datasæt, der er integreret i min rapport.In the Dataset Properties dialog box, select Use a dataset embedded in my report.

  3. Ud for Datakilde skal du vælge Ny.Next to Data source, select New.

    Skærmbillede af Ny integreret datakilde.

  4. I dialogboksen Egenskaber for datakilde skal du vælge Brug en forbindelse, der er integreret i min rapport.In the Data Source Properties dialog box, select Use a connection embedded in my report.

  5. I dialogboksen Vælg forbindelsestype skal du vælge ANGIV DATA > OK.In the Select connection type box, select ENTER DATA > OK.

    Skærmbillede af ANGIV DATA i datakilde.

  6. Tilbage i dialogboksen Egenskaber for datasæt skal du vælge Forespørgselsdesigner.Back in the Dataset Properties dialog box, select Query Designer.

  7. I ruden Forespørgselsdesigner skal du højreklikke og indsætte dataene i tabellen.In the Query Designer pane, right-click and paste your data in the table.

    Skærmbillede af Angiv data i Forespørgselsdesigner.

  8. Hvis du vil angive kolonnenavnene, skal du dobbeltklikke på hver NewColumn og angive kolonnenavnet.To set the column names, double-click each NewColumn and type the column name.

    Skærmbillede af Angiv kolonnenavne.

  9. Hvis den første række indeholder kolonneoverskrifter fra de oprindelige data, skal du højreklikke og slette dem.If the first row contains column headings from the original data, right-click and delete it.

  10. Datatypen for hver kolonne er som standard Streng.By default, the data type for each column is String. Hvis du vil ændre datatypen, skal du højreklikke på kolonneoverskriften > Ændringstype og angive den til en anden datatype, f.eks Dato eller Flydende.To change the data type, right-click the column header > Change Type, and set it to another data type, such as Date or Float.

    Skærmbillede af Skift datatype.

  11. Når du er færdig med at oprette tabellen, skal du vælge OK.When you’ve finished creating the table, select OK.

    Den forespørgsel, der oprettes, er den samme, som du vil se med en XML-datakilde.The query that’s generated is the same as you’d see with an XML data source. Under overfladen bruger vi XML som dataprovider.Under the covers, we’re using XML as the data provider. Vi har ændret den for også at muliggøre dette scenarie.We’ve repurposed it to enable this scenario as well.

    Skærmbillede af XML-datastruktur.

  12. I dialogboksen Egenskaber for datasæt skal du vælge OK.In the Dataset Properties dialog box, select OK.

  13. Du kan se din datakilde og dit datasæt i ruden Rapportdata.You see your data source and dataset in the Report Data pane.

    Skærmbillede af Datasæt i ruden Rapportdata.

Du kan bruge dit datasæt som grundlag for datavisualiseringer i din rapport.You can use your dataset as the basis for data visualizations in your report. Du kan også tilføje et andet datasæt og bruge den samme datakilde til det.You can also add another dataset and use the same data source for it.

Design rapportenDesign the report

Nu, hvor du har en datakilde og et datasæt, er du klar til at oprette din rapport.Now that you have a data source and dataset, you're ready to create your report. Med følgende procedure oprettes en enkel rapport baseret på dataene i forrige afsnit.The following procedure creates a simple report based on the data in the previous section.

  1. I menuen Indsæt skal du vælge Tabel > Guiden Tabel.On the Insert menu, select Table > Table Wizard.

    Skærmbillede af valg af indstillingen Guiden Tabel.

  2. Vælg det datasæt, du lige har oprettet > Næste.Select the dataset you just created > Next.

    Skærmbillede af dialogboksen Vælg et datasæt.

  3. Træk de felter, du vil gruppere efter, i boksen Tilgængelige felter til boksen Rækkegrupper på siden Arranger felter.In the Arrange fields page, drag fields you want to group by from the Available fields box to the Row groups box. I dette eksempel:In this example:

    • CountryRegionCountryRegion
    • SalesYearSalesYear
  4. Træk de felter, du vil samle, fra boksen Tilgængelige felter til boksen Værdier.Drag the fields you want to aggregate from the Available fields box to the Values box. I dette eksempel:In this example:

    • SalgsbeløbSalesAmount

    Report Builder opsummerer som standard felterne i boksen Værdier, men du kan vælge en anden sammenlægning.By default, Report Builder sums the fields in the Values box, but you can choose another aggregation.

    Skærmbillede af forskellige sammenlægninger, du kan vælge imellem.

  5. Vælg Næste.Select Next.

  6. På siden Vælg layout skal du beholde alle standardindstillingerne, men rydde Vis/skjul grupper.In the Choose the layout page, keep all the default settings, but clear Expand/collapse groups. Det er generelt en god idé at udvide og skjule grupper, men denne gang vil vi gerne se alle dataene.In general, expanding and collapsing groups is great, but this time we want to see all the data.

  7. Vælg Næste > Afslut.Select Next > Finish. Tabellen vises i designområdet.The table is displayed on the design surface.

    Skærmbillede af rapporten i Designvisning.

Kør rapportenRun the report

Hvis du vil se de faktiske værdier og få forhåndsvist rapporten, skal du køre den.To see the actual values and preview the report, you run it.

  1. Vælg Kør på båndet Hjem.Select Run in the Home ribbon.

    Skærmbillede af valg af Kør på båndet Hjem.

    Nu kan du se værdierne.Now you see the values. Matrixen har flere rækker, end du så i Designvisning.The matrix has more rows than you saw in Design view! Du kan enten formatere siden eller vælge at bruge standardindstillingerne, før du gemmer på din lokale computer eller publicerer til tjenesten.You can either format the page or decide to use the default settings before saving to your local computer or publishing to the service.

  2. Vælg Udskriftslayout for at se, hvordan rapporten vil se ud, når du udskriver den.To see how your report will look when you print it, select Print Layout.

    Skærmbillede af valg af Udskriftslayout.

    Nu kan du se den, som den vil se ud på en trykt side.Now you see it as it will look on a printed page.

    Skærmbillede af rapporten i visningen Udskriftslayout.

Upload den sideinddelte rapport i Power BI-tjenestenUpload the paginated report to the Power BI service

Nu, hvor sideinddelte rapporter understøttes i Power BI-tjenesten, kan du uploade din sideinddelte rapport til en Premium-kapacitet.Now that paginated reports are supported in the Power BI service, you can upload your paginated report to a Premium capacity. Se flere detaljer under Upload en sideinddelt rapport.See Upload a paginated report for details.

Upload den sideinddelte rapport til en rapportserverUpload the paginated report to a report server

Du kan også uploade din sideinddelte rapport til en Power BI-rapportserver eller SQL Server Reporting Services 2016- eller 2017-rapportserver.You can also upload your paginated report to a Power BI Report Server or SQL Server Reporting Services 2016 or 2017 report server. Inden du gør det, skal du føje følgende element til din RsReportServer.config som en ekstra dataudvidelse.Before you do, you need to add the following item to your RsReportServer.config as an additional data extension. Sikkerhedskopiér din RsReportServer.config-fil, inden du foretager ændringen, i tilfælde af, at støder på problemer.Back up your RsReportServer.config file before you make the change, in case you run into any issues.

<Extension Name="ENTERDATA" Type="Microsoft.ReportingServices.DataExtensions.XmlDPConnection,Microsoft.ReportingServices.DataExtensions">
    <Configuration>
        <ConfigName>ENTERDATA</ConfigName>
    </Configuration>
</Extension>

Når du har redigeret den, bør listen over dataudbydere se ud som følger i config-filen:After you've edited it, here's what the list of data providers in the config file should look like:

Skærmbillede af konfigurationsfilen RsReportServer.

Det var det. Du kan nu publicere rapporter, der bruger denne nye funktionalitet til rapportserveren.That’s it – you can now publish reports that use this new functionality to your report server.

Næste trinNext steps