Produktivitätsleitfaden für Visual StudioProductivity guide for Visual Studio

Wenn Sie beim Schreiben von Code Zeit sparen möchten, sind Sie hier richtig.If you want to save time while you're writing code, you're in the right place. Dieser Produktivitätsleitfaden enthält Tipps, die Sie bei ersten Schritten mit Visual Studio, beim Schreiben von Code, beim Debuggen von Code, beim Behandeln von Fehlern und bei der Verwendung von Tastenkombinationen unterstützen können. Und all dies auf einer Seite.This productivity guide includes tips that can help you get started with Visual Studio, write code, debug code, handle errors, and use keyboard shortcuts—all on one page.

Informationen zu nützlichen Tastenkombinationen finden Sie unter Tastenkombinationen für die Produktivität.For information about helpful keyboard shortcuts, see Productivity shortcuts. Eine vollständige Liste von Tastenkombinationen für Befehle finden Sie unter Standardtastenkombinationen.For a complete list of command shortcuts, see Default keyboard shortcuts.

Erste SchritteGet started

Sparen Sie Zeit beim Durchforsten von Menüs, indem Sie schnell nach allem suchen, was Sie benötigen, einschließlich Befehlen, Einstellungen, Dokumentation und Installationsoptionen.Save time digging through menus by quickly searching for anything you need, including commands, settings, documentation, and install options. Zeigen Sie Tastenkombinationen für Befehle innerhalb Ihrer Suchergebnisse in Visual Studio an, damit Sie sich diese leichter merken können.See keyboard shortcuts for commands within your search results in Visual Studio so you can memorize them more easily.

  • Mock-Code mit Aufgabenliste.Mock code using task list. Wenn Sie nicht genügend Anforderungen haben, um ein Codesegment zu vervollständigen, verwenden Sie die Aufgabenliste, um Codekommentare, die Token wie TODO und HACK verwenden, nachzuverfolgen und um Verknüpfungen zu verwalten, mit denen Sie direkt zu einem vordefinierten Speicherort im Code gelangen.If you don't have enough requirements to complete a piece of code, use Task List to track code comments that use tokens such as TODO and HACK, or custom tokens, and to manage shortcuts that take you directly to a predefined location in code. Weitere Informationen finden Sie unter Verwenden der Aufgabenliste.For more information, see Use the Task List.

  • Verwenden von Tastenkombinationen im Projektmappen-Explorer.Use Solution Explorer shortcuts. Wenn Sie mit Visual Studio noch nicht vertraut sind, sind diese Tastenkombinationen praktisch und sparen Ihnen Zeit, während Sie schnell mit einer neuen Codebase arbeiten.If you're new to Visual Studio, these shortcuts will come in handy and save you time while you're coming up to speed on a new codebase. Eine vollständige Liste der Tastenkombinationen finden Sie unter Standardtastenkombinationen in Visual Studio.For the full list of shortcuts, see Default keyboard shortcuts in Visual Studio.

  • Identifizieren und Anpassen von Tastenkombinationen in Visual Studio .Identify and customize keyboard shortcuts in Visual Studio. Sie können Tastenkombinationen für Visual Studio-Befehle nachschlagen, diese Tastenkombinationen anpassen und sie dann exportieren, damit andere Benutzer sie verwenden können.You can identify keyboard shortcuts for Visual Studio commands, customize those shortcuts, and export them for others to use. Sie können eine Tastenkombination im Dialogfeld „Optionen“ immer nachschlagen und ändern.You can always find and change a keyboard shortcut in the Options dialog box.

  • Größere Barrierefreiheit in Visual Studio.Make Visual Studio more accessible. Visual Studio verfügt über integrierte Barrierefreiheitsfunktionen, die mit Sprachausgaben und anderen Hilfstechnologien kompatibel sind.Visual Studio has built-in accessibility features that are compatible with screen readers and other assistive technologies. Eine vollständige Liste der verfügbaren Funktionen finden Sie unter Tipps und Tricks zur Barrierefreiheit für Visual Studio.See Accessibility tips and tricks for Visual Studio for the full list of available features.

  • Informieren Sie sich über den Projektlebenszyklus und die Wartung in Visual Studio.Check out the Visual Studio Product Lifecycle and Servicing. Informationen dazu, wie Sie Updates für Visual Studio, Supportoptionen für Enterprise- und Professional-Kunden, Support für ältere Versionen von Visual Studio und Komponenten erhalten, die nicht von der Visual Studio-Wartung abgedeckt werden, finden Sie unter Produktlebenszyklus und Wartung in Visual Studio.For information on how to get updates for Visual Studio, support options for Enterprise and Professional customers, support for older versions of Visual Studio, and components not covered by Visual Studio servicing, see Visual Studio Product Lifecycle and Servicing.

  • Installieren und Verwalten von NuGet-Paketen in Visual Studio.Install and manage NuGet packages in Visual Studio. Über die Benutzeroberfläche des NuGet-Paket-Managers in Visual Studio können Sie auf einfache Weise NuGet-Pakete in Projekten und Lösungen installieren, deinstallieren und aktualisieren.The NuGet Package Manager UI in Visual Studio on Windows allows you to easily install, uninstall, and update NuGet packages in projects and solutions. Weitere Informationen finden Sie unter Installieren und Verwalten von Paketen in Visual Studio mit dem NuGet-Paket-Manager.For more information, see Install and manage packages in Visual Studio using the NuGet Package Manager.

Schreiben von CodeWrite code

Schreiben Sie Code schneller, indem Sie die folgenden Funktionen verwenden.Write code more quickly by using the following features.

  • Verwenden von benutzerfreundlichen Befehlen.Use convenience commands. Visual Studio verfügt über verschiedene Befehle, mit denen Sie gängige Bearbeitungsaufgaben schneller bewerkstelligen können.Visual Studio contains various commands to help you accomplish common editing tasks faster. Beispielsweise können Sie einen Befehl auswählen, um ganz einfach eine Codezeile zu duplizieren, ohne diese kopieren, die Position des Cursors ändern und die Zeile einfügen zu müssen.For example, you can choose a command to easily duplicate a line of code without having to copy it, reposition the cursor, and then paste it. Wählen Sie Bearbeiten > Duplizieren oder drücken Sie die Tasten STRG+E,V.Choose Edit > Duplicate or press Ctrl+E,V. Sie können eine Auswahl von Texten rasch erweitern oder verkleinern, indem Sie Bearbeiten > Erweitert > Auswahl erweitern oder Bearbeiten > Erweitert > Auswahl verkleinern auswählen oder die Tasten UMSCHALT+ALT+ = oder UMSCHALT+ALT+ - drücken.You can also quickly expand or contract a selection of text by choosing Edit > Advanced > Expand Selection or Edit > Advanced > Contract Selection, or by pressing Shift+Alt+= or Shift+Alt+-.

  • Verwenden von IntelliSense.Use IntelliSense. Wie Sie Code im Editor eingeben, werden IntelliSense-Informationen, wie Listenmember, Parameterinformationen, QuickInfos, Signaturhilfe und Wortvervollständigung angezeigt.As you enter code in the editor, IntelliSense information, such as List Members, Parameter Info, Quick Info, Signature Help, and Complete Word, appears. Diese Funktionen unterstützen Fuzzyübereinstimmung des Texts. So umfasst die Ergebnisliste für die Listenmember nicht nur Einträge, die mit dem Zeichen beginnen, das Sie eingegeben haben, sondern auch Einträge, die die Zeichenkombination an einer beliebigen Stelle im Namen enthalten.These features support fuzzy matching of text; for example, the results lists for List Members include not only entries that start with the characters that you have entered but also entries that contain the character combination anywhere in their names. Weitere Informationen finden Sie unter Verwenden von IntelliSense.For more information, see Use IntelliSense.

  • Ändern der Optionen für Autoeinfügung von IntelliSense bei der Codeeingabe.Change auto-insertion of IntelliSense options as you enter code. Wenn Sie den Vorschlagsmodus in IntelliSense umschalten, können Sie festlegen, dass IntelliSense-Optionen nur eingefügt werden, wenn Sie sie explizit auswählen.By switching IntelliSense to suggestion mode, you can specify that IntelliSense options are inserted only if you explicitly choose them.

    Um den Vorschlagmodus zu aktivieren, drücken Sie die Tasten STRG+ALT+LEERTASTE, oder klicken Sie in der Menüleiste auf Bearbeiten > IntelliSense > Beendigungsmodus umschalten.To enable suggestion mode, choose the Ctrl+Alt+Spacebar keys, or, on the menu bar, choose Edit > IntelliSense > Toggle Completion Mode.

  • Verwenden von Codeausschnitten.Use code snippets. Sie können die integrierten Ausschnitte verwenden oder eigene Ausschnitte erstellen.You can use built-in snippets, or create your own snippets.

    Zum Einfügen eines Ausschnittes wählen Sie in der Menüleiste Bearbeiten > IntelliSense > Ausschnitt einfügen oder Umschließen mit aus, oder öffnen Sie das Kontextmenü in einer Datei, und wählen Sie Ausschnitt > Ausschnitt einfügen oder Umschließen mit aus.To insert a snippet, on the menu bar, choose Edit > IntelliSense > Insert Snippet or Surround With, or open the shortcut menu in a file and choose Snippet > Insert Snippet or Surround With. Weitere Informationen finden Sie unter Codeausschnitte.For more information, see Code Snippets.

  • Inline-Behebung von Codefehlern.Fix code errors inline. Mit schnellen Aktionen können Sie ganz leicht Code mit einer einzelnen Aktion umgestalten, generieren oder anderweitig ändern.Quick Actions let you easily refactor, generate, or otherwise modify code with a single action. Diese Aktionen können mithilfe des Schraubendrehers Schraubendrehersymbol oder der Glühbirne Glühbirnensymbol oder durch Drücken der Tasten Alt+EINGABETASTE oder STRG+ . angewendet werden,These actions can be applied using the screwdriver Screwdriver icon or light bulb Light bulb icon icons, or by pressing Alt+Enter or Ctrl+. wenn sich Ihr Cursor in der entsprechenden Codezeile befindet.when your cursor is on the appropriate line of code. Weitere Informationen finden Sie unter Schnelle Aktionen.See Quick Actions for more information.

  • Anzeigen und Bearbeiten der Definition eines Codeelements.Show and edit the definition of a code element. Sie können das Modul schnell anzeigen und bearbeiten, in dem ein Codeelement, wie ein Member, eine Variable oder eine lokale Variable, definiert ist.You can quickly show and edit the module in which a code element, such as a member, a variable, or a local, is defined.

    Um eine Definition in einem Popupfenster zu öffnen, markieren Sie das Element, und drücken Sie dann die Tasten ALT+F12, oder öffnen Sie das Kontextmenü für das Element, und klicken Sie dann auf Definition einsehen.To open a definition in a pop-up window, highlight the element and then choose the Alt+F12 keys, or open the shortcut menu for the element and then choose Peek Definition. Um eine Definition in einem separaten Codefenster zu öffnen, öffnen Sie das Kontextmenü für das Codeelement, und wählen Sie dann Gehe zu Definition aus.To open a definition in a separate code window, open the shortcut menu for the element, and then choose Go to Definition.

  • Verwenden von Beispielanwendungen.Use sample applications. Sie können Anwendungsentwicklung beschleunigen, indem Sie Beispielanwendungen von Microsoft Developer Network herunterladen und installieren.You can speed up application development by downloading and installing sample applications from Microsoft Developer Network. Sie können eine bestimmte Technologie oder ein Programmierkonzept auch kennenlernen, indem Sie ein Beispielpaket für diesen Bereich herunterladen und untersuchen.You can also learn a particular technology or programming concept by downloading and exploring a Sample Pack for that area.

  • Ändern der Klammerformatierung durch Formatierung/Neue Zeilen.Change brace formatting with Formatting/New Lines. Auf der Optionsseite Formatierung können Sie Optionen zur Formatierung von Code im Code-Editor festlegen, z. B. auch neue Zeilen.Use the Formatting options page to set options for formatting code in the code editor, including new lines. Weitere Informationen zur Verwendung dieser Einstellung in C# finden Sie im Dialogfeld „Optionen“: Text-Editor > C# > Codeformat > Formatierung.For more information on how to use this setting in C#, see Options dialog box: Text Editor > C# > Code Style > Formatting. Informationen zu C++ finden Sie unter Festlegen der C++-Codierungseinstellungen in Visual Studio.For C++, see Set your C++ coding preferences in Visual Studio. Informationen zu Python finden Sie unter Formatieren von Python-Code.For Python, see Format Python code.

  • Ändern des Einzugs mit Tabstoppzeichen.Change your indentation with Tabs. Verwenden Sie benutzerdefinierte Editor-Einstellungen, die auf jede CodeBase individuell zugeschnitten sind, um einen konsistente Codierungsstil für mehrere Entwickler zu erzwingen, die an demselben Projekt mit verschiedenen Editoren und IDEs arbeiten.Use custom editor settings, tailored to each codebase, to enforce consistent coding styles for multiple developers working on the same project across different editors and IDEs. Stellen Sie sicher, dass Ihr gesamtes Team dieselben Sprachkonventionen, Benennungskonventionen und Formatierungsregeln befolgt.Ensure your whole team follows the same language conventions, naming conventions, and formatting rules. Da diese benutzerdefinierten Einstellungen portabel sind und mit Ihrem Code weitergegeben werden, können Sie Codierungsstile auch außerhalb von Visual Studio durchsetzen.Since these custom settings are portable and travel with your code, you can enforce coding styles even outside of Visual Studio. Weitere Informationen finden Sie unter Optionen, Text-Editor, Alle Sprachen, Tabstoppzeichen.For more information, see Options, Text Editor, All Languages, Tabs.

Sie können verschiedene Methoden verwenden, um bestimmte Positionen im Code schneller zu finden und dorthin zu wechseln.You can use various techniques to find and move to specific locations in your code more quickly. Sie können auch das Layout Ihrer Visual Studio-Fenster basierend auf Ihren Einstellungen ändern.You can also change the layout of your Visual Studio windows based on your preferences.

  • Speichern von Codezeilen als Lesezeichen.Bookmark lines of code. Sie können Lesezeichen verwenden, um schnell zu bestimmten Codezeilen in einer Datei zu navigieren.You can use bookmarks to navigate quickly to specific lines of code in a file.

    Wählen Sie zum Festlegen einer Textmarke in der Menüleiste Bearbeiten > Textmarken > Textmarke umschalten aus.To set a bookmark, on the menu bar, choose Edit > Bookmarks > Toggle Bookmark. Sie können alle Lesezeichen für eine Projektmappe im Fenster Lesezeichen anzeigen.You can view all of the bookmarks for a solution in the Bookmarks window. Weitere Informationen finden Sie unter Festlegen von Lesezeichen im Code.For more information, see Set bookmarks in code.

  • Suchen nach Symboldefinitionen in einer Datei.Search for symbol definitions in a file. Sie können in einer Projektmappe nach Symboldefinitionen und Dateinamen suchen. Die Suchergebnisse enthalten jedoch keine Namespaces oder lokalen Variablen.You can search within a solution to locate symbol definitions and file names, but search results don't include namespaces or local variables.

    Um auf dieses Feature zuzugreifen, wählen Sie in der Menüleiste Bearbeiten > Navigieren zu aus.To access this feature, on the menu bar, choose Edit > Navigate To.

  • Durchsuchen der Gesamtstruktur des Codes.Browse the overall structure of your code. Im Projektmappen-Explorer können Sie Klassen und ihre Typen und Member in den Projekten suchen.In Solution Explorer, you can search and browse classes and their types and members in your projects. Sie können auch nach Symbolen suchen, die Aufrufhierarchie einer Methode anzeigen, Symbolverweise suchen und andere Aufgaben ausführen.You can also search for symbols, view a method's Call Hierarchy, find symbol references, and perform other tasks. Wenn Sie ein Codeelement im Projektmappen-Explorer auswählen, wird die dazugehörige Datei auf einer Registerkarte Vorschau angezeigt, und der Cursor wird auf das Element in der Datei verschoben.If you choose a code element in Solution Explorer, the associated file opens in a Preview tab, and the cursor moves to the element in the file. Weitere Informationen finden Sie unter Anzeigen der Codestruktur.For more information, see View the structure of code.

  • Springen zu einer Position in einer Datei mit dem Zuordnungsmodus.Jump to a location in a file with map mode. Im Zuordnungsmodus werden Codezeilen als Miniaturansicht auf der Scrollleiste angezeigt.Map mode displays lines of code, in miniature, on the scroll bar. Weitere Informationen zu diesem Anzeigemodus finden Sie unter Vorgehensweise: Anpassen der Scrollleiste.For more information about this display mode, see How to: Customize the scroll bar.

  • Verstehen der Codestruktur mit Code Map.Understand your code structure with code map. Codezuordnungen können Sie dabei unterstützen, Abhängigkeiten im gesamten Code visuell darzustellen und zu erkennen, wie diese zusammenspielen, ohne dass Dateien und Codezeilen gelesen werden müssen.Code maps can help you visualize dependencies across your code, and see how it fits together without reading through files and lines of code. Weitere Informationen finden Sie unter Map dependencies with code maps (Zuordnen von Abhängigkeiten mit Code Maps).For more information, see Map dependencies with code maps.

  • Weitere Informationen finden Sie unter „Häufig verwendete Dateien mit Bearbeiten/Zu zuletzt verwendeter Datei wechseln“ .See frequently used files with Edit/Go to Recent File. Verwenden Sie die Wechseln zu-Befehle in Visual Studio, um eine zielgerichtete Suche in Ihrem Code auszuführen, damit Sie angegebene Elemente schneller finden.Use the Go To commands in Visual Studio to perform a focused search of your code to help you quickly find specified items. Ausführliche Anweisungen finden Sie unter Suchen nach Code mithilfe von „Wechseln zu“-Befehlen.For detailed instructions, see Find code using Go To commands.

  • Verschieben des Fensters „Eigenschaften“ auf die rechte Seite.Move the Properties window to the right-hand side. Wenn Sie ein vertrauteres Fensterlayout bevorzugen, können Sie das Fenster „Eigenschaften“ in Visual Studio verschieben, indem Sie F4 drücken.If you're looking for a more familiar window layout, you can move the Properties window in Visual Studio by pressing F4.

Schnelleres Suchen von ElementenFind items faster

Sie können in der IDE nach Befehlen, Dateien und Optionen suchen und gleichzeitig die Inhalte der Toolfenster filtern, um relevante Informationen nur für die aktuelle Aufgabe anzuzeigen.You can search across the IDE for commands, files, and options, in addition to filtering the contents of tool windows to show only relevant information for your current task.

  • Filtern der Inhalte von Toolfenstern.Filter the contents of tool windows. Sie können in den Inhalten vieler Toolfenster, z. B. der Fenster Toolbox, Eigenschaften und im Projektmappen-Explorer suchen. Es werden aber nur Elemente angezeigt, deren Namen die Zeichen enthalten, die Sie angeben.You can search within the contents of many tool windows, such as the Toolbox, the Properties window, and Solution Explorer, but display only items whose names contain the characters that you specify.

  • Zeigen Sie nur die Fehler an, die berücksichtigt werden sollen.Display only the errors you want to address. Wenn Sie die Schaltfläche Filter auf der Symbolleiste Fehlerliste auswählen, können Sie die Anzahl der Fehler reduzieren, die im Fenster Fehlerliste angezeigt werden.If you choose the Filter button on the Error List toolbar, you can reduce the number of errors that appear in the Error List window. Sie können nur die Fehler in den Dateien anzeigen, die im Editor geöffnet sind, nur die Fehler in der aktuellen Datei oder nur die Fehler im aktuellen Projekt.You can display only the errors in the files that are open in the editor, only the errors in the current file, or only the errors in the current project. Sie können im Fenster Fehlerliste auch nach bestimmten Fehlern suchen.You can also search within the Error List window to find specific errors.

  • Suchen von Dialogfeldern, Menübefehlen, Optionen und mehr.Find dialog boxes, menu commands, options, and more. Geben Sie im Suchfeld Schlüsselwörter oder Ausdrücke für die Elemente ein, die Sie suchen.In the search box, enter keywords or phrases for the items that you're trying to find. Beispielsweise werden die folgenden Optionen angezeigt, wenn Sie Neues Projekt eingeben:For example, the following options appear if you enter new project:

    Schnellstartergebnisse für "Neues Projekt"

    Schnellstart zeigt unter anderem Links zum Erstellen eines neuen Projekts, zum Hinzufügen eines neuen Elements zu einem Projekt und zum Wechseln zur Seite Projekte und Projektmappen im Dialogfeld Optionen an.Quick Launch displays links to create a new project, to add a new item to a project, and to the Projects and Solutions page in the Options dialog box, among others. Zu den Suchergebnissen können auch Projektdateien und Toolfenster zählen.Search results can also include project files and tool windows.

    Screenshot: Suchergebnisse für „new project“ (Neues Projekt)

    Drücken Sie STRG+Q, um direkt zum Suchfeld zu wechseln.Press Ctrl+Q to jump straight to the search box.

Debuggen von CodeDebug code

Debuggen kann viel Zeit in Anspruch nehmen, aber die folgenden Tipps können Ihnen helfen, den Prozess zu beschleunigen.Debugging can consume a lot of time, but the following tips can help you speed up the process.

  • Verwenden der Visual Studio-Debuggertools.Use the Visual Studio debugger tools. Wenn Sie Ihre App im Visual Studio-Kontext debuggen, bedeutet dies in der Regel, dass Sie die Anwendung im Debugmodus ausführen.In the Visual Studio context, when you debug your app, it usually means that you are running the application in debugger mode. Der Debugger bietet viele Möglichkeiten zum Ermitteln der Aktionen Ihres Codes während der Ausführung.The debugger provides many ways to see what your code is doing while it runs. Eine Anleitung für die ersten Schritte finden Sie unter Erster Blick auf den Visual Studio-Debugger.See First look at the Visual Studio Debugger for a guide to getting started.

  • Testen Sie die gleiche Seite, Anwendung oder Website in unterschiedlichen Browsern.Test the same page, application, or site in different browsers. Wenn Sie den Code debuggen, können Sie zwischen den installierten Webbrowsern, einschließlich Seitenprüfung (Visual Studio), problemlos wechseln, ohne dass Sie das Dialogfeld Browserauswahl öffnen müssen.As you debug your code, you can easily switch among the installed web browsers, including Page Inspector (Visual Studio), without having to open the Browse With dialog box. Sie können die Liste Debugziel verwenden, die auf der Symbolleiste Standard neben der Schaltfläche Debuggen starten zu finden ist, um beim Debuggen oder Anzeigen von Seiten schnell zu überprüfen, welchen Browser Sie verwenden.You can use the Debug Target list, which is on the Standard toolbar next to the Start Debugging button, to quickly verify which browser you're using as you debug or view pages.

    Auswählen von Debuggingoptionen für den Webbrowser

  • Legen Sie temporäre Haltepunkte fest.Set temporary breakpoints. Sie können einen temporären Haltepunkt in der aktuellen Zeile des Codes erstellen und gleichzeitig den Debugger starten.You can create a temporary breakpoint in the current line of code and start the debugger simultaneously. Wenn Sie diese Codezeile erreicht haben, gibt der Debugger Unterbrechungsmodus ein.When you hit that line of code, the debugger enters break mode. Weitere Informationen finden Sie unter Navigate through code with the debugger (Navigieren im Code mit dem Debugger).For more information, see Navigate through code with the debugger.

    Drücken Sie die Tasten STRG+F10, um dieses Feature zu verwenden, oder öffnen Sie das Kontextmenü für die Codezeile, bei der Sie unterbrechen möchten, und klicken Sie dann auf Ausführen bis Cursor.To use this feature, choose the Ctrl+F10 keys, or open the shortcut menu for the line of code on which you want to break, and then choose Run To Cursor.

  • Verschieben Sie den Ausführungspunkt während des Debuggens.Move the execution point during debugging. Sie können den aktuellen Ausführungspunkt zu einem anderen Codeabschnitt verschieben und Debuggen von diesem Punkt neu starten.You can move the current execution point to a different section of code and then restart debugging from that point. Diese Methode ist hilfreich, wenn Sie einen Codeabschnitt debuggen möchten, ohne alle Schritte neu erstellen zu müssen, die erforderlich sind, um diesen Abschnitt zu erreichen.This technique is useful if you want to debug a section of code without having to recreate all of the steps that are required to reach that section. Weitere Informationen finden Sie unter Navigate through code with the debugger (Navigieren im Code mit dem Debugger).For more information, see Navigate through code with the debugger.

    Ziehen Sie die gelbe Pfeilspitze zu einer Position, an der Sie die folgende Anweisung in derselben Quelldatei festlegen möchten, um den Ausführungspunkt zu verschieben, und drücken Sie dann F5, um das Debuggen fortzusetzen.To move the execution point, drag the yellow arrowhead to a location where you want to set the next statement in the same source file, and then choose the F5 key to continue debugging.

  • Erfassen Sie Wertinformationen für Variablen.Capture value information for variables. Sie können einer Variablen im Code einen DataTip hinzufügen und diesen fixieren, damit Sie auf den letzten bekannten Wert für die Variable zugreifen können, nachdem der Debugvorgang abgeschlossen hat.You can add a DataTip to a variable in your code and pin it so that you can access the last known value for the variable after debugging has finished. Weitere Informationen finden Sie unter Anzeigen von Datenwerten als Datentipps.For more information, see View data values in Data Tips.

    Zum Hinzufügen eines DataTips muss sich der Debugger im Unterbrechungsmodus befinden.To add a DataTip, the debugger must be in break mode. Platzieren Sie den Cursor in der Variablen, und wählen Sie dann die Anheftschaltfläche auf dem angezeigten DataTip aus.Place the cursor on the variable, and then choose the pin button on the DataTip that appears. Wenn das Debuggen beendet wird, wird in der Quelldatei ein blaues Anheftsymbol neben der Codezeile angezeigt, die die Variable enthält.When debugging is stopped, a blue pin icon appears in the source file next to the line of code that contains the variable. Wenn Sie auf den blauen Pin zeigen, wird der Wert der Variablen aus der letzten Debugsitzung angezeigt.If you point to the blue pin, the value of the variable from the most recent debugging session appears.

  • Löschen Sie das Direktfenster.Clear the Immediate window. Sie können den Inhalt des Direktfensters zur Entwurfszeit löschen, indem Sie >cls oder >Edit.ClearAll eingeben.You can erase the contents of the Immediate window at design time by entering >cls or >Edit.ClearAll

    Weitere Informationen zu weiteren Befehlen finden Sie unter Visual Studio-Befehlsaliase.For more information about additional commands, see Visual Studio command aliases.

  • Ermitteln von Änderungen am Code und anderer Verläufe mit CodeLens .Find code changes and other history with CodeLens. Mit CodeLens können Sie sich auf Ihre Arbeit konzentrieren, während Sie ermitteln, was mit Ihrem Code geschehen ist. Dazu müssen Sie nicht einmal den Editor schließen.CodeLens lets you stay focused on your work while you find out what happened to your code—without leaving the editor. Suchen Sie Verweise auf Codeabschnitte und -änderungen, verknüpfte Fehler, Arbeitselemente, Code Reviews und Komponententests.You can find references to a piece of code, changes to your code, linked bugs, work items, code reviews, and unit tests.

  • Verwenden von Live Share, um in Echtzeit mit anderen Entwicklern zu debuggen.Use Live Share to debug in real time with others. Live Share ermöglicht Ihnen gemeinsames Bearbeiten und Debuggen mit anderen in Echtzeit – unabhängig von Ihren verwendeten Programmiersprachen oder erstellten App-Typen.Live Share enables you to collaboratively edit and debug with others in real time, regardless of the programming languages you're using or app types you're building. Weitere Informationen finden Sie unter Was ist Visual Studio Live Share?For more information, see What is Visual Studio Live Share?

  • Verwenden Sie des interaktiven Fensters zum Schreiben und Testen von kleinen Codeanschnitten.Use Interactive Window to write and test small code. Visual Studio bietet ein interaktives REPL-Fenster (Read-Evaluate-Print-Loop), mit dem Sie beliebigen Code eingeben und unmittelbare Ergebnisse anzeigen können.Visual Studio provides an interactive read-evaluate-print-loop (REPL) window that lets you enter arbitrary code and see immediate results. Diese Art der Codierung unterstützt Sie beim Lernen und Experimentieren mit APIs und Bibliotheken und beim interaktiven Entwickeln von funktionierendem Code, den Sie in Ihre Projekte einfügen können.This way of coding helps you to learn and experiment with APIs and libraries, and to interactively develop working code to include in your projects. Weitere Informationen für Python finden Sie unter Arbeiten mit dem interaktiven Python-Fenster.For Python, see Work with the Python Interactive window. Die Funktion „Interaktives Fenster“ ist auch für C# verfügbar.The Interactive Window feature is also available for C#.

Zugreifen auf Visual Studio-ToolsAccess Visual Studio tools

Sie können schnell auf die Developer-Eingabeaufforderung oder auf ein anderes Visual Studio-Tool zugreifen, wenn Sie diese bzw. dieses im Startmenü oder in der Taskleiste fixieren.You can quickly access the Developer Command Prompt, or another Visual Studio tool, if you pin it to the Start menu or the taskbar.

  1. Navigieren Sie im Windows-Explorer zu %ProgramData%\Microsoft\Windows\Start Menu\Programs\Visual Studio 2017\Visual Studio Tools.In Windows Explorer, browse to %ProgramData%\Microsoft\Windows\Start Menu\Programs\Visual Studio 2017\Visual Studio Tools.
  1. Navigieren Sie im Windows-Explorer zu %ProgramData%\Microsoft\Windows\Start Menu\Programs\Visual Studio 2019\Visual Studio Tools.In Windows Explorer, browse to %ProgramData%\Microsoft\Windows\Start Menu\Programs\Visual Studio 2019\Visual Studio Tools.
  1. Klicken Sie mit der rechten Maustaste darauf, oder öffnen Sie das Kontextmenü, um Developer-Eingabeaufforderung auszuwählen. Wählen Sie dann An "Start" anheften oder An Taskleiste anheften aus.Right-click or open the context menu for Developer Command Prompt, and then choose Pin to Start or Pin to taskbar.

Verwalten von Dateien, Symbolleisten und FensternManage files, toolbars, and windows

Bei der Entwicklung einer Anwendung möchten Sie jederzeit in mehreren Codedateien arbeiten und sich in mehreren Toolfenstern bewegen können.At any one time, you may be working in multiple code files and moving among several tool windows as you develop an application. Mit folgenden Tipps behalten Sie die Übersicht:You can keep organized by using the following tips:

  • Halten Sie Dateien, die Sie häufig verwenden, im Editor sichtbar.Keep files that you frequently use visible in the editor. Sie können die Dateien, die Sie häufig verwenden, an der linken Seite der Registerkartenreihe anheften, damit Sie unabhängig davon, wie viele Dateien im Editor geöffnet sind, sichtbar bleiben.You can pin files to the left side of the tab so that they remain visible regardless of how many files are open in the editor.

    Um eine Datei anzuheften, wählen Sie die Registerkarte der Datei, und wählen Sie dann die Schaltfläche Anheftstatus umschalten aus.To pin a file, choose the file's tab, and then choose the Toggle Pin Status button.

  • Verschieben Sie Dokumente und Fenster auf andere Bildschirme.Move documents and windows to other monitors. Wenn Sie bei der Entwicklung einer Anwendung mehr als einen Bildschirm verwenden, können Sie leichter an Teilen der Anwendung arbeiten, wenn Sie Dateien, die im Editor geöffnet sind, auf einen anderen Bildschirm verschieben.If you use more than one monitor when you develop applications, you can work on portions of your application more easily by moving files that are open in the editor to another monitor. Sie können Toolfenster, wie z.B. Debuggerfenster, auf einen anderen Bildschirm verschieben und Dokument- und -Toolfenster miteinander verbinden, um „Flösse“ zu erstellen.You can also move tool windows, such as debugger windows, to another monitor and tab dock document and tool windows together to create "rafts." Weitere Informationen finden Sie unter Anpassen der Fensterlayouts in Visual Studio.For more information, see Customize window layouts in Visual Studio.

    Sie können Dateien auch einfacher verwalten, indem Sie eine weitere Instanz des Projektmappen-Explorers erstellen und sie auf einen anderen Bildschirm verschieben.You can also manage files more easily by creating another instance of Solution Explorer and moving it to another monitor. Um eine andere Instanz des Projektmappen-Explorers zu erstellen, öffnen Sie ein Kontextmenü im Projektmappen-Explorer, und wählen Sie dann Neue Projektmappen-Explorer-Ansicht aus.To create another instance of Solution Explorer, open a shortcut menu in Solution Explorer, and then choose New Solution Explorer View.

  • Passen Sie die Schriftarten an, die in Visual Studio angezeigt werden.Customize the fonts that appear in Visual Studio. Sie können die Schriftart, Größe und Farbe ändern, die für Text in der IDE verwendet wird.You can change the font face, size, and color that's used for text in the IDE. Beispielsweise können Sie die Farbe von bestimmten Codeelementen im Editor und die Schriftart in Toolfenstern oder in der IDE anpassen.For example, you can customize the color of specific code elements in the editor and the font face in tool windows or throughout the IDE. Weitere Informationen finden Sie unter Vorgehensweise: Ändern von Schriftarten und Farben in Visual Studio und Vorgehensweise: Ändern der im Editor in Visual Studio 2017 verwendeten Schriftarten und Farben.For more information, see How to: Change fonts and colors and How to: Change fonts and colors in the editor.

Siehe auchSee also