Επισκόπηση ερωτημάτων στο Power BI DesktopQuery overview in Power BI Desktop

Με το Power BI Desktop μπορείτε να συνδεθείτε στον κόσμο των δεδομένων, να δημιουργήσετε εντυπωσιακές αναφορές και αναφορές υποδομής και να μοιραστείτε τις προσπάθειές σας με άλλους χρήστες οι οποίοι μπορούν, στη συνέχεια, να επεκτείνουν στην εργασία σας και να αναπτύξουν τις προσπάθειες επιχειρηματικής ευφυΐας τους.With Power BI Desktop you can connect to the world of data, create compelling and foundational reports, and share your efforts with others – who can then build on your work, and expand their business intelligence efforts.

Το Power BI Desktop διαθέτει τρεις προβολές:Power BI Desktop has three views:

  • Προβολή αναφοράς – στην οποία χρησιμοποιείτε ερωτήματα δικής σας κατασκευής, για να δημιουργήσετε ελκυστικές απεικονίσεις, να ρυθμίσετε τη διάταξή τους ώστε να εμφανίζονται με τη σειρά που θέλετε και με πολλές σελίδες που μπορείτε να μοιραστείτε με άλλους χρήστεςReport view – where you use queries you create to build compelling visualizations, arranged as you want them to appear, and with multiple pages, that you can share with others
  • Προβολή δεδομένων – δείτε τα δεδομένα στην αναφορά σας σε μορφή μοντέλου δεδομένων, όπου μπορείτε να προσθέσετε μετρήσεις, να δημιουργήσετε νέες στήλες και να διαχειριστείτε σχέσειςData view – see the data in your report in data model format, where you can add measures, create new columns, and manage relationships
  • Προβολή σχέσεων – λάβετε μια γραφική απεικόνιση των σχέσεων που έχουν καθοριστεί στο μοντέλο δεδομένων και διαχειριστείτε ή τροποποιήστε τις ανάλογα με τις ανάγκες σας.Relationships view – get a graphical representation of the relationships that have been established in your data model, and manage or modify them as needed.

Αποκτήστε πρόσβαση σε αυτές τις προβολές, επιλέγοντας ένα από τα τρία εικονίδια κατά μήκος της αριστερής πλευράς του Power BI Desktop.Access these views by selecting one of the three icons along the left side of Power BI Desktop. Στην παρακάτω εικόνα, η προβολή Αναφορά είναι επιλεγμένη και υποδεικνύεται από την κίτρινη ζώνη δίπλα στο εικονίδιο.In the following image, Report view is selected, indicated by the yellow band beside the icon.

Στιγμιότυπο οθόνης του Power BI Desktop που εμφανίζει επιλεγμένη την προβολή Αναφορά.

Το Power BI Desktop συνοδεύεται επίσης από το πρόγραμμα επεξεργασίας Power Query.Power BI Desktop also comes with Power Query Editor. Χρησιμοποιήστε το πρόγραμμα επεξεργασίας Power Query για να συνδεθείτε σε μία ή πολλές προελεύσεις δεδομένων, να διαμορφώσετε και να μετασχηματίσετε τα δεδομένα ώστε να ανταποκρίνονται στις ανάγκες σας και έπειτα να φορτώσετε αυτό το μοντέλο στο Power BI Desktop.Use Power Query Editor to connect to one or many data sources, shape and transform the data to meet your needs, then load that model into Power BI Desktop.

Αυτό το έγγραφο παρέχει μια επισκόπηση της εργασίας με δεδομένα στο πρόγραμμα επεξεργασίας Power Query, αλλά, υπάρχουν και άλλα να μάθετε.This document provides an overview of the work with data in the Power Query Editor, but there's more to learn. Στο τέλος αυτού του εγγράφου, θα βρείτε συνδέσεις για λεπτομερείς οδηγίες σχετικά με τους υποστηριζόμενους τύπους δεδομένων.At the end of this document, you'll find links to detailed guidance about supported data types. Επίσης, θα βρείτε οδηγίες σχετικά με τη σύνδεση σε δεδομένα, τη διαμόρφωση δεδομένων, τη δημιουργία σχέσεων και τον τρόπο με τον οποίο μπορείτε να ξεκινήσετε.You'll also find guidance about connecting to data, shaping data, creating relationships, and how to get started.

Πρώτα όμως, ας εξοικειωθούμε με το πρόγραμμα επεξεργασίας Power Query.But first, let's see get acquainted with Power Query Editor.

Πρόγραμμα επεξεργασίας Power QueryPower Query Editor

Για να φτάσετε στο πρόγραμμα επεξεργασίας Power Query, επιλέξτε Μετασχηματισμός δεδομένων από την αρχική καρτέλα του Power BI Desktop.To get to Power Query Editor, select Transform data from the Home tab of Power BI Desktop.

Στιγμιότυπο οθόνης Power BI Desktop που εμφανίζει την αρχική καρτέλα του προγράμματος επεξεργασίας Power Query.

Χωρίς συνδέσεις δεδομένων, το πρόγραμμα επεξεργασίας Power Query εμφανίζεται ως ένα κενό τμήμα παραθύρου, έτοιμο για δεδομένα.With no data connections, Power Query Editor appears as a blank pane, ready for data.

Στιγμιότυπο οθόνης του παραθύρου Power BI Desktop που εμφανίζει το Πρόγραμμα επεξεργασίας Power Query χωρίς συνδέσεις δεδομένων.

Όταν φορτωθεί ένα ερώτημα, η προβολή του προγράμματος επεξεργασίας Power Query γίνεται πιο ενδιαφέρουσα.Once a query is loaded, Power Query Editor view becomes more interesting. Αν συνδεθούμε στην ακόλουθη προέλευση δεδομένων Web, το πρόγραμμα επεξεργασίας Power Query φορτώνει πληροφορίες σχετικά με τα δεδομένα, τα οποία μπορείτε να ξεκινήσετε να διαμορφώνετε:If we connect to the following Web data source, Power Query Editor loads information about the data, which you can then begin to shape:

https://www.bankrate.com/retirement/best-and-worst-states-for-retirement/

Δείτε πώς εμφανίζεται το πρόγραμμα επεξεργασίας Power Query όταν πραγματοποιηθεί μια σύνδεση δεδομένων:Here's how Power Query Editor appears once a data connection is established:

  1. Στην κορδέλα, υπάρχουν πολλά κουμπιά που είναι πλέον ενεργά για αλληλεπίδραση με τα δεδομένα στο ερώτημα.In the ribbon, many buttons are now active to interact with the data in the query.

  2. Στο αριστερό τμήμα παραθύρου, παρατίθενται τα ερωτήματα και είναι διαθέσιμα για επιλογή, προβολή και διαμόρφωση.In the left pane, queries are listed and available for selection, viewing, and shaping.

  3. Στο κεντρικό τμήμα παραθύρου, εμφανίζονται τα δεδομένα από το επιλεγμένο ερώτημα και είναι διαθέσιμα για διαμόρφωση.In the center pane, data from the selected query is displayed and available for shaping.

  4. Εμφανίζεται το τμήμα παραθύρου Ρυθμίσεις ερωτήματος, στο οποίο παρατίθενται οι ιδιότητες του ερωτήματος και τα βήματα που έχουν εφαρμοστεί.The Query Settings pane appears, listing the query's properties and applied steps.

    Στιγμιότυπο οθόνης του παραθύρου Power BI Desktop που εμφανίζει το παράθυρο Ρυθμίσεις ερωτήματος στο Πρόγραμμα επεξεργασίας Power Query.

Θα εξετάσουμε κάθε μία από αυτές τις τέσσερις περιοχές: την κορδέλα, το τμήμα παραθύρου "Ερωτήματα", την προβολή "Δεδομένα" και το τμήμα παραθύρου "Ρυθμίσεις ερωτήματος".We'll look at each of these four areas: the ribbon, the Queries pane, the Data view, and the Query Settings pane.

Η κορδέλα ερωτήματοςThe query ribbon

Η κορδέλα στο πρόγραμμα επεξεργασίας Power Query αποτελείται από τέσσερις καρτέλες: Αρχική, Μετασχηματισμός, Προσθήκη στήλης και Προβολή.The ribbon in Power Query Editor consists of four tabs: Home, Transform, Add Column, and View.

Η καρτέλα Αρχική περιέχει τις συνήθεις εργασίες ερωτήματος.The Home tab contains the common query tasks.

Στιγμιότυπο οθόνης του παραθύρου Power BI Desktop που εμφανίζει την κορδέλα ερωτήματος στο Πρόγραμμα επεξεργασίας Power Query.

Για να συνδεθείτε σε δεδομένα και να ξεκινήσετε τη διαδικασία δημιουργίας ερωτημάτων, επιλέξτε Νέα προέλευση.To connect to data and begin the query building process, select New Source. Εμφανίζεται ένα μενού, το οποίο παρέχει τις πιο κοινές προελεύσεις δεδομένων.A menu appears, providing the most common data sources.

Στιγμιότυπο οθόνης του Power BI Desktop που εμφανίζει το κουμπί Νέα προέλευση.

Για περισσότερες πληροφορίες σχετικά με τις διαθέσιμες προελεύσεις δεδομένων, ανατρέξτε στο θέμα Προελεύσεις δεδομένων.For more information about available data sources, see Data Sources. Για πληροφορίες, παραδείγματα και οδηγίες σχετικά με τη σύνδεση σε δεδομένα, ανατρέξτε στο θέμα Σύνδεση σε δεδομένα.For information about connecting to data, including examples and steps, see Connect to Data.

Η καρτέλα Μετασχηματισμός παρέχει πρόσβαση σε κοινές εργασίες μετασχηματισμού δεδομένων, όπως:The Transform tab provides access to common data transformation tasks, such as:

  • Προσθήκη ή κατάργηση στηλώνAdding or removing columns
  • Αλλαγή τύπων δεδομένωνChanging data types
  • Διαίρεση στηλώνSplitting columns
  • Άλλες εργασίες που βασίζονται σε δεδομέναOther data-driven tasks

Στιγμιότυπο οθόνης του Power BI Desktop που εμφανίζει την καρτέλα Αρχική.

Για περισσότερες πληροφορίες και παραδείγματα σχετικά με τον μετασχηματισμό δεδομένων, ανατρέξτε στο θέμα Εκμάθηση: Συνδυασμός και διαμόρφωση δεδομένων στο Power BI Desktop.For more information about transforming data, including examples, see Tutorial: Shape and combine data in Power BI Desktop.

Η καρτέλα Προσθήκη στήλης παρέχει πρόσθετες εργασίες που σχετίζονται με την προσθήκη μιας στήλης, τη μορφοποίηση μιας στήλης δεδομένων και την προσθήκη προσαρμοσμένων στηλών.The Add Column tab provides additional tasks associated with adding a column, formatting column data, and adding custom columns. Στην ακόλουθη εικόνα εμφανίζεται η καρτέλα Προσθήκη στήλης.The following image shows the Add Column tab.

Στιγμιότυπο οθόνης του παραθύρου Power BI Desktop που εμφανίζει την καρτέλα Προσθήκη στήλης.

Η καρτέλα Προβολή στην κορδέλα χρησιμοποιείται για την ενεργοποίηση ή απενεργοποίηση της εμφάνισης κάποιων παραθύρων ή τμημάτων παραθύρου.The View tab on the ribbon is used to toggle whether certain panes or windows are displayed. Χρησιμοποιείται επίσης για την εμφάνιση του Προηγμένου προγράμματος επεξεργασίας.It's also used to display the Advanced Editor. Στην ακόλουθη εικόνα εμφανίζεται η καρτέλα Προβολή.The following image shows the View tab.

Στιγμιότυπο οθόνης του Power BI Desktop που εμφανίζει την καρτέλα Προβολή.

Είναι χρήσιμο να γνωρίζετε ότι πολλές από τις εργασίες που είναι διαθέσιμες από την κορδέλα είναι επίσης διαθέσιμες κάνοντας δεξί κλικ σε μια στήλη ή σε άλλα δεδομένα στο κεντρικό τμήμα παραθύρου.It's useful to know that many of the tasks available from the ribbon are also available by right-clicking a column, or other data, in the center pane.

Το αριστερό τμήμα παραθύρου (Ερωτήματα)The left (Queries) pane

Το αριστερό τμήμα παραθύρου ή τμήμα παραθύρου Ερωτήματα, εμφανίζει τον αριθμό των ενεργών ερωτημάτων και το όνομα του ερωτήματος.The left pane, or Queries pane, displays the number of active queries and the name of the query. Όταν επιλέγετε ένα ερώτημα από το αριστερό τμήμα παραθύρου, τα δεδομένα του εμφανίζονται στο κεντρικό τμήμα παραθύρου, όπου μπορείτε να διαμορφώσετε και να μετασχηματίσετε τα δεδομένα ώστε να ανταποκρίνονται στις ανάγκες σας.When you select a query from the left pane, its data is displayed in the center pane, where you can shape and transform the data to meet your needs. Στην ακόλουθη εικόνα εμφανίζεται το αριστερό τμήμα παραθύρου με ένα ερώτημα.The following image shows the left pane with a query.

Στιγμιότυπο οθόνης του παραθύρου Power BI Desktop που εμφανίζει τα Ερωτήματα στο αριστερό τμήμα παραθύρου.

Το κεντρικό τμήμα παραθύρου (Δεδομένα)The center (Data) pane

Στο κεντρικό τμήμα παραθύρου, γνωστό και ως τμήμα παραθύρου Δεδομένα, εμφανίζονται τα δεδομένα από το επιλεγμένο ερώτημα.In the center pane, or Data pane, data from the selected query is displayed. Σε αυτό το σημείο πραγματοποιείται το μεγαλύτερο μέρος της εργασίας της προβολής Ερώτημα.This pane is where much of the work of the Query view is accomplished.

Στην παρακάτω εικόνα εμφανίζεται η σύνδεση δεδομένων Web που καθορίστηκε νωρίτερα.In the following image shows the Web data connection established earlier. Η στήλη Προϊόν είναι επιλεγμένη και έχει γίνει δεξί κλικ στην κεφαλίδα της για να εμφανίσει τα διαθέσιμα στοιχεία μενού.The Product column is selected, and its header is right-clicked to show the available menu items. Παρατηρήστε ότι πολλά από αυτά τα στοιχεία του μενού δεξιού κλικ είναι ίδια με τα κουμπιά στις καρτέλες της κορδέλας.Notice that many of these right-click menu items are the same as buttons in the ribbon tabs.

Στιγμιότυπο οθόνης του Power BI Desktop που εμφανίζει το στοιχείο Δεδομένα στο κεντρικό τμήμα παραθύρου.

Όταν επιλέγετε ένα στοιχείο μενού δεξιού κλικ (ή ένα κουμπί στην κορδέλα), το ερώτημα εφαρμόζει το βήμα στα δεδομένα.When you select a right-click menu item (or a ribbon button), the query applies the step to the data. Το αποθηκεύει επίσης ως μέρος του ίδιου του ερωτήματος.It also saves step as part of the query itself. Τα βήματα καταγράφονται στο τμήμα παραθύρου Ρυθμίσεις ερωτήματος με διαδοχική σειρά, όπως περιγράφεται στην επόμενη ενότητα.The steps are recorded in the Query Settings pane in sequential order, as described in the next section.

Το δεξιό τμήμα παραθύρου (Ρυθμίσεις ερωτήματος)The right (Query Settings) pane

Το δεξιό τμήμα παραθύρου ή το παράθυρο Ρυθμίσεις ερωτήματος, είναι το σημείο στο οποίο εμφανίζονται όλα τα βήματα που σχετίζονται με ένα ερώτημα.The right pane, or Query Settings pane, is where all steps associated with a query are displayed. Για παράδειγμα, στην παρακάτω εικόνα, η ενότητα Εφαρμοσμένα βήματα του τμήματος παραθύρου Ρυθμίσεις ερωτήματος αντικατοπτρίζει το γεγονός ότι μόλις αλλάξαμε τον τύπο της στήλης Συνολική βαθμολογία.For example, in the following image, the Applied Steps section of the Query Settings pane reflects the fact that we just changed the type of the Overall score column.

Στιγμιότυπο οθόνης του Power BI Desktop που εμφανίζει τις Ρυθμίσεις ερωτήματος στο δεξιό τμήμα παραθύρου.

Καθώς προστίθενται επιπλέον βήματα διαμόρφωσης στο ερώτημα, αυτά καταγράφονται στην ενότητα Εφαρμοσμένα βήματα.As additional shaping steps are applied to the query, they're captured in the Applied Steps section.

Είναι σημαντικό να γνωρίζετε ότι τα υποκείμενα δεδομένα δεν έχουν αλλάξει.It's important to know that the underlying data isn't changed. Αντίθετα, το πρόγραμμα επεξεργασίας Power Query ρυθμίζει και διαμορφώνει την προβολή των δεδομένων.Rather, Power Query Editor adjusts and shapes its view of the data. Επίσης, διαμορφώνει και προσαρμόζει την προβολή οποιασδήποτε αλληλεπίδρασης με τα υποκείμενα δεδομένα που προκύπτει με βάση τη μορφή και την τροποποιημένη προβολή του προγράμματος επεξεργασίας Power Query για αυτά τα δεδομένα.It also shapes and adjusts the view of any interaction with the underlying data that occurs based on Power Query Editor's shaped and modified view of that data.

Στο τμήμα παραθύρου Ρυθμίσεις ερωτήματος, μπορείτε να μετονομάσετε, να διαγράψετε ή να αναδιατάξετε τα βήματα όπως επιθυμείτε.In the Query Settings pane, you can rename steps, delete steps, or reorder the steps as you see fit. Για να το κάνετε αυτό, κάντε δεξί κλικ στο βήμα στην ενότητα Εφαρμοσμένα βήματα και έπειτα κάντε μια επιλογή από το μενού που εμφανίζεται.To do so, right-click the step in the Applied Steps section, and choose from the menu that appears. Όλα τα βήματα εκτελούνται με τη σειρά που εμφανίζονται στο τμήμα παραθύρου Εφαρμοσμένα βήματα.All query steps are carried out in the order they appear in the Applied Steps pane.

Στιγμιότυπο οθόνης του Power BI Desktop που εμφανίζει τα φίλτρα Ιδιότητες ρυθμίσεων ερωτημάτων και Εφαρμοσμένα βήματα.

Προηγμένο πρόγραμμα επεξεργασίαςAdvanced Editor

Το Προηγμένο πρόγραμμα επεξεργασίας σάς επιτρέπει να βλέπετε τον κωδικό που δημιουργεί το πρόγραμμα επεξεργασίας Power Query με κάθε βήμα.The Advanced Editor lets you see the code that Power Query Editor is creating with each step. Σας επιτρέπει επίσης να δημιουργήσετε τον δικό σας κώδικα διαμόρφωσης.It also lets you create your own shaping code. Για να εκκινήσετε το Προηγμένο πρόγραμμα επεξεργασίας, επιλέξτε Προβολή από την κορδέλα και έπειτα επιλέξτε Προηγμένο πρόγραμμα επεξεργασίας.To launch the advanced editor, select View from the ribbon, then select Advanced Editor. Θα ανοίξει ένα παράθυρο που εμφανίζει τον υπάρχοντα κώδικα του ερωτήματος.A window appears, showing the existing query code.
Στιγμιότυπο οθόνης του Power BI Desktop που εμφανίζει το παράθυρο διαλόγου Προηγμένο πρόγραμμα επεξεργασίας.Screenshot of Power B I Desktop showing Advanced Editor dialog box.

Μπορείτε να επεξεργαστείτε απευθείας τον κώδικα στο παράθυρο Προηγμένο πρόγραμμα επεξεργασίας.You can directly edit the code in the Advanced Editor window. Για να κλείσετε το παράθυρο, επιλέξτε το κουμπί Τέλος ή Άκυρο.To close the window, select the Done or Cancel button.

Αποθήκευση της εργασίας σαςSaving your work

Όταν το ερώτημά σας είναι στο σημείο που θέλετε, επιλέξτε Κλείσιμο και εφαρμογή από το μενού Αρχείο του προγράμματος επεξεργασίας Power Query.When your query is where you want it, select Close & Apply from Power Query Editor's File menu. Αυτή η ενέργεια εφαρμόζει τις αλλαγές και κλείνει το πρόγραμμα επεξεργασίας.This action applies the changes and closes the editor.
Στιγμιότυπο οθόνης του Power BI Desktop που εμφανίζει την επιλογή Κλείσιμο και εφαρμογή στην καρτέλα Αρχείο.Screenshot of Power B I Desktop showing Close and Apply option under File tab.

Το Power BI Desktop ανοίγει ένα παράθυρο διαλόγου στο οποίο εμφανίζεται η κατάσταση της προόδου.As progress is made, Power BI Desktop provides a dialog to display its status.
Στιγμιότυπο οθόνης του Power BI Desktop που εμφανίζει το παράθυρο διαλόγου επιβεβαίωσης Εφαρμοσμένες αλλαγές ερωτήματος.

Όταν είστε έτοιμοι, το Power BI Desktop μπορεί να αποθηκεύσει την εργασία σας με τη μορφή ενός αρχείου .pbix.When you're ready, Power BI Desktop can save your work in the form of a .pbix file.

Για να αποθηκεύσετε την εργασία σας, επιλέξτε Αρχείο > ΑποθήκευσηΑρχείο > Αποθήκευση ως), όπως φαίνεται στην παρακάτω εικόνα.To save your work, select File > Save (or File > Save As), as shown in the following image.
Στιγμιότυπο οθόνης του παραθύρου Power BI Desktop που εμφανίζει την καρτέλα "Αρχείο" του προγράμματος επεξεργασίας Power Query.Screenshot of Power B I Desktop showing Power Query Editor File tab.

Επόμενα βήματαNext steps

Υπάρχουν πολλά πράγματα που μπορείτε να κάνετε με το Power BI Desktop.There are all sorts of things you can do with Power BI Desktop. Για περισσότερες πληροφορίες σχετικά με τις δυνατότητές του, δείτε τους παρακάτω πόρους:For more information on its capabilities, check out the following resources: