Adatmegjelenítés vonaldiagramként, tortadiagramként vagy sávdiagramként a PowerAppsbenShow data in a line, pie, or bar chart in PowerApps

Adatai megjelenítéséhez vonaldiagramot, tortadiagramot vagy sávdiagramot is használhat.Use line charts, pie charts, and bar charts to display your data. Diagramokkal való munkánál az importált adatokat az alábbi módon kell strukturálni:When working with charts, the data that you import should be structured like the following:

  • Minden sorozatnak az első sorban kell lennie.Each series should be in the first row.
  • A címkéknek a bal szélen lévő oszlopban kell lenniük.Labels should be in the leftmost column.

Az adatok például az alábbi módon nézhetnek ki:For example, your data should look similar to the following:

A diagramokat létrehozhatja és használhatja a PowerApps szolgáltatásban.You can create and use these charts within PowerApps. Tegyük meg az első lépéseket!Let's get started.

ElőfeltételekPrerequisites

  • Regisztráljon a PowerApps szolgáltatásra, és telepítse a PowerAppst.Sign up for PowerApps, and then install PowerApps. A PowerApps megnyitásakor a regisztráció során használt hitelesítő adatokkal jelentkezzen be.When you open PowerApps, sign in using the same credentials that you used to sign up.
  • Hozzon létre alkalmazást sablon vagy adatok alapján, vagy sablon nélkül.Create an app from a template, from data, or from scratch.
  • Ismerje meg a vezérlők konfigurálásának módját a PowerAppsben.Learn how to configure a control in PowerApps.
  • Töltse le a ChartData.zip fájlt, amely mintaadatokat tartalmaz XML formátumban.Download ChartData.zip, which contains sample data as an XML file. Az ebben az oktatóanyagban leírtak szerint importálja az alkalmazásába.Follow the steps in this topic to import it directly into your app. Másik megoldásként kibonthatja a .zip fájlt, és az XML-fájlt megnyithatja az Excelben, majd mentheti egy felhőbeli tárfiókba.As an alternative, decompress the .zip file, open the XML file in Excel, and save it to a cloud-storage account.

A mintaadatok importálásaImport the sample data

Ebben a lépésben a mintaadatokat a ProductRevenue nevű gyűjteménybe importáljuk.In these steps, we import the sample data into a collection, named ProductRevenue.

  1. A Beszúrás lapon kattintson a Vezérlők, majd az Importálás elemre:On the Insert tab, select Controls, and then select Import:

  2. Állítsa be a vezérlő OnSelect tulajdonságához a következő függvényt:Set the control's OnSelect property to the following function:
    Collect(ProductRevenue, Import1.Data)
  3. Nyomja meg az F5 billentyűt az Előnézet mód megnyitásához, majd válassza az Adatok importálása gombot.Press F5 to open Preview mode, and then select the Import Data button.
  4. A Megnyitás párbeszédablakban válassza a ChartData.zip fájlt, majd a Megnyitás gombot, és végül nyomja meg az ESC billentyűt.In the Open dialog box, select ChartData.zip, select Open, and then press Esc.
  5. A Fájl menüben válassza a Gyűjtemények lehetőséget.On the File menu, select Collections.

    A ProductRevenue gyűjtemény megjelenik az importált diagramadatokban:The ProductRevenue collection is listed with the chart data you imported:

    Megjegyzés

    Az importálási vezérlő segítségével Excel-adatokhoz hasonló adatokat importálhat, és létrehozhatja a gyűjteményt.The import control is used to import Excel-like data and create the collection. Az importálási vezérlő adatokat importál az alkalmazás létrehozása és előzetes megtekintése során.The import control imports data when you are creating your app, and previewing your app. Az alkalmazás közzététele során az importálási vezérlő jelenleg nem importál adatokat.Currently, the import control does not import data when you publish your app.

  6. Az Esc billentyű lenyomásával térjen vissza az alapértelmezett munkaterületre.Press Esc to return to the default workspace.

Tortadiagram hozzáadásaAdd a pie chart

  1. A Beszúrás lapon kattintson a Diagramok elemre, majd válassza a Tortadiagramot.On the Insert tab, select Charts, and then select Pie Chart.
  2. Húzza a tortadiagramot az Adatok importálása gomb alá.Move the pie chart under the Import data button.
  3. A tortadiagram vezérlőelemben válassza ki a diagram közepét:In the pie-chart control, select the middle of the pie chart:

  4. A tortadiagram Items tulajdonságát állítsa erre a kifejezésre:Set the Items property of the pie chart to this expression:

    
     ![][2]  
    
     <span data-ttu-id="de941-136">A tortadiagram a 2014-es bevételi adatokat mutatja.</span><span class="sxs-lookup"><span data-stu-id="de941-136">The pie chart shows the revenue data from 2014.</span></span>
    
     ![][3]  
    
    
    

Adatok megjelenítése sávdiagram hozzáadásávalAdd a bar chart to display your data

Most használjuk ezt a ProductRevenue gyűjteményt a sávdiagrammal:Now, let's use this ProductRevenue collection in a bar chart:

  1. Adjon hozzá egy új képernyőt a Kezdőlap lapon.On the Home tab, add a screen.
  2. A Beszúrás lapon kattintson a Diagramok elemre, majd válassza a Oszlopdiagramot.On the Insert tab, select Charts, and then select Column Chart.
  3. Válassza ki a diagram közepét.Select the middle of the column chart. Az oszlopdiagram Items tulajdonságát állítsa a következő értékre ProductRevenue:Set the Items property of the column chart to ProductRevenue:

    Az oszlopdiagram a 2012-es bevételi adatokat mutatja:The column chart shows the revenue data from 2012:

  4. Az oszlopdiagramban válassza ki a középső négyzetet:In the column chart, select the center square:

  5. A Diagram lapon válassza a Number of Series (Sorozatok száma) elemet, és írja a 3 számot a képletsávba:On the Chart tab, select Number of Series, and then enter 3 in the formula bar:

    Az oszlopdiagram ekkor az egyes termékekhez tartozó bevételt jeleníti meg egy három éves időszakban:The column chart shows revenue data for each product over three years: