Sviluppare script U-SQL tramite Strumenti Data Lake per Visual StudioDevelop U-SQL scripts by using Data Lake Tools for Visual Studio

Informazioni su come usare Visual Studio per creare account Azure Data Lake Analytics, definire processi in U-SQL e inviare processi al servizio Data Lake Analytics.Learn how to use Visual Studio to create Azure Data Lake Analytics accounts, define jobs in U-SQL, and submit jobs to the Data Lake Analytics service. Per altre informazioni su Data Lake Analytics, vedere Panoramica di Azure Data Lake Analytics.For more information about Data Lake Analytics, see Azure Data Lake Analytics overview.

Importante

Per prepararsi al nuovo Regolamento generale sulla protezione dei dati (GDPR) che entrerà in vigore il 25 maggio 2018, si consiglia agli utenti di Strumenti Azure Data Lake per Visual Studio di eseguire l'aggiornamento alla versione 2.3.3000.4 o successiva.In preparation for the new General Data Protection Regulation (GDPR) going into effect on May 25, 2018, it is recommended that users of Azure Data Lake Tools for Visual Studio upgrade to version 2.3.3000.4 or later. Questa versione include modifiche apportate in base ai requisiti di protezione dei dati più recenti.This version includes changes based on the most recent data protection requirements. Le versioni precedenti non sono disponibili per il download e sono deprecate.Note that previous versions are not available for download and are deprecated.

Cosa occorre fare?What do I need to do?

  1. Controllare se si stia usando una versione di Strumenti Azure Data Lake per Visual Studio precedente alla 2.3.3000.4.Check if you are using an earlier version than 2.3.3000.4 of Azure Data Lake Tools for Visual Studio.

    Controllare la versione degli strumenti

  2. Se la versione è precedente alla 2.3.3000.4, eseguire l'aggiornamento di Strumenti Azure Data Lake per Visual Studio visitando l'Area download:If your version is an earlier version of 2.3.3000.4, update your Azure Data Lake Tools for Visual Studio by visiting the download center:

prerequisitiPrerequisites

Installare Strumenti Azure Data Lake per Visual StudioInstall Azure Data Lake Tools for Visual Studio

Installare Strumenti Azure Data Lake per Visual Studio 2017Install Azure Data Lake Tools for Visual Studio 2017

Strumenti Azure Data Lake per Visual Studio è supportato in Visual Studio 2017 15.3 o versioni successive.Azure Data Lake Tools for Visual Studio is supported in Visual Studio 2017 15.3 or above. Lo strumento fa parte dei carichi di lavoro Elaborazione ed archiviazione dati e Sviluppo di Azure nel programma di installazione di Visual Studio.The tool is part of the Data storage and processing and Azure Development workloads in Visual Studio Installer. Abilitare uno di questi due carichi di lavoro durante l'installazione di Visual Studio.Enable either one of these two workloads as part of your Visual Studio installation.

Abilitare il carico di lavoro Elaborazione ed archiviazione dati come illustrato: Abilitare il carico di lavoro Elaborazione ed archiviazione datiEnable the Data storage and processing workload as shown: Enable Data storage and processing workload

Abilitare il carico di lavoro Sviluppo di Azure come illustrato: Abilitare il carico di lavoro Sviluppo di AzureEnable the Azure development workload as shown: Enable Azure development workload

Installare Strumenti Azure Data Lake per Visual Studio 2013 e 2015Install Azure Data Lake Tools for Visual Studio 2013 and 2015

Scaricare e installare Strumenti Azure Data Lake per Visual Studio dall'Area download.Download and install Azure Data Lake Tools for Visual Studio from the Download Center. Dopo l'installazione si noti che:After installation, note that:

  • Il nodo Esplora server > Azure contiene un nodo Data Lake Analytics.The Server Explorer > Azure node contains a Data Lake Analytics node.
  • Il menu Strumenti include una voce Data Lake.The Tools menu has a Data Lake item.

Connettersi a un account Azure Data Lake AnalyticsConnect to an Azure Data Lake Analytics account

  1. Aprire Visual Studio.Open Visual Studio.
  2. Aprire Esplora server selezionando Visualizza > Esplora Server.Open Server Explorer by selecting View > Server Explorer.
  3. Fare clic con il pulsante destro del mouse su Azure.Right-click Azure. Scegliere quindi Connetti a sottoscrizione di Microsoft Azure e seguire le istruzioni.Then select Connect to Microsoft Azure Subscription and follow the instructions.
  4. In Esplora server selezionare Azure > Data Lake Analytics.In Server Explorer, select Azure > Data Lake Analytics. Verrà visualizzato un elenco degli account Data Lake Analytics.You see a list of your Data Lake Analytics accounts.

Scrivere il primo script U-SQLWrite your first U-SQL script

Il testo seguente è un semplice script U-SQL.The following text is a simple U-SQL script. Definisce un set di dati di piccole dimensioni e scrive tale set di dati nell'istanza predefinita di Data Lake Store come file denominato /data.csv.It defines a small dataset and writes that dataset to the default Data Lake Store as a file called /data.csv.

@a  = 
    SELECT * FROM 
        (VALUES
            ("Contoso", 1500.0),
            ("Woodgrove", 2700.0)
        ) AS 
              D( customer, amount );
OUTPUT @a
    TO "/data.csv"
    USING Outputters.Csv();

Inviare un processo di Data Lake AnalyticsSubmit a Data Lake Analytics job

  1. Selezionare File > Nuovo > Progetto.Select File > New > Project.

  2. Selezionare il tipo di Progetto U-SQL e quindi fare clic su OK.Select the U-SQL Project type, and then click OK. Visual Studio crea una soluzione con un file Script.usql.Visual Studio creates a solution with a Script.usql file.

  3. Incollare lo script precedente nella finestra Script.usql.Paste the previous script into the Script.usql window.

  4. Nell'angolo superiore sinistro della finestra Script.usql specificare l'account Data Lake Analytics.In the upper-left corner of the Script.usql window, specify the Data Lake Analytics account.

    Invio progetto Visual Studio U-SQL

  5. Nell'angolo superiore sinistro della finestra Script.usql selezionare Invia.In the upper-left corner of the Script.usql window, select Submit.

  6. Verificare il nome presente in Account Analytics e quindi selezionare Invia.Verify the Analytics Account, and then select Submit. Al termine dell'invio, nella finestra dei risultati di Strumenti Data Lake per Visual Studio saranno disponibili i risultati dell'operazione di invio.Submission results are available in the Data Lake Tools for Visual Studio Results after the submission is complete.

    Invio progetto Visual Studio U-SQL

  7. Per visualizzare lo stato più aggiornato del processo e aggiornare la schermata, fare clic su Aggiorna.To see the latest job status and refresh the screen, click Refresh. Quando il processo ha esito positivo, vengono visualizzate le schede Grafico del processo, Operazioni metadati, Cronologia dello stato e Diagnostica:When the job succeeds, it shows the Job Graph, MetaData Operations, State History, and Diagnostics:

    Grafico delle prestazioni del processo di Analisi Data Lake per Visual Studio U-SQL

    • Riepilogo processo mostra il riepilogo del processo.Job Summary shows the summary of the job.
    • Dettagli processo mostra informazioni più specifiche sul processo, inclusi script, risorse e vertici.Job Details shows more specific information about the job, including the script, resources, and vertices.
    • Grafico del processo visualizza l'andamento del processo.Job Graph visualizes the progress of the job.
    • Operazioni metadati mostra tutte le azioni eseguite nel catalogo U-SQL.MetaData Operations shows all the actions that were taken on the U-SQL catalog.
    • Dati mostra tutti gli input e gli output.Data shows all the inputs and outputs.
    • Diagnostica fornisce un'analisi avanzata per l'ottimizzazione dell'esecuzione e delle prestazioni del processo.Diagnostics provides an advanced analysis for job execution and performance optimization.

Per controllare lo stato del processoTo check job state

  1. In Esplora server selezionare Azure > Data Lake Analytics.In Server Explorer, select Azure > Data Lake Analytics.
  2. Espandere il nome dell'account Data Lake Analytics.Expand the Data Lake Analytics account name.
  3. Fare doppio clic su Processi.Double-click Jobs.
  4. Selezionare il processo inviato in precedenza.Select the job that you previously submitted.

Per visualizzare l'output di un processoTo see the output of a job

  1. In Esplora server cercare il processo inviato.In Server Explorer, browse to the job you submitted.
  2. Fare clic sulla scheda Dati .Click the Data tab.
  3. Nella scheda Output del processo selezionare il file "/data.csv".In the Job Outputs tab, select the "/data.csv" file.

Passaggi successiviNext steps