Panoramica delle query in Power BI DesktopQuery overview in Power BI Desktop

Con Power BI Desktop è possibile connettersi a un mondo di dati, creare report efficaci e fondamentali e condividere il proprio impegno con altri utenti, che potranno quindi basarsi sul lavoro già svolto ed espandere le proprie attività di business intelligence.With Power BI Desktop you can connect to the world of data, create compelling and foundational reports, and share your efforts with others – who can then build on your work, and expand their business intelligence efforts.

Power BI Desktop offre tre visualizzazioni:Power BI Desktop has three views:

  • Report : consente di usare le query create dall'utente per generare visualizzazioni interessanti, organizzate nella sequenza preferita e con più pagine, che è possibile condividere con altriReport view – where you use queries you create to build compelling visualizations, arranged as you want them to appear, and with multiple pages, that you can share with others
  • Dati : consente di visualizzare i dati nel report in formato di modello di dati, a cui è possibile aggiungere misure, creare nuove colonne e gestire le relazioniData view – see the data in your report in data model format, where you can add measures, create new columns, and manage relationships
  • Relazioni : consente di ottenere una rappresentazione grafica delle relazioni che sono state stabilite nel modello di dati e di gestirle o modificarle in base alle esigenze.Relationships view – get a graphical representation of the relationships that have been established in your data model, and manage or modify them as needed.

Per accedere a queste visualizzazioni, selezionare una delle tre icone lungo il lato sinistro di Power BI Desktop.Access these views by selecting one of the three icons along the left side of Power BI Desktop. Nella figura seguente è selezionata la visualizzazione Report, indicata dalla striscia di colore giallo accanto all'icona.In the following image, Report view is selected, indicated by the yellow band beside the icon.

Screenshot di Power BI Desktop che mostra la visualizzazione Report selezionata.

Insieme a Power BI Desktop è disponibile anche l'editor di Power Query.Power BI Desktop also comes with Power Query Editor. Con questo editor è possibile connettersi a una o più origini dati, eseguire il data shaping e trasformare i dati in base alle esigenze, quindi caricare il modello in Power BI Desktop.Use Power Query Editor to connect to one or many data sources, shape and transform the data to meet your needs, then load that model into Power BI Desktop.

Questo documento offre una panoramica delle operazioni sui dati eseguite nell'editor di Power Query, ma sono disponibili molte altre informazioni.This document provides an overview of the work with data in the Power Query Editor, but there's more to learn. Alla fine di questo documento, seguire i collegamenti alle linee guida dettagliate sui tipi di dati supportati.At the end of this document, you'll find links to detailed guidance about supported data types. Sono anche disponibili altre informazioni sulla connessione ai dati, sul data shaping, sulla creazione di relazioni e su come iniziare.You'll also find guidance about connecting to data, shaping data, creating relationships, and how to get started.

Prima di tutto è necessario acquisire familiarità con l'editor di Power Query.But first, let's see get acquainted with Power Query Editor.

Editor di Power QueryPower Query Editor

Per aprire l'editor di Power Query, selezionare Modifica query nella scheda Home di Power BI Desktop.To get to Power Query Editor, select Edit Queries from the Home tab of Power BI Desktop.

Screenshot di Power BI Desktop che mostra la scheda Home dell'editor di Power Query.

Senza connessioni dati, l'editor di Power Query appare come un riquadro vuoto, pronto per i dati.With no data connections, Power Query Editor appears as a blank pane, ready for data.

Screenshot di Power BI Desktop che mostra l'editor di Power Query senza connessioni dati.

Dopo il caricamento di una query, i dati visualizzati nell'editor di Power Query diventano più interessanti.Once a query is loaded, Power Query Editor view becomes more interesting. Se ci si connette all'origine dati Web seguente, l'editor di Power Query carica le informazioni relative ai dati, a cui è possibile iniziare a dare forma:If we connect to the following Web data source, Power Query Editor loads information about the data, which you can then begin to shape:

https://www.bankrate.com/retirement/best-and-worst-states-for-retirement/

Ecco come viene visualizzato l'editor di Power Query dopo l'attivazione di una connessione dati:Here's how Power Query Editor appears once a data connection is established:

  1. Nella barra multifunzione molti pulsanti sono ora attivi per interagire con i dati nella query.In the ribbon, many buttons are now active to interact with the data in the query.

  2. Nel riquadro sinistro le query sono elencate e disponibili per la selezione, la visualizzazione e il data shaping.In the left pane, queries are listed and available for selection, viewing, and shaping.

  3. Nel riquadro centrale i dati della query selezionata vengono visualizzati e sono disponibili per il data shaping.In the center pane, data from the selected query is displayed and available for shaping.

  4. Viene visualizzato il riquadro Impostazioni query, che elenca le proprietà della query e i passaggi applicati.The Query Settings pane appears, listing the query's properties and applied steps.

    Screenshot di Power BI Desktop che mostra il riquadro Impostazioni query nell'editor di Power Query.

Nelle sezioni seguenti si esamineranno queste quattro aree: la barra multifunzione, il riquadro Query, la visualizzazione Dati e il riquadro Impostazioni query.We'll look at each of these four areas: the ribbon, the Queries pane, the Data view, and the Query Settings pane.

Barra multifunzione queryThe query ribbon

La barra multifunzione dell'editor di Power Query è costituita da quattro schede: Home, Trasforma, Aggiungi colonna e Visualizza.The ribbon in Power Query Editor consists of four tabs: Home, Transform, Add Column, and View.

La scheda Home contiene le attività comuni relative alle query.The Home tab contains the common query tasks.

Screenshot di Power BI Desktop che mostra la barra multifunzione per la query dell'editor di Power Query.

Per connettersi ai dati e iniziare a creare query, selezionare il pulsante Nuova origine.To connect to data and begin the query building process, select New Source. Viene visualizzato un menu, che fornisce le origini dati più comuni.A menu appears, providing the most common data sources.

Screenshot di Power BI Desktop che mostra il pulsante Nuova origine.

Per altre informazioni sulle origini dati disponibili, vedere Origini dati.For more information about available data sources, see Data Sources. Per informazioni sulla connessione ai dati, includi gli esempi e i passaggi, vedere Connettersi ai dati.For information about connecting to data, including examples and steps, see Connect to Data.

La scheda Trasforma consente di accedere alle attività di trasformazione dei dati comuni, ad esempio:The Transform tab provides access to common data transformation tasks, such as:

  • Aggiunta o rimozione di colonneAdding or removing columns
  • Modifica dei tipi di datiChanging data types
  • Suddivisione di colonneSplitting columns
  • Altre attività guidate dai datiOther data-driven tasks

Screenshot di Power BI Desktop che mostra la scheda Home.

Per altre informazioni sulla trasformazione dei dati, inclusi gli esempi, vedere Esercitazione: Data shaping e combinazione di dati in Power BI Desktop.For more information about transforming data, including examples, see Tutorial: Shape and combine data in Power BI Desktop.

La scheda Aggiungi colonna fornisce ulteriori attività associate all'aggiunta di una colonna, la formattazione di dati della colonna e l'aggiunta di colonne personalizzate.The Add Column tab provides additional tasks associated with adding a column, formatting column data, and adding custom columns. L'immagine seguente mostra la scheda Aggiungi colonna .The following image shows the Add Column tab.

Screenshot di Power BI Desktop che mostra la scheda Aggiungi colonna.

La scheda Visualizza sulla barra multifunzione viene usata per attivare/disattivare la visualizzazione di determinati riquadri o finestre.The View tab on the ribbon is used to toggle whether certain panes or windows are displayed. Viene usata anche per visualizzare l'Editor avanzato.It's also used to display the Advanced Editor. La figura seguente mostra la scheda Visualizza.The following image shows the View tab.

Screenshot di Power BI Desktop che mostra la scheda Visualizza.

È utile sapere che molte delle attività disponibili nella barra multifunzione sono accessibili anche facendo clic con il pulsante destro del mouse su una colonna, o su altri dati, nel riquadro centrale.It's useful to know that many of the tasks available from the ribbon are also available by right-clicking a column, or other data, in the center pane.

Riquadro sinistro (Query)The left (Queries) pane

Nel riquadro sinistro, o Query, viene visualizzato il numero di query attive, oltre al nome della query.The left pane, or Queries pane, displays the number of active queries and the name of the query. Quando si seleziona una query nel riquadro di sinistra, i relativi dati vengono visualizzati nel riquadro centrale, dove è possibile eseguirne lo shaping e la trasformazione in base alle proprie esigenze.When you select a query from the left pane, its data is displayed in the center pane, where you can shape and transform the data to meet your needs. La figura seguente mostra il riquadro sinistro con una query.The following image shows the left pane with a query.

Screenshot di Power BI Desktop che mostra le query nel riquadro sinistro.

Riquadro centrale (Dati)The center (Data) pane

Nel riquadro centrale, o riquadro Dati, vengono visualizzati i dati della query selezionata.In the center pane, or Data pane, data from the selected query is displayed. È in questo riquadro che viene eseguita gran parte delle attività della visualizzazione Query.This pane is where much of the work of the Query view is accomplished.

La figura seguente illustra la connessione dati Web stabilita in precedenza.In the following image shows the Web data connection established earlier. La colonna Product è stata selezionata ed è stato fatto clic con il pulsante destro del mouse sull'intestazione per visualizzare le voci di menu disponibili.The Product column is selected, and its header is right-clicked to show the available menu items. Si noti che molte di queste voci del menu di scelta rapida corrispondono ai pulsanti disponibili nelle schede della barra multifunzione.Notice that many of these right-click menu items are the same as buttons in the ribbon tabs.

Screenshot di Power BI Desktop che mostra i dati nel riquadro centrale.

Quando si seleziona una voce di un menu di scelta rapida (o un pulsante della barra multifunzione), la query applica il passaggio ai datiWhen you select a right-click menu item (or a ribbon button), the query applies the step to the data. e lo salva come parte della query stessa.It also saves step as part of the query itself. I passaggi vengono registrati nel riquadro Impostazioni query in ordine sequenziale, come descritto nella sezione successiva.The steps are recorded in the Query Settings pane in sequential order, as described in the next section.

Riquadro destro (Impostazioni query)The right (Query Settings) pane

Nel riquadro destro, o Impostazioni query, vengono visualizzati tutti i passaggi associati a una query.The right pane, or Query Settings pane, is where all steps associated with a query are displayed. Ad esempio, nell'immagine seguente, nella sezione Passaggi applicati del riquadro Impostazioni query riflette il fatto che è stato appena modificato il tipo della colonna Overall score .For example, in the following image, the Applied Steps section of the Query Settings pane reflects the fact that we just changed the type of the Overall score column.

Screenshot di Power BI Desktop che mostra le impostazioni di query nel riquadro destro.

Man mano che vengono applicati alla query, i passaggi di shaping vengono acquisiti nella sezione Passaggi applicati.As additional shaping steps are applied to the query, they're captured in the Applied Steps section.

È importante sapere che i dati sottostanti non vengono modificati.It's important to know that the underlying data isn't changed. L'editor di Power Query modifica ed esegue lo shaping della sola visualizzazione dei datiRather, Power Query Editor adjusts and shapes its view of the data. e di qualsiasi interazione con i dati sottostanti che avviene in base alla visualizzazione dei dati modificata e sottoposta a data shaping dall'editor.It also shapes and adjusts the view of any interaction with the underlying data that occurs based on Power Query Editor's shaped and modified view of that data.

Nel riquadro Impostazioni query , è possibile rinominare, eliminare o riordinare i passaggi secondo necessità.In the Query Settings pane, you can rename steps, delete steps, or reorder the steps as you see fit. A tale scopo, fare clic con il pulsante destro del mouse sul passaggio nella sezione Passaggi applicati e scegliere dal menu di scelta rapida.To do so, right-click the step in the Applied Steps section, and choose from the menu that appears. Tutte le query vengono eseguite nell'ordine in cui vengono visualizzate nel riquadro Passaggi applicati.All query steps are carried out in the order they appear in the Applied Steps pane.

Screenshot di Power BI Desktop che mostra i filtri Proprietà e Passaggi applicati del riquadro Impostazioni query.

Editor avanzatoAdvanced Editor

L'Editor avanzato consente di visualizzare il codice che l'editor di Power Query sta creando con ogni passaggioThe Advanced Editor lets you see the code that Power Query Editor is creating with each step. e anche di creare codice di shaping personalizzato.It also lets you create your own shaping code. Per avviare l'editor avanzato, selezionare Visualizza dalla barra multifunzione, quindi selezionare Editor avanzato.To launch the advanced editor, select View from the ribbon, then select Advanced Editor. Verrà visualizzata una finestra che mostra il codice della query esistente.A window appears, showing the existing query code.
Screenshot di Power BI Desktop che mostra la finestra di dialogo Editor avanzato.Screenshot of Power B I Desktop showing Advanced Editor dialog box.

È possibile modificare direttamente il codice nella finestra Editor avanzato .You can directly edit the code in the Advanced Editor window. Per chiudere la finestra, selezionare il pulsante Fatto o Annulla .To close the window, select the Done or Cancel button.

Salvare il lavoroSaving your work

Quando la query è definita nel modo desiderato, selezionare Chiudi e applica dal menu File dell'editor di Power Query.When your query is where you want it, select Close & Apply from Power Query Editor's File menu. Questa azione ha l'effetto di applicare le modifiche e chiudere l'editor.This action applies the changes and closes the editor.
Screenshot di Power BI Desktop che mostra l'opzione Chiudi e applica nella scheda File.Screenshot of Power B I Desktop showing Close and Apply option under File tab.

Durante l'avanzamento, una finestra di dialogo di Power BI Desktop ne mostra lo stato.As progress is made, Power BI Desktop provides a dialog to display its status.
Screenshot di Power BI Desktop che mostra la finestra di dialogo di conferma dell'applicazione delle modifiche alla query.

Quando la query è completata, Power BI Desktop può salvare il lavoro in un file con estensione pbix.When you're ready, Power BI Desktop can save your work in the form of a .pbix file.

Per salvare il lavoro, selezionare File > Salva (o File > Salva con nome), come illustrato nella figura seguente.To save your work, select File > Save (or File > Save As), as shown in the following image.
Screenshot di Power BI Desktop che mostra la scheda File dell'editor di Power Query.Screenshot of Power B I Desktop showing Power Query Editor File tab.

Passaggi successiviNext steps

Power BI Desktop offre infinite possibilità.There are all sorts of things you can do with Power BI Desktop. Per altre informazioni sulle capacità disponibili, vedere le risorse seguenti:For more information on its capabilities, check out the following resources: