Visual Studio Icon Visual Studio 2019 バージョン16.10 のリリースノートVisual Studio 2019 version 16.10 Release Notes



開発者コミュニティ |システム要件 |互換性 |再頒布可能コード |ライセンス条項 |ブログ |Visual Studio の新ドキュメントDeveloper Community | System Requirements | Compatibility | Distributable Code | License Terms | Blogs | Whats New in Visual Studio Docs


ボタンをクリックして、Visual Studio 2019 の最新バージョンをダウンロードします。Click a button to download the latest version of Visual Studio 2019. Visual Studio 2019 のインストールと更新の手順については、「Update Visual Studio 2019 to the most recent release」(Visual Studio 2019 を最新リリースに更新する) をご覧ください。For instructions on installing and updating Visual Studio 2019, see the Update Visual Studio 2019 to the most recent release. また、オフラインでインストールする方法の手順もご覧ください。Also, see instructions on how to install offline.

Community Download Button Professional Download Button Enterprise Download Button


Visual Studio 2019 バージョン16.10 の新機能What's New in Visual Studio 2019 version 16.10

Visual Studio 2019 バージョン16.10 のリリースVisual Studio 2019 version 16.10 Releases

Visual Studio 2019 アーカイブされているリリース ノートVisual Studio 2019 Archived Release Notes

Visual Studio 2019 ブログVisual Studio 2019 Blog

Visual Studio 2019 ブログ は、Visual Studio エンジニアリング チームからの製品の分析情報の公式な情報源です。The Visual Studio 2019 Blog is the official source of product insight from the Visual Studio Engineering Team. Visual Studio 2019 リリースの詳細については、次の投稿を参照してください。You can find in-depth information about the Visual Studio 2019 releases in the following posts:


Release Notes Icon Visual Studio 2019 バージョン16.10.0Visual Studio 2019 version 16.10.0 New release icon

リリース日は2021年5月25日released May 25, 2021

このリリースの Visual Studio 2019 バージョン16.10.0 の新機能の概要Summary of What's New in this Release of Visual Studio 2019 version 16.10.0

C++C++

  • このスイッチでは、すべての C++ 20 機能を使用できるようになりました /std:c++latestAll C++20 features are now available under the /std:c++latest switch. MSVC の C++ 20 標準の実装 (現在は ISO によって発行されている) は機能の完了ですが、いくつかの重要な C++ 20 ライブラリ機能は、今後の欠陥報告 (ISO C++ 20 バグ修正) によって修正されることが予想されています。これは、ABI と互換性がありません。While MSVC’s implementation of the C++20 standards (as currently published by ISO) is feature complete, some key C++20 library features are expected to be amended by upcoming Defect Reports (ISO C++20 bug fixes) that may change them in an ABI-incompatible way. 詳細については、 Microsoft/STL の問題 #1814 を参照してください。Please see Microsoft/STL Issue #1814 for more details.
    • C++20 の即時関数と constinit のサポートが、16.10 で追加されましたC++20 immediate functions & constinit support added in 16.10
    • <chrono> の最後の部分: 新しいクロック、うるう秒、タイム ゾーン、解析The final pieces of <chrono>: new clocks, leap seconds, time zones, and parsing
    • テキストの書式設定に対する <format> の実装Implementation of <format> for text formating
  • /openmp:llvm が、x64 に加えて、x86 と ARM64 でも使用できるようになりました。/openmp:llvm is now available on x86 and ARM64, in addition to x64
  • カスタマイズされたコンパイル警告レベルとコード分析設定により、インクルード ディレクトリを外部として指定できるようになりました。Include directories can now be designated as external with customized compilation warning levels and code analysis settings.
  • 以前の言語モードに C++20 スタイルのコルーチンを有効にする /await:strict スイッチを追加しました。Added the /await:strict switch to enable C++20-style coroutines in earlier language modes.
  • デバッガーで std::coroutine_handle<T> が視覚化され、元のコルーチン関数の名前とシグネチャ、および現在の中断ポイントが表示されるようになりました。Debugger visualization of std::coroutine_handle<T> now displays the original coroutine function name and signature and the current suspend point.
  • CMakePresets のサポートを追加しました。Added support for CMakePresets.
  • Visual Studio で新しいリモート接続を追加するときに、サーバーによって提示されるホスト キーのフィンガープリントを受け入れるか拒否するかが求められるようになります。You will now be required to accept or deny the host key fingerprint presented by the server when adding a new remote connection in Visual Studio.
  • 警告の目的で外部として扱われる必要があるヘッダーを指定するために、MSVC に /external スイッチを追加しました。Added an /external switch to MSVC for specifying headers which should be treated as external for warning purposes.

Docker ツールの機能強化Docker Tools improvements

  • どのサービスを開始するかを構成する起動プロファイルを Compose ファイル内に作成する機能。Ability to create a launch profile that configures which services to start in your Compose file.
  • イメージにタグを付ける機能。Ability to tag an image.
  • コンテナーの [ボリューム] タブを追加しました。Added a Volumes tab for containers.
  • コンテナーの [ラベル] タブを追加しました。Added a Labels tab for containers.
  • イメージの [ラベル] タブを追加しました。Added a Labels tab for images.
  • コンテナーは、Compose プロジェクトによってグループ化されました。Containers are now grouped by Compose project.

[エディター]Editor

  • すっきりした表示がお好みの場合は、Visual Studio の検索 (Ctrl + Q) で "行間" を検索して、行間を変更できます。For folks who want a less crowded experience, line spacing can be modified by searching for "line spacing" in Visual Studio Search (Ctrl+Q). このオプションは、[テキスト エディター] > [全般] の下にあります。The option is under Text Editor\General.
  • [フォルダーを指定して検索] と [すべての参照の検索] には、結果を保持するためのコントロールがあります。Find in Files and Find all References have a control to keep results. コミュニティからのフィードバックに基づいて、[結果を保持] オプションを既定でオンに切り替えるオプションを追加しました。Based on feedback from our community, we've added an option to toggle the "Keep Results" option to on by default. このオプションは、Visual Studio の検索 (Ctrl + Q) で "既定で検索結果を保持する" を検索することで見つけることができます。This option can be found by searching for "keep search results by default" in Visual Studio Search (Ctrl+Q). このオプションは、[環境] > [検索と置換] の下にあります。The option is under Environment\Find and Replace. 現在、ユーザーは、[フォルダーを指定して検索] は 5 件、[すべての参照の検索] はさらに 5 件の結果に制限されています。Note that users are currently limited to 5 results for Find in Files and 5 more results for Find all References.
  • [フォルダーを指定して検索] の新しいオプションを使用すると、ユーザーは追加の検索を実行し、その結果を前の検索に追加できます。A new option in Find in Files allows users to run additional searches and append those results to a previous search.

エディターの拡張性Editor Extensibility

  • IntraTextAdornmentTags を管理するコードの動作が変更されました。The behavior of the code that manages IntraTextAdornmentTags has changed. この変更により、他の ITagger と同様に、基になるタグが変更された場合はタグ変更イベントを発生させる必要があります。With this change, just like with any other ITagger, you must raise a tags changed event when the underlying tags change. そうしないと、タグが更新されないおそれがあります。Otherwise, your tags may never be updated.

デバッグと診断Debugging & Diagnostics

  • メモリ ダンプの診断分析に、マネージド Linux のコア ダンプが含まれるようになりました。Diagnostic Analysis of memory dumps now includes Managed Linux core dumps.

Git の生産性Git Productivity

  • ディープ リンクを使用して Web に移動し、新しい pull request を作成し、Git メニューから GitHub または Azure DevOps の PR を表示します。Jump to the web with deep links to create a new pull request and view PRs on GitHub or Azure DevOps from the Git menu.
  • ブランチ ピッカーから 1 回の選択でローカルとリモートのブランチをチェックアウトします。Checkout local and remote branches with a single select from the branch picker.
  • コンテキスト メニューを使用して、リポジトリ ピッカーから項目を削除します。Remove items from the repository picker through the context menu.
  • [Git] > [設定] を使用して、Git リポジトリを開くときのソリューションの自動読み込みを有効にします。Turn on automatic loading of the solution when opening a Git repository through Git > Settings.
  • [Git] > [設定] を使用して、Git リポジトリ ウィンドウからブランチをチェックアウトするためのダブルクリックの動作を切り替えます。Toggle behavior of double-clicking to check out branches from the Git Repository window through Git > Settings.
  • [Git 変更] ウィンドウのオーバーフロー メニューから、ブランチと複数のリモートを同期 (プルしてプッシュ) します。Sync (Pull then Push) your branch with multiple remotes from the Git Changes window overflow menu.
  • オーバーフロー メニューから、[Git 変更] ウィンドウのツール バーに表示される操作 (フェッチ、プル、プッシュ、同期) をカスタマイズします。Customize your visible Git Changes window toolbar actions (Fetch, Pull, Push, Sync) from the overflow menu.
  • [Git 変更] ウィンドウのオーバーフロー メニューから、ブラウザーでリポジトリを開きます。Open your repository in the browser from the Git Changes window overflow menu.
  • ステータス バーからローカル ブランチとリモート ブランチを検索してチェックアウトします。Search and checkout local and remote branches from the status bar.
  • ステータス バーからローカル Git リポジトリを検索して切り替えます。Search and switch between local Git repositories from the status bar.
  • [Git] メニューのローカル リポジトリの一覧が Visual Studio の起動時に読み込まれない問題を修正しました。Fixed an issue where local repositories list in the Git menu wasn't loading on Visual Studio launch.
  • リポジトリを開いたときに、入れ子になったプロジェクトのサブリポジトリをローカル リポジトリの一覧に追加します。Add nested project sub-repos to your local repositories list when opening a repository.
  • [Git] > [設定] を使用してリポジトリを切り替えるときに、ソリューションを開いたままにします。Keep solution open when switching repositories through Git > Settings.
  • [Git] > [設定] を使用してリポジトリを開くときに、フォルダーを開く機能を無効にします。Turn off open folder when opening repositories through Git > Settings.
  • ステータス バーの [プッシュされていないコミット] ボタンまたは [Git] メニューの [同期] コマンドを使用して、ブランチをリモートと同期します。Sync your branch with the remote from the unpushed commits button in the status bar, and from the Sync command in Git Menu.
  • 受信コミットがない場合でも、[Git リポジトリ] ウィンドウの履歴ペインからフェッチしてプルします。Fetch and pull from the Git Repository window history pane even when there are no incoming commits.
  • [コミットの詳細] と、[Git リポジトリ] ウィンドウに埋め込まれたファイルの変更の比較を表示します。View Commit Details and the comparison of file changes embedded in the Git Repository window.
  • Azure DevOps Git リポジトリを開いたときに、自動的に再接続するか、最初の Azure DevOps 接続を確立するようにプロンプトを表示します。Automatically re-connect or prompt to establish initial Azure DevOps connection when opening an Azure DevOps Git repository.
  • マージやリベースの際に、ソースとターゲットという紛らわしい用語に代わって、ブランチ名が表示されます。Merge and rebase with visible branch names, replacing confusing Source / Target terminology.
  • ソリューション エクスプローラーのソース管理のグリフのパフォーマンスと信頼性を強化しました。Improved performance and reliability for source control glyphs in Solution Explorer.
  • 空の場合でも、[Git リポジトリ] ウィンドウで受信セクションと送信セクションが保持されます。Preserve incoming/outgoing sections in Git Repository window even when empty.
  • [Git Changes](Git 変更) ウィンドウの複数のリモートのフェッチ/プル/プッシュのドロップダウンを 1 つのアクション メニューに統合しました。Consolidated Fetch/Pull/Push dropdowns for multiple remotes in Git Changes window to a single Action menu.

.NET の生産性.NET Productivity

  • メソッド呼び出しの引数入力候補Argument completion in method calls
  • EditorConfig UIEditorConfig UI
  • 継承チェーンを視覚的に検査して移動するVisually inspect and navigate the inheritance chain
  • キャスト、インデクサー、および演算子の IntelliSense 入力候補IntelliSense completion for casts, indexers, and operators
  • ソース ジェネレーターのデバッガー サポートDebugger support for Source Generators
  • Visual Basic のコード クリーンアップ サポートCode cleanup support for Visual Basic
  • エディット コンティニュ (EnC) の更新Edit and Continue (EnC) updates
  • Remove Unused References(未使用の参照の削除)Remove Unused References
  • スマート改行Smart Break Line
  • [LINQ 式の簡略化] のリファクタリングSimplify LINQ expression refactoring
  • 列挙値に対する IntelliSense 入力候補IntelliSense completion for Enum values
  • IntelliSense 入力候補のモード設定IntelliSense completion mode setting
  • 新しい行のコード スタイルの設定Code style preference for new lines
  • ソース ジェネレーターでの [すべての参照の検索] のサポートFind All References support for Source Generators

Razor (ASP.NET Core) プレビュー エディターRazor (ASP.NET Core) Preview Editor

  • IntelliSense 入力候補の更新IntelliSense completion updates
  • ジェネリック コンポーネントの定義サポートに移動しますGo to Definition support for generic components
  • タブとスペースの新しいコード スタイルの構成New code style configuration for tabs and spaces
  • ツール オプションの Razor テキスト エディターが Razor (ASP.NET Core) と呼ばれるようになりましたRazor text editor in Tools Options is now called Razor (ASP.NET Core)

テスト エクスペリエンスのアクセシビリティの向上Test Experience Accessibility improvements

  • Console.Writeline がテスト エクスプローラーに表示されるようになりましたConsole.Writeline now shows in the Test Explorer
  • テスト出力でタグを保持できるようになったため、ログ ファイルからでもハイパーリンクとスタックトレース リンクをナビゲートできます。Test output can now preserve tags so hyperlinks and stacktrace links are navigable even from the log files.
  • 出力が 300 文字を超える場合、またはテスト結果に 10 個を超えるファイルがアタッチされている場合は、1 回のテスト結果に対してログ ファイルが作成されます。Log files are created for a single test result when output is over 300 characters or if there are over 10 files attached to the test result.
  • また、ログ ファイルをプレビューで開くことができるようになり、タブの管理が容易になりました。Log files can also now open in preview so it’s easier to manage your tabs.
  • ログ ファイルとテスト エクスプローラーは、カーソルを移動する Ctrl + PgUp/PgDn と、選択のための Shift + Ctrl PgUp/PgDn をサポートしています。Log files and the Test Explorer support Ctrl PgUp/PgDn for navigating the cursor and Shift+Ctrl PgUp/PgDn for selection.
  • ログ ファイル エディターで IVsTextView インターフェイスが使用されるようになり、非常に大きなテキスト ファイルを開くことができるようになります。The log file editor is now using the IVsTextView interface which means it will now be able to open very large text files. これにより、ユーザーは切り捨てられたログの Copy All を行い、メモ帳などの別のエディターで開く必要がなくなります。This should eliminate the need for users to Copy All truncated logs and open them in a separate editor such as Notepad. MSTest の場合は、データ行ごとに個別のログ ファイルを用意するだけではなく、すべての出力を集計する単一のログ ファイルも含まれるようになりました。For MSTest, we now also include a single log file that aggregates all the output instead of only having individual log files for each data row.
  • Dotnet cli を使用して、Ubuntu および Alpine のコマンドラインでクロスプラットフォームのコードカバレッジを取得できるようになりました。You can now get cross-platform code coverage at the command-line on Ubuntu and Alpine with the dotnet cli. これらのプラットフォームを対象とするコンピューターでコードカバレッジを取得することに関心があるユーザーには、windows で通常使用するものと同じコードカバレッジコレクションコマンドを追加できるようになりました。For users interested in getting code coverage on machines targeting those platforms you can now add the same code coverage collection commands that you'd normally use on windows. Dotnet テストの詳細については、こちらを参照してください。See more documentation for dotnet test.
  • テストエクスプローラーの [すべて折りたたみ] ボタンの横にある [すべて展開] ボタンが表示されるようになりました。There is now an expand all button next to the collapse all button in the Test Explorer. このコマンドは、キーボードショートカット (Ctrl + A、Ctrl + →) を使用して利用できますが、ボタンを追加することによって追加された UI の方がよいことが示されています。This command has been available through keyboard shortcuts (Ctrl+A, Ctrl+ right arrow), but more feedback indicated adding a button was worth the additional UI. いつでもご意見をお聞かせいただきありがとうござい https://developercommunity.visualstudio.com/ ます。As always, thank you for letting us know what you think via https://developercommunity.visualstudio.com/.
  • テスト エクスプローラーで "古さ" が表示される方法にも若干の変更があります。There are also some slight changes to how the Test Explorer shows "staleness." "Staleness" は、結果が最新のテスト実行からの結果でなかったかどうかを示すグレー表示または "フェード" のテスト結果です。"Staleness" is the grayed out or "faded" test results that indicate the result was not from the latest test run. 結果が最新のテスト実行の一部ではない場合は、古いとして表示されます。If a result is not a part of the most recent test run it will appear as stale. 以前は、新しいテスト検出 (または再検出された古いテスト結果) も、単色のアイコンで表示されました。Previously, new test discoveries (or even old test results that were rediscovered) were also shown with solid icons. これにより、一部の 'Not Run' テストがフェードアウトされた理由と、他のテストがフェードアウトされていない理由について、混乱が生じしました。This caused some confusion on why some 'Not Run' tests were faded and why others were not. この変更により、古さの複雑さが軽減されます。This change will reduce the complexity of staleness.
  • 永続化されたテスト結果機能 (バージョン 16.2 で追加) を使用すると、最後のテスト実行のテスト結果を確認できます。この機能を閉じて開きVisual Studio。With the persisted test results feature (added in version 16.2) you can see test results from the last test run even if you've closed and re-opened Visual Studio. これにより、ユーザーは、別のテスト実行を必要とせずに、自分が離した場所を記憶し、より多くのコンテキストを提供するのに役立ちます。This helps users remember where they left off and gives more context without requiring another test run. また、永続化された結果が常に古く表示される動作も変更しました。We also modified the behavior of persisted results so they will always appear stale. これは、現在のテスト セッション中に実行されたテストの実行からできなVisual Studioです。This better indicates that they were not from a test run that executed during the current Visual Studio session.

Web ツール:Web Tools:

  • Azure AD プロビジョニング用の API の V2 への切り替えSwitch to V2 of API for Azure AD provisioning
  • 接続済みサービスとしての Azure App Configuration が動的構成に対応するようになったAzure App Configuration as a Connected Service now supports dynamic configuration

Windows アプリケーション パッケージ プロジェクトの依存関係ツリーWindows Application Packaging Project Dependencies Tree

  • WAP プロジェクトに "依存関係ツリー" が追加されましたAdded a "Dependencies Tree" to the WAP Project

XAML ツールの機能強化XAML Tooling Improvements

  • Xamarin.Forms のお客様向XAML ホット リロード XAML IntelliSense とサポートの強化Improved XAML IntelliSense and XAML Hot Reload for Xamarin.Forms customers
  • WPF で 選択された ItemsControls の XAML サンプル データが導入されましたIntroduced XAML Sample Data for select ItemsControls in WPF
  • 一般的に編集されるプロパティにすばやくアクセスできる新しい電球を追加しましたAdded new lightbulb for quick access to commonly edited properties
  • ビュー モデルの作成に役立つ新しい電球を XAML エディターに追加しましたAdded new lightbulb in the XAML Editor to help create a view-model

Service Fabric ToolsService Fabric Tools

  • アプリケーションStartupServices.xmlのService Fabricの紹介Introducing StartupServices.xml in Service Fabric Applications

Visual Studio 2019 バージョン 16.10 の新機能の詳細Details of What's New in Visual Studio 2019 version 16.10

Docker ツールDocker Tools

[コンテナー] ツール ウィンドウContainers Tool Window

このリリースでは、コンテナーとイメージを簡単に表示して操作できるように、[コンテナー] ツール ウィンドウに追加しました。In this release, we made additions to the Containers tool window to make it easier to view and interact with containers and images. 新しい機能を試すには、 [表示] > [その他のウィンドウ] > [コンテナー] に移動するだけです。Just navigate to View > Other Windows > Containers to try out the new features.

  • コンテナーは、Compose プロジェクトによってグループ化されました。Containers are now grouped by Compose project. これにより、どのコンテナーがアプリケーションを表しているかを簡単に判断できます。This makes it simple to tell which containers represent your application. また、開発中に使用しているラベルを簡単に確認できるように、 [コンテナー] に [ラベル] タブを追加しました。Also shown, we added a Labels tab in Containers so you can easily see which labels you are using during development.
View of Compose grouping and Containers Label tab
グループ化オプションとコンテナー ラベル タブの作成Compose grouping option and containers label tab
  • イメージの [ラベル] タブも追加しました。We also added a Labels tab for images.
View of Images Label tab
イメージの [ラベル] タブImagese Label tab
  • 新しい [ボリューム] タブで、実行中のコンテナーのボリュームを表示でき、Visual Studio でファイルを開くこともできます。The new Volumes tab allows you to see the volumes of a running container and even open the files in Visual Studio.
Animation of opening folder of container in Volumes tab
コンテナーの [ボリューム] タブContainer Volumes tab
  • [コンテナー] ツール ウィンドウからイメージにタグを付ける機能をサポートしました。We now support the ability to tag an image from the Containers tool window. [イメージ] から、イメージを右クリックして [タグ] を選択します。From Images, right-click an image and select Tag.
Animation of tagging an image in Images tab
イメージにタグを付けるTagging an image
作成Compose
  • Visual Studio の Docker Compose ツールに、Compose ファイルで定義したサービスの任意の組み合わせを実行する機能が備わりました。Docker Compose tooling in Visual Studio now provides the ability to run any combination of services defined in your Compose files. [デバッグ] ドロップダウンを開くか、docker-compose プロジェクトを右クリックして、[Manage Docker Compose Launch Settings](Docker Compose 起動設定の管理) を選択して作業を開始します。Either open the Debug dropdown or right-click on your docker-compose project and select Manage Docker Compose Launch Settings to get started.
Right click menu shown with Manage Docker Compose Launch Settings highlighted
Docker Compose 起動設定の管理Manage Docker Compose Launch Settings

Git の生産性Git Productivity

  • Visual Studio で pull request を容易に作成できるように、リポジトリの PR を作成したり PR の一覧を表示したりすることができる Web ページへのディープ リンク ショートカットであるメニュー項目を追加しました。To start making it easier to create pull requests while you're in Visual Studio, we added menu items that are deep link shortcuts to the webpages that allow you to create a PR or view a list of PRs for your repository. リポジトリが GitHub と Azure DevOps のどちらにあるかに基づいて、メニューは動的に作成されます。The menu is dynamic based on whether your repository is on GitHub or Azure DevOps.
Create a PR and view list of PRs on the web from the Git menu.
Git メニューから、Web 上の PR を作成したり PR の一覧を作成したりするCreate a PR and view list of PRs on the web from the Git menu
  • ステータス バーのブランチ ピッカーと [Git 変更] ウィンドウで、ブランチをシングル選択すると、ローカルまたはリモートのブランチがチェックアウトされるようになりました。The branch picker in the status bar and the Git Changes window now checks out a local or remote branch when you single-select the branch. コンテキスト メニューには、その他のアクションが表示されます。You can find additional actions in the context menu.
Left click to check out a branch and right click for additional actions.
左クリックしてブランチをチェックアウトし、右クリックして追加のアクションを実行するLeft click to check out a branch and right click for additional actions
  • ステータス バーの新しいリポジトリ ピッカーには、一覧から項目を削除できる右クリックのコンテキスト メニューがあります。The new repository picker in the status bar has a context menu on right-click that allows you to remove items from the list.
Remove items from the repository picker list through the context menu.
コンテキスト メニューを使用して、リポジトリ ピッカーの一覧から項目を削除するRemove items from the repository picker list through the context menu
  • リポジトリ ピッカーまたは Git メニューのローカル リポジトリ一覧を使用すると、リポジトリを開いてもソリューションは自動的に読み込まれなくなります。When using the repository picker or Git menu Local Repositories list, opening a repository won’t automatically load the solution anymore. 代わりに、フォルダー ビューと使用できるソリューションが一覧に表示されて選択できます。You’ll instead see the folder view and solution available in a list you can select from. この動作は、[Git] > [設定] でチェック ボックスを切り替えて変更できます。You can change this behavior through Git > Settings by toggling the checkbox.

  • [Git リポジトリ] ウィンドウでブランチ名をダブルクリックすることにより、ブランチをチェックアウトできます。You can choose to check out a branch from the Git Repository window by double-clicking the branch name. この動作を変更する場合は、[Git] > [設定] でチェック ボックスを切り替えます。If you want to change this behavior, then toggle the checkbox in Git > Settings.

Settings to toggle auto-sln load and branch check out.
auto-sln の読み込みとブランチのチェックアウトを切り替えるための設定Settings to toggle auto-sln load and branch check out
  • [Git 変更] ウィンドウからさらに多くのアクションを実行できるようになりました。You can perform even more actions now from the Git Changes window. ツール バーのアイコンはカスタマイズ可能であり、表示するアクションを選択できます。The toolbar icons are customizable and you can choose which actions to show. オーバーフロー メニューから複数のリモートと同期できます。You can Sync with multiple remotes from the overflow menu. また、ブラウザーでリポジトリのリモート Web ページを開くことができます。And you can open your repository’s remote webpage in the browser.
Git Changes overflow menu with callouts to Sync, open in browser, and toolbar actions.
[Git 変更] ウィンドウから同期し、ブラウザーを開き、ツール バー アクションをカスタマイズするSync, open in browser, and customize toolbar actions from the Git Changes window
  • ローカル ブランチとリモート ブランチを検索し、ステータス バーのブランチ ピッカーから一般的なブランチ アクションを実行します。Search local and remote branches and perform common branch actions from the status bar branch picker.
Branch picker in the status bar.
ステータス バーのブランチ ピッカーBranch picker in the status bar
  • ステータス バーのリポジトリ ピッカーからローカル Git リポジトリを検索して切り替えます。Search and switch between local Git repositories from the status bar repository picker.
Repo picker in the status bar.
ステータス バーのリポジトリ ピッカーRepo picker in the status bar
  • Git メニューのローカル リポジトリの一覧が Visual Studio の起動時に読み込まれない問題を修正しました。Fixed an issue where the local repositories list in the Git menu wasn't loading on Visual Studio launch.

  • [Git] > [設定] に、リポジトリを開いて切り替える方法を管理する 2 つの新しいオプションを追加しました。We added two new options in Git > Settings to manage how you open and switch repositories. 別のリポジトリに切り替えるときに、現在のソリューションを開いたままにすることができるようになりました

    Setting to keep solution open.You can now keep the current solution open when switching to another repository
    Setting to keep solution open.
    現在のソリューションを開いたままにするための設定Setting to keep current solution open

  • リポジトリを開くときにリポジトリのルート フォルダーを読み込まないように選択することもできます。You can also choose to not load the repository root folder when opening a repository.

Setting to open folder.
フォルダーを開くための設定Setting to open the folder
  • ステータス バーの [プッシュされていないコミット] ボタンまたは [Git] メニューの [同期] コマンドを使用して、ブランチをリモートと同期 (プルしてからプッシュ) します。Sync (Pull then Push) your branch with the remote from the unpushed commits button in the status bar, and from the Sync command in Git Menu.
Sync button in the status bar.
ステータス バーの [同期] ボタンSync button in the status bar
  • 受信コミットがない場合でも、[Git リポジトリ] ウィンドウの履歴ペインからフェッチしてプルします。Fetch and pull from the Git Repository window history pane even when there are no incoming commits. これらのセクションには、ステータス バーまたはキーボード ショートカットの Ctrl + 0 + Y からアクセスします。Access these sections from the status bar or the keyboard shortcut Ctrl+0+Y.
Incoming section in Git Repository window with a callout to fetch and pull buttons.
[Git リポジトリ] ウィンドウの受信セクションにある [フェッチ] および [プル] ボタンIncoming section in the Git Repository window with fetch and pull buttons
  • [Git リポジトリ] ウィンドウでコミットを選択すると、その詳細とファイルの変更の比較が表示されるので、他のウィンドウに移動する必要がありません。Select a commit in the Git Repository window to view its details and the comparison of file changes without having to navigate to other windows. 2 つのコミットを選択し、右クリックして同じウィンドウ内で比較します。Select two commits and right-click to compare them in the same window. 詳細をそれぞれのウィンドウに全画面でポップアップ表示して、変更点を詳しく調べます。Pop out the details into their own window for full screen visibility to deep-dive into the changes.
Embedded commit details and file comparison in Git Repository window.
[Git リポジトリ] ウィンドウでの埋め込みコミットの詳細とファイルの比較Embedded commit details and file comparison in Git Repository window
  • ファイル内の削除と挿入の数を表示し、比較のレイアウトを変更します。View the number of deletions and insertions in a file, and change the layout of the comparison.
Popped out Commit window with callouts to number of file changes and layout view buttons in toolbar
複数の [コミット] ウィンドウをポップアップ表示Popped out multiple Commit windows
  • Azure DevOps Git リポジトリを開いたときに、自動的に再接続するか、最初の Azure DevOps 接続を確立するようにプロンプトを表示します。Automatically re-connect or prompt to establish initial Azure DevOps connection when opening an Azure DevOps Git repository. これにより、開いているリポジトリの作業項目とビルドにアクセスできるようになります。This enables access to work items and builds for the opened repository.
Info bar in Git Changes window prompting you to connect to Azure DevOps for the current repository.
Azure DevOps の初期接続ができない場合に表示される情報バーInfo bar prompting Azure DevOps initial connection when missing
  • リベースまたはマージの競合を解決すると、マージ エディターとコンテキスト メニューに、現在のブランチと受信ブランチの名前が表示されます。When resolving rebase or merge conflicts, the merge editor and the context menu will show you the branch names for the Current and Incoming branches. これにより、ソースとターゲットという紛らわしい用語が修正されます。This fixes the confusing Source and Target terminology.
Context menu when resolving conflicts displays the branch names.
競合を解決するときのコンテキスト メニューにブランチ名が表示されますContext menu when resolving conflicts displays the branch names
Rebase and Merge editor displays branch names in the headings.
リベースとマージ エディターの見出しにブランチ名が表示されますRebase and Merge editor displays branch names in the heading

.NET の生産性.NET Productivity

  • 使用していないプロジェクト参照と NuGet パッケージをクリーンアップできる、 [Remove Unused References](未使用の参照の削除) コマンドを追加しました。We added a Remove Unused References command that allows you to clean up project references and NuGet packages that have no usage. このオプションは既定でオフになっているので、 [ツール] > [オプション] > [テキスト エディター] > [C#] > [詳細設定] で、 [Show “remove Unused References” command in Solution Explorer (experimental)](ソリューション エクスプローラーで "未使用の参照の削除" コマンドを表示する (実験段階)) をオンにする必要があります。This option is off by default so you will need to enable it in Tools > Options > Text Editor > C# > Advanced and select Show “remove Unused References” command in Solution Explorer (experimental). このオプションをオンにすると、 [Remove Unused References](未使用の参照の削除) コマンドがプロジェクト名の右クリック メニューまたはソリューション エクスプローラーの Dependencies ノードに表示されます。
    Remove Unused References commandOnce the option is enabled the Remove Unused References command will appear in the right-click menu of a project name or dependencies node in Solution Explorer:
    Remove Unused References command
    [Remove Unused References](未使用の参照の削除) コマンドRemove Unused References command

[Remove Unused References](未使用の参照の削除) を選択すると、ダイアログが開き、削除されるすべての参照が表示されます。維持する必要がある参照を保持するオプションも用意されています。

Remove Unused References dialogSelecting Remove Unused References will open a dialog where you can view all references that are going to be removed with an option to preserve the ones that you want to keep:
Remove Unused References dialog
[Remove Unused References](未使用の参照の削除) ダイアログRemove Unused References dialog

  • コミット文字として Shift+Enter を使用すると、一組の中かっこを自動的に挿入し、それらのかっこの間にキャレットを配置する、スマート改行 という新しいコマンドを追加しました。We added a new command called Smart Break Line that automatically inserts a set of braces and places the caret within those braces when using Shift+Enter as a commit character. スマート改行は、中かっこのほかにプロパティ、イベント、フィールド、およびオブジェクト作成式を必要とする、すべての型宣言で機能します。Smart Break Line works for all type declarations that require braces as well as properties, events, fields, and object creation expressions. 以下の例では、クラスとフィールドにスマート改行を使用しています。The example below shows Smart Break Line used on a class and a field. フィールドの末尾にセミコロンがない場合は、Shift+Enter を押すと、一組の中かっこが追加され、フィールドがプロパティに変換されます。If the field doesn’t have a semicolon at the end, typing Shift+Enter will convert the field to a property by adding a set of braces. もう一度 Shift+Enter を押してコミットを取り消すことができます。これにより、フィールドの末尾にセミコロンが自動的に追加されます。

    Smart Break LineYou can press Shift+Enter again to undo the commit which will also automatically add a semicolon at the end of the field:
    Smart Break Line
    スマート改行Smart Break Line

  • [LINQ 式の簡略化] がリファクタリングされました。これにより、 .Where() メソッドの Enumerable に対する不要な呼び出しが削除され、パフォーマンスと読みやすさの向上につながります。There is now a refactoring to simplify LINQ expressions which will remove the unnecessary call to the Enumerable for the .Where() method to help improve performance and readability. LINQ 式にカーソルを置きます。Place your cursor on the LINQ expression. (Ctrl+ . ) キーを押して、 [クイック アクションとリファクタリング] メニューをトリガーします。Press (Ctrl+.) to trigger the Quick Actions and Refactorings menu. [LINQ 式の簡略化] を選択します。Select Simplify LINQ expression.

Simplify LINQ Expression
LINQ 式の簡略化Simplify LINQ Expression
  • 列挙型 名が入力されていなくても、型がわかっている場合に、列挙 値に対して IntelliSense 入力補完が機能するようになりました。There is now IntelliSense completion for Enum values when a type is known even if the Enum name is not entered.
IntelliSense completion for Enum values
列挙値に対する IntelliSense 入力候補IntelliSense completion for Enum values
  • IntelliSense 入力補完の新しいモード設定を追加しました。これにより、入力補完の既定のオプションを設定できます。We added a new IntelliSense completion mode setting that gives you the ability to set default completion options. この新しい設定は、 [ツール] > [オプション] > [テキスト エディター] > [詳細設定] > [Default IntelliSense completion mode](IntelliSense 入力補完の既定のモード) から使用できます。Ctrl+Alt+Space で最後に使用した設定が保持される [Last used](最後の使用) 、タブ上でのみ補完する [Tab-only](タブのみ) 、現在の既定の動作で、句読点と特殊文字を補完する [自動] のオプションの中から選択できます。This new setting is available in Tools > Options > Text Editor > Advanced > Default IntelliSense completion mode where you can choose from the following options: Last used which will preserve the last setting you used with Ctrl+Alt+Space, Tab-only which will only complete on tab, and Automatic which is currently the default behavior that will complete on punctuation and special characters.
IntelliSense completion mode setting
IntelliSense 入力候補のモード設定IntelliSense completion mode setting
  • 新しい行の新しいコード スタイルの基本設定を追加しました。We added new code style preferences for new lines. これらの基本設定を構成するには、EditorConfig ファイルを使用するか、 [ツール] > [オプション] > [テキスト エディター] > [C#] > [コード スタイル] > [New line preferences (experimental)](改行設定 (実験段階)) で構成します。You can configure these preferences with an EditorConfig file or within Tools > Options > Text Editor > C# > Code Style > New line preferences (experimental).
Code style options for new lines
新しい行のコード スタイルのオプションCode style options for new lines

たとえば、コード スタイルの基本設定を設定して、診断を報告し、余分な空白行を削除するコード修正を提供できます。

Code fix remove extra blank linesFor example, you can set your code style preference to report a diagnostic and offer a code fix to remove extra blank lines:
Code fix remove extra blank lines
余分な空白行を削除するコード修正Code fix remove extra blank lines

  • ソース ジェネレーターで [すべての参照の検索] がサポートされることで、ソースが生成されたドキュメントで参照を見つけることができるようになりました。There is now Find All References support for Source Generators that allows you to find references in a source generated document.

  • これで、メソッド呼び出しを記述するときに引数を自動的に挿入する補完オプションが追加されました。There is now a completion option that automatically inserts arguments when writing a method call. この機能は既定ではオフになっているため、[ツール] > [オプション] > [テキスト エディター] > [C#] > [IntelliSense] で有効にし、Tab キーを 2 回選択して引数を挿入する必要があります (実験段階)。This feature is off by default so you will need to enable it in Tools > Options > Text Editor > C# > IntelliSense and select Tab twice to insert arguments (experimental). メソッド呼び出しの記述を開始し、Tab キーを 2 回 (Tab + Tab) 押します。Start writing a method call and press tab twice (tab+tab). メソッド呼び出しに、メソッドの既定値に基づく引数が挿入されることに注目します。Notice that the method call includes arguments based on the method’s default values. 次に、パラメーター ヒントを使用して、挿入したい引数の一覧を上下方向キーを押して循環させることができます。You can then use parameter info to cycle through the list of arguments that you would like inserted by pressing the up and down arrow keys. また、引数の入力を開始して IntelliSense 入力候補一覧を表示し、セミコロンを入力してその引数をコミットし、メソッド呼び出しの末尾にセミコロンを追加することができます。You can also start typing an argument to bring up the IntelliSense completion list and type semicolon which will commit the argument and add a semicolon to the end of the method call.

Method call argument completion
メソッド呼び出しの引数の入力候補Method call argument completion
  • EditorConfig 用の UI を作成しました。We created a UI for EditorConfig. ソリューションから C# または Visual Basic EditorConfig ファイルを開きます。Open any C# or Visual Basic EditorConfig file from your solution. 新しい UI が開き、C# と Visual Basic の両方のコード スタイルとコード品質構成オプションが表示されることに注目します。Notice that the new UI will open displaying code style and code quality configuration option for both C# and Visual Basic.
EditorConfig UI
EditorConfig UIEditorConfig UI
  • これで、継承チェーンの移動と検査を視覚的に表現できるようになりました。There is now a visual representation for navigating and inspecting the inheritance chain. このオプションは既定でオフになっているので、[ツール] >[オプション] > [テキスト エディター] > [C#] > [詳細設定] を選択し、[Show inheritance margin](継承の余白を表示) を選択します。This option is off by default so you will need to turn it on in Tools > Options > Text Editor > C# > Advanced and select Show inheritance margin. 継承の余白を有効にすると、コードの実装とオーバーライドを表す新しいアイコンが余白に追加されます。Enabling inheritance margin will add new icons to the margins representing your code’s implementations and overrides. [Inheritance Margin](継承の余白) アイコンをクリックすると、移動先として選択できる継承オプションが表示されます。Clicking on the inheritance margin icon will display inheritance options that you can select to navigate to.
Navigate the Inheritance Chain
[Inheritance Margin]\(継承の余白\) アイコンInheritance Margin Icons
  • キャスト、インデクサー、および演算子の IntelliSense 入力候補が追加されました。There is now IntelliSense completion for casts, indexers, and operators.
IntelliSense completion for casts, indexers, and operators
キャスト、インデクサー、および演算子の IntelliSense 入力候補IntelliSense completion for casts, indexers, and operators
  • ソース ジェネレーターのデバッガー サポートが追加されました。There is now debugger support for Source Generators. まず、Visual Studio インストーラーから .NET Compiler Platform SDK コンポーネントをインストールする必要があります。You will first need to install the .NET Compiler Platform SDK component from the Visual Studio Installer. 次に、自分のプロジェクト ファイルに <IsRoslynComponent>true</IsRoslynComponent> プロパティを追加する必要があります。You will then need to add the <IsRoslynComponent>true</IsRoslynComponent> property to your your project file. 次に、[プロジェクトのプロパティ] [デバッグ] ページで [Roslyn Component] デバッガー オプションを有効にして、適切なターゲット プロジェクトを選択します。Next, enable the 'Roslyn Component' debugger option in the Project Properties Debug page and select the appropriate target project. 次に、ジェネレーター プロジェクトで F5 キーを押します。これにより、ターゲット プロジェクトをビルドする CSC.exe/VBC.exe が開始され、ジェネレーター コードをデバッグできるようになります。Next, press F5 on the generator project which will start the CSC.exe/VBC.exe that builds the target project allowing you to debug the generator code.
Source Generator debugger
ソース ジェネレーター デバッガーSource Generator debugger
Source Generator debugger target project
ソース ジェネレーター デバッガーのターゲット プロジェクトSource Generator debugger target project

このリリースでは、Visual Studio のエディット コンティニュ (EnC) デバッグ エクスペリエンスに次の拡張機能も追加しました。In this release we also added the following enhancements to the Edit and Continue (EnC) debugging experience in Visual Studio:

  • 部分クラス内のコードに変更を適用できるようになりました。It is now possible to apply changes in code that is within a partial class.
  • 生成されたソース ファイル内で変更を適用できるようになりました。You can now apply changes within a Source Generated) file.
  • using ディレクティブを追加または変更できるようになりました。It is now possible to add and/or change a using directive.
  • 信頼性の向上とメモリ消費の削減。Improvements in reliability and lower memory consumption.

3 つの変更はすべて、EnC が現在サポートされている場所であればどこでも利用でき、C# と Visual Basic の両方のソース ファイルで動作します。All three changes are available anywhere where EnC is supported today and work with both C# and Visual Basic source files.

デバッガーと診断Debugger & Diagnostics

  • マネージド メモリ ダンプの一般的な問題を検出するために、いくつかのアナライザーを開発しました。We have developed several analyzer to help catch common issues in managed memory dumps. この分析が、マネージド Linux のコア ダンプで実行できるようになりました。This analysis can now be performed on managed Linux core dumps.
Automatically analyze memory dumps
診断分析Diagnostics Analysis
##### ご協力ありがとうございましたThank you 最後になりましたが、今月の .NET の生産性に貢献してくれた以下の方々に感謝いたします。(またはLast but certainly not least, a big Thank You to the following people who contributed this month to .NET Productivity (a.k.a. [Roslyn](https://github.com/dotnet/roslyn)):[Roslyn](https://github.com/dotnet/roslyn)):

Razor (ASP.NET Core) プレビュー エディターRazor (ASP.NET Core) Preview Editor

新しいプレビューの Razor エディターで、以下の Razor 編集機能がサポートされるようになりました。The new preview Razor editor now supports the following Razor editing features:

  • IntelliSense 入力候補で、HTML コンポーネント、TagHelper 要素、および C# 属性がフィルター処理されるようになりました。

    Razor IntelliSense filtersIntelliSense completion now filters for HTML components, TagHelper elements, and C# attributes:
    Razor IntelliSense filters
    Razor IntelliSense フィルターRazor IntelliSense filters

  • C# オーバーライドの IntelliSense 入力候補。IntelliSense completion for C# overrides.

  • ジェネリック コンポーネントの定義サポートに移動します。Go to Definition support for generic componenets.

  • タブとスペースの新しいコード スタイルの構成オプション。New code style configuration options for tabs vs spaces. これらのコード スタイルは、新しい Razor ファイルを入力、書式設定、および作成するときに尊重されます。These code styles will be respected when typing, formatting, and creating a new Razor file. [ツール] > [オプション] > [テキスト エディター] > [Razor (ASP.NET Core)] > [タブ] でタブとスペースを構成できます。You can configure tabs and spaces in Tools > Options > Text Editor > Razor (ASP.NET Core) > Tabs.

  • [ツール] オプションの Razor テキスト エディターの名前が "ASP.NET Core Razor 言語サービス" から Razor (ASP.NET Core) に変更されました。The Razor text editor in Tools Options has been renamed from ASP.NET Core Razor Language Services to Razor (ASP.NET Core).

新しいプレビューの Razor エディターを有効にするには、[ツール]> [オプション]> [環境] > [プレビュー機能] に移動し、 [Enable experimental Razor editor](試験段階の Razor エディターを有効にする) を選択して、Visual Studio を再起動します。To enable the new preview Razor editor, go to Tools > Options > Environment > Preview Features, select Enable experimental Razor editor, and then restart Visual Studio.

テスト エクスペリエンスのアクセシビリティの向上Test Experience Accessibility Improvements

  • Console.Writeline がテスト エクスプローラーに表示されるようになりました。Console.Writeline now shows in the Test Explorer! 長い出力は、[テスト詳細の概要] ペインに折りたたみ可能なセクションとして表示されます。Long output appears as a collapsible section in the test detail summary pane. 出力が一定の長さを超える場合、最初の数行が表示され、テスト ログを別のウィンドウで開くオプションにより、切り捨てられます。Output over a certain length displays the first several lines and is then truncated with an option to open the test log in a separate window. 20 個を超えるフレームがある場合はスタックトレースが切り捨てられ、最初と最後の 10 フレームのみが表示されます。The stacktrace truncates if there are over 20 frames and will then only show the first and last 10 frames. 切り捨てデザインの重要な部分として、テストの実行で大きな出力がある場合の VS のフリーズを減らすことにも重点を置きました。An important part of the truncation design was also focused on reducing VS freezes when test runs have large output. 出力が大きいテストによって、UI スレッドがブロックされることがなくなります。Tests that have large output will no longer block the UI thread.
Test output includes Console.Writeline
テスト出力に Console.Writeline が含まれますTest output includes Console.Writeline
  • テスト出力でタグを保持できるようになったため、ログ ファイルからでもハイパーリンクとスタックトレース リンクをナビゲートできます。Test output can now preserve tags so hyperlinks and stacktrace links are navigable even from the log files. これらのリンクが、キーボードにも対応しました。These links are now keyboard friendly as well.
Test output preserves hyperlinks and stacktraces
テスト出力によって、ハイパーリンクとスタックトレースが保持されますTest output preserves hyperlinks and stacktraces
Test logs also preserve hyperlinks and stacktraces
テスト ログによっても、ハイパーリンクとスタックトレースが保持されますTest logs also preserve hyperlinks and stacktraces
  • 出力が 300 文字を超える場合、またはテスト結果に 10 個を超えるファイルがアタッチされている場合は、1 回のテスト結果に対してログ ファイルが作成されます。Log files are created for a single test result when output is over 300 characters or if there are over 10 files attached to the test result. また、ログ ファイルをプレビューで開くことができるようになり、タブの管理が容易になりました。Log files can also now open in preview so it’s easier to manage your tabs. ログ ファイルとテスト エクスプローラーは、カーソルを移動する Ctrl + PgUp/PgDn と、選択のための Shift + Ctrl PgUp/PgDn をサポートしています。Log files and the Test Explorer support Ctrl PgUp/PgDn for navigating the cursor and Shift+Ctrl PgUp/PgDn for selection.
Test logs are easier to select with keyboard shortcuts
テスト ログをキーボード ショートカットで簡単に選択できますTest logs are easier to select with keyboard shortcuts
  • ログ ファイル エディターで IVsTextView インターフェイスが使用されるようになり、非常に大きなテキスト ファイルを開くことができるようになります。The log file editor is now using the IVsTextView interface which means it will now be able to open very large text files. これにより、ユーザーは切り捨てられたログの Copy All を行い、メモ帳などの別のエディターで開く必要がなくなります。This should eliminate the need for users to Copy All truncated logs and open them in a separate editor such as Notepad. MSTest の場合は、データ行ごとに個別のログ ファイルを用意するだけではなく、すべての出力を集計する単一のログ ファイルも含まれるようになりました。For MSTest, we now also include a single log file that aggregates all the output instead of only having individual log files for each data row.

テスト ツールTest tools

  • dotnet cli を使用して、Ubuntu と Alpine のコマンド ラインでクロスプラットフォーム コード カバレッジを取得できます。You can now get cross-platform code coverage at the command-line on Ubuntu and Alpine with the dotnet cli. これらのプラットフォームを対象とするコンピューターでコードカバレッジを取得することに関心があるユーザーには、windows で通常使用するものと同じコードカバレッジコレクションコマンドを追加できるようになりました。For users interested in getting code coverage on machines targeting those platforms you can now add the same code coverage collection commands that you'd normally use on windows. Dotnet テストの詳細については、こちらを参照してください。See more documentation for dotnet test.
  • テストエクスプローラーの [すべて折りたたみ] ボタンの横にある [すべて展開] ボタンが表示されるようになりました。There is now an expand all button next to the collapse all button in the Test Explorer. このコマンドは、キーボードショートカット (Ctrl + A、Ctrl + →) を使用して利用できますが、ボタンを追加することによって追加された UI の方がよいことが示されています。This command has been available through keyboard shortcuts (Ctrl+A, Ctrl+ right arrow), but more feedback indicated adding a button was worth the additional UI. いつでもご意見をお聞かせいただきありがとうござい https://developercommunity.visualstudio.com/ ます。As always, thank you for letting us know what you think via https://developercommunity.visualstudio.com/.
  • また、テストエクスプローラーが "staleness" を表示する方法に若干の変更が加えられています。There are also some slight changes to how the Test Explorer shows "staleness." "Staleness" は、結果が最新のテスト実行からのものではないことを示す、グレー表示または "フェードされた" テストの結果です。"Staleness" is the grayed out or "faded" test results that indicate the result was not from the latest test run. 結果が最新のテストの実行の一部でない場合は、古いものとして表示されます。If a result is not a part of the most recent test run it will appear as stale. 以前は、新しいテスト検出 (または再検出された古いテスト結果) も、ソリッドアイコンと共に表示されていました。Previously, new test discoveries (or even old test results that were rediscovered) were also shown with solid icons. これにより、一部の "実行されていない" テストがフェードされて、他のテストが行われなかった理由に混乱が生じました。This caused some confusion on why some 'Not Run' tests were faded and why others were not. この変更により、staleness の複雑さが軽減されます。This change will reduce the complexity of staleness.
  • 永続化されたテスト結果機能 (バージョン16.2 で追加) を使用すると、Visual Studio を閉じて再度開いた場合でも、前回のテスト実行のテスト結果を表示できます。With the persisted test results feature (added in version 16.2) you can see test results from the last test run even if you've closed and re-opened Visual Studio. これにより、ユーザーが中断された箇所を記憶し、別のテストの実行を必要とすることなく、より多くのコンテキストを提供できます。This helps users remember where they left off and gives more context without requiring another test run. また、永続化された結果の動作を変更して、常に古いものとして表示されるようにしました。We also modified the behavior of persisted results so they will always appear stale. これは、現在の Visual Studio セッション中に実行されたテストの実行からのものではないことを示しています。This better indicates that they were not from a test run that executed during the current Visual Studio session.
Persisted test results from last Visual Studio session appear faded
前回の Visual Studio セッションからの永続化されたテスト結果が薄く表示されるPersisted test results from last Visual Studio session appear faded

Web ツールWeb Tools

動的構成により、構成リソースをミドルウェアを使用して自動的に最新の情報に更新できます。Dynamic configuration allows for configuration resources to be refreshed automatically using a middleware. 接続済みサービスとしての App Configuration で、動的構成をアプリケーションに自動的に統合できるようになりました。App Configuration as a Connected Service can now automatically integrate dynamic configuration into your application. この接続済みサービスを使用するには、[接続済みサービス] をクリックし、Azure App Configuration を [サービスの依存関係] として追加しますTo use this connected service, click on Connected Services and add Azure App Configuration as a Service Dependency.

Windows アプリケーション パッケージ プロジェクトの "依存関係ツリー"Windows Application Packaging Project "Dependencies Tree"

  • 昨年の作業に従って、Windows アプリケーションパッケージプロジェクト (WAP) で NuGet パッケージ参照を有効にすると、WAP のソリューションエクスプローラーエクスペリエンスで新しい UI が有効になりました。Following up on last year’s work to enable NuGet package references in the Windows Application Packaging Project (WAP), we have enabled a new UI in the WAP’s Solution Explorer experience. 以前のエクスペリエンスでは、これらのパッケージ参照が表示されなかったか、または UI を使用して NuGet パッケージを追加できませんでした。The old experience didn’t show these package references or allow you to add NuGet packages via the UI.
Windows Application Packaging Project Old User Interface.
WAP プロジェクトの古いユーザー インターフェイスWAP Project Old User Interface
  • 新しいエクスペリエンスでは、CPS と .NET プロジェクト システムを利用して、"アプリケーション" サブツリーを介してプロジェクト参照を引き続き表示する一方、NuGet パッケージを管理できる "パッケージ" サブツリーも備えた、"依存関係ツリー" が有効にされました。In the new experience, with the help of CPS and the .NET Project System, we have enabled a “Dependencies Tree" that continues to display project references via the “Applications” subtree, but also features a “Packages” subtree that will allow you to manage NuGet packages as well.
Windows Application Packaging Project New User Interface.
WAP プロジェクトの新しいユーザー インターフェイスWAP Project New User Interface

XAML ツールの機能強化 (WPF & Xamarin.Forms)XAML Tooling Improvements (WPF & Xamarin.Forms)

Xamarin.FormsXamarin.Forms

このリリースでは、Xamarin.Forms のお客様向けに XAML IntelliSense と XAML ホット リロードの 2 つの小さな改良を行いました。In this release we’ve made two small improvements to XAML IntelliSense and XAML Hot Reload for Xamarin.Forms customers. ホット リロードの “変更のみ” で次の誤ったエラーが報告されなくなります。Hot Reload “change only” will no longer report false errors for:

  • VisualStateManager のセッターで型を指定せずにプロパティを参照 ( など)。Setters in VisualStateManager referencing properties without specifying type, e.g. .
  • マージされた ResourceDictionary が<ResourceDictionary.MergedDictionaries> 要素にラップされていないMerged ResourceDictionaries not wrapped into <ResourceDictionary.MergedDictionaries> element

例:Example:

    <Application>
    <Application.Resources>
        <ResourceDictionary Source='Colors.xaml'/>
        <Style TargetType='Label'> ... <Style>
    </Application.Resources>
    </Application>

XAML サンプル データXAML Sample Data

このリリースでは、ItemsControls に汎用サンプル データを追加する新しい方法を導入して、XAML デザイナーのデザイン時データ機能をさらに強化しました。In this release we've further enhanced the XAML Designer's design-time data capability by introduced a new way to add generic sample data to your ItemsControls. この機能は、WPF の ListBox、ListView、DataGrid に対してのみ機能します。This feature works for ListBox, ListView and DataGrid in WPF only.

  • ListBox、ListView、または DataGrid に d:ItemSource='{d:SampleData}' を設定することで、サンプル データを有効にできますSample Data can be enabled by setting d:ItemSource='{d:SampleData}' on your ListBox, ListView or DataGrid
  • これにより、デザイナーのコントロールに、DataTemplates とバインディング パスに一致する 5 つの項目セットのみが表示されますThis will populate your control in the designer only with a set of 5 items that match your DataTemplates and Binding Paths
  • ItemCount プロパティを使用して、生成される項目の数を変更できます。例: d:ItemSource='{d:SampleData ItemCount=3}'You can change how many items are generated using the ItemCount property, for example: d:ItemSource='{d:SampleData ItemCount=3}'
ListBox showing Sample Data.
ListBox で有効になっているサンプル データSample Data enabled on a ListBox

XAML デザイナーのクイック アクションXAML Designer Quick Actions

  • XAML デザイナー で選択したコントロールの隅付近にある新しい電球を使用すると、そのコントロールで一般的に編集されるプロパティにすばやくアクセスできます。A new lightbulb near the corner of a selected control in the XAML Designer can be used for quick access to commonly edited properties for that control.

  • サポートされているコントロールは次のとおりです。Supported controls include:

    • UWP: Border、Button、Canvas、CheckBox、ComboBox、Grid、HyperlinkButton、Image、ListBox、ListView、NavigationView、RadioButton、Slider、StackPanel、TextBlock、TextBoxUWP: Border, Button, Canvas, CheckBox, ComboBox, Grid, HyperlinkButton, Image, ListBox, ListView, NavigationView, RadioButton, Slider, StackPanel, TextBlock, TextBox
    • WPF: Border、Button、Canvas、CheckBox、ComboBox、Grid、Image、Label、ListBox、ListView、StackPanel、TextBlock、TextBoxWPF: Border, Button, Canvas, CheckBox, ComboBox, Grid, Image, Label, ListBox, ListView, StackPanel, TextBlock, TextBox
  • この機能は、UWP、WPF .NET Core、WPF .NET Framework で使用できます (オプション ダイアログで [新しい WPF XAML デザイナー for .NET Framework] プレビュー機能が有効になっています)。This feature is available for UWP, WPF .NET Core, and WPF .NET Framework (with the “New WPF XAML Designer for .NET Framework” preview feature enabled in the options dialog).

  • XAML デザイナーのクイック アクションには、機能拡張モデルも用意されています。XAML Designer Quick Actions also has an extensibility model. 独自のアクションの作成の詳細については、XAML デザイナー拡張性の GitHub

を参照してくださいFor more information on creating your own actions, see the [XAML Designer Extensibility GitHub](https://github.com/microsoft/xaml-designer-extensibility)
XAML Designer Quick Actions on a Button
ボタンの XAML デザイナー クイック アクションXAML Designer Quick Actions on a Button

XAML 用 MVVM ツールMVVM Tooling for XAML

このリリースでは、ビュー モデルを作成するために XAML エディターに電球を導入しました。In this release, we’ve introduced a lightbulb in the XAML Editor to create a view-model. この電球は、プロジェクトで MVVM フレームワークが使用されているのが検出されると、XAML ドキュメントのルート要素に表示されます。This lightbulb is surfaced on the root element of the XAML document when we detect that an MVVM framework is being used in the project. ダイアログを使用すると、生成されたビュー モデル名前空間、フォルダー、および継承された基本ビュー モデルをカスタマイズできます。The dialog allows for customization of the generated view-model namespace, folder and inherited base view-model.

Create view-model lightbulb experience
ビュー モデルの電球エクスペリエンスを作成するCreate view-model lightbulb experience

また、この電球は、生成されたビュー モデルを XAML ドキュメントの x:DataType(Xamarin.Forms) または d:DataContext (他のすべてのプラットフォーム) として設定します。ユーザーは XAML エディターの電球をさらに活用して、ビュー モデルでバインドされたプロパティとコマンドを生成できます。The lightbulb also sets the generated view-model as the x:DataType(Xamarin.Forms) or d:DataContext(all other platforms) for the XAML document, allowing the user to further leverage the XAML Editor lightbulbs to generate bound properties and commands in view-models.

Service Fabric ToolsService Fabric Tools

この機能では、StartupServices.xmlアプリケーション設計でService Fabricが導入されています。This feature introduces StartupServices.xml file in a Service Fabric Application design. このファイルは、 の DefaultServices セクションをホストApplicationManifest.xml。This file hosts DefaultServices section of ApplicationManifest.xml. この実装では、DefaultServices とサービス定義に関連するパラメーターが、既存の ApplicationManifest.xml から、この新しいファイル StartupServices.xml。With this implementation, DefaultServices and Service definition-related parameters are moved from existing ApplicationManifest.xml to this new file called StartupServices.xml. このファイルは、 の各機能 (Build/Rebuild/F5/Ctrl + F5/Publish) で使用Visual Studio。This file is used in each functionalities (Build/Rebuild/F5/Ctrl+F5/Publish) in Visual Studio.

このリリースで修正された主な問題Top Issues Fixed in this Release

  • Edit.SmartBreakline コマンドを呼び出す C# 開発者が Property の アクセサー内のすべてのコンテンツを削除する問題を修正しました。Fixed an issue where C# developers invoking the Edit.SmartBreakline command would remove all the content in the accessor of Property.
  • コードスタイル設定を更新する開発者が、目的のフォルダー内ではなく、すべての Visual Studio インスタンスに変更が適用される問題を修正しました。Fixed an issue where developers updating a codestyle setting would have the change apply in all Visual Studio instances instead of just inside the desired folder.
  • "コード変更の適用" アイコンは、natvie またはマージされたプロジェクトが開くたびに表示されました。The "Apply Code Changes" icon was showing whenever a natvie or merged project was opened. これは、開発者がデバッグを開始した後にのみ有効になります。It will only be enabled once a developer starts debugging.
  • AudioUnitPropertyIDType の重要な変更を修正しましたFixes breaking change in AudioUnitPropertyIDType
  • UWP 単体テスト フレームワークを使用する開発者がリモート デバイスでテストを実行できない問題を修正しました。Fixed an issue where developers using UWP unit test framework were unable to run tests on remote devices.

Developer Community からFrom Developer Community

Developer Community には、このリリースに付属しているすべての項目の完全な一覧があります。Developer Community has a complete list of all of items shipping in this release.

ここでは、16.10 でリリースされた上位の問題をいくつか紹介します。Here are some of the top voted issues released in 16.10:


既知の問題Known Issues

Visual Studio 2019 のすべての未解決のイシューと、利用可能な回避策を以下のリンクから参照してください。See all open issues and available workarounds in Visual Studio 2019 by following the below link.


フィードバックと提案Feedback and suggestions

皆様のご意見をお待ちしております。We would love to hear from you! 問題がある場合は、インストーラーまたは Visual Studio IDE 自体の右上隅にある [問題の報告] オプションからお知らせください。For issues, let us know through the Report a Problem option in the upper right-hand corner of either the installer or the Visual Studio IDE itself. 次に、The Feedback Icon アイコンは、右上隅にあります。icon is located in the upper right-hand corner. 製品に関する提案をしたり、Visual Studio 開発者コミュニティで問題を追跡したりすることにより、質問、回答の検索、新機能を提案したりすることができます。You can make a product suggestion or track your issues in the Visual Studio Developer Community, where you can ask questions, find answers, and propose new features. ライブ チャット サポートを介して、無料のインストールのヘルプを取得することもできます。You can also get free installation help through our Live Chat support.


ブログBlogs

開発者ツールのブログで提供されている洞察や推奨事項を活用すると、すべての新しいリリースに関する最新情報を入手し続けることができ、さまざまな機能について掘り下げた記事を参照することもできます。Take advantage of the insights and recommendations available in the Developer Tools Blogs site to keep you up-to-date on all new releases and include deep dive posts on a broad range of features.


Visual Studio 2019 リリース ノート履歴Visual Studio 2019 Release Notes History

過去のバージョンの Visual Studio 2019 に関連する詳細については、「Visual Studio 2019 リリース ノート履歴」のページを参照してください。For more information relating to past versions of Visual Studio 2019, see the Visual Studio 2019 Release Notes History page.


ページのトップへ

Top of Page