Dostosowywanie układów okien w programie Visual StudioCustomize window layouts in Visual Studio

W programie Visual Studio można dostosować położenie, rozmiar i zachowanie systemu windows, aby utworzyć układy okna, które najlepiej działać dla różnych przepływów pracy programowania.In Visual Studio, you can customize the position, size, and behavior of windows to create window layouts that work best for various development workflows. Podczas dostosowywania układu IDE pamięta.When you customize the layout, the IDE remembers it. Na przykład, jeśli zmienisz lokalizację dokowania Eksploratora rozwiązań , a następnie zamknij program Visual Studio przy następnym, Otwórz program Visual Studio, nawet jeśli pracujesz na innym komputerze, Eksploratora rozwiązańbędzie zadokowany w tym samym miejscu.For example, if you change the docking location of Solution Explorer and then close Visual Studio, the next time that you open Visual Studio, even if you're working on another computer, Solution Explorer will be docked in that same location.

Możesz też nazwać i zapisać niestandardowe układy i następnie przełączać się między układy za pomocą jednego polecenia.You can also name and save a custom layout and then switch between layouts with a single command. Na przykład można utworzyć układ do edycji i układu do debugowania i przełączać się między nimi przy użyciu okna > Zastosuj układ okna polecenia menu.For example, you could create a layout for editing and a layout for debugging, and switch between them by using the Window > Apply Window Layout menu command.

Rodzaje okienKinds of windows

Narzędzia i okna dokumentuTool and document windows

IDE ma dwa typy podstawowe okna, okna narzędzi i dokumentu windows.The IDE has two basic window types, tool windows and document windows. Okna narzędzi obejmują Eksploratora rozwiązań, Eksploratora serwera, okno danych wyjściowych, lista błędów, projektantów, oknach debugera , i tak dalej.Tool windows include Solution Explorer, Server Explorer, Output Window, Error List, the designers, the debugger windows, and so on. Okna dokumentów zawierają pliki kodu źródłowego, pliki dowolnego tekstu, pliki konfiguracji i tak dalej.Document windows contain source code files, arbitrary text files, config files, and so on. Okna narzędzi można ze zmienionym rozmiarem i przeciągnąć przez ich paska tytułu.Tool windows can be resized and dragged by their title bar. Okna dokumentów można przeciągać za jego kartę. Kliknij prawym przyciskiem myszy, na karcie lub pasek tytułu można ustawić inne opcje w oknie.Document windows can be dragged by their tab. Right-click on the tab or title bar to set other options on the window.

Okna menu wyświetlane są opcje dla dokowania, liczb zmiennoprzecinkowych i ukrywanie okna w IDE.The Window menu shows options for docking, floating and hiding windows in the IDE. Kliknij prawym przyciskiem myszy pasek okna karty lub tytuł, aby wyświetlić dodatkowe opcje dla tego określonego okna.Right click on a window tab or title bar to see additional options for that specific window. Możesz wyświetlić więcej niż jedno wystąpienie niektórych okien narzędzi w danym momencie.You can display more than one instance of certain tool windows at a time. Na przykład, można wyświetlić więcej niż jedno okno przeglądarki sieci web i utworzyć dodatkowe wystąpienia niektórych oknach narzędzi, wybierając nowe okno na okna menu.For example, you can display more than one web browser window, and you can create additional instances of some tool windows by choosing New Window on the Window menu.

Karta (wersja zapoznawcza) (system windows dokumentu)Preview tab (document windows)

W Podgląd karty, możesz wyświetlać pliki w edytorze bez ich otwierania.In the Preview tab, you can view files in the editor without opening them. Możesz wyświetlić podgląd plików, wybierając je w Eksploratora rozwiązań, podczas debugowania, gdy wkroczenia do plików, za pomocą przejdź do definicji, a podczas przeglądania wyników wyszukiwania.You can preview files by choosing them in Solution Explorer, during debugging when you step into files, with Go to Definition, and when you browse through results of a search. Pliki (wersja zapoznawcza) są wyświetlane na karcie po prawej stronie obszaru karty dokumentu.Preview files appear in a tab on the right side of the document tab well. Plik zostanie otwarty do edycji, jeśli możesz go zmodyfikować, lub wybrać Otwórz.The file opens for editing if you modify it or choose Open.

ZakładekTab groups

Zakładek rozszerzyć możliwości zarządzania ograniczone obszaru roboczego podczas pracy z co najmniej dwóch otwartych dokumentów w IDE.Tab groups extend your ability to manage limited workspace while you are working with two or more open documents in the IDE. Można organizować wiele okien dokumentu i okna narzędzi w obu grupach kartę pionową lub poziomą i manipulowanie dokumentami z jednej karty, grupy, do innego.You can organize multiple document windows and tool windows into either vertical or horizontal tab groups and shuffle documents from one tab group to another.

Podzielone oknaSplit windows

Jeżeli masz wyświetlić lub edytować dwóch lokalizacjach jednocześnie w dokumencie, można podzielić systemu windows.When you have to view or edit two locations at once in a document, you can split windows. Aby dokumentu należy podzielić na dwie sekcje niezależnie przewijania, kliknij przycisk podziału na okna menu.To divide your document into two independently scrolling sections, click Split on the Window menu. Kliknij przycisk Usuń podział na okna menu, aby przywrócić jednego widoku.Click Remove Split on the Window menu to restore the single view.

Paski narzędziToolbars

Paski narzędzi mogą być ułożone przez przeciąganie lub za pomocą Dostosuj okno dialogowe.Toolbars can be arranged by dragging, or by using the Customize dialog box. Aby uzyskać więcej informacji o tym, jak to pozycjonowania i dostosowywanie pasków narzędzi, zobacz jak: Dostosowywanie menu i pasków zadań.For more information about how to position and customize toolbars, see How to: Customize menus and toolbars.

Aranżowanie i dokowanie okienArrange and dock windows

Okno dokumentu lub okna narzędzi mogą być zadokowany, dzięki czemu ma położenie i rozmiar w obrębie ramki okna środowiska IDE lub zmiennoprzecinkowego jako oddzielne okno niezależnie od środowiska IDE.A document window or tool window can be docked, so that it has a position and size within the IDE window frame, or floating as a separate window independent of the IDE. Narzędzia systemu windows może być zadokowane w dowolne miejsce wewnątrz ramki IDE; Niektóre narzędzia systemu windows może być zadokowane jako okien z zakładkami w ramce edytora.Tool windows can be docked anywhere inside the IDE frame; some tool windows can be docked as tabbed windows in the editor frame. Okna dokumentów, może być zadokowane w ramce edytora i można przypiąć do bieżącego położenia w kolejności tabulacji.Document windows can be docked within the editor frame, and they can be pinned to their current position in the tab order. Można zadokować wiele okien float razem w tratwie nad lub poza IDE.You can dock multiple windows to float together in a raft over or outside of the IDE. Można również ukryte okna narzędzi lub zminimalizowana.Tool windows can also be hidden or minimized.

Rozmieść z systemu windows, w następujący sposób:You can arrange windows in the following ways:

  • Przypnij dobrze okna dokumentu do lewej strony karty.Pin document windows to the left of the tab well.

  • Karta dokowanie okien do ramki edycji.Tab-dock windows to the editing frame.

  • Dokowanie okien narzędzi do krawędzi ramki w IDE.Dock tool windows to the edge of a frame in the IDE.

  • Przestawianie okien dokumentu lub narzędzia na lub poza IDE.Float document or tool windows over or outside the IDE.

  • Ukrywanie okien narzędzi wzdłuż krawędzi środowiska IDE.Hide tool windows along the edge of the IDE.

  • Wyświetlaj okna na różnych monitorach.Display windows on different monitors.

  • Resetowanie położenia okna, domyślny układ lub zapisanego układu niestandardowego.Reset window placement to the default layout or to a saved custom layout.

Rozmieść okna dokumentów i narzędzi, przeciągając, przy użyciu poleceń w okna menu, klikając prawym przyciskiem myszy pasek tytułu okna.Arrange tool and document windows by dragging, using commands on the Window menu, or by right-clicking the title bar of the window to be arranged.

Dokowanie okienDock windows

W przypadku kliknij i przeciągnij pasek tytułu okna narzędzi lub na karcie okna dokumentu romb przewodnik pojawia się.When you click and drag the title bar of a tool window, or the tab of document window, a guide diamond appears. Podczas operacji przeciągania gdy wskaźnik myszy znajduje się nad jedną strzałki rombu, zacieniony obszar pojawi się informujący o tym, gdzie okna zostanie zadokowany po zwolnieniu przycisku myszy teraz.During the drag operation, when the mouse cursor is over one of the arrows in the diamond, a shaded area will appear that shows you where the window will be docked if you release the mouse button now.

Aby przenieść okno zadokowane bez przyciągania go w miejscu, naciśnij klawisz Ctrl klucza podczas przeciągania okna.To move a dockable window without snapping it into place, press the Ctrl key while you drag the window.

Aby przywrócić jego najnowsze położenie zadokowanego okna narzędzi lub okno dokumentu, naciśnij klawisz Ctrl gdy klikniesz dwukrotnie pasek tytułu lub karcie okna.To return a tool window or document window to its most recent docked location, press Ctrl while you double-click the title bar or tab of the window.

Poniższa ilustracja przedstawia dokowania dla okien dokumentu, które może być zadokowane tylko wewnątrz ramki edycji:The following illustration shows the guide diamond for document windows, which can only be docked within the editing frame:

Romb przewodnik okna dokumentu

Okna narzędzi mogą być mocowane po jednej stronie ramki w IDE lub wewnątrz ramki edycji.Tool windows can be fastened to one side of a frame in the IDE or within the editing frame. Romb przewodnik pojawia się po przeciągnięciu okna narzędzia do innej lokalizacji, aby pomóc łatwo ponownie zadokować okno.A guide diamond appears when you drag a tool window to another location to help you to easily redock the window.

Diamenty przewodnik okna narzędzi

Poniższa ilustracja przedstawia Eksploratora rozwiązań jest zadokowany w nowej lokalizacji, która jest zaznaczonymi przez niebieski zacieniony obszar:The following illustration shows Solution Explorer being docked in a new location that's demarcated by the blue shaded area:

Dokowanie Eksploratora rozwiązań w nowym położeniu

Zamknij i automatyczne ukrywanie okien narzędziClose and auto-hide tool windows

Możesz zamknąć okna narzędzi, klikając X w prawym górnym rogu paska tytułu.You can close a tool window by clicking the X in the upper right of the title bar. Aby ponownie otworzyć okno, polecenie jego klawiatury skrótów lub menu.To reopen the window, use its keyboard shortcut or menu command. Okna narzędzi obsługują funkcję o nazwie Autoukrywanie, co powoduje, że okno chowa sposób w przypadku, gdy używasz innego okna się.Tool windows support a feature named auto hide, which causes a window to slide out of the way when you use a different window. Gdy okno jest autohidden, jego nazwa jest wyświetlana na karcie na krawędzi IDE.When a window is autohidden, its name appears on a tab at the edge of the IDE. Aby ponownie użyć okna, wskaż kartę tak, że okno zostanie wsunięte z powrotem do widoku.To use the window again, point to the tab so that the window slides back into view.

Autoukrywanie

Note

Aby ustalić, czy automatyczne ukrywanie działa narzędzie windows indywidualnie czy jako zadokowane grupy, zaznacz lub wyczyść przycisku automatycznego ukrywania wpływa na aktywne okna narzędzi tylko w opcje okno dialogowe.To set whether auto hide operates on tool windows individually or as docked groups, select or clear Auto Hide button affects active tool windows only in the Options dialog box. Aby uzyskać więcej informacji, zobacz ogólne, środowisko, opcje, okno dialogowe.For more information, see General, Environment, Options dialog box.

Note

Okna narzędzi, które mają Autoukrywanie włączone może tymczasowo Przesuń do widoku, gdy okno jest ustawiony fokus.Tool windows that have auto hide enabled may temporarily slide into view when the window has focus. Aby ukryć okno ponownie, zaznacz element spoza bieżącego okna.To hide the window again, select an item outside of the current window. Gdy okno traci fokus, jest wycofywane z widoku.When the window loses focus, it slides back out of view.

Określanie drugim monitorzeSpecifying a second monitor

Jeśli masz drugi monitor, a system operacyjny obsługuje go, można wybrać, który monitor wyświetla okno.If you have a second monitor and your operating system supports it, you can choose which monitor displays a window. Użytkownik może nawet grupować liczne okna razem w tratwach na innych monitorach.You can even group multiple windows together in rafts on other monitors.

Tip

Możesz utworzyć wiele wystąpień Eksploratora rozwiązań i przenieść je do innego monitora.You can create multiple instances of Solution Explorer and move them to another monitor. Kliknij prawym przyciskiem myszy okno, a następnie wybierz nowy widok Eksploratora rozwiązania.Right-click the window and choose New Solution Explorer View. Wszystkie systemy windows można wrócić do oryginalnego monitora, klikając dwukrotnie podczas wybierania Ctrl klucza.You can return all windows back to the original monitor by double-clicking while choosing the Ctrl key.

Resetowanie, nazwę i przełączać się między układy okienReset, name, and switch between window layouts

Możesz powrócić IDE do oryginalnego layoutu okna zestawu ustawień za pomocą Zresetuj układ okna polecenia.You can return the IDE to the original window layout for your settings collection by using the Reset Window Layout command. Po uruchomieniu tego polecenia, są wykonywane następujące akcje:When you run this command, the following actions occur:

  • Wszystkie okna są przenoszone do ich domyślnych pozycji.All windows are moved to their default positions.

  • Windows, które zostały zamknięte w domyślnym układzie okien są zamknięte.Windows that are closed in the default window layout are closed.

  • Windows, które są otwarte w domyślnym układzie okien są otwarte.Windows that are open in the default window layout are opened.

Utworzyć i zapisać niestandardowe układyCreate and save custom layouts

Program Visual Studio można zapisać maksymalnie 10 niestandardowe układy okien i szybko przełączaj się między nimi.Visual Studio enables you to save up to 10 custom window layouts and quickly switch between them. Poniższe kroki pokazują sposób tworzenia, zapisywania, wywołania i zarządzać układy niestandardowe, które wykorzystują wielu monitorów z oba okna zadokowane i przestawne narzędzie.The following steps show how to create, save, invoke, and manage custom layouts that take advantage of multiple monitors with both docked and floating tool windows.

Najpierw utwórz test rozwiązanie, które ma dwa projekty: każdy inny, optymalny układ.First, create a test solution that has two projects, each with a different optimal layout.

Utwórz projekt interfejsu użytkownika i dostosować układCreate a UI project and customize the layout

  1. Utwórz nową C# aplikacja WPF projektu.Create a new C# WPF App project. Załóżmy, że w tym projekcie, będzie tworzenia interfejsu użytkownika.Imagine that in this project, you'll be developing a user interface. Chcesz zmaksymalizować miejsce w oknie projektanta, a następnie przejść z innymi oknami narzędzi.You want to maximize the space for the designer window and move other tool windows out of the way.

  2. Jeśli masz wiele monitorów, ściąganie Eksploratora rozwiązań okna i właściwości okna za pośrednictwem drugiego monitora.If you have multiple monitors, pull the Solution Explorer window and the Properties window over to your second monitor. W systemie pojedynczy monitor Zamknij wszystkie okna z wyjątkiem projektanta.On a single monitor system, try closing all the windows except the designer.

  3. Naciśnij klawisz Ctrl+Alt+X do wyświetlenia przybornika okna.Press Ctrl+Alt+X to display the Toolbox window. Jeśli okno jest zadokowany, przeciągnij go tak, że jest ona wyświetlana innym miejscu, gdzie chcesz umieścić go.If the window is docked, drag it so that it floats somewhere where you'd like to position it.

  4. Naciśnij klawisz F5 aby umieścić programu Visual Studio w trybie debugowania.Press F5 to put Visual Studio into debugging mode. Dopasować położenie Autos, stos wywołań, i dane wyjściowe debugowania systemu windows w żądany sposób.Adjust the position of the Autos, Call Stack, and Output debugging windows the way you want them. Układ, który masz zamiar utworzyć dotyczą zarówno trybem edycji i w trybie debugowania.The layout you're about to create will apply to both editing mode and debugging mode.

  5. Kiedy układów w trybie debugowania i tryb edycji są, jak chcesz, wybierz polecenie okna > Zapisz układ okna.When your layouts in both debugging mode and editing mode are how you want them, choose Window > Save Window Layout. Wywołaj ten układ "Designer".Call this layout "Designer."

    Należy pamiętać, nowy układ jest przypisany dalej skrótu klawiaturowego z listy zarezerwowanych Ctrl+Alt+1... 0.Note that your new layout is assigned the next keyboard shortcut from the reserved list of Ctrl+Alt+1...0.

Tworzenie bazy danych projektu i układuCreate a database project and layout

  1. Dodaj nową bazy danych SQL Server projektu do rozwiązania.Add a new SQL Server Database project to the solution.

  2. Kliknij prawym przyciskiem myszy nad nowym projektem w Eksploratora rozwiązań i wybierz polecenie widoku w Eksploratorze obiektów.Right-click on the new project in Solution Explorer and choose View in Object Explorer. Spowoduje to wyświetlenie Eksplorator obiektów SQL Server okno, które umożliwia dostęp do tabel, widoków i innych obiektów w bazie danych.This displays the SQL Server Object Explorer window, which enables you to access tables, views and other objects in your database. Można przestawić to okno lub zostawić zadokowany.You can either float this window or leave it docked. Dostosuj innymi oknami narzędzi w żądany sposób.Adjust the other tool windows the way you want them. Dla dodano realizmu można dodać istniejącej bazy danych, ale nie jest konieczne w ramach tego przewodnika.For added realism, you can add an actual database, but it's not necessary for this walkthrough.

  3. Gdy układ jest, jak chcesz, w menu głównym wybierz okna > Zapisz układ okna.When your layout is how you want it, from the main menu choose Window > Save Window Layout. Wywołaj ten układ "Projekt bazy danych".Call this layout "DB Project." (Firma Microsoft nie będą odblokowane z układem trybu debugowania dla tego projektu.)(We won't bother with a debug mode layout for this project.)

Przełączanie między układówSwitch between the layouts

Aby przełączyć się między układów, skróty klawiaturowe lub w menu głównym wybierz okna > Zastosuj układ okna.To switch between layouts, use the keyboard shortcuts, or from the main menu choose Window > Apply Window Layout.

Zastosuj menu układu okna

Po zastosowaniu układ interfejsu użytkownika, należy pamiętać, jak zachować układ zarówno w trybie edycji, jak i w trybie debugowania.After applying the UI layout, note how the layout is preserved both in editing mode and in debug mode.

Jeśli masz wielu konfiguracji monitora, w miejscu pracy oraz pojedynczy monitor komputera przenośnego w domu, można utworzyć układów, które są zoptymalizowane dla każdego komputera.If you have a multi monitor setup at work and a single monitor laptop at home, you can create layouts that are optimized for each machine.

Note

Jeśli zastosujesz układ wielu monitorów w systemie jednego monitora zmiennoprzecinkowy systemu windows, które umieszczone na drugim monitorze teraz będzie ukryty pod okna programu Visual Studio.If you apply a multi-monitor layout on a single-monitor system, the floating windows that you placed on the second monitor will now be hidden behind the Visual Studio window. Możesz wyświetlić te okna na pierwszym planie, naciskając klawisz Alt + Tab. Po otwarciu programu Visual Studio z wieloma monitorami, stosując ponownie układ można przywrócić systemu windows do ich określonych pozycji.You can bring these windows to the front by pressing Alt + Tab. If you later open Visual Studio with multiple monitors, you can restore the windows to their specified positions by re-applying the layout.

Zarządzanie i są przekazywane układówManage and roam your layouts

Można usunąć, zmienić lub zmiana kolejności układu niestandardowego, wybierając okna > Zarządzanie układami okien.You can remove, rename or reorder your custom layout by choosing Window > Manage Window Layouts. Jeśli przenosisz układu, klucz powiązania jest automatycznie dostosowywany do nowej pozycji na liście.If you move a layout, the key binding is automatically adjusted to reflect the new position in the list. Powiązania nie może być inny sposób modyfikować, a więc może przechowywać maksymalnie 10 układów w danym momencie.The bindings cannot be otherwise modified, and so you can store a maximum of 10 layouts at a time.

Zarządzanie układami okien

Przypominał klawiatury, którego skrót jest przypisany do którego układu, wybierz polecenie okna > Zastosuj układ okna.To remind yourself which keyboard shortcut is assigned to which layout, choose Window > Apply Window Layout.

Te układy automatycznie przenoszone między wersjami programu Visual Studio, a także między wystąpieniami programu Blend na oddzielnych komputerach i z dowolnej wersji Express do innej organizacji Express.These layouts automatically roam between Visual Studio editions, and also between Blend instances on separate machines, and from any Express edition to any other Express organization. Jednak układy nie są przekazywane między Visual Studio, program Blend i Express.However, layouts do not roam across Visual Studio, Blend and Express.

Zobacz takżeSee also