Panoramica dell'interfaccia utente dell'editor di moduli delle app basate su modello

Nell'editor di moduli vengono visualizzati i comandi in tre schede: File, Home e Inserisci.

L'editor di moduli è suddiviso in tre aree: Navigazione, Corpo ed Esplora.

Interfaccia utente dell'editor di moduli

Navigazione
L'area di navigazione si trova sul lato sinistro e serve a controllare l'accesso alle entità correlate o per aggiungerne collegamenti agli URL da visualizzare nel riquadro principale del modulo. Per modificare la navigazione, è innanzitutto necessario selezionare il comando Navigazione nel gruppo Seleziona della scheda Home.

I moduli principali forniscono opzioni di navigazione tramite la barra di navigazione, ma è possibile utilizzare gli stessi dati presenti nell'area di navigazione per controllare quali opzioni di navigazione sono disponibili. Ulteriori informazioni: Modificare la struttura di navigazione

Testo
Utilizzare l'area del testo posizionata al centro per controllare il layout del modulo. È possibile selezionare e trascinare gli elementi del modulo per posizionarli. Se si fa doppio clic su un elemento verranno visualizzate le proprietà di tale elemento.

Per impostazione predefinita, per i moduli principali Caso, Contatto e Account, la prima sezione nella scheda Riepilogo mostra il modulo scheda dell'account o del contatto di tipo Visualizzazione rapida. Per le entità personalizzate, questa sezione non è disponibile per impostazione predefinita. Puoi aggiungere una nuova sezione e inserirvi un modulo di visualizzazione rapida. Il modulo di scheda mostra un massimo di cinque campi. Al di là dei campi, non è possibile mostrare altri controlli nel riquadro blu anche se questo si trova nel modulo di visualizzazione rapida.

Nota

Per mantenere il formato della scheda (come illustrato nell'immagine che segue), ti consigliamo di non spostare il modulo di visualizzazione rapida in un'altra sezione del modulo.

Formato scheda

Ulteriori informazioni: Creare e modificare moduli di visualizzazione rapida

  • Per aggiungere un campo, selezionarlo in Esplora campi e trascinarlo in una sezione.

    • Per aggiungere un elemento che non è un campo, selezionare il punto in cui si desidera posizionarlo e utilizzare il comando appropriato dalla scheda Inserisci per aggiungerlo.

    • Per eliminare un elemento, selezionarlo e utilizzare il comando Rimuovi nel gruppo Modifica della scheda Home.

    • Per modificare l'Intestazione o il Piè di pagina per il modulo, è necessario scegliere innanzitutto il comando corrispondente nel gruppo Seleziona della scheda Home.

Esplora
Il contenuto di quest'area, posizionata a sinistra, dipende dal contesto.

Quando viene selezionato Testo, Intestazione o Piè di pagina nel gruppo Seleziona della scheda Home verrà visualizzato Esplora campi. Utilizzare Esplora campi per trascinare i campi da visualizzare in una sezione nel modulo o all'interno dell'intestazione o del piè di pagina. È possibile includere lo stesso campo più volte in un modulo. Utilizzare il pulsante Nuovo campo come collegamento per creare un nuovo campo.

Quando viene selezionato Navigazione nel gruppo Seleziona della scheda Home, verrà visualizzato Esplora relazione. Trascinare tutte le relazioni in uno dei gruppi nell'area di navigazione. Non è possibile aggiungere due volte la stessa relazione. Le relazioni sono disponibili in base alla loro configurazione. Se si configura una relazione in modo da non essere visualizzata, questa non verrà visualizzata in Esplora relazioni. Per informazioni su come configurare le opzioni di visualizzazione predefinite per le relazioni, vedere Elemento del riquadro di spostamento per l'entità primaria.

È possibile utilizzare i pulsanti Nuovo 1:N e Nuovo N:N come collegamento per aggiungere nuove relazioni di entità.

Scheda File

Selezionare la scheda File per aggiungere/visualizzare le opzioni seguenti:

  • Nuovo impegno: aggiunge un nuovo impegno
  • Nuovo record: aggiunge un nuovo record
  • Strumenti utilizza le opzioni come Importare dati, Rilevamento duplicati e l'Eliminazione in blocco guidata
  • Opzioni modifica le impostazioni di visualizzazione predefinite per personalizzare la soluzione predefinita e gestire i modelli di posta elettronica
    • Generale
    • Sincronizzazione
    • Impegni
    • Formati
    • Modelli di messaggio
    • Firme e-mail
    • E-mail
    • Privacy
    • Lingue
  • ?
  • Chiudi

Scheda Home

Nella scheda Home vengono visualizzati i comandi elencati nella tabella seguente:

Scheda Home classica dell'editor di moduli

Raggruppa Comando Descrizione
Salva Salva (CTRL+S) Salvare il modulo.
Salva con nome Consente di creare una copia del modulo con un nome diverso.
Salva e chiudi Consente di salvare il modulo e chiudere l'editor di moduli.
Pubblicazione Consente di pubblicare il modulo. Ulteriori informazioni: Pubblicazione delle personalizzazioni
Modifica Cambia proprietà Consente di cambiare le proprietà dell'elemento selezionato nel testo.

Vedere le sezioni seguenti in base all'elemento selezionato:

- Proprietà scheda
- Proprietà sezione
- Proprietà campo comuni
- Proprietà campo speciali
- Proprietà griglia secondaria
- Proprietà controllo di visualizzazione rapida
Rimuovi Rimuovere l'elemento selezionato.
Annulla (CTRL+Z) Annulla l'azione precedente.
Ripeti (CTRL+Y) Consente di ripetere l'azione precedente.
Seleziona Testo Consente di modificare il corpo principale del modulo.
Intestazione Consente di modificare l'intestazione del modulo.
Piè di pagina Modifica il piè di pagina del modulo.
Navigazione Modifica la struttura di navigazione del modulo.

Ulteriori informazioni: Modificare la struttura di navigazione
Modulo Regole di business Consente di visualizzare, modificare o creare nuove regole di business tramite Esplora regole di business. Nota: Per i moduli interattivi, è supportato solo l'ambito "Entità" e "Tutti i moduli".

Ulteriori informazioni: Creare e modificare le regole di business
Proprietà modulo Ulteriori informazioni: Proprietà modulo
Anteprima Utilizzare questa opzione per visualizzare l'aspetto del modulo dopo che viene pubblicato. È inoltre possibile visualizzare in anteprima per testare gli script associati agli eventi.
Abilita ruoli di sicurezza Utilizzare questa opzione per impostare i ruoli di sicurezza che avranno accesso ai moduli. Ulteriori informazioni: Controllare l'accesso ai moduli Importante: se si crea un nuovo modulo, solo l'amministratore di sistema e l'addetto alla personalizzazione avranno accesso al modulo. È necessario assegnare l'accesso ad altri ruoli di sicurezza prima che gli utenti possano utilizzarlo.
Mostra dipendenze Vedere quali componenti di soluzione dipendono da questo modulo e quali componenti della soluzione sono necessari per questo modulo.
Proprietà gestite Per il comando proprietà gestite sono disponibili due proprietà Personalizzabile e Eliminabile. Se si impostano queste proprietà su false, il modulo non sarà personalizzabile né eliminabile dopo averlo incluso in una soluzione, esportare tale soluzione come soluzione gestita e importare la soluzione gestita in un altro ambiente. Ulteriori informazioni: Proprietà gestite
Aggiorna Unire i moduli Se applicabile, questa opzione consente di unire il modulo con un modulo da una versione precedente del modulo di Dynamics 365

Scheda Inserisci

Scheda Inserisci classica dell'editor di moduli

Nella scheda Inserisci vengono visualizzati i comandi nella tabella seguente:

Gruppo Comando Descrizione
Sezione Aggiungere una sezione a una scheda selezionata. È possibile includere una sezione che dispone da una a quattro colonne.

Puoi inoltre inserire un pannello di riferimento nei moduli interattivi. Il pannello di riferimento viene inoltre aggiunto come sezione al modulo Principale - Esperienza interattiva. Per impostazione predefinita, la sezione del pannello di riferimento viene aggiunta ai moduli Caso, Account, Contatto ed Entità personalizzata.

Ulteriori informazioni: Proprietà sezione
3 schede Tre colonne Inserisce una scheda a tre colonne di uguale larghezza.

Ulteriori informazioni: Proprietà scheda
Tre colonne Inserisce una scheda a tre colonne con la colonna intermedia più larga.
2 schede Due colonne Consente di inserire una scheda a due colonne con la colonna di destra più larga.
Due colonne Consente di inserire una scheda a due colonne con la colonna di sinistra più larga.
Due colonne Consente di inserire una scheda a due colonne di uguale larghezza.
Scheda a 1 Una colonna Consente di inserire una scheda a una colonna.
Controllo Griglia secondaria Formatta una griglia secondaria e la inserisce nel modulo.

Ulteriori informazioni: Proprietà griglia secondaria
Spaziatore Inserisce uno spazio vuoto.
Modulo di visualizzazione rapida Consente di inserire un modulo di visualizzazione rapida.

Ulteriori informazioni: Proprietà del controllo di visualizzazione rapida.
Risorsa Web Inserisci una risorsa Web per incorporare il contenuto da alter posizioni in una pagina.

Ulteriori informazioni: Proprietà delle risorse Web
IFRAME È possibile aggiungere un elemento IFRAME a un modulo per integrare il contenuto da un altro sito Web in un modulo.
Sequenza temporale Inserire un controllo sequenza temporale nel modulo. Il controllo mostra le tempistiche di impegni relativi all'entità in un modulo.
Collegamento di spostamento Grazie a questa opzione, è possibile inserire un collegamento nella navigazione del modulo.
Timer Inserire un controllo Timer a un modulo dell'entità per tenere traccia del tempo rispetto a un contratto di servizio. Ulteriori informazioni: Aggiungere un controllo Timer
Ricerca nella Knowledge Base Consente di inserire un controllo di ricerca che gli utenti possono utilizzare per cercare articoli della Knowledge Base. Ulteriori informazioni: Controllo di ricerca nella Knowledge Base.
Assistente alle relazioni Grazie a questa opzione, è possibile inserire un controllo Assistente alle relazioni nel modulo.

Nota

I seguenti componenti non sono supportati nei moduli principali:

  • Bing Maps
  • Yammer
  • Feed attività

Passaggi successivi

Utilizzare il modulo principale e i relativi componenti