Tipy pro vyšší produktivitu sady Visual StudioProductivity tips for Visual Studio

V tomto článku jsou popsány tipy pro funkce sady Visual Studio, které vám pomůžou rychleji a efektivně psát, Procházet a ladit kód.This articles discusses tips for Visual Studio features that help you write, navigate, and debug your code more quickly and efficiently.

Informace o užitečných klávesových zkratkách najdete v tématu věnovaném zástupcům produktivity.For information about helpful keyboard shortcuts, see Productivity shortcuts. Úplný seznam klávesových zkratek najdete v tématu výchozí klávesové zkratky.For a complete list of command shortcuts, see Default keyboard shortcuts.

Psaní kóduWrite code

Napište kód rychleji s využitím následující funkce.Write code more quickly by using the following features.

  • Pomocí příkazů pohodlí.Use convenience commands. Visual Studio obsahuje různé příkazy můžete provádět běžné úlohy úprav rychleji.Visual Studio contains various commands to help you accomplish common editing tasks faster. Můžete například zvolit příkaz pro snadné duplikování řádku kódu bez nutnosti jeho zkopírování, přemístění kurzoru a vložení.For example, you can choose a command to easily duplicate a line of code without having to copy it, reposition the cursor, and then paste it. Zvolte upravit > duplicitní nebo stiskněte klávesu Ctrl+E,V.Choose Edit > Duplicate or press Ctrl+E,V. Výběr textu můžete také rychle rozbalit nebo zúžit výběrem možnosti upravit > Upřesnit > rozšířit výběr nebo upravit > pokročilý výběr kontraktu > nebo stisknutím klávesy SHIFT+ALT+ = nebo SHIFT+ALT+ - .You can also quickly expand or contract a selection of text by choosing Edit > Advanced > Expand Selection or Edit > Advanced > Contract Selection, or by pressing Shift+Alt+= or Shift+Alt+-.

  • Použijte technologii IntelliSense.Use IntelliSense. Při zadávání kódu v editoru, zobrazí se informace technologie IntelliSense, jako je například seznam členů, informace o parametrech, rychlé informace, pomoc při podpisu a dokončit slovo.As you enter code in the editor, IntelliSense information, such as List Members, Parameter Info, Quick Info, Signature Help, and Complete Word, appears. Tyto funkce podporují fuzzy vyhledávání textu. například seznam výsledků pro seznam členů obsahuje nejen pouze položky, které začínají znaky, zda jste zadali, ale také záznamy, které obsahují kombinaci znaků kdekoli v jejich názvy.These features support fuzzy matching of text; for example, the results lists for List Members includes not only entries that start with the characters that you have entered but also entries that contain the character combination anywhere in their names. Další informace najdete v tématu použití IntelliSense.For more information, see Use IntelliSense.

  • Změna automatického vkládání technologie možnosti technologie IntelliSense při vkládání kódu.Change auto-insertion of IntelliSense options as you enter code. Přepnutím technologie IntelliSense do režimu návrhu, můžete určit, aby možnosti technologie IntelliSense byly vloženy pouze po jejich explicitním výběru.By switching IntelliSense to suggestion mode, you can specify that IntelliSense options are inserted only if you explicitly choose them.

    Povolení režimu návrhu, zvolte Ctrl+Alt+MEZERNÍK klíče, nebo na panelu nabídek zvolte upravit > IntelliSense > přepnout režim dokončení.To enable suggestion mode, choose the Ctrl+Alt+Spacebar keys, or, on the menu bar, choose Edit > IntelliSense > Toggle Completion Mode.

  • Používání fragmentů kódu.Use code snippets. Můžete použít předdefinované fragmenty kódu nebo vytvořit vlastní fragmenty kódu.You can use built-in snippets, or create your own snippets.

    Chcete-li vložit fragment kódu na řádku nabídek zvolte upravit > IntelliSense > Vložit fragment nebo obklopit fragmentem, nebo v souboru otevřete místní nabídku a zvolte fragment > Vložit fragment nebo obklopit fragmentem.To insert a snippet, on the menu bar, choose Edit > IntelliSense > Insert Snippet or Surround With, or open the shortcut menu in a file and choose Snippet > Insert Snippet or Surround With. Další informace najdete v tématu fragmenty kódu.For more information, see Code Snippets.

  • Oprava chyby vložený kód.Fix code errors inline. Rychlé akce vám umožní snadno Refaktorujte, generovat nebo jinak upravit kód pomocí jedné akce.Quick Actions let you easily refactor, generate, or otherwise modify code with a single action. Tyto akce lze aplikovat pomocí šroubovák šroubovák ikonu nebo žárovky ikonou žárovky ikony, nebo stisknutím klávesy Alt + Zadejte nebo Ctrl+ .These actions can be applied using the screwdriver Screwdriver icon or light bulb Light bulb icon icons, or by pressing Alt+Enter or Ctrl+. Když je ukazatel myši na příslušný řádek kódu.when your cursor is on the appropriate line of code. Zobrazit rychlé akce Další informace.See Quick Actions for more information.

  • Zobrazit a upravit definici prvku kódu.Show and edit the definition of a code element. Můžete rychle zobrazit a upravit modul, ve kterém je definován prvek kódu, jako je například člen, proměnná nebo místní.You can quickly show and edit the module in which a code element, such as a member, a variable, or a local, is defined.

    Chcete-li otevřít definici v překryvném okně, zvýrazněte element a klikněte na tlačítko Alt+F12 klíče, nebo otevřete místní nabídku pro prvek a pak zvolte operace Peek Definice.To open a definition in a pop-up window, highlight the element and then choose the Alt+F12 keys, or open the shortcut menu for the element and then choose Peek Definition. Pro otevření definice v samostatném okně s kódem, otevřete místní nabídku pro prvek a klikněte na tlačítko přejít k definici.To open a definition in a separate code window, open the shortcut menu for the element, and then choose Go to Definition.

  • Použití ukázkových aplikací.Use sample applications. Můžete urychlit vývoj aplikací stažením a instalací ukázkové aplikace od Microsoft Developer Network.You can speed up application development by downloading and installing sample applications from Microsoft Developer Network. Určitou technologii nebo programovací koncept můžete také naučit stáhnutím a Prozkoumáním balíčku ukázek pro tuto oblast.You can also learn a particular technology or programming concept by downloading and exploring a Sample Pack for that area.

Různé techniky slouží k vyhledání a přesunutí na konkrétní místo v kódu rychleji.You can use various techniques to find and move to specific locations in your code more quickly.

  • Záložka pro řádky kódu.Bookmark lines of code. Pomocí záložek lze rychle přejít na konkrétní řádky kódu v souboru.You can use bookmarks to navigate quickly to specific lines of code in a file.

    Chcete-li nastavit záložky, na panelu nabídek, zvolte upravit > záložky > Přepnout záložku.To set a bookmark, on the menu bar, choose Edit > Bookmarks > Toggle Bookmark. Můžete zobrazit všechny záložky řešení v záložky okna.You can view all of the bookmarks for a solution in the Bookmarks window. Další informace najdete v tématu nastavení záložek v kódu.For more information, see Set bookmarks in code.

  • Vyhledání definice symbolů v souboru.Search for symbol definitions in a file. V rámci řešení lze vyhledat definice symbolů a názvy souborů, ale výsledky hledání neobsahují obory názvů ani místní proměnné.You can search within a solution to locate symbol definitions and file names, but search results don't include namespaces or local variables.

    Chcete-li použít tuto funkci na řádku nabídek zvolte upravit > přejít na.To access this feature, on the menu bar, choose Edit > Navigate To.

  • Projděte celkovou strukturu kódu.Browse the overall structure of your code. V Průzkumníka řešení, můžete vyhledat a procházet třídy a jejich typy a členy v projektech.In Solution Explorer, you can search and browse classes and their types and members in your projects. Můžete také hledat symboly, zobrazit hierarchii volání metod, najít odkazy na symboly a provádět další úlohy.You can also search for symbols, view a method's Call Hierarchy, find symbol references, and perform other tasks. Pokud se rozhodnete prvek kódu v Průzkumníka řešení, související soubor se otevře v ve verzi Preview kartu a kurzor se přesune k prvku v souboru.If you choose a code element in Solution Explorer, the associated file opens in a Preview tab, and the cursor moves to the element in the file. Další informace najdete v tématu zobrazení struktury kódu.For more information, see View the structure of code.

Hledání položek rychlejiFind items faster

Můžete hledat v prostředí IDE pro příkazy, soubory a možnosti, kromě filtrování obsahu okna nástrojů, chcete-li zobrazit pouze relevantní informace pro aktuální úlohu.You can search across the IDE for commands, files, and options, in addition to filtering the contents of tool windows to show only relevant information for your current task.

  • Filtrujte obsah okna nástrojů.Filter the contents of tool windows. Můžete vyhledávat v obsahu mnoha nástrojových oken, například nástrojů, vlastnosti okně a Průzkumníka řešení, ale zobrazit jenom položky, jejichž názvy obsahovat znaky, které zadáte.You can search within the contents of many tool windows, such as the Toolbox, the Properties window, and Solution Explorer, but display only items whose names contain the characters that you specify.

  • Zobrazit pouze chyby, které chcete na adresu.Display only the errors you want to address. Pokud se rozhodnete filtr tlačítko seznam chyb nástrojů, můžete snížit počet chyb, které se zobrazují v seznam chyb okno.If you choose the Filter button on the Error List toolbar, you can reduce the number of errors that appear in the Error List window. Můžete zobrazit pouze chyby v souborech, které jsou otevřeny v editoru, pouze chyby v aktuálním souboru, nebo pouze chyby v aktuálním projektu.You can display only the errors in the files that are open in the editor, only the errors in the current file, or only the errors in the current project. Můžete také hledat v rámci seznam chyb okno najít konkrétní chyby.You can also search within the Error List window to find specific errors.

  • Najděte dialogová okna, příkazy nabídky, možnosti a další.Find dialog boxes, menu commands, options, and more. Do vyhledávacího pole zadejte klíčová slova nebo fráze pro položky, které se pokoušíte najít.In the search box, enter keywords or phrases for the items that you're trying to find. Například následující možnosti se zobrazí, pokud zadáte Nový projekt:For example, the following options appear if you enter new project:

    Rychlé spuštění výsledky pro "nový projekt.

    Rychlé spuštění zobrazuje odkazy na vytvoření nového projektu, pro přidání nové položky do projektu a na stránku projekty a řešení v dialogovém okně Možnosti mimo jiné.Quick Launch displays links to create a new project, to add a new item to a project, and to the Projects and Solutions page in the Options dialog box, among others. Výsledky hledání mohou také zahrnovat soubory projektu a okna nástrojů.Search results can also include project files and tool windows.

    Výsledky hledání pro nový projekt

    Stisknutím kombinace kláves Ctrl+Q můžete přejít přímo do vyhledávacího pole.Press Ctrl+Q to jump straight to the search box.

Ladění kóduDebug code

Ladění může spotřebovat spoustu času, ale následující tipy vám pomůžou zrychlit proces.Debugging can consume a lot of time, but the following tips can help you speed up the process.

  • Testování stejnou stránku, aplikaci nebo web v různých prohlížečích.Test the same page, application, or site in different browsers. Při ladění kódu můžete snadno přepínat mezi nainstalovanými webovými prohlížeči, včetně nástroj Page Inspector (Visual Studio), aniž byste museli otevřít procházet s dialogové okno.As you debug your code, you can easily switch among the installed web browsers, including Page Inspector (Visual Studio), without having to open the Browse With dialog box. Můžete použít cíl ladění seznam, který se nachází na standardní nástrojů vedle položky spustit ladění tlačítko pro rychlé kontrole aktuálně používaného ladění webového prohlížeče nebo zobrazení stránek.You can use the Debug Target list, which is on the Standard toolbar next to the Start Debugging button, to quickly verify which browser you're using as you debug or view pages.

    Vyberte možnosti ladění webového prohlížeče

  • Nastavení dočasných zarážek.Set temporary breakpoints. Můžete vytvořit dočasnou zarážku na aktuálním řádku kódu a zároveň spustit ladicí program.You can create a temporary breakpoint in the current line of code and start the debugger simultaneously. Při dosažení tohoto řádku přejde ladicí program do režimu přerušení.When you hit that line of code, the debugger enters break mode. Další informace najdete v tématu Navigovat prostřednictvím kódu s ladicím programem.For more information, see Navigate through code with the debugger.

    Chcete-li tuto funkci použít, zvolte Ctrl+F10 klíče, nebo otevřete místní nabídku pro řádek kódu, na kterém chcete přerušit a klikněte na tlačítko provést do pozice kurzoru .To use this feature, choose the Ctrl+F10 keys, or open the shortcut menu for the line of code on which you want to break, and then choose Run To Cursor.

  • Přesuňte bod provádění během ladění.Move the execution point during debugging. Můžete přesunout do jiné části kódu aktuální bod provádění a pak znovu spusťte ladění od tohoto okamžiku.You can move the current execution point to a different section of code and then restart debugging from that point. Tato technika je užitečná, pokud chcete ladit sekci kódu bez nutnosti provádět všechny kroky, které jsou potřeba k dosažení této části.This technique is useful if you want to debug a section of code without having to recreate all of the steps that are required to reach that section. Další informace najdete v tématu Navigovat prostřednictvím kódu s ladicím programem.For more information, see Navigate through code with the debugger.

    Přesunout bod spuštění, přetáhněte žlutou šipku do umístění, ve které chcete nastavit další příkaz ve stejném zdrojovém souboru a klikněte na tlačítko F5 klíč pro pokračování v ladění.To move the execution point, drag the yellow arrowhead to a location where you want to set the next statement in the same source file, and then choose the F5 key to continue debugging.

  • Zachycení informací o hodnotách proměnných.Capture value information for variables. Můžete přidat DataTip proměnné ve vašem kódu a připnout ho tak, aby po dokončení ladění můžete přistupovat k poslední známé hodnotě proměnné.You can add a DataTip to a variable in your code and pin it so that you can access the last known value for the variable after debugging has finished. Další informace najdete v tématu zobrazení hodnot dat v datových tipech.For more information, see View data values in Data Tips.

    Pro přidání DataTip musí být ladicí program v režimu pozastavení.To add a DataTip, the debugger must be in break mode. Umístěte kurzor na proměnnou a pak klikněte na tlačítko připnout na, které se zobrazí.Place the cursor on the variable, and then choose the pin button on the DataTip that appears. Při zastavení ladění, zobrazí se ikona s modrým ve zdrojovém souboru vedle řádku kódu, který obsahuje proměnné.When debugging is stopped, a blue pin icon appears in the source file next to the line of code that contains the variable. Pokud přejděte myší na modrý špendlík se zobrazí hodnota proměnné z poslední relace ladění.If you point to the blue pin, the value of the variable from the most recent debugging session appears.

  • Vymazání příkazového podokna.Clear the Immediate window. Můžete vymazat obsah podokna v době návrhu zadáním >cls nebo >Edit.ClearAllYou can erase the contents of the Immediate window at design time by entering >cls or >Edit.ClearAll

    Další informace o dalších příkazech najdete v tématu aliasy příkazů sady Visual Studio.For more information about additional commands, see Visual Studio command aliases.

Přístup k nástrojům Visual StudioAccess Visual Studio tools

Můžete rychle získat Developer Command Prompt nebo jiného nástroje Visual Studio, jej můžete připnout do nabídky Start nebo na hlavním panelu.You can quickly access the Developer Command Prompt, or another Visual Studio tool, if you pin it to the Start menu or the taskbar.

  1. V Průzkumníku Windows přejděte do %ProgramData%\Microsoft\Windows\Start Menu\Programs\Visual studia 2017 \ Visual Studio Tools.In Windows Explorer, browse to %ProgramData%\Microsoft\Windows\Start Menu\Programs\Visual Studio 2017\Visual Studio Tools.
  1. V Průzkumníku Windows přejděte do %ProgramData%\Microsoft\Windows\Start Menu\Programs\Visual studia 2019 \ Visual Studio Tools.In Windows Explorer, browse to %ProgramData%\Microsoft\Windows\Start Menu\Programs\Visual Studio 2019\Visual Studio Tools.
  1. Klikněte pravým tlačítkem myši nebo otevřete kontextovou nabídku pro Developer Command Prompta klikněte na tlačítko připnout na Start nebo připnout na hlavní panel.Right-click or open the context menu for Developer Command Prompt, and then choose Pin to Start or Pin to taskbar.

Správa souborů, panelů nástrojů a windowsManage files, toolbars, and windows

V jednu chvíli můžete být práce ve více souborech s kódem a budete přecházet mezi několika okny nástrojů při vývoji aplikace.At any one time, you may be working in multiple code files and moving among several tool windows as you develop an application. Pomocí následujících tipů můžete dál organizovat:You can keep organized by using the following tips:

  • Soubory, které často používají ve viditelném stavu v editoru.Keep files that you frequently use visible in the editor. Dobře, takže zůstávají viditelné bez ohledu na to, kolik souborů je otevřen v editoru můžete připnout soubory k levé straně karty.You can pin files to the left side of the tab well so that they remain visible regardless of how many files are open in the editor.

    Pokud chcete připnout soubor, zvolte kartu Soubor a klikněte na tlačítko změnit stav Připnutí tlačítko.To pin a file, choose the file's tab, and then choose the Toggle Pin Status button.

  • Přesuňte dokumenty a okna do jiných monitorů.Move documents and windows to other monitors. Pokud používáte více než jeden monitor při vývoji aplikací, můžete pracovat na částech aplikace snadněji přesunutím souborů, které jsou otevřeny v editoru na jiný monitor.If you use more than one monitor when you develop applications, you can work on portions of your application more easily by moving files that are open in the editor to another monitor. Můžete také přesunout ukotvení okna nástrojů, jako je například okna ladicího programu na jinou kartu a sledování dokumentů a nástrojů systému windows dohromady a vytvoří "řady."You can also move tool windows, such as debugger windows, to another monitor and tab dock document and tool windows together to create "rafts." Další informace najdete v tématu přizpůsobení rozložení oken v sadě Visual Studio.For more information, see Customize window layouts in Visual Studio.

    Můžete také spravovat soubory snadněji tak, že vytvoříte jiná instance Průzkumníka řešení a jeho přesunutím na jiný monitor.You can also manage files more easily by creating another instance of Solution Explorer and moving it to another monitor. K vytvoření další instance okna Průzkumníka řešení, otevřete místní nabídku v Průzkumníka řešenía klikněte na tlačítko nové zobrazení Průzkumníka řešení.To create another instance of Solution Explorer, open a shortcut menu in Solution Explorer, and then choose New Solution Explorer View.

  • Přizpůsobte písmo zobrazené v sadě Visual Studio.Customize the fonts that appear in Visual Studio. Můžete změnit vzhled písma, velikost a barvu, která se používá pro text v integrovaném vývojovém prostředí.You can change the font face, size, and color that's used for text in the IDE. Například lze upravit barvu konkrétních prvků kódu v editoru a řez písma v oknech nástrojů nebo v celém rozhraní IDE.For example, you can customize the color of specific code elements in the editor and the font face in tool windows or throughout the IDE. Další informace najdete v tématu postupy: Změna písma a barev a postupy: Změna písma a barev v editoru.For more information, see How to: Change fonts and colors and How to: Change fonts and colors in the editor.

Viz také:See also