Visual Studio Icon Informacje o wersji dla programu Visual Studio 2019 w wersji 16.8



Developer Community | Wymagania systemowe | Zgodność | Kod dystrybucyjny | Postanowienia licencyjne | Blogi | Znane problemy w najnowszej wersji | Whats New in Visual Studio Docs


Kliknij przycisk, aby pobrać najnowszą wersję programu Visual Studio 2019. Aby uzyskać instrukcje dotyczące instalowania i aktualizowania programu Visual Studio 2019, zobacz informacje o aktualizowaniu programu Visual Studio 2019 do najnowszej wersji. Ponadto zobacz instrukcje na temat sposobu instalowania w trybie offline.

Community Download Button Professional Download Button Enterprise Download Button


Co nowego w programie Visual Studio 2019 w wersji 16.8

Wydania programu Visual Studio 2019 w wersji 16.8

Informacje o starszych wersjach programu Visual Studio 2019

Blog dotyczący programu Visual Studio 2019

Blog dotyczący programu Visual Studio 2019 to oficjalne źródło informacji o produkcie pochodzących od zespołu inżynierów ds. programu Visual Studio. Szczegółowe informacje na temat wersji programu Visual Studio 2019 można znaleźć w następujących wpisach:


Zobacz tę pełną listę wszystkich elementów Community developer w wersji 16.8 Visual Studio 2019

Release Notes Icon Visual Studio 2019 r. w wersji 16.8.7 New release icon

wydany 9 marca 2021 r.

Problemy rozwiązane w tej wersji programu Visual Studio 2019 w wersji 16.8.7

Zalecenia dotyczące zabezpieczeń

CVE-2021-21300 Luka w zabezpieczeniach usługi Git Visual Studio zdalnego wykonywania kodu

Istnieje luka w zabezpieczeniach dotycząca zdalnego wykonywania kodu, gdy program Visual Studio klonuje złośliwe repozytorium.

CVE-2021-26701 Luka w zabezpieczeniach umożliwiająca zdalne wykonywanie kodu na komputerze .NET Core

Istnieje luka w zabezpieczeniach zdalnego wykonywania kodu na platformach .NET 5 i .NET Core spowodowana tym, jak jest wykonywane kodowanie tekstu.


Release Notes Icon Visual Studio 2019 r. w wersji 16.8.6 New release icon

wydany 22 lutego 2021 r.

Problemy rozwiązane w tej wersji programu Visual Studio 2019 w wersji 16.8.6


Release Notes Icon Visual Studio 2019 r. w wersji 16.8.5

wydany 9 lutego 2021 r.

Zalecenia dotyczące zabezpieczeń

CVE-2021-1639 Luka w zabezpieczeniach umożliwiająca zdalne wykonywanie kodu w usłudze językowej TypeScript

Luka w zabezpieczeniach umożliwiająca zdalne wykonywanie kodu występuje, Visual Studio ładuje złośliwe repozytorium zawierające pliki kodu JavaScript lub TypeScript.

CVE-2021-1721 Odmowa usługi na oprogramowaniu .NET Core

Luka w zabezpieczeniach umożliwiająca atak typu "odmowa usługi" występuje podczas tworzenia żądania internetowego HTTPS podczas tworzenia łańcucha certyfikatów X509.

CVE-2021-24112 Luka w zabezpieczeniach umożliwiająca zdalne wykonywanie kodu na komputerach .NET 5 i .NET Core

Luka w zabezpieczeniach umożliwiająca zdalne wykonywanie kodu występuje w przypadku rozsyłania metaplików, gdy interfejs graficzny nadal ma do niego odwołanie. Ta luka w zabezpieczeniach występuje tylko w systemach z systemem MacOS lub Linux.

Problemy rozwiązane w tej wersji programu Visual Studio 2019 w wersji 16.8.5

  • Rozwiązaliśmy problem, który umożliwiał zaktualizowanie rozszerzenia ExtensionSDKs przy użyciu poprawnego podpisu w rozszerzeniu Appx pakietu Microsoft.VCLibs w wersji x86.
  • Naprawiono przeciek pamięci podczas korzystania z funkcji C++ DesignTime.
  • Rozwiązano problem, który miał miejsce, gdy wystąpił wyjątek, jeśli hasło nie zostało zapamiętyne podczas importowania istniejącej bazy danych do projektu SSDT.
  • Rozwiązaliśmy problem, który powoduje, że przycisk publikowania był wyłączany przy pierwszym publikowaniu projektów .NET Core przez klientów w folderze lub innych elementach docelowych hostingu.
  • Rozwiązano problem z zawieszaniem się, które sporadycznie występowało, gdy deweloperzy otwierali stronę widoku profilów publikowania.
  • Dodaje obsługę Xcode 12.4.

Elementy z listy Community


Release Notes Icon Visual Studio 2019 w wersji 16.8.4

data wydania: 12 stycznia 2021 r.

Zalecenia dotyczące zabezpieczeń

CVE-2021-1651 / CVE-2021-1680 Luka w zabezpieczeniach dotycząca podniesienia poziomu uprawnień standardowej usługi modułu zbierającego centrum diagnostyki

Luka w zabezpieczeniach dotycząca podniesienia uprawnień występuje, gdy standardowy moduł zbierający centrum diagnostyki nieprawidłowo obsługuje operacje na danych.

CVE-2020-26870 Luka w zabezpieczeniach dotycząca zdalnego wykonywania kodu w instalatorze programu Visual Studio

Luka w zabezpieczeniach dotycząca zdalnego wykonywania kodu występuje, gdy instalator programu Visual Studio próbuje wykazać złośliwy znacznik markdown.

CVE-2021-1723 Luka w zabezpieczeniach umożliwiająca atak typu „odmowa usługi” na platformie ASP.NET Core i w programie Visual Studio

Luka w zabezpieczeniach umożliwiająca atak typu „odmowa usługi” dotyczy sposobu analizowania żądań HTTP/2 przez protokół Kestrel.

Problemy rozwiązane w tej wersji programu Visual Studio 2019 w wersji 16.8.4

  • Rozwiązano problem polegający na tym, że składniki rozszerzenia IntelliCode specyficzne dla języka C# mogą nie być instalowane, jeśli rozszerzenie zostało już zainstalowane z witryny Visual Studio Marketplace w starszych wersjach programu Visual Studio
  • Przechodnie odwołania do projektów są teraz stosowane, gdy projekty PackageReference odwołują się do projektów packages.config z zależnościami PackageReference.
  • Obsługa programu Xcode 12.3.
  • Poprawki systemu watchOS 7.0 x86_64 oraz obsługa symulatora
  • Naprawiliśmy wyniki fałszywie dodatnie (C33001 ~ C33005) na użytek wariancji wariancji zwracanych przez funkcję.
  • Poprawka rozmytego awarii programu VS w projektancie WinForms .NET Core podczas zamykania projektu lub rozwiązania.
  • Naprawiono błąd Project: Przeciągnięcie pliku z Eksploratora rozwiązań do otwartego pliku to usunięcie pliku z systemu plików.
  • Naprawiono klikanie aktualizacji w funkcji Porównywanie schematów SQL nie powoduje zapisania zmian w pliku sqlproj
  • Usunięto usterkę, która oznaczała, że kompilacje nie powiodły się z błędami "Nie znaleziono tabeli/kolumny".
  • Rozwiązaliśmy problem z polem wyboru "Zat zatwierdzeniu po scaleniu" Team Explorer -> Gałęzie.
  • Naprawiono błąd, który Visual Studio może przestać odpowiadać przez kilka sekund podczas sprawdzania aktualizacji.
  • DeploymentAppRecipe.exe obsługuje teraz uruchamianie z dowolnego bieżącego katalogu. Teraz zwraca również niezerową wartość zwracaną za każdym razem, gdy wdrożenie zakończy się niepowodzeniem, i drukuje komunikaty o błędach do standardowego strumienia błędów.

Zgłaszane na forum Developer Community



Release Notes Icon Visual Studio 2019 w wersji 16.8.3

wydany 8 grudnia 2020 r.

Zalecenia dotyczące zabezpieczeń

CVE-2020-17156 Luka w zabezpieczeniach dotycząca zdalnego wykonywania kodu w programie Visual Studio

Istnieje luka w zabezpieczeniach dotycząca zdalnego wykonywania kodu, gdy program Visual Studio klonuje złośliwe repozytorium.

Problemy rozwiązane w tej wersji programu Visual Studio 2019 w wersji 16.8.3

  • Naprawiono wewnętrzny błąd kompilatora występujący, gdy zagnieżdżony szablon funkcji jest definiowany poza klasą nadrzędną.
  • Naprawiono nieprawidłowy błąd C2355 występujący, gdy element „this” jest używany w inicjatorze niestatycznej składowej danych.
  • Naprawiono błąd ładowania zestawu reguł dla niestandardowego zestawu reguł używającego opcji /analyze:ruleset z opcją /analyze:rulesetdirectory i/lub /analyze:projectdirectory.
  • Poprawka dla sporadycznej awarii w programie Visual Studio podczas korzystania z programu .NET Core Designer.
  • Wstawienie platformy .NET 5.0.1 w programie Visual Studio w wersji 16.8.3
  • Rozwiązano problem polegający na tym, że niektóre okna narzędzi aktywowane za pomocą kontekstu interfejsu użytkownika mogły powodować awarię programu Visual Studio.
  • Naprawiono wypychanie ze strony Zarządzanie gałęziami, gdy nie ma żadnej gałęzi śledzenia zdalnego usługi Git.
  • Dodano obsługę programu Xcode 12.2.

Zgłaszane na forum Developer Community



Release Notes Icon Visual Studio 2019 w wersji 16.8.2

wydany 19 listopada 2020 r.

Problemy rozwiązane w tym wydaniu programu Visual Studio 2019 w wersji 16.8.2

  • Naprawiono usterkę optymalizacji w pętlach.
  • Usunięto wewnętrzny błąd kompilatora w implementacji gwarantowanego pominięcia kopii (funkcja języka C++ 17).
  • Naprawiono regresję wydajności kompilacji dla dużych zastosowań typów anonimowych.
  • Rozwiązano problem polegający na tym, że złoty pasek z komunikatem „Określony argument znajdował się poza zakresem prawidłowych wartości” pojawiał się podczas edycji kodu w języku C#.
  • Rozwiązano problem, który mógł powodować wyjątek MissingMethodException podczas kompilowania projektu z szablonami T4.
  • Rozwiązano problem polegający na tym, że wyszukiwanie w oknie dialogowym nowego projektu mogło zwracać zero wyników.

Zgłaszane na forum Developer Community



Release Notes Icon Visual Studio 2019 w wersji 16.8.1

wydany 12 listopada 2020 r.

Problemy rozwiązane w tym wydaniu programu Visual Studio 2019 w wersji 16.8.1

  • Rozwiązano znaczący problem polegający na wyświetlaniu ostrzeżenia „Pakiet »SourceExplorerPackage« nie został załadowany poprawnie” podczas klonowania repozytorium we wtyczce Team Explorer. Gdy użytkownicy napotykali ten problem, produkt przestawał odpowiadać.

Release Notes Icon Visual Studio 2019 w wersji 16.8.0

wydany 10 listopada 2020 r.

Podsumowanie nowości w tym wydaniu programu Visual Studio 2019 w wersji 16.8


F# :

  • Język F# 5 jest teraz wydawany wraz z platformą .NET 5
  • Usprawnienia wydajności i poprawki dla narzędzi programu Visual Studio za pośrednictwem pakietu F# Tools w wersji 11.0.0
  • Pełne informacje o wersji są dostępne w witrynie GitHub

C++:

  • Koprocedury języka C++20 są teraz obsługiwane dla opcji /std:c++latest i nagłówka <coroutine>.
  • Funkcja IntelliSense oferuje teraz obsługę elementu <concepts> języka C++20 i nagłówków <ranges> oraz zmienianie nazw i przeglądanie definicji koncepcji.
  • Nasza biblioteka STL obsługuje teraz większość zakresów języka C++20.
  • Program MSVC obsługuje teraz warunkowo trywialne specjalne funkcje składowe.
  • Wersje C11 i C17 są teraz obsługiwane dla przełączników /std:C11 i /std:C17.
  • Dodatkowe ulepszenia biblioteki STL obejmują pełną obsługę dla std::atomic_ref, std::midpoint i std::lerp oraz std::execution::unseq, optymalizacje dla std::reverse_copy i nie tylko.
  • Uaktualniono wersję programu CMake dostarczanego z programem Visual Studio do wersji CMake 3.18.
  • Nasze narzędzia do analizy kodu obsługują teraz standard SARIF 2.1: standardowy w branży format statycznego dziennika analizy.
  • W przypadku braku narzędzi do kompilacji w projektach systemu Linux na pasku narzędzi będzie teraz wyświetlane ostrzeżenie, a lista błędów będzie zawierać jasny opis brakujących narzędzi.
  • Teraz można debugować zrzuty pamięci systemu Linux w zdalnym systemie Linux lub podsystemie WSL bezpośrednio z poziomu programu Visual Studio.
  • W języku C++ w przypadku generowania komentarzy w narzędziu Doxygen dodaliśmy kolejne opcje stylu komentarza (/*! oraz //!).
  • Dodatkowe powiadomienia vcpkg
  • Obsługa kompilatora dla wyrażeń lambda w nieocenionych kontekstach
  • Ulepszona wydajność linku /debug:full dzięki wielowątkowości tworzenia pliku pdb. W kilku dużych aplikacjach i grach AAA można zauważyć od 2 do 4 razy szybsze łączenie.
  • Debuger programu Visual Studio obsługuje teraz typ char8_t.
  • Obsługa projektów ARM64 przy użyciu clang-cl.
  • Obsługa funkcji wewnętrznych Intel AMX.

Debuger:

  • Obsługa debugowania zrzutu pamięci systemu Linux na platformie .NET Core
  • Automatyczna analiza na platformach .NET i .NET Core
  • Automatyczna analiza aktywnej ścieżki pamięci na platformach .NET i .NET Core

Eksperymentalne aktualizacje edytora Razor:

  • Żarówki Blazor
  • Żarówki C#
  • Udoskonalone formatowanie Razor
  • Zmienianie nazwy składników Razor w znacznikach w plikach razor
  • Przechodzenie do definicji w przestrzeni nazw tagów składnika Blazor
  • Kolorowanie wskaźnika C#
  • Kolorowanie etykietek narzędzia uzupełniania C#
  • Przechodzenie do definicji/implementacji dla składni Razor z uwzględnieniem plików zamkniętych
  • Znajdowanie wszystkich odwołań w zamkniętych plikach Razor
  • Ulepszona stabilność i wydajność edytowania składni Razor w przypadku dużych projektów i rozwiązań

Platforma Fakes z projektami w stylu zestawu SDK:

  • W przypadku korzystania z nowej obsługi platformy Fakes dla projektów w stylu zestawu SDK niektórzy użytkownicy napotykali następujący błąd podczas generowania podkładek

Wydajność usługi Git:

  • Dowiedz się więcej na temat używania wszystkich funkcji usługi Git z naszej nowej dokumentacji online
  • W dowolnym momencie otwórz okno repozytorium usługi Git za pośrednictwem okna zmian usługi Git, menu Widok i paska stanu
  • Pobieranie, ściąganie i wypychanie z wielu lokalizacji zdalnych w oknie zmian usługi Git
  • Wyświetlanie komunikatów o powodzeniu i błędach dla poleceń Git w górnej części okna repozytorium usługi Git
  • Utwórz nową gałąź na podstawie elementu roboczego usługi Azure DevOps
  • Otwórz repozytorium Git z listy repozytoriów lokalnych w menu usługi Git
  • Domyślnym dostawcą kontroli źródła jest teraz Git zamiast TFVC
  • Przełączanie jednym kliknięciem między historiami rozgałęzień w oknie Repozytorium Git
  • Wyświetlanie i wybieranie z listy rozwiązań w Eksploratorze rozwiązań po otwarciu repozytorium
  • Modyfikowanie widoku historii i wyszukiwanie zatwierdzeń za pomocą paska narzędzi w oknie Repozytorium Git
  • Pobieranie, ściąganie oraz wypychanie z sekcji zatwierdzeń przychodzących i wychodzących na grafie historii gałęzi
  • Monity o utworzenie żądania ściągnięcia po wypchnięciu gałęzi do repozytorium zdalnego
  • Wyświetlanie nazw gałęzi w poleceniach merge i rebase w menu kontekstowym listy gałęzi
  • Dostęp do poleceń systemu Git za pomocą menu kontekstowego w Eksploratorze rozwiązań i edytorze
  • Obserwowanie postępu klonowania za pomocą nowego modalnego okna dialogowego z opcją wykonywania procesu w tle

IntelliCode:

  • Spersonalizowane uzupełnienia funkcji IntelliCode można uzyskać w dokumentacji programu Visual Studio
  • Aktualizuj uzupełnienia funkcji IntelliCode za pomocą bazy kodu i udostępniaj w ramach dokumentacji przepływu pracy CI zespołu

Produktywność platformy .NET:

  • Analizatory Roslyn są teraz dołączone do zestawu .NET 5.0 SDK
  • Refaktoryzacja, która wprowadza w języku C# 9 nową składnię dopasowywania wzorców not, gdy jest obecny operator pomijania
  • Refaktoryzacja metody wbudowanej w celu ułatwienia zastąpienia użycia metody statycznej, wystąpienia i rozszerzenia w ramach treści jednej instrukcji
  • Poprawka kodu do konwertowania wystąpień funkcji typeof na funkcję nameof w języku C# i funkcji GetType na funkcję NameOf w języku Visual Basic
  • Obsługa języków C# i Visual Basic w zakresie wskazówek dotyczących nazw parametrów wbudowanych, które wstawiają zakończenia literałów, literałów rzutowanych i tworzonych wystąpień obiektów przed każdym argumentem w wywołaniach funkcji
  • Refaktoryzacja, która wyodrębnia składowe z wybranej klasy do nowej klasy bazowej w językach C# i Visual Basic
  • Funkcja Oczyszczanie kodu ma nowe opcje konfiguracji, które umożliwiają zastosowanie formatowania i preferencji nagłówka pliku ustawionych w pliku EditorConfig w pojedynczym pliku lub w całym rozwiązaniu
  • Poprawka kodu umożliwiająca usunięcie słowa kluczowego in z miejsc, w których argument nie powinien być przekazywany przez referencję
  • Refaktoryzacja, która wprowadza nowe kombinatory wzorców C#9 i sugestie dopasowania wzorców, takie jak konwersja == w celu użycia is, jeśli jest to możliwe
  • Poprawka kodu zmieniającą klasę w klasę abstrakcyjną, gdy próbujesz napisać metodę abstrakcyjną w klasie, która nie jest abstrakcyjna
  • Uzupełnienie funkcji IntelliSense w literałach ciągów DateTime i TimeSpan jest wyświetlane automatycznie po wpisaniu pierwszego cudzysłowu
  • Poprawka kodu usuwająca zbędne pragma suppressions i zbędne obiekty SuppressMessageAttributes
  • Funkcje Rename i Find All References obsługują teraz odwołania do symboli w ciągu docelowym globalnych obiektów SuppressMessageAttributes
  • Wycofanie słowa kluczowego ByVal, aby uznać je za niepotrzebne, i udostępnienie poprawki kodu służącej do usuwania zbędnych słów kluczowych ByVal w języku Visual Basic
  • Obsługa okna Interactive dla wielu środowisk uruchomieniowych, takich jak .NET Framework i .NET Core.
  • Dodano nowy interfejs API RegisterAdditionalFileAction, który umożliwia autorom analizatorów utworzenie analizatora dla dodatkowych plików.

Środowisko IDE programu Visual Studio 2019:

  • Dodaj swoje konto usługi GitHub przy użyciu środowiska zarządzania kontami
  • W tej wersji starsze środowisko Znajdź w plikach stało się przestarzałe i wszyscy użytkownicy zostali przeniesieni do nowego środowiska. Zespół edytora pracuje z osobami, które przesłały opinię na forum Developer Community i które napotykają problemy z nowoczesnym środowiskiem Znajdź w plikach.
  • Dostawca publikacji technologii ClickOnce jest teraz dostępny dla aplikacji klasycznych systemu Windows na platformach .NET Core 3.1 i .NET 5.0.

Okienko szczegółów testu zawijania w eksploratorze testów:

  • Teraz można zawijać tekst w okienku szczegółów testu w eksploratorze testów.

Narzędzia XAML (WPF, UWP i Xamarin.Forms):

  • Ulepszenia diagnostyki błędów powiązań XAML
  • Ustawienia przeładowywania kodu XAML na gorąco zostały przeniesione do obszaru „Debugowanie > Przeładowywanie na gorąco”
  • Wypełnianie zestawu narzędzi z nieużywanych pakietów NuGet

JavaScript/TypeScript:

  • Debuger języka JavaScript/TypeScript obsługuje teraz debugowanie procesów roboczych usługi, internetowych procesów roboczych, elementów iFrame i kodu JavaScript strony w tym samym czasie. Ponadto nowe środowisko debugowania dodaje obsługę jednoczesnego debugowania aplikacji serwera węzła zaplecza i kodu JavaScript po stronie klienta w przeglądarce. Ta funkcja jest nadal eksperymentalna. Nowe środowisko debugowania można włączyć w menu Opcje debugowania.
  • Teraz można wyzwalać refaktoryzacje wszędzie tam, gdzie mogą być dostępne, za pomocą skrótu akcji kodu (ctrl + .). Nie trzeba nawet zaznaczać żadnego tekstu — język TypeScript jest teraz wystarczająco inteligentny, aby wyszukiwać najlepsze dostępne refaktoryzacje wokół lokalizacji kursora!
  • Teraz w języku TypeScript można dostrajać wyszukiwanie pakietów w celu automatycznego ukończenia importu. Może to prowadzić do usprawnienia wydajności niektórych projektów z wieloma zależnościami. Aby uzyskać więcej informacji, zapoznaj się z (informacjami o wersji) języka TypeScript 4.0 [https://www.typescriptlang.org/docs/handbook/release-notes/typescript-4-0.html ]
  • W okienku danych wyjściowych dodaliśmy komunikat z informacjami o typach zainstalowanych w celu obsługi funkcji IntelliSense. Zalecamy dodanie do projektu pliku tsconfig w celu dostosowania używanych typów.
  • Należy pamiętać, że dołączamy kompilator i usługę języka TypeScript 4.0

Zalecenia dotyczące zabezpieczeń

CVE-2020-17100 Luka w zabezpieczeniach polegająca na nieuprawnionej modyfikacji w programie Visual Studio

Luka w zabezpieczeniach polegająca na nieuprawnionej modyfikacji występuje podczas tworzenia folderu python27 za pomocą dodatku Python Tools for Visual Studio. Atakujący, któremu udałoby się wykorzystać tę lukę w zabezpieczeniach, mógłby uruchamiać procesy w kontekście o podniesionych uprawnieniach.

Problemy rozwiązane w tym wydaniu

  • Rozwiązano problem, który powodował wystąpienie błędów kompilatora podczas kompilowania w programie Visual Studio 2019 16.7 za pomocą kompilatora Intel C++ Compiler z 80-bitowymi liczbami podwójnej precyzji, co uniemożliwiało kompilację projektu.
  • Rozwiązano problem polegający na tym, że Live Unit Testing odmawiał uruchomienia w niektórych scenariuszach.
  • Platforma .NET 5.0. RC2 dodana do programu Visual Studio 2019 16.8 w wersji zapoznawczej 4
  • Rozwiązano problem polegający na tym, że rozpoczęta operacja usługi Git nigdy się nie kończyła.
  • Dodaliśmy dodatkowe funkcje związane z tworzeniem środowisk Visual Studio Codespaces i łączeniem się z nimi. Zarejestruj się w ucieku Codespaces Visual Studio, aby spróbować.
  • Usunięto usterkę powodującą awarię lub brak odpowiedzi programu Visual Studio 2019 podczas zamykania lub opuszczania rozwiązań ASP.NET Core.
  • Rozwiązano problem polegający na tym, że ładowanie systemu projektu C++ nie powiodło się po odinstalowaniu i ponownym zainstalowaniu programu Visual Studio 2019.

Szczegóły nowości w programie Visual Studio 2019 w wersji 16.8.0

C++

  • Koprocedury języka C++20 są teraz obsługiwane dla opcji /std:c++latest i nagłówka <coroutine>. Obsługa naszego starszego zachowania jest dostępna w obszarze <experimental/coroutine> i przełączniku /await.
  • Funkcja IntelliSense oferuje teraz obsługę elementu <concepts> języka C++20 i nagłówków <ranges> oraz zmienianie nazw i przeglądanie definicji koncepcji. Istnieje znany problem, którego rozwiązanie planujemy w wersji zapoznawczej 4.
  • Nasza biblioteka STL obsługuje teraz większość zakresów języka C++20. Możesz śledzić postęp naszego problemu w usłudze GitHub dotyczącego zakresów.
  • Program MSVC obsługuje teraz warunkowo trywialne specjalne funkcje składowe.
  • Wersje C11 i C17 są teraz obsługiwane dla przełączników /std:C11 i /std:C17.
  • Dodatkowe ulepszenia biblioteki STL obejmują pełną obsługę dla std::atomic_ref, std::midpoint i std::lerp oraz std::execution::unseq, optymalizacje dla std::reverse_copy i nie tylko. Wszystkie aktualizacje można znaleźć w dzienniku zmian.
  • Uaktualniliśmy program CMake dostarczany z programem Visual Studio do wersji CMake 3.18.
  • Nasze narzędzia do analizy kodu obsługują teraz standard SARIF 2.1: standardowy w branży format statycznego dziennika analizy. Więcej informacji na temat formatu SARIF można znaleźć w oficjalnej specyfikacji.
  • W przypadku braku narzędzi do kompilacji w projektach systemu Linux na pasku narzędzi będzie teraz wyświetlane ostrzeżenie, a lista błędów będzie zawierać jasny opis brakujących narzędzi.
  • Teraz można debugować zrzuty pamięci systemu Linux w zdalnym systemie Linux lub podsystemie WSL bezpośrednio z poziomu programu Visual Studio.
  • W języku C++ w przypadku generowania komentarzy w narzędziu Doxygen dodaliśmy kolejne opcje stylu komentarza (/*! oraz //!).
  • Dodatkowe powiadomienia vcpkg
  • Dodaliśmy obsługę kompilatora dla wyrażeń lambda w nieocenionych kontekstach, co umożliwia używanie wyrażeń lambda w specyfikatorach decltype.
  • W programie Visual Studio jest teraz dostępny linter w trakcie pisania oraz poprawki. Aby skonfigurować, wybierz pozycję Narzędzia -> Opcje -> Edytor tekstu -> C/ C++ -> Styl kodu -> Linter + poprawki.
As-you-type linter showing warning for using bitwise & instead of logical && on bools
Linter w trakcie pisania

Debuger

Obsługa debugowania zrzutu pamięci systemu Linux na platformie .NET Core

Debugowanie zarządzanych zrzutów pamięci systemu Linux w systemie Windows było do tej pory trudne do wykonania i zazwyczaj oznaczało konieczność skonfigurowania innego środowiska systemu Linux, które dokładnie odzwierciedlało środowisko produkcyjne, a następnie zainstalowanie zestawu narzędzi do analizy. Na szczęście w programie Visual Studio 2019 16.8 (wersja zapoznawcza 3) możesz po prostu przeciągnąć i upuścić zarządzany zrzut pamięci systemu Linux bezpośrednio do środowiska IDE i natychmiast rozpocząć debugowanie.

Automatyczna analiza na platformie .NET

Programowanie asynchroniczne już od kilku lat jest obecne na platformie .NET, jednak zawsze było je trudno wykonać dobrze. Wprowadziliśmy zarządzany analizator zrzutów pamięci, który pomaga identyfikować następujące scenariusze i antywzorce:

  • Sync-over-Async
  • Wyczerpanie puli wątków

Automatyczna analiza aktywnej ścieżki pamięci na platformach .NET i .NET Core

Dzięki temu klienci mogą intuicyjnie wyświetlać dominujące typy obiektów w stercie pamięci przy użyciu adnotacji płomieniowej w oknie narzędzi diagnostyki pamięci.

Platforma Fakes z projektami w stylu zestawu SDK generuje problem z podkładką

W przypadku korzystania z nowej obsługi platformy Fakes dla projektów w stylu zestawu SDK niektórzy użytkownicy napotykali następujący błąd podczas generowania podkładek.

Cannot generate shim for System.DateTime: type is not supported because of internal limitations

Odpowiednią poprawkę wprowadzono w wersji 16.8 (wersja zapoznawcza 3). Jeśli używasz wersji 16.7.*, możesz zastosować następujące obejście:

  1. Dodaj wartość <FakesUseV2Generation>False</FakesUseV2Generation> do elementu PropertyGroup w pliku csproj.
  2. Dodaj wartość <Fakes Include="Fakes\*.fakes" /> do elementu ItemGroup w pliku csproj.
  3. Dodaj odwołanie do wygenerowanych zestawów platformy Fakes w elemencie ProjectDir/FakesAssemblies.

Możesz także śledzić opinie społeczności deweloperów, aby uzyskać dodatkowe aktualizacje.

Eksperymentalne aktualizacje edytora Razor

Nowy eksperymentalny edytor Razor obsługuje teraz następujące funkcje edytowania Razor:

  • Żarówki Blazor:
    • Wyodrębnij do kodu w tle*:
    • Utwórz składnik z tagu*
    • Dodaj dyrektywę @using dla składnika
    • W pełni kwalifikowana nazwa tagu składnika
  • Żarówki C#
    • Dodaj dyrektywę @using
    • W pełni kwalifikowana nazwa typu
  • Udoskonalone formatowanie Razor
  • Zmienianie nazwy składników Razor w znacznikach w plikach razor
  • Przechodzenie do definicji w nazwach tagów składnika Blazor
  • Kolorowanie wskaźnika C#
  • Kolorowanie etykietek narzędzia uzupełniania C#
  • Znajdowanie wszystkich odwołań w zamkniętych plikach Razor
  • Ulepszona stabilność i wydajność edytowania składni Razor w przypadku dużych projektów i rozwiązań

*Działa tylko w lokalnych scenariuszach Razor, które nie są jeszcze obsługiwane Visual Studio Codespaces lub Live Share.

Aby włączyć eksperymentalny edytor Razor, wybierz kolejno opcje Narzędzia > Opcje > Środowisko > Funkcje w wersji zapoznawczej, wybierz pozycję Włącz eksperymentalny edytor Razor, a następnie ponownie uruchom program Visual Studio.

Środowisko IDE programu Visual Studio 2019

  • Dodaj swoje konto usługi GitHub przy użyciu znajomego środowiska zarządzania kontami programu Visual Studio. Dzięki temu kontrola wersji, zintegrowany terminal i inne funkcje będą mogły korzystać z poświadczeń tego konta w celu spełnienia wymagań związanych z uwierzytelnianiem w usłudze GitHub.
Inline parameter name hints with GitHub
Dodawanie kont usługi GitHub w programie Visual Studio
  • Dostawca publikacji technologii ClickOnce jest teraz dostępny dla aplikacji klasycznych systemu Windows na platformach .NET Core 3.1 i .NET 5.0. Aby rozpocząć, kliknij prawym przyciskiem myszy projekt w Eksploratorze rozwiązań i wybierz polecenie Publikuj lub wybierz menu Kompilacja > Publikuj <AppName>. Technologię ClickOnce można znaleźć w kategorii folderów.
Inline parameter name hints with GitHub Image
Dostawca publikowania technologii ClickOnce w programie Visual Studio

Wydajność usługi Git

  • Utwórz nową gałąź na podstawie elementu roboczego usługi Azure DevOps

    Create a new branch from an Azure DevOps work item
    Tworzenie nowej gałęzi na podstawie elementu roboczego

  • Otwórz repozytorium Git z listy repozytoriów lokalnych w menu usługi Git

Local Repositories list
Lista repozytoriów lokalnych w menu usługi Git
  • Domyślnym dostawcą kontroli źródła jest teraz usługa Git zamiast programu TFVC, co można zmienić w obszarze Narzędzia — Opcje — Kontrola źródła

  • Przełączanie jednym kliknięciem między historiami rozgałęzień w oknie Repozytorium Git

  • Wyświetlanie i wybieranie z listy rozwiązań w repozytorium w Eksploratorze rozwiązań po otwarciu repozytorium

    Preview Feature toggle to show list of Views when opening a repo
    Przełączanie funkcji w wersji zapoznawczej w celu wyświetlenia listy widoków podczas otwierania repozytorium

List of Views in Solution Explorer
Lista widoków w Eksploratorze rozwiązań

Produktywność platformy .NET

  • Analizatory platformy kompilatora .NET (Roslyn) sprawdzają kod C# lub Visual Basic pod kątem bezpieczeństwa, wydajności, projektu i innych problemów. Począwszy od wersji .NET 5.0, te analizatory są uwzględnione w zestawie .NET SDK. Analizatory są domyślnie włączona dla projektów przeznaczonych dla platformy .NET 5.0 lub nowszej. Możesz włączyć analizę kodu dla projektów przeznaczonych dla wcześniejszych wersji platformy .NET, ustawiając dla właściwości EnableNETAnalyzers wartość true. Możesz wyłączyć analizę kodu dla projektu, ustawiając dla właściwości EnableNETAnalyzers wartość false. Aby włączyć/wyłączyć analizatory platformy .NET, można również użyć okna Właściwości projektu. Aby uzyskać dostęp do okna Właściwości projektu, kliknij prawym przyciskiem myszy projekt w Eksploratorze rozwiązań i wybierz pozycję Właściwości. Następnie wybierz kartę Analiza kodu, gdzie możesz zaznaczyć lub wyczyścić pole wyboru Włącz analizatory platformy .NET.
Project Properties window to enable .NET Analyzers
Włączanie analizatorów platformy .NET w oknie Właściwości projektu
  • Dostępna jest już refaktoryzacja, która wprowadza w języku C+ 9 nową składnię dopasowywania wzorców not, gdy jest obecny operator pomijania. Umieść kursor na operatorze pomijania. Naciśnij klawisze (Ctrl+ . ), aby wywołać menu Szybkie akcje i operacje refaktoryzacji. Wybierz pozycję Użyj dopasowywania wzorców.
Refactoring introducing C# 9 not pattern matching syntax
Refaktoryzacja wprowadzająca składnię dopasowywania wzorca not w języku C# 9
  • Dostępna jest teraz refaktoryzacja metody wbudowanej, która ułatwia zastępowanie użycia metody static, instance i extension w ramach treści jednej instrukcji z opcją usunięcia oryginalnej deklaracji metody. Umieść kursor na użyciu metody. Naciśnij klawisze (Ctrl+ . ), aby wywołać menu Szybkie akcje i operacje refaktoryzacji. Wybierz jedną z następujących opcji:

Wybierz pozycję Umieść w tekście element <QualifiedMethodName> , aby usunąć deklarację metody wbudowanej:

Inline Method refactoring removing declaration
Refaktoryzacja metody wbudowanej — usuwanie deklaracji

Wybierz pozycję Umieść w tekście i zachowaj element <QualifiedMethodName> , aby zachować oryginalną deklarację metody:

Inline Method refactoring preserving declaration
Refaktoryzacja metody wbudowanej — zachowywanie deklaracji

  • Podczas tworzenia nowego pliku języka C# lub Visual Basic z szablonu respektowane są ustawienia stylu kodu EditorConfig. Następujące style kodu zostaną automatycznie zastosowane podczas tworzenia nowych plików: nagłówki plików, sortowanie za pomocą dyrektyw i umieszczanie przy użyciu dyrektyw wewnątrz przestrzeni nazw lub poza nimi.

  • Dodano obsługę języków C# i Visual Basic w zakresie wskazówek dotyczących nazw parametrów wbudowanych, które wstawiają zakończenia literałów, literałów rzutowanych i tworzonych wystąpień obiektów przed każdym argumentem w wywołaniach funkcji. Najpierw należy włączyć tę opcję w obszarze Narzędzia > Opcje > Edytor tekstów > C# lub Basic > Zaawansowane i wybrać pozycję Wyświetlaj wskazówki dotyczące nazw parametrów wbudowanych (eksperymentalnie) . Wskazówki dotyczące nazwy parametrów wbudowanych pojawią się w plikach języków C# i Visual Basic.

Inline parameter name hints
Wskazówki dotyczące nazw parametrów wbudowanych
  • Można teraz wyodrębnić elementy członkowskie z wybranej klasy do nowej klasy bazowej przy użyciu nowej refaktoryzacji Wyodrębnij klasę bazową. Umieść kursor na nazwie klasy lub wyróżnionym elemencie członkowskim. Naciśnij klawisze (Ctrl+ . ), aby wywołać menu Szybkie akcje i operacje refaktoryzacji. Wybierz opcję Ściągnij elementy członkowskie do nowej klasy bazowej. Zostanie otwarte okno dialogowe Wyodrębnij klasę bazową, w którym można określić nazwę klasy bazowej i lokalizację, w której należy ją umieścić. Można wybrać elementy członkowskie, które mają zostać przeniesione do nowej klasy bazowej, i opcję ich wyabstrahowania, zaznaczając pole wyboru w kolumnie Wyabstrahuj.
Extract Base Class
Wyodrębnij klasę bazową

Po wybraniu OK zostanie wyświetlona nowa klasa bazowa z elementami członkowskimi.

Dla języka C# wybierz opcję Konwertuj typeof na nameof :

Convert typeof to nameof
Konwertuj element typeof na element nameof

Dla języka Visual Basic wybierz opcję Konwertuj GetType na NameOf :

Convert GetType to NameOf
Konwertuj element GetType na NameOf
  • Funkcja Oczyszczanie kodu ma nowe opcje konfiguracji, które umożliwiają zastosowanie formatowania i preferencji nagłówka pliku ustawionych w pliku EditorConfig w pojedynczym pliku lub w całym rozwiązaniu.
Formatting and File Header support in Code Cleanup
Obsługa formatowania i nagłówka pliku w funkcji Oczyszczanie kodu
  • Udostępniono poprawkę kodu umożliwiającą usunięcie słowa kluczowego in z miejsc, w których argument nie powinien być przekazywany przez referencję. Umieść kursor na błędzie. Naciśnij klawisze (Ctrl+ . ), aby wywołać menu Szybkie akcje i operacje refaktoryzacji. Wybierz pozycję Usuń słowo kluczowe „in” .
Remove in keyword code fix
Poprawka kodu służąca do usuwania słowa kluczowego `in`
  • Udostępniono refaktoryzację wprowadzającą nowe kombinatory wzorców C#9. Oprócz sugestii dopasowywania wzorców, takich jak konwertowanie znaków == na słowo kluczowe is, gdy ma to zastosowanie, ta poprawka kodu sugeruje również kombinatory wzorców and, or i not w przypadku dopasowywania wielu różnych wzorców i negacji. Umieść kursor wewnątrz instrukcji. Naciśnij klawisze (Ctrl+ . ), aby wywołać menu Szybkie akcje i operacje refaktoryzacji. Wybierz pozycję Użyj dopasowywania wzorców.
Introduce C#9 Pattern Combinators
Wprowadzenie kombinatorów wzorców C#9
  • Udostępniono poprawkę kodu zmieniającą klasę w klasę abstrakcyjną, gdy próbujesz napisać metodę abstrakcyjną w klasie, która nie jest abstrakcyjna. Umieść kursor na błędzie metody. Naciśnij klawisze (Ctrl+ . ), aby wywołać menu Szybkie akcje i operacje refaktoryzacji. Wybierz pozycję Zmień na klasę „abstract” .
Make Class Abstract
Zmiana klasy na abstrakcyjną
  • W wersji 16.7 (wersja zapoznawcza 1) dodaliśmy uzupełnianie funkcji IntelliSense w literałach ciągu DateTime i TimeSpan. W tej wersji ta lista uzupełniania jest automatycznie wyświetlana po wpisaniu pierwszego cudzysłowu. W przeszłości konieczne było naciśnięcie kombinacji klawiszy Ctrl+spacja, aby wyświetlić tę listę uzupełniania. Umieść kursor wewnątrz literału ciągu DateTime lub TimeSpan i wpisz pierwszy cudzysłów. Zobaczysz opcje uzupełniania oraz objaśnienie znaczenia poszczególnych znaków. Zostanie podany format daty i godziny, a także przykład.
IntelliSense Completion in DateTime and TimeSpan String Literals
Uzupełnianie funkcji IntelliSense w literałach ciągu DateTime i TimeSpan
This improvement also works for interpolated strings when you type a colon
To ulepszenie działa również w przypadku ciągów interpolowanych po wpisaniu dwukropka
  • Udostępniono poprawkę kodu usuwającą zbędne pominięcia instrukcji pragma i zbędne obiekty SuppressMessageAttributes. Umieść kursor na ostrzeżeniu pragma lub obiekcie SuppressMessageAttribute. Naciśnij klawisze (Ctrl+ . ), aby wywołać menu Szybkie akcje i operacje refaktoryzacji. Wybierz pozycję Usuń zbędne pominięcie.
Remove Unnecessary Pragmas
Usuwanie zbędnych instrukcji pragma
Remove Unnecessary SuppressMessageAttributes
Usuwanie niepotrzebnych obiektów SuppressMessageAttributes
  • Funkcje Zmień nazwę i Znajdź wszystkie odwołania obsługują teraz odwołania do symboli w ciągu docelowym globalnych pominięć SuppressMessageAttribute.
Rename SuppressMessageAttribute
Zmień nazwę — SuppressMessageAttribute
Find All References for SuppressMessageAttribute
Znajdź wszystkie odwołania — SuppressMessageAttribute
  • Program Visual Basic obsługiwał wiele sposobów przekazywania parametrów, ByVal i ByRef, a przez długi czas metoda ByVal była opcjonalna. Teraz wycofujemy słowo kluczowe ByVal, aby uznać je za niepotrzebne, i udostępniamy poprawkę kodu służącą do usuwania zbędnych słów kluczowych ByVal. Umieść kursor na słowie kluczowym ByVal. Naciśnij klawisze (Ctrl+ . ), aby wywołać menu Szybkie akcje i operacje refaktoryzacji. Wybierz pozycję Słowo kluczowe „ByVal” jest zbędne i można je usunąć.
Visual Basic Remove ByVal Refactoring
Usunięcie refaktoryzacji ByVal w programie Visual Basic
  • Udostępniono obsługę okna Interactive dla wielu środowisk uruchomieniowych, takich jak .NET Framework i .NET Core.
Interactive Window Support in .NET Core
Obsługa okna Interactive na platformie .NET Core
  • Udostępniono nowy interfejs API RegisterAdditionalFileAction, który umożliwia autorom analizatorów utworzenie analizatora dla dodatkowych plików.

Okienko szczegółów testu zawijania w eksploratorze testów

Ta często żądana funkcja umożliwia użytkownikowi wybranie zawijania tekstu lub pozostawienie domyślnego wyrównania wierszy tekstu. Gdy wyrównanie tekstu nie jest potrzebne, zawijanie może sprawiać, że informacje zwrotne z przebiegu testu są znacznie łatwiejsze do wyświetlenia, i eliminuje potrzebę użycia poziomego paska przewijania. Możesz to włączyć z poziomu menu ustawienia eksploratora testów lub menu kontekstowego okienka podsumowania.

Wrap test details from the Test Settings menu
Menu ustawień testu
Wrap test details from the right-click context menu
Szczegóły testu zawijania z menu kontekstowego po kliknięciu prawym przyciskiem myszy

Narzędzia XAML (WPF, UWP i Xamarin.Forms)

Ulepszenia diagnostyki błędów powiązań XAML

Deweloperzy pracujący nad projektami WPF, UWP, WinUI i Xamarin.Forms muszą często wykrywać i rozwiązywać błędy powiązań danych języka XAML w aplikacjach. Aby ulepszyć narzędzia diagnostyczne w tym scenariuszu dodaliśmy dwa nowe środowiska do programu Visual Studio 2019 w wersji 16.8 lub nowszej:

  • Ikona wskaźnika błędu powiązania języka XAML: nowa ikona wskaźnika błędu powiązania języka XAML jest teraz dostępna na pasku narzędzi w aplikacji dla projektów WPF i UWP oraz w dynamicznym drzewie wizualnym dla wszystkich projektów XAML zawierających zestaw narzędzi Xamarin.Forms. Ta ikona będzie pokazywać czerwony wskaźnik w przypadku wykrycia co najmniej jednego błędu powiązania. Kliknięcie ikony spowoduje przejście do nowego okna błędów powiązań języka XAML.
Binding Failure Icon (in-app toolbar)
Ikona błędu powiązania (pasek narzędzi w aplikacji)
  • Okno błędów powiązań języka XAML: nowe okno błędów powiązań języka XAML jest teraz dostępne dla projektów WPF, UWP, WinUI i Xamarin.Forms. To nowe dedykowane środowisko zapewnia rozbudowany interfejs użytkownika dotyczący informacji o błędzie powiązania, które były wcześniej dostępne tylko w oknie danych wyjściowych. Ulepszenia obejmują możliwość wyświetlania błędów jako zestawu kolumn, które można sortować i dostosowywać, i które są w pełni przeszukiwalne. Ponadto pogrupowaliśmy razem podobne błędy, aby ograniczyć szumy, które mogą wystąpić w przypadku pewnej kombinacji błędów szablonów powiązań danych, udostępniając jednocześnie wszystkie oryginalne, nieprzetworzone informacje o błędach, które można łatwo skopiować za pomocą opcji menu dostępnego po kliknięciu prawym przyciskiem myszy. (uwaga: wymaga platformy Xamarin w wersji 4.5.0.266-pre3 lub nowszej)
  • Przechodzenie do źródła dla błędów powiązań: We współpracy z zespołem podsystemu WPF umożliwiliśmy przechodzenie do źródła błędów powiązań dla tych klientów, którzy korzystają z podsystemu WPF na platformie .NET 5 (RC2 lub nowsze).
XAML Binding Failure Window & LVT Icon
Okno błędów powiązań języka XAML i ikona LVT

Gorące ponowne ładowanie XAML

  • Funkcja „tylko zmiany” funkcji przeładowywania na gorąco kodu XAML w interfejsie Xamarin.Forms obsługuje teraz platformę UWP: w tej wersji rozpoczynamy wprowadzanie obsługi bardzo oczekiwanej funkcji umożliwiającej włączenie obsługi wyłącznie nowych zmian funkcji przeładowywania na gorąco kodu XAML w projektach interfejsu Xamarin.Forms podczas kierowania do platformy UWP. Należy pamiętać, że ta funkcja jest nadal w trakcie tworzenia i podczas edycji kodu XAML wyzwala teraz aktualizacje w działającej aplikacji, a inne funkcje, takie jak pasek narzędzi w aplikacji (wybieranie elementów itp.), nie są jeszcze w pełni zaimplementowane, ale będą w przyszłym wydaniu.
  • Ustawienia przeładowywania kodu XAML na gorąco zostały przeniesione do obszaru „Debugowanie > Przeładowywanie na gorąco”: W tym wydaniu skonsolidowaliśmy ustawienia przeładowywania kodu XAML na gorąco na platformach WPF, UWP i Xamarin.Forms na ujednoliconym ekranie ustawień w obszarze „Debugowanie > Przeładowywanie na gorąco”. Po raz pierwszy umożliwiliśmy też wyłączanie i włączanie przeładowywania kodu XAML na gorąco dla każdej platformy osobno w celu zapewnienia pełnej kontroli nad tym, kiedy ta funkcja jest dostępna. (Uwaga: Podczas tej migracji nie zostaną zmienione żadne ustawienia, więc wszystkie istniejące wybory nadal będą obowiązywać tylko w tej nowej lokalizacji)
XAML Hot Reload Consolidated Settings
Skonsolidowane ustawienia przeładowywania kodu XAML na gorąco

Edytor kodu XAML:

  • Obsługa funkcji IntelliSense w interfejsie WinUI 3.0: To wydanie obejmuje lepszą obsługę funkcji IntelliSense dla deweloperów tworzących aplikacje przy użyciu nowego interfejsu WinUI 3.0 w wersji zapoznawczej 3 lub nowszej. Aby dowiedzieć się więcej o interfejsie WinUI 3.0, zapoznaj się z dokumentacją, a w celu przekazania opinii odwiedź repozytorium GitHub języka XAML interfejsu użytkownika systemu Windows. Uwaga: Najnowsza wersja zapoznawcza interfejsu WinUI 3.0 jest zalecana dla wersji 16.9 (wersja zapoznawcza 1) ze względu na zaktualizowane środowisko narzędzi.
  • Ulepszenie obsługi wzorca MVVM: Podczas tworzenia dokumentu XAML można ustawić kontekst d:DataContext, aby uzyskać dokładne powiązanie IntelliSense dla dokumentu XAML. W przeszłości ręczne określanie typu kontekstu danych było uciążliwe. Trzeba było wyjść z dokumentu XAML, znaleźć żądany typ widoku modelu, a następnie skopiować i wkleić jego przestrzeń nazw oraz nazwę do deklaracji d:DataContext. W tej wersji wprowadzamy nową funkcję, która pozwala szybko zadeklarować kontekst d:DataContext za pośrednictwem żarówki, która sugeruje możliwe opcje wyświetlania modelu.
XAML IntelliSense for MVVM d:DataContext
Funkcja IntelliSense kodu XAML dla MVVM d:DataContext

Rozszerzalność

  • Wypełnianie zestawu narzędzi z nieużywanych pakietów NuGet: W tej wersji dodaliśmy obsługę plików VisualStudioToolsManifest.xml specyficznych dla monikera TargetFrameworkMoniker podczas wypełniania przybornika kontrolkami z nieużywanych pakietów NuGet. Dzięki temu pakiet może na przykład uwidaczniać różne zestawy kontrolek dla projektów platformy .NET Core 3.1 i .NET 5.0.

Zgłaszane na forum Developer Community


Znane problemy

Zobacz wszystkie otwarte problemy i dostępne obejścia w programie Visual Studio 2019, wybierając poniższy link.


Opinie i sugestie

Chcemy poznać Twoją opinię! Problemy możesz zgłaszać za pomocą opcji Zgłoś problem w prawym górnym rogu instalatora lub bezpośrednio w środowisku IDE programu Visual Studio. Program Feedback Icon znajduje się w prawym górnym rogu. Zgłaszanie sugestii dotyczących produktów i śledzenie problemów jest możliwe w społeczności deweloperów programu Visual Studio, gdzie można też zadawać pytania, znajdować odpowiedzi i proponować nowe funkcje. Możesz też uzyskać bezpłatną pomoc dotyczącą instalacji za pośrednictwem naszej pomocy technicznej przez czat na żywo.


Blogi

Skorzystaj ze szczegółowych informacji i zaleceń dostępnych w witrynie blogów dotyczących narzędzi programistycznych, aby być na bieżąco ze wszystkimi nowymi wersjami i zyskać dostęp do szczegółowych wpisów dotyczących szerokiego zakresu funkcji.


Historia informacji o wersji programu Visual Studio 2019

Więcej informacji na temat poprzednich wersji programu Visual Studio 2019 można znaleźć na stronie Historia informacji o wersji programu Visual Studio 2019.


Początek strony