Visual Studio Icon Visual Studio wersji 2019 16.9



Developer Community | Wymagania systemowe | Zgodność | Kod dystrybucyjny | Postanowienia licencyjne | Blogi | Znane problemy w najnowszej wersji | Whats New in Visual Studio Docs


Kliknij przycisk, aby pobrać najnowszą wersję programu Visual Studio 2019. Aby uzyskać instrukcje dotyczące instalowania i aktualizowania programu Visual Studio 2019, zobacz informacje o aktualizowaniu programu Visual Studio 2019 do najnowszej wersji. Ponadto zobacz instrukcje na temat sposobu instalowania w trybie offline.

Community Download Button Professional Download Button Enterprise Download Button


Co nowego w programie Visual Studio 2019 w wersji 16.9

Ramy czasowe pomocy technicznej

Visual Studio 2019 r. w wersji 16.9 jest czwartym obsługiwanym planem bazowym obsługi dla Visual Studio 2019 r. Zachęcamy klientów korzystających z wersji Enterprise i Professional, którzy muszą wdrożyć długoterminowe, stabilne i bezpieczne środowisko programistyczne do standaryzacji do tej wersji. Jak wyjaśniono bardziej szczegółowo w zasadach cyklu życia i pomocy technicznej,poprawki i aktualizacje zabezpieczeń w wersji 16.9 będą obsługiwane do października 2022 r. Październik 2022 r. to rok po wydaniu wersji 16.11 programu Visual Studio 2019, która została zadeklarowana jako ostateczny plan bazowy obsługi.

Ponadto teraz, gdy jest dostępna wersja 16.9, wersja 16.7, która była ostatnim planem bazowym obsługi, będzie obsługiwana przez dodatkowe 12 miesięcy i nie będzie dostępna w kwietniu 2022 r. Należy również zauważyć, że wersja 16.8 również nie jest już w ramach obsługi. Te wersje pośrednie otrzymywały poprawki serwisowe tylko do momentu wydania następnej pomocniczej aktualizacji.

Najnowszą najbezpiecznszą wersję programu Visual Studio 2019 w wersji 16.9 można uzyskać w sekcji pobierania witryny my.visualstudio.com lub katalogu firmy Microsoft.   Aby uzyskać więcej informacji o obsługiwanych planach bazowych programu Visual Studio, zapoznaj się z zasadami pomocy technicznej dla programu Visual Studio 2019.

Visual Studio 2019 w wersji 16.9

Informacje o starszych wersjach programu Visual Studio 2019

Blog dotyczący programu Visual Studio 2019

Blog dotyczący programu Visual Studio 2019 to oficjalne źródło informacji o produkcie pochodzących od zespołu inżynierów ds. programu Visual Studio. Szczegółowe informacje na temat wersji programu Visual Studio 2019 można znaleźć w następujących wpisach:


Release Notes Icon Visual Studio 2019 w wersji 16.9.11 New release icon

wydany 14 września 2021 r.

Problemy rozwiązane w tej wersji:

  • Naprawiliśmy krytyczny wewnętrzny błąd kompilatora spowodowany przez nienazwane struktury, których pola są przywoływane z adnotacji SAL.
  • Naprawia rzadkie awarie podczas analizowania kodu z szablonu, który używa __uuidof.

Zalecenia dotyczące zabezpieczeń

CVE-2021-26434 Visual Studio luka w zabezpieczeniach eskalacji uprawnień nieprawidłowego przypisania uprawnień

Luka w zabezpieczeniach umożliwiająca przypisanie uprawnień istnieje Visual Studio po zainstalowaniu programowania gier w języku C++ i wybraniu obciążenia Instalator Aparatu Unreal Engine. System jest narażony na lpe podczas instalacji, tworząc katalog z dostępem do zapisu dla wszystkich użytkowników.

Zgłaszane na forum Developer Community


Release Notes Icon Visual Studio 2019 w wersji 16.9.10

wydany 10 sierpnia 2021 r.

Problemy rozwiązane w tej wersji:

  • Nie wysyłaj już ścieżek na dysk podczas raportowania, które rozszerzenia są zainstalowane.
  • Usunięto awarię funkcji IntelliSense, która miała miejsce podczas przetwarzania statycznych składowych danych w specjalizacjach szablonów w klasie.
  • Rozwiązano problem, który wpłynęł na wykonywanie polecenia update w wierszu polecenia. Jeśli aktualizacja zakończy się niepowodzeniem za pierwszym razem, kolejne wydanie polecenia aktualizacji spowoduje teraz wznowienie poprzedniej operacji, w której została ona wyłączona.

Zalecenia dotyczące zabezpieczeń

CVE-2021-26423 Odmowa usługi na oprogramowaniu .NET Core

Istnieje luka w zabezpieczeniach umożliwiająca atak typu "odmowa usługi", w przypadku której aplikacje serwera .NET (Core) zapewniające punkty końcowe webSocket mogą być wymuszone w nieskończoność w pętli podczas próby odczytu pojedynczej ramki webSocket.

CVE-2021-34485 Luka w zabezpieczeniach umożliwiająca ujawnienie informacji na temat programu .NET Core

Luka w zabezpieczeniach umożliwiająca ujawnienie informacji występuje, gdy zrzuty utworzone przez narzędzie do zbierania zrzutów awaryjnego i zrzutów na żądanie są tworzone z globalnymi uprawnieniami do odczytu w systemach Linux i macOS.

CVE-2021-34532 Luka w zabezpieczeniach umożliwiająca ujawnienie ASP.NET Core informacji

Istnieje luka w zabezpieczeniach umożliwiająca ujawnienie informacji, w której token JWT jest rejestrowany, jeśli nie może być analizowany.


Release Notes Icon Visual Studio 2019 r. w wersji 16.9.9

wydany 13 lipca 2021 r.

Problemy rozwiązane w tej wersji:

  • Rozwiązano problem z procesorem ARM64X, który Outlook ulegał awarii podczas korzystania z dodatków.
  • Rozwiązano problem, który w kompilatorze języka C++ niepoprawnie przeprowadzał konwersje if.
  • Rozwiązano problem ASan ze zgodnością w najnowszej Windows aktualizacji.
  • ASan nie zgłasza już błędu nakładania się fałszywie dodatnich regionów pamięci memcpy.
  • Szablon funkcji z parametrem funkcji bez nazwy typu tablicy spowodował, że parser pominął kolejne definicje funkcji, co spowodowało niepożądany błąd constexpr, że funkcja jest niezdefiniowana podczas oceny wywołania do niego w wyrażeniu stałym. Poprawka ponownie umożliwia analizowanie pominiętej definicji funkcji.
  • Naprawiliśmy problem z wydajnością i wyniki fałszywie dodatnie spowodowane przez jedno z rozszerzeń sprawdzania, które znajduje usterki w nieprawidłowym użyciu WANN.
  • Rozwiązaliśmy problem z wydajnością spowodowany przez jedno z rozszerzeń sprawdzania, które znajduje usterki w nieprawidłowym użyciu wartości wyliczek jako indeksu.
  • Naprawiono przeciek braku pamięci podczas kompilowania wielu otów.
  • Analizator współbieżności nie powinien już tworzyć fałszywych ostrzeżeń C26110 (niepowodzenie uzyskania blokady) z wzorcami automatycznego blokowania.
  • Ta poprawka przywraca zachowanie nagłówków zewnętrznych, pomijając analizę nagłówków zewnętrznych i pomijając ostrzeżenia z nagłówków zewnętrznych.
  • Testy współbieżności w analizie kodu są inteligentniejsze. Są one trudniejsze do oszukać przy użyciu złożonego przepływu sterowania.
  • Rozwiązano problem związany z tworzeniem układu.
  • Rozwiązano problem, który mógł zakończyć się niepowodzeniem aktualizacji z powodu braku informacji o kanale aktualizacji.

Zgłaszane na forum Developer Community


Release Notes Icon Visual Studio 2019 w wersji 16.9.8

wydany 15 czerwca 2021 r.

Zgłaszane na forum Developer Community


Release Notes Icon Visual Studio 2019 w wersji 16.9.7

wydany 8 czerwca 2021 r.

Problemy rozwiązane w tej wersji:

  • Usunięto usterkę w klonie instrukcji SSA.
  • Rozwiązano problem powodujący awarię mspdbcore.dll awarii.
  • Rozwiązano problem z długotrwałą/przechowaną kompilacją baz kodu klienta.
  • Rozwiązano problem uniemożliwiający deweloperom tworzenie aplikacji PyTorch.
  • Naprawia wewnętrzny błąd MSBuild (MSB0001), który pojawił się, gdy duża baza kodu została zbudowana przy użyciu 32-bitowego MSBuild.exe procesu.
  • Rozwiązano problem w oknie narzędzia kontenera powodujący awarię programu Visual Studio 2019, gdy deweloperzy próbowali wyświetlić zamapowane porty, a następnie przełączyć się do innego kontenera.

Zalecenia dotyczące zabezpieczeń

CVE-2021-31957 ASP.NET odmowa usługi

Luka w zabezpieczeniach typu "odmowa usługi" występuje, ASP.NET Core nieprawidłowo obsługuje rozłączenie klienta.

Zgłaszane na forum Developer Community

Lista Community zawiera pełną listę wszystkich elementów w tej wersji.

Oto niektóre najważniejsze problemy wydane w wersji 16.9.7:

Release Notes Icon Visual Studio 2019 w wersji 16.9.6

wydany 18 maja 2021 r.

Problemy rozwiązane w tej wersji:

  • Poprawki "Nie można uzyskać dostępu do usuniętego obiektu. Nazwa obiektu:'System.Net.Http.StringContent'" podczas próby utworzenia certyfikatu lub uruchomienia automatycznej aprowingu.
  • Rozwiązano problem uniemożliwiający poprawne uruchamianie funkcji ponownego uruchamiania na gorąco systemu iOS.

Zgłaszane na forum Developer Community

Lista Community zawiera pełną listę wszystkich elementów w tej wersji.

Oto niektóre najważniejsze problemy wydane w wersji 16.9.6:


Release Notes Icon Visual Studio 2019 w wersji 16.9.5

wydany 11 maja 2021 r.

Problemy rozwiązane w tej wersji:

  • Rozwiązano problem, który Office narzędzia nie działały zgodnie z oczekiwaniami podczas korzystania z eksportów.
  • Usunięto awarię Visual Studio 2019, która wystąpiła podczas niektórych wywołań wirtualnych między bibliotekami DLL x64 i ARM64EC.
  • Rozwiązano problem fałszywie dodatni podczas uruchamiania wielowątkowego kodu z instrumentami ASan.
  • Usunięto błąd projektu, który zwracał błąd "HRESULT E_FAIL został zwrócony z wywołania składnika COM".
  • Rozwiązuje problem podczas otwierania pliku C++ podczas uruchamiania, który czasami Visual Studio 2019 przestać odpowiadać.
  • Rozwiązano problem z konfiguracją plików CmakeSettings.json, w której nie można było utrwalić nowych ustawień.
  • Naprawiono wewnętrzny błąd kompilatora, który został spowodowany analizą pliku źródłowego, gdy ścieżka pliku zawiera co najmniej jeden znak ASCII niebędący znakiem ASCII.
  • Rozwiązano problem z otwieraniem plików pokrycia, który dotyczył wielu wpisów w jednej bibliotece w pliku pokrycia kodu.
  • Usunięto usterkę powodującą, że klienci, którzy logują się przy użyciu kont innych niż służbowe z włączonym pulpitem zdalnym, mogą powodować odmowę dostępu.
  • Usunięto usterkę powodującą awarię Visual Studio 2019, gdy deweloperzy dostosowywali menu i klikali separator w oknie dialogowym dostosowywania.
  • Okna dokumentów przestawnych są przywracane podczas otwierania rozwiązania.
  • Rozwiązano problem powodujący niepowodzenie aktualizacji, gdy administrator tworzy nowy układ Visual Studio wdrażania aktualizacji. Aktualizacja maszyny klienckiej nie powiedzie się, ponieważ układ został przeniesiony do lokalizacji.
  • Rozwiązano problem powodujący niepowodzenie kompilacji projektu z włączonym szybkim wdrożeniem lub długi czas wdrażania.
  • Dodano obsługę Xcode 12.5.
  • Rozwiązano problem powodujący niepowodzenie aktualizacji, gdy administrator tworzy nowy układ Visual Studio wdrażania aktualizacji. Aktualizacja maszyny klienckiej nie powiedzie się, ponieważ układ został przeniesiony do lokalizacji.

Zalecenia dotyczące zabezpieczeń

CVE-2021-27068 Możliwe RCE podczas python.exe w folderze zagnieżdżonych

Luka w zabezpieczeniach umożliwiająca zdalne wykonywanie kodu występuje podczas otwierania obszaru roboczego za pomocą kodu języka Python i zawiera python.exe w podfolderze skryptów.

CVE-2021-31204 Luka w zabezpieczeniach podniesienia uprawnień w programie .NET Core

Luka w zabezpieczeniach podniesienia uprawnień występuje na platformach .NET 5.0 i .NET Core 3.1, gdy użytkownik uruchamia pojedynczą aplikację pliku w systemach operacyjnych opartych na systemie Linux lub macOS.

Zgłaszane na forum Developer Community

Lista Community zawiera pełną listę wszystkich elementów w tej wersji.

Oto niektóre najważniejsze problemy wydane w wersji 16.9.5:


Release Notes Icon Visual Studio 2019 w wersji 16.9.4

wydany 13 kwietnia 2021 r.

Problemy rozwiązane w tej wersji:

  • Usunięto usterkę SFINAE powodującą błąd z niektórymi formami nazw szablonów w niezależnych klasach bazowych.
  • Rozwiązano problem, w którym funkcja IntelliCode próbowała zalogować się do katalogu tymczasowego i odmówiono dostępu do katalogu tymczasowego.
  • Rozwiązano problem, Visual Studio niektórych funkcji zarządzania uprawnieniami był ograniczony, gdy zainstalowano również oprogramowanie do zarządzania uprawnieniami innych firm.
  • Rozwiązano problem, który wielokrotnie rozpoczynał debugowanie w aplikacji XBox przez klientów, co wielokrotnie zużywało więcej zasobów jądra. Ostatecznie wymaganie ponownego uruchomienia aplikacji XBox, co może utracić jakikolwiek stan.
  • Rozwiązano zawieszanie się podczas debugowania kodu natywnego przy użyciu kompilacji insider preview Windows.
  • Usunięto usterkę ułatwień dostępu z fokusem klawiatury.
  • Dodano brakujące szablony platformy Xamarin (biblioteka klas systemu iOS/Android, biblioteka powiązań systemu iOS/Android, Android Wear, Xamarin.UITest) w oknie dialogowym Project aplikacji. Te szablony zostały ukryte przez pomyłkę.
  • W przypadku projektów opartych na CMake przeznaczonych dla systemu Linux korzystających z połączenia SSH katalog docelowy określony we właściwości został przywrócony do poprzedniego zachowania w programie CMakeSettings.json VS 16.8, gdzie miejsce docelowe kopii odpowiada katalogowi głównemu katalogu remoteCMakeListsRoot źródłowego. Szczegóły w bilecie Połączenie ze zdalną maszyną z systemem Linux używa nieprawidłowej ścieżki docelowej.

Zalecenia dotyczące zabezpieczeń

CVE-2021-27064 Instalator programu Visual Studio luka w zabezpieczeniach podniesienia uprawnień

Luka w zabezpieczeniach umożliwiająca zdalne wykonywanie kodu występuje, Visual Studio instalator wykonuje klienta opinii w stanie podwyższonym poziomem uprawnień.

CVE-2021-28313 / CVE-2021-28321 / CVE-2021-28322 Luka w zabezpieczeniach podniesienia poziomu uprawnień standardowej usługi modułu zbierającego centrum diagnostyki

Luka w zabezpieczeniach dotycząca podniesienia uprawnień występuje, gdy standardowy moduł zbierający centrum diagnostyki nieprawidłowo obsługuje operacje na danych.

Zgłaszane na forum Developer Community

Lista Community zawiera pełną listę wszystkich elementów wysyłkowych w tej wersji.

Oto niektóre z najgorętszych problemów wydanych w wersji 16.9.4:


Release Notes Icon Visual Studio 2019 w wersji 16.9.3

wydany 30 marca 2021 r.

Problemy rozwiązane w tej wersji:

  • Usunięto awarię w MSBuild, która miała miejsce podczas próby skompilowania rozwiązania za pomocą MSBuild.exe zawierającego projekt witryny internetowej.
  • Rozwiązano problem ze scenariuszem awarii spowodowanym przez niektóre zależności w usłudze ServiceHub.
  • Rozwiązano problem blokujący, który zabraniał zdalnego debugowania użytkownikom narzędzia Visual Diagnostics Tool języka XAML na urządzeniach Xbox lub IoT.

Zgłaszane na forum Developer Community

Lista Community zawiera pełną listę wszystkich elementów wysyłkowych w tej wersji.

Oto niektóre z najgorętszych problemów wydanych w wersji 16.9.3:


Release Notes Icon Visual Studio 2019 r. w wersji 16.9.2

wydany 16 marca 2021 r.

Problemy rozwiązane w tej wersji:

  • Aktualizowanie nazw wskaźników funkcji globalnych ARM64X
  • Poprawka rozpakowania pierwszego OBJ biblioteki ARM64X z linkiem -lib -extract
  • Usunięto błąd kompilowania kodu za pomocą programu Address Sanitizer, co może spowodować awarię programu Visual Studio 2019.
  • Usunięto awarię spowodowaną przez dodawanie funkcji za pomocą edytora okien dialogowych w Edytorze zasobów
  • Nuget.org nie trzeba już usuwać jako źródła pakietu dwa razy
  • Ulepszona NuGet analizowania pakietów
  • Naprawiono komunikat o błędzie informujący o przestarzałych interfejsach API otrzymanych przez klienta podczas Azure SQL Database węzła w Eksplorator serwera
  • Rozwiązano problem powodujący komunikat o błędzie wskazujący, że pakiet CascadePackage nie został załadowany poprawnie
  • Rozwiązano problem powodujący niepowodzenie wdrożenia projektu budowania z włączonym szybkim wdrożeniem lub dodatkowy czas
  • Rozwiązano problem powodujący wyświetlanie Przeładowywanie na gorąco zmian w trybie "Pełna strona"
  • Rozwiązano problem z Przeładowywanie na gorąco, który powodował, że na żywo drzewo wizualne nie działało ani nie powodowało zastosowania zmian.

Zgłaszane na forum Developer Community

Lista Community zawiera pełną listę wszystkich elementów wysyłkowych w tej wersji.

Oto niektóre z najgorętszych problemów wydanych w wersji 16.9.2:


Release Notes Icon Visual Studio 2019 w wersji 16.9.1

wydany 9 marca 2021 r.

Zalecenia dotyczące zabezpieczeń

CVE-2021-21300 Luka w zabezpieczeniach usługi Git Visual Studio zdalnego wykonywania kodu

Istnieje luka w zabezpieczeniach dotycząca zdalnego wykonywania kodu, gdy program Visual Studio klonuje złośliwe repozytorium.

CVE-2021-26701 Luka w zabezpieczeniach umożliwiająca zdalne wykonywanie kodu na komputerze .NET Core

Istnieje luka w zabezpieczeniach zdalnego wykonywania kodu na platformach .NET 5 i .NET Core spowodowana tym, jak jest wykonywane kodowanie tekstu.

Problemy rozwiązane w tej wersji:

  • Poprawka rozsyłania nieprawidłowych metadanych USŁUGI ARM64EC do elementów OBJ.
  • Rozwiązaliśmy problem, który polegał na tym, że w języku C++ z włączoną opcją FixIts , która jest opcją domyślną, podczas otwierania kodu był wyświetlany komunikat o błędzie.
  • W niektórych przypadkach funkcja IntelliSense w języku C++ próbuje użyć bardzo dużej liczby ścieżek dołączania i staje się nieodpowiedzialnościowa.
  • Zwiększona stabilność Live Share w scenariuszach języka C++.
  • Rozwiązano problem, który oznaczał, że funkcja IntelliCode przestałaby ładować symbole.
  • Poprawia obciążenie rozwiązania i czas zamknięcia w scenariuszach, w których użytkownicy mają włączony nowy eksperymentalny edytor Razor.
  • Naprawiono scenariusz awarii w usłudze ServiceHub, który mógł wystąpić po otwarciu okna dialogowego Rozszerzenia i aktualizacje, a następnie zamknięciu Visual Studio.
  • Naprawiono błąd, który zawierał komunikat informujący o tym, że podczas sprawdzania aktualizacji na wolniejszych maszynach nie były dostępne żadne aktualizacje.
  • Zwiększa wydajność uruchamiania projektów WAP z programu Visual Studio podczas zmian przyrostowych.
  • Rozwiązano problem powodujący niepowodzenie uruchamiania instalatora podczas korzystania z włoskich ustawień regionalnych.
  • Rozwiązano problem ze scenariuszem uaktualniania, który musiałby powodować, że instalator przestawał odpowiadać przez bardzo długi czas, gdy pamięć podręczna tempalte programu .NET Core była inicjalizowana.

Zgłaszane na forum Developer Community

Lista Community zawiera pełną listę wszystkich elementów wysyłkowych w tej wersji.

Oto niektóre z najgorętszych problemów wydanych w wersji 16.9.1:


Release Notes Icon Visual Studio 2019 w wersji 16.9.0

wydany 2 marca 2021 r.

Podsumowanie nowości w tej wersji programu Visual Studio 2019 w wersji 16.9.0

C++

  • Moduł czyszczący adresy:
    • Obsługa usługi sanitizer adresów na Windows nie jest już eksperymentalna i ma ogólną dostępność.
    • Rozszerzono obsługę elementu RtlAllocateHeap oraz rozwiązano problem ze zgodnością z interceptorami RtlCreateHeap i RtlAllocateHeap podczas tworzenia pul pamięci wykonywalnej.
    • Dodano obsługę starszej rodziny funkcji pamięci GlobalAlloc i LocalAlloc. Te interceptory można włączyć przy użyciu elementu ASAN_OPTIONS=windows_hook_legacy_allocators=true.
    • Zaktualizowano komunikaty o błędach stosowane w przypadku niepowodzenia przejmowania i przeplatania pamięci w tle, aby umożliwić jawną obsługę problemów i rozwiązań.
    • Integracja środowiska IDE może teraz obsługiwać kompletną kolekcję wyjątków, które może zgłaszać rozwiązanie ASan.
    • Kompilator i konsolidator będą sugerować emitowanie informacji debugowania, jeśli wykryją, że kompilujesz za pomocą rozwiązania ASan, ale nie emitujesz informacji dotyczących debugowania
  • Teraz możesz określić wersję maszyny wirtualnej niskiego poziomu środowiska uruchomieniowego OpenMP przy użyciu nowego przełącznika CL /openmp:llvm. Powoduje to dodanie obsługi klauzuli lastprivate w sekcjach omp #pragma i niepodpisane zmienne indeksu działające równolegle w pętlach. Przełącznik /openmp:llvm jest obecnie dostępny tylko dla elementu docelowego amd64 i nadal jest to wersja eksperymentalna.
  • Projekty narzędzia CMake w programie Visual Studio oferują teraz doskonałą obsługę zdalnego programowania w systemie Windows. Obejmuje to konfigurowanie projektu CMake do docelowego użycia w systemie Windows ARM64, wdrażanie projektu na komputerze zdalnym z systemem Windows i debugowanie projektu na komputerze zdalnym z systemem Windows z poziomu programu Visual Studio.
  • Wersja narzędzia Ninja dostarczana z programem Visual Studio w systemie Windows została zaktualizowana do wersji 1.10. Aby uzyskać szczegółowe informacje na temat uwzględnionych funkcji, zobacz informacje o wersji narzędzia Ninja 1.10.
  • Wersja narzędzia CMake dostarczana z programem Visual Studio została zaktualizowana do wersji 3.19. Aby uzyskać szczegółowe informacje na temat uwzględnionych funkcji, zobacz informacje o wersji narzędzia CMake 3.19.
  • Wiele typów blokady/ochrony w STL zostało oznaczonych jako nodiscard: https://github.com/microsoft/STL/pull/1495
  • IntelliSense:
  • Kompilator MSVC określa teraz poprawne środowiska uruchomieniowe modułu czyszczącego adresy wymagane dla plików binarnych. Projekt programu Visual Studio automatycznie pobierze nowe zmiany. W przypadku korzystania z modułu czyszczącego adresy w wierszu polecenia wystarczy teraz przekazać flagę /fsanitize=address do kompilatora.
  • Menedżer połączeń programu Visual Studio obsługuje teraz klucze prywatne przy użyciu algorytmu klucza publicznego ECDSA.
  • Zaktualizowano wersje maszyny wirtualnej niskiego poziomu i narzędzia Clang dostarczone w naszym instalatorze do wersji 11. Aby uzyskać więcej informacji, zapoznaj się z informacjami o wersji dotyczącymi maszyny wirtualnej niskiego poziomu i narzędzia Clang.
  • Program Visual Studio będzie teraz używać zmiennych narzędzia CMake z plików łańcucha narzędzi w celu skonfigurowania funkcji IntelliSense. To zapewni lepsze środowisko programowania aplikacji osadzonych i aplikacji dla systemu Android.
  • Implementacja propozycji dotyczącej większej liczby kontenerów constexpr, dzięki której destruktory i nowe wyrażenia mogą być constexpr. Otwiera to drogę dla narzędzi takich jak constexpr std::vector i std::string.
  • Rozszerzona obsługa technologii IntelliSense modułów języka C++20, w tym funkcji Przejdź do definicji, Przejdź do modułu i uzupełniania składowych.
  • Skrócone szablony funkcji są teraz obsługiwane w MSVC kompilatora.

Javascript/TypeScript

  • Obecnie obsługujemy debugowanie przy użyciu języka WebView2 JavaScript/TypeScript opartego na programie Edge Chromium dla aplikacji, takich jak projekty WPF, WinForms i WinUI 3. Tę funkcję można włączyć, wybierając debuger języka JavaScript w okna dialogowym właściwości projektu. Szczegółowe informacje na temat rozpoczynania pracy z funkcją można znaleźć tutaj

Debuger

  • Dodano nowy analizator automatyczny, który sprawdza wątki pod uwagę zakleszczenia.
Auto Analyzer that inspects threads for deadlocks
  • Dodano nowy automatyczny analizator, który sprawdza kolejkę finalizatora platformy .NET Core i wykrywa obiekty, które mogą powodować blokady.
Auto Analyzer that inspects the .NET Core Finalizer queue
  • Visual Studio odfiltrowuje teraz nadmiarowe powtarzające się ramki ze stosu wywołań, gdy debuger zatrzyma się w wyjątku StackOverflow. Teraz można zobaczyć podstawę stosu, z którego pochodzi nieskończona rekursja, co, miejmy nadzieję, ułatwi badanie tego rodzaju usterek.
Filters out redundant repeating frames from the call stack when the debugger stops on a StackOverflow Exception

Profiler

  • Dodano nowy scenariusz instrumentacji dynamicznej, który jest szybszy (nie wymaga vsInstr) i umożliwia instrumentację aplikacji .NET Core bez konieczności użycia plików PDB.
Dynamic Instrumentation Profiling

Narzędzia języka F# i F#

Ta wersja zawiera kilka funkcji zwiększających produktywność i ulepszenia wydajności dla narzędzi języka F# dla Visual Studio:

  • Obsługa fsi .NET Core
  • Signature Help for function applications (Pomoc dla sygnatur dla aplikacji funkcji)
  • 14 nowych szybkich poprawek
  • Istotne poprawki dotyczące wydajności i czasu odpowiedzi dla narzędzi języka F#

Informacje o nich można znaleźć w aktualizacjach narzędzi języka F# i F# dla wersji Visual Studio 16.9 lub w informacjach o wersji produktu.

Produktywność platformy .NET

  • Obecnie jest dostępna opcja uzupełniania symboli preprocesora w funkcji IntelliSense.
  • Eksplorator rozwiązań wyświetla teraz nowe generatory źródeł platformy .NET 5.0.
  • Opcja Przejdź do wszystkich nie spowoduje wyświetlania zduplikowanych wyników w aplikacjach netcoreapp3.1 i netcoreapp2.0.
  • Funkcja Szybkie informacje wyświetla teraz identyfikatory lub numery ostrzeżeń kompilatora w przypadku pominięć.
  • Dyrektywy using będą teraz automatycznie dodawane podczas kopiowania i wklejania typów do nowego pliku.
  • Po naciśnięciu klawisza , aby zaakceptować metodę z listy uzupełniania, funkcja IntelliSense będzie teraz automatycznie wstawiać nawiasy wraz z średnikiem do tworzenia obiektów ; i wywołań metod.
  • Kolorowanie semantyczne dla rekordów języka C# 9.0.
  • Refaktoryzacja usuwająca zbędne odrzucenia.
  • Refaktoryzacja, która konwertuje dosłowny i zwykły ciąg na ciąg interpolowany z zachowaniem nawiasów klamrowych mających się znaleźć w danych wyjściowych.
  • Poprawka kodu w języku Visual Basic, która usuwa słowo kluczowe shared podczas konwertowania metod udostępnionych do modułu.
  • Refaktoryzacja, która sugeruje użycie funkcji new(…) w niespornych scenariuszach
  • Poprawka kodu, która usuwa nadmiarowe wyrażenia równości w językach C# i Visual Basic
  • Analizatory stylu kodu platformy .NET (IDE) można teraz wymuszać podczas kompilacji
  • Rozszerzenie Syntax Visualizer pokazuje bieżący kolor pierwszego planu dla kolorów rozszerzonych
  • Nowa etykietka narzędzia jest wyświetlana po umieszczeniu wskaźnika myszy na identyfikatorze diagnostyki dla ostrzeżeń pragma
  • Po naciśnięciu klawisza Return z poziomu komentarza nowy wiersz jest teraz automatycznie opatrzony komentarzem
  • Ulepszenia wskazówek dotyczących nazw parametrów wbudowanych
  • Debugowanie platformy .NET Core za pomocą podsystemu WSL 2

Aktualizacje podpowiedzi audio i ułatwień dostępu w Eksploratorze testów

  • Teraz można konfigurować podpowiedzi audio przy użyciu Eksploratora testów, dostęp do menu Grupuj według na czytnikach zawartości ekranu jest łatwiejszy, a wyświetlanie długich danych wyjściowych testów jest łatwiejsze dzięki możliwym do kliknięcia linkom, które bezpośrednio otwierają pliki dzienników.

Eksperymentalne aktualizacje edytora Razor

  • Semantyczne kolorowanie kodu HTML i C#
  • Zmiany nazw symboli języka C# odzwierciedlone w zamkniętych plikach Razor
  • Więcej żarówek języka C# w plikach Razor
  • Dalsze ulepszenia formatowania zawartości mieszanej w plikach Razor

Narzędzia internetowe dla platformy .NET

  • Wdróż aplikacje Steeltoe do usługi Azure Spring Cloud przy użyciu funkcji publikowania programu Visual Studio (np. kliknięcie prawym przyciskiem myszy > Publikuj w Eksploratorze rozwiązań).

Narzędzia sieci Web

  • Rozszerzono obsługę platformy .NET na potrzeby usługi Azure App Configuration jako usługi połączonej
  • Zarządzanie ustawieniami konfiguracji aplikacji i flagami funkcji przez integrację Azure App Configuration jako usługi połączonej

Narzędzia XAML (WPF, WinUI, UWP & Xamarin.Forms)

Narzędzia MVVM

  • Ulepszona obsługa MVVM: W tej wersji wprowadziliśmy żarówki w edytorze XAML w celu generowania właściwości i poleceń w dostępnych modelach widoków. Dodaliśmy również żarówki, aby ułatwić ustawienie projektu DataContext w języku XAML na dostępne modele widoków w celu ulepszenia powiązania funkcji IntelliSense.

Xamarin.Forms

W tej wersji wprowadzono wiele ulepszeń dla deweloperów platformy Xamarin.Forms:

  • Przeładowywanie kodu XAML na gorąco "tylko zmiany" jest teraz trybem domyślnym dla projektów Xamarin.Forms 5.x: Począwszy od wersji Visual Studio 16.9 Przeładowywanie kodu XAML na gorąco tryb "tylko zmiany" jest teraz domyślnym trybem Przeładowywanie kodu XAML na gorąco dla projektów przeznaczonych dla platformy Xamarin.Forms 5.x lub wyższej. Projekty przeznaczone dla wersji 4.x automatycznie przejdą do "pełnej strony", Przeładowywanie kodu XAML na gorąco ponieważ "tylko zmiany" są zgodne tylko z zestawem Xamarin.Forms 5.x lub nowszą. Jeśli używasz platformy Xamarin.Forms 5.x i z jakiegoś powodu chcesz użyć starego trybu "pełnej strony" Przeładowywanie na gorąco, możesz to zrobić, przechodząc do ustawień programu Przeładowywanie na gorąco w obszarze Narzędzia > Opcje > Debugowanie > Przeładowywanie na gorąco.

  • Przeładowywanie kodu XAML na gorąco stanu w oknie danych wyjściowych: Klienci korzystający z platformy Xamarin.Forms Przeładowywanie kodu XAML na gorąco mogą teraz zobaczyć więcej szczegółów na temat tego, co dzieje się z potokiem Przeładowywanie kodu XAML na gorąco przy użyciu okna danych wyjściowych. Aby rozpocząć, otwórz okno danych wyjściowych za pomocą polecenia View > Output (Wyświetl dane wyjściowe) i wybierz pozycję Xamarin Przeładowywanie na gorąco w obszarze Show output from (Pokaż dane wyjściowe) w górnej części okna.

XAML Hot Reload - Output window information
  • Xamarin.Forms + UWP — rozwiązano problem System.ExecutionEngineException: Począwszy od wersji 16.8 programu Visual Studio 2019 przypadkowo wprowadziliśmy wyjątek środowiska uruchomieniowego, który wyzwala błędy System.ExecutionEngineException, gdy deweloperzy będą debugować aplikację Xamarin.Forms, która jest docelowa dla platformy Windows (UWP). Począwszy od tej wersji (16.9 (wersja zapoznawcza 4) i w połączeniu z aktualizacją do platformy Microsoft.NETCore.UniversalWindowsPlatform NuGet (wersja 6.2.12 lub nowsza), ten problem powinien zostać rozwiązany. Uwaga: ta poprawka nie dotyczy tylko programu Visual Studio 2019 w wersji 16.9. Aktualizacja projektów w celu używania nowego NuGet powinna rozwiązać ten problem również Visual Studio wersji 16.9.

Tools for Unity

  • Wyświetlanie obiektów gry głównej podczas debugowania w nowym węźle Aktywna scena w oknie Locals (Lokalne).
  • Wyświetl wszystko składniki w pliku GameObject podczas debugowania w nowym węźle this.gameObject w oknie Locals (Elementy lokalne).
  • Wyświetl wszystko podrzędne obiekty i składniki gier przy użyciu węzłów Elementy podrzędne i Składniki okna Elementy lokalne.
  • Zobacz lokalizację obiektu GameObject w scenie podczas inspekcji we właściwości Active Scene.
  • Obsługa funkcji JobEntityBatch/Lambdas w przypadku używania jednostek z generatorami źródła.
  • Ulepszona obsługa wyświetlania dużych tablic przy użyciu zasobników indeksów.
  • Wyróżnianie składni dla cieniowania promieniowych, plików UXML i USS.
  • Visual Studio wykryje, których składników brakuje, i wyświetli monit o ich zainstalowanie podczas korzystania z projektów aparatu Unity.
  • Interfejs API komunikatów aparatu Unity dla wszystkich metod używanych jako zaktualizowane coroutyny.

Wydajność usługi Git

  • Odświeżyliśmy flagę funkcji w wersji zapoznawczej dla nowego środowiska użytkownika usługi Git za pomocą wbudowanego linku Dodawaj opinię, który kieruje bezpośrednio do zespołu produktu.
  • Team Explorer strony Połączenie strony Połączenie wyświetlać szczegółową zawartość w celu przejścia do nowego środowiska użytkownika usługi Git.
  • Obsługa niestandardowych zdalnych w powiadomieniach wypychanych gałęzi.
  • Kliknij dwukrotnie gałąź w oknie Repozytorium Git, aby wyewidencjonować.
  • Zateń zmiany za pomocą skrótu klawiaturowego Ctrl+Enter.
  • Wypychanie wszystkich tagów z poziomu okna zmian usługi Git.

Instalator programu Visual Studio

  • Instalator programu Visual Studio nie ma już podnoszonego poziomu uprawnień podczas uruchamiania
  • Instalator programu Visual Studio obsługuje teraz wyświetlacze HDR
  • Instalator programu Visual Studio obsługuje czytnik ekranu nawigatora
  • Aktualizacje instalatora zostały usprawnione w ramach aktualizacji programu Visual Studio
  • Instalator programu Visual Studio dodaje obsługę motywu ciemnego

Szczegóły nowości w programie Visual Studio 2019 w wersji 16.9.0

Wydajność usługi Git

  • Zatwierdzanie zmian za pomocą skrótu klawiaturowego Ctrl+Enter

    Ctrl+Enter to Commit
    Zatwierdzanie zmian za pomocą klawiszy Ctrl+Enter

  • Wypychanie wszystkich tagów z poziomu okna zmian usługi Git.

Push all Tags
Wypychanie wszystkich tagów do repozytorium zdalnego

Produktywność platformy .NET

  • Debugowanie platformy .NET Core za pomocą podsystemu WSL 2 umożliwia debugowanie i uruchamianie konsoli .NET Core i aplikacji internetowych w podsystemie WSL 2 w programie Visual Studio. Umożliwia to deweloperom systemu Windows tworzącym na potrzeby środowisk produkcyjnych systemu Linux uzyskanie większej wierności lokalnego środowiska debugowania.
.NET Core Debugging with WSL 2
Debugowanie platformy .NET Core za pomocą podsystemu WSL 2
  • Teraz dostępna jest refaktoryzacja, która sugeruje użycie funkcji new(…) w niespornych scenariuszach. Umieść kursor na deklaracji pola. Naciśnij klawisze (Ctrl+ . ), aby wywołać menu Szybkie akcje i operacje refaktoryzacji. Wybierz pozycję Use ‘new(…)’ (Użyj funkcji „new (...)”).
Use new(...) refactoring
Używanie refaktoryzacji new(...)
  • Udostępniono poprawkę kodu, która usuwa nadmiarowe wyrażenia równości dla języków C# i Visual Basic. Umieść kursor na nadmiarowym wyrażeniu równości. Naciśnij klawisze (Ctrl+ . ), aby wywołać menu Szybkie akcje i operacje refaktoryzacji. Wybierz pozycję Remove redundant equality (Usuń nadmiarową równość).
Remove redundant equality expressions code fix
Poprawka kodu dotycząca usuwania nadmiarowych wyrażeń równości
  • Analizatory stylu kodu platformy .NET (IDE) można teraz wymuszać podczas kompilacji. Analizatory stylu kodu platformy .NET można zainstalować jako pakiet NuGet dla języków C# i Visual Basic lub można je włączyć we właściwościach projektu. Aby uzyskać dostęp do okna Właściwości projektu, kliknij prawym przyciskiem myszy projekt w Eksploratorze rozwiązań i wybierz pozycję Właściwości. Następnie wybierz kartę Analiza kodu, gdzie możesz wybrać pozycję Enforce CodeStyle on build (experimental) (Wymuszaj styl kodu podczas kompilacji (funkcja eksperymentalna)).
Project Properties window to enable .NET Code Style Analyzers
Włączanie analizatorów stylu kodu platformy .NET w oknie Właściwości projektu
  • Rozszerzenie Syntax Visualizer (instalowane z zestawem SDK platformy kompilatora .NET) pokazuje teraz bieżący kolor pierwszego planu dla kolorów rozszerzonych. Wystarczy użyć wizualizatora, aby przejść do tekstu, dla którego chcesz zmienić kolory, lub wybrać w edytorze, a następnie kliknąć sklasyfikowany kolor, aby go zmienić.
Syntax Visualizer Colorization
Kolorowanie rozszerzenia Syntax Visualizer
  • Po umieszczeniu wskaźnika myszy na identyfikatorze diagnostyki dla ostrzeżeń pragma jest teraz wyświetlana etykietka narzędzia. Diagnostyczna etykietka narzędzia ma również link do kliknięcia, który prowadzi do dokumentacji.
Diagnostic Tooltip for Pragma Warnings
Diagnostyczna etykietka narzędzia dla ostrzeżeń pragma
  • Po naciśnięciu klawisza Return z poziomu komentarza można zauważyć, że nowy wiersz jest teraz automatycznie opatrzony komentarzem. Jest to nowa opcja, która jest domyślnie włączona. Aby wyłączyć automatyczne komentowanie nowego wiersza, wybierz pozycję Narzędzia > Opcje > Edytor tekstów > C# lub Basic > Zaawansowane i usuń zaznaczenie pola wyboru Insert // at the start of new lines when writing // comments (Wstaw // na początku nowych wierszy podczas pisania // komentarzy).

W wersji zapoznawczej 2 dla wersji 16.8 dodaliśmy wskazówki dotyczące nazw parametrów wbudowanych, które wstawiają zakończenia literałów, literałów rzutowanych i tworzonych wystąpień obiektów przed każdym argumentem w wywołaniach funkcji. Ta wersja obejmuje następujące ulepszenia:

  • Więcej opcji dostosowywania dla typów zakończeń, które chcesz wstawić.

  • Wbudowane wskazówki dotyczące typu dla zmiennych z typami wywnioskowanymi i typami parametrów lambda.

  • Opcja wyłączenia wbudowanych wskazówek dotyczących nazw parametrów, gdy nazwy parametrów są zgodne z intencją metody i gdy nazwy parametrów różnią się tylko sufiksem.

  • Dyrektywy using będą teraz automatycznie dodawane podczas kopiowania i wklejania typów do nowego pliku. Najpierw należy włączyć tę opcję w obszarze Narzędzia > Opcje > Edytor tekstów > C# lub Basic > Zaawansowane i wybrać pozycję Dodaj brakujące dyrektywy using przy wklejaniu.

Add missing using directives on paste
Dodawanie brakujących dyrektyw using przy wklejaniu
  • Po naciśnięciu klawisza , aby zaakceptować metodę z listy uzupełniania, funkcja IntelliSense będzie teraz automatycznie wstawiać nawiasy wraz z średnikiem do tworzenia obiektów ; i wywołań metod.
Method call completion
Uzupełnianie wywołania metody
  • Udostępniono kolorowanie semantyczne dla rekordów języka C# 9.0. Kolory można dostosować w obszarze Narzędzia > Opcje > Środowisko > Czcionki i kolory. W obszarze Wyświetl elementy przewiń do pozycji Typy użytkowników — rekordy i wybierz kolor, który ma zostać zastosowany do rekordów.
Semantic colorization for records
Kolorowanie semantyczne dla rekordów
  • W przypadku języka C# 9.0 odrzucenia nie są potrzebne w niektórych przypadkach dopasowania wzorca. Obecnie wycofujemy zbędne odrzucenia i oferujemy poprawkę kodu, aby je usunąć. Umieść kursor na wycofanym odrzuceniu. Naciśnij klawisze (Ctrl+ . ), aby wywołać menu Szybkie akcje i operacje refaktoryzacji. Wybierz pozycję Usuń zbędne odrzucenie.
Remove unnecessary discard
Usuwanie zbędnych odrzuceń
  • Udostępniono refaktoryzację, która konwertuje dosłowny ciąg i zwykły ciąg na ciąg interpolowany, co spowoduje zachowanie nawiasów klamrowych mających się znaleźć w danych wyjściowych. Ta refaktoryzacja nie jest oferowana, jeśli ciąg jest przypisany do stałej. Umieść kursor na ciągu. Naciśnij klawisze (Ctrl+ . ), aby wywołać menu Szybkie akcje i operacje refaktoryzacji. Wybierz pozycję Konwertuj na ciąg interpolowany.
Convert to an interpolated string that will preserve curly braces
Konwertowanie na ciąg interpolowany, który będzie przechowywać nawiasy klamrowe
  • Udostępniono poprawkę kodu w języku Visual Basic, która usuwa słowo kluczowe shared podczas konwertowania metod udostępnionych do modułu.

  • Obecnie jest dostępna opcja uzupełniania symboli preprocesora w funkcji IntelliSense. Zacznij wpisywać dyrektywę #if, aby wyświetlić nowe opcje uzupełniania dla symboli, które są obecnie zdefiniowane w zakresie.

IntelliSense completion for preprocessor symbols
Uzupełnianie symboli preprocesora w funkcji IntelliSense
  • Eksplorator rozwiązań wyświetla teraz nowe generatory źródła platformy .NET 5.0 w obrębie węzła analizatora, dzięki czemu można łatwo nawigować i wyświetlać wygenerowany kod.
Source Generators node in Solution Explorer
Węzeł generatorów źródła w Eksploratorze rozwiązań
  • W oknie Przejdź do wszystkich nie będą wyświetlane zduplikowane wyniki w aplikacjach netcoreapp3.1 i netcoreapp2.0 ani wyniki dla typów częściowych, które istnieją tylko na potrzeby zawijania innego typu zagnieżdżonego. Pomoże to uporządkować wyniki, co ułatwi wyszukiwanie kodu i przechodzenie do niego. Wyniki zawierają również teraz nazwę pliku dla symboli częściowych.
Go To All will not display duplicate results across netcoreapp3.1 and netcoreapp2.0
W oknie Przejdź do wszystkich nie będą wyświetlane zduplikowane wyniki z aplikacji netcoreapp3.1 i netcoreapp2.0
  • Funkcja Szybkie informacje wyświetla teraz identyfikatory lub numery ostrzeżeń kompilatora w przypadku pominięć. Umieść kursor nad identyfikatorami lub numerami ostrzeżeń, aby wyświetlić szybkie informacje na temat danego identyfikatora diagnostyki.
Quick Info on compiler warning IDs or numbers for suppressions
Szybkie informacje dotyczące identyfikatorów lub numerów ostrzeżeń kompilatora w przypadku pominięć

Dziękujemy

Na koniec wielkie podziękowania dla następujących osób, które w tym miesiącu przyczyniły się do zwiększania produktywności platformy .NET (vel Roslyn)

Narzędzia internetowe dla platformy .NET

  • Wdróż aplikacje Steeltoe do usługi Azure Spring Cloud przy użyciu funkcji publikowania programu Visual Studio (np. kliknięcie prawym przyciskiem myszy > Publikuj w Eksploratorze rozwiązań). Jeśli nie widzisz tej opcji, upewnij się, że projekt zawiera pakiet NuGet Microsoft.Azure.SpringCloud.Client w wersji 1.0.0-preview.1 lub nowszej.
Deploy your Steeltoe applications to Azure Spring Cloud
Wdrażanie aplikacji Steeltoe w usłudze Azure Spring Cloud

Narzędzia internetowe

Dodawanie konfiguracji aplikacji jako połączonej usługi automatycznie łączy aplikację z zasobem usługi Azure App Configuration. Obecnie obsługiwane jest automatyczne generowanie kodu dla projektów konsoli .NET Core oraz automatyczne dodawanie pakietów NuGet dla projektów .NET Framework. Aby zintegrować tę usługę połączoną z aplikacją, kliknij pozycję Usługi połączone i dodaj usługę Azure App Configuration jako zależność usługi.

Add App Config to Connected Services
Dodawanie usługi App Configuration jako usługi połączonej
  • Karta Usługi połączone obsługuje teraz usługę Azure App Configuration. Usługa App Configuration umożliwia centralne zarządzanie ustawieniami aplikacji i flagami funkcji. Po dodaniu tej zależności usługi kod jest automatycznie aktualizowany w celu nawiązania połączenia z zasobem usługi App Configuration. Obejmuje to zainstalowanie najaktualniejszych pakietów NuGet i przechowywanie wpisów tajnych lokalnie lub w usłudze Key Vault.
Manage your configurations with Azure App Configuration
Zarządzanie konfiguracjami przy użyciu połączenia usługi Azure App Configuration

Instalator programu Visual Studio

W instalatorze programu Visual Studio dołączono kilka nowych funkcji w odpowiedzi na żądania klientów.

Wielu użytkowników korzysta teraz z instalatora w celu identyfikowania, uruchamiania i zarządzania wieloma kopiami programu Visual Studio. Aby ułatwić użycie tego wzorca, instalator programu Visual Studio nie wymaga już podniesienia uprawnień przy uruchamianiu, a wymaga tylko podniesienia uprawnień w celu wprowadzania zmian w programie Visual Studio oraz na maszynie. Inne działania, takie jak eksportowanie konfiguracji instalacji, przechodzenie do wiadomości i wyświetlanie szczegółów aktualizacji, nie wymagają już od użytkownika wcześniejszego podniesienia poziomu uprawnień.

Wcześniejsze wersje instalatora czasami prosiły użytkowników o wykonanie dodatkowego kroku w celu zaktualizowania Instalatora. Dzięki tej aktualizacji wymagane aktualizacje instalatora są teraz obsługiwane jako część operacji instalacji, usuwając dodatkowy krok.

W instalatorze dodano obsługę wyboru motywu trybu ciemnego. Użytkownicy mogą zmieniać motyw Instalatora za pomocą przycisku słońce / księżyc (☼ / ☽) na pasku tytułu. Aktualizacje uruchomione z poziomu środowiska Visual Studio IDE będą korzystać z bieżącego motywu programu Visual Studio.

VS Installer with dark theme and inline installer update
Instalator programu VS z aktualizacją motywu ciemnego i instalatora wbudowanego

Aktualizacje podpowiedzi audio i ułatwień dostępu w Eksploratorze testów

  • Eksplorator testów może teraz odtwarzać dźwięk po zakończeniu przebiegu testu. Można wybrać dwa dźwięki: jeden wskazujący, że przebieg testu zakończył się powodzeniem ze wszystkimi testami z wynikami pozytywnymi, i drugi wskazujący, że przebieg testu zakończył się z co najmniej jednym testem z wynikiem negatywnym. Ta funkcja została stworzona na żądanie użytkownika i udoskonala ułatwienia dostępu Eksploratora testów przez dodanie podpowiedzi audio przydatnych dla niedowidzących deweloperów. Do wybierania dźwięku jest używane okno dialogowe domyślnych dźwięków systemu Windows 10, w którym można także wybrać wstępnie zdefiniowane dźwięki lub dowolny plik audio z komputera.
  • Dostęp do opcji Grupuj według w Eksploratorze testów jest teraz łatwiejszy dzięki możliwości użycia bardziej zwięzłych fraz i kolejności wyrazów w przypadku odczytywania za pomocą czytnika ekranu.
  • Wyświetlanie długich danych wyjściowych testów z poziomu okienka Szczegóły testu w Eksploratorze testów jest teraz łatwiejsze dzięki użyciu linku, który umożliwia otwieranie pliku dziennika bezpośrednio, zamiast specjalnej kontrolki dokumentu.

Środowisko testowe

  • Dodano obsługę zbierania danych o pokryciu kodu dla projektów testowych platformy .NET Core, które korzystają z platformy Fakes.
  • Skrócono czas wymagany do scalenia wielu raportów pokrycia kodu.

IntelliCode

  • Funkcja rozszerzenia IntelliCode udostępnia teraz powtarzane sugestie edycji bezpośrednio na liście uzupełniania IntelliSense. Możesz wyświetlić podgląd sugerowanej zmiany, zastosować ją do danej lokalizacji lub zignorować podobne sugestie bezpośrednio od elementu ukończenia. Dowiedz się więcej na temat sugestii rozszerzenia IntelliCode.

Eksperymentalne aktualizacje edytora Razor

  • Semantyczne kolorowanie kodu HTML i C#
  • Zmiany nazw symboli języka C# odzwierciedlone w zamkniętych plikach Razor
  • Więcej żarówek języka C# w plikach Razor:
    • Dodawanie atrybutu DebuggerDisplay
    • Tworzenie i przypisywanie właściwości
    • Tworzenie i przypisywanie pola
    • Implementowanie interfejsu lub klasy abstrakcyjnej, w tym obsługi „za pomocą wzorca”, tj. „Implementuj interfejs za pomocą wzorca likwidacji”
    • Generowanie elementów Equals, Hashcode, Constructor
  • Dodaj sprawdzenie wartości null i Dodaj wszystkie sprawdzenia wartości null dla parametrów
  • Dalsze ulepszenia formatowania zawartości mieszanej w plikach Razor

Aby włączyć eksperymentalny edytor Razor, wybierz kolejno opcje Narzędzia > Opcje > Środowisko > Funkcje w wersji zapoznawczej, wybierz pozycję Włącz eksperymentalny edytor Razor, a następnie ponownie uruchom program Visual Studio.

Zgłaszane na forum Developer Community

Lista Community zawiera pełną listę wszystkich elementów wysyłkowych w tej wersji.

Oto niektóre z najgorętszych problemów wydanych w wersji 16.9.0:


Znane problemy

Zobacz wszystkie otwarte problemy i dostępne obejścia w programie Visual Studio 2019, wybierając poniższy link.


Opinie i sugestie

Chcemy poznać Twoją opinię! Problemy możesz zgłaszać za pomocą opcji Zgłoś problem w prawym górnym rogu instalatora lub bezpośrednio w środowisku IDE programu Visual Studio. Program Feedback Icon znajduje się w prawym górnym rogu. Zgłaszanie sugestii dotyczących produktów i śledzenie problemów jest możliwe w społeczności deweloperów programu Visual Studio, gdzie można też zadawać pytania, znajdować odpowiedzi i proponować nowe funkcje. Możesz też uzyskać bezpłatną pomoc dotyczącą instalacji za pośrednictwem naszej pomocy technicznej przez czat na żywo.


Blogi

Skorzystaj ze szczegółowych informacji i zaleceń dostępnych w witrynie blogów dotyczących narzędzi programistycznych, aby być na bieżąco ze wszystkimi nowymi wersjami i zyskać dostęp do szczegółowych wpisów dotyczących szerokiego zakresu funkcji.


Historia informacji o wersji programu Visual Studio 2019

Więcej informacji na temat poprzednich wersji programu Visual Studio 2019 można znaleźć na stronie Historia informacji o wersji programu Visual Studio 2019.


Początek strony